• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[RECOVERY][OFFICIAL][3.3.1-x] TWRP for Galaxy S9 and S9+ Exynos

Search This thread

Tarar

Senior Member
Aug 10, 2014
79
3
Islamabad
Did anyone try rooting with the latest TWRP 3.5.0_9-1 and One UI 2.5? I have tried disabling encryption with multiple files and no one seems to work. Here's what i have tried
Installed new stock firmware
Flashed TWRP lastest version
Formatted Data and rebooted into the recovery
Installed no-verity-opt-encrypt 6.1 Failed
Installed Disable DM Verity Forced encrypt 11-4-2020 Installed but upon rebooting, phone stuck in loop.
Can anyone help please?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 26
    Ae08b8N.png

    Official TWRP 3.3.1-* For Galaxy S9/S9+ Exynos
    Only for exynos variants - G960F (Europe, Global Single-SIM); G960FD (Global Dual-SIM); G960N (South Korea); G965F (Europe, Global Single-SIM); G965FD (Global Dual-SIM); G965N (South Korea);
    Disclaimer
    I am not responsible for bricked devices, dead SD cards, thermonuclear war, or you getting fired because the alarm app failed.
    Please do some research if you have any concerns about features included in this recovery before flashing it!
    YOU are choosing to make these modifications, and if you point the finger at me for messing up your device, I will laugh at you.


    Features:
    Code:
    - built from Android 10 kernel source
    - built from android-9.0 recovery sources
    - built in full 64 mode
    - fully compatible with Android 9.0/10.0

    Downloads:

    Instructions:
    Odin

    1. Download latest Odin zip from downloads.corsicanu.ro/samsung
    2. Download and install Samsung Drivers (if you have them installed you can skip this step)
    3. Go to settings/Developer options and enable OEM unlock (If you don't see developer settings, go into Settings/About phone/Software info and tap "Build number" 10 times to show Developer options menu)
    4. Download TWRP_*.tar
    5. Switch off the phone
    6. Use Bixby Key+Volume Down+Power to enter Download Mode and connect the device to usb
    7. Open Odin and untick autoreboot in "options" tab. Also make sure that your device is detected
    8. Put TWRP_*.tar.md5 file into AP tab
    9. Click Start
    10. When Odin shows "PASS", take your device in hands, disconnect the usb cable and press simultaneously the "Bixby key" + "Vol. Down" + "Power" buttons until the downoad mode disappears
    11. At the precise moment the screen becomes black, immediately release the "Vol.Down" button and press the "Bixby key" + "Vol. UP" + "Power" buttons during 10 to 15sec to forcefully enter TWRP
    12. If it didn`t worked, redo the steps from #1 more careful this time.

    TWRP
    • Download TWRP_*.img, push it into phone storage, choose install image in your current recovery, navigate to downloaded *.img file, select it, select to flash as recovery.
    After booting in TWRP download and flash no-verity-opt-encrypt-6.1 zip to disable data partition encryption
    If for any reason you fail to install TWRP multiple times/different methods, make sure you check this thread


    Sources:
    Credits:
    • TeamWin, jesec, geiti94, dyneteve, testers, donors and anyone else involved in making this possible
    10
    FAQ / Further reading
    Q: TWRP can't mount data partition, what to do?
    A: Make sure you formatted data partition.

    Q: Phone is not booting even after 20 minutes
    A: Try to reboot. If still not booting, make sure you formatted data partition.

    Q: How to format data partition?
    A:
    ymlnQUE.jpg


    Q: Phone is showing only Samsung logo
    A: Try to reboot. If still not booting, consider installing an older TWRP build or a more recent firmware.

    Q: I get "Failed to mount /preload message", what to do?
    A: From wipe menu select Advanced Wipe, select preload partition to be wiped and reboot recovery.

    Q: Why do i need to format data partition?
    A: Because old rom encrypted your data partition and new rom can't decrypt and use that content / root needs access to data partition to place misc files / phone not booting after flashing root until data partition gets formatted.
    1
    Is there anyone who got TWRP 3.4.0 working with encryption on a Samsung Galaxy S9?

    My experiences after 1 hard week:
    1. On Stock: TWRP always showed an unlock option via PIN, but it was never able to decrypt (neither default_password, nor disabling lockscreen, nor setting another PIN/Password in locksetings helped)
    2. On Magisk: TWRP never showed an unlock option & was never able to decrypt
    3. Only option was to disabled encryption --> the old encryption disabler from OP doesn't work, updated Disable_Dm-Verity_ForceEncrypt_03.04.2020 has to be used ( https://forum.xda-developers.com/an...rceencrypt-t3817389/post77091359#post77091359 ) --> patter lock & fingerprint cannot be used in the future

    A little disappointing considering that the unlock option of TWRP & changelog suggests that decrypting should work.

    @moocou
    BTW: Put TWRP_*.tar file into AP tab