[RECOVERY] [OFFICIAL] TWRP 3.2.1-0 for Xiaomi Redmi 4A [rolex] [20171210]

Search This thread
Sep 27, 2016
Xiaomi Redmi 8
I bought this device some days ago and I have the same problem with red/blue line. I tried many different twrp recoveries for this device and the only one which works is cofface_recovery_redmi4A_test. I also tried redwolf' s recovery after I read this thread, which also has this problem.
Try this? - https://androidfilehost.com/?fid=818070582850510950

I don't have the link but as another one that works has a name of twrp-rolex-vendor-v3.img
  • Like
Reactions: mpliax and fedz14
Jun 2, 2017
Quezon City
Version 3.2.2 is random restarting when flashing. Thanks a lot

---------- Post added at 12:17 PM ---------- Previous post was at 12:16 PM ----------

version 3.2.2 is random restarting when flashing. Thanks a lot


Senior Member
Jan 2, 2007
I could not locate it. Do you can share the link?

I think I found it on 4pda.ru. I must check again because I don' t use it. I found a way to use the other twrps which don't work. Using Carliv image kitchen I unpack both the non working twrp and the original recovery.img and then I just replace the file "recovery.image.kernel" in unpacked twrp with the one from the original recovery. After that I repack the twrp and then is working fine on my device. The only problem is that takes about 20 secs to boot, but I had this problem in all the working twrps I tried too.

the file is here, but I think you need to register before you can download, which is not so easy if you don't know russian.
Last edited:
  • Like
Reactions: mpliax


New member
Sep 24, 2018
Make a video upon it...........
There are many videos are available on youtube but not in this method...


Senior Member
Dec 9, 2014
  • Merge AOSP 9.0 r3 (Dees_Troy)
  • Use ANDROID_ROOT variable instead of hard coding to /system (CaptainThrowback)
  • Decrypt FBE on 9.0 and metadata decrypt (Dees_Troy)
  • vold decrypt updates (CaptainThrowback and nijel8)
  • Support vibration on LED class devices (notsyncing)
  • Metadata decrypt support for Pixel 3 (Dees_Troy)
  • Support rotating the display via build flag (vladimiroltean)
  • Reboot to EDL mode button (mauronofrio)
  • Support MTP on FFS devices (bigbiff)
  • Update FDE decrypt to support keymaster 3 and 4 (Dees_Troy)
  • Detect mkfs.f2fs version to properly format on f2fs partitions (Dees_Troy)
  • Allow TWRP to use md5 and sha256 checksums for zip installs (bigbiff)
  • TWRP can use /data/cache/recovery and /persist/cache/recovery on AB devices with no cache partition (bigbiff)
  • Switch part of advanced menus in TWRP to use a listbox of options (Dees_Troy)
  • Use magiskboot to allow repacking boot images for installing TWRP (Dees_Troy with thanks to topjohnwu of course)


Senior Member
Dec 9, 2014
I tried latest version and don't work well for me, its imposible to wipe anything and get MUI stock on bootloop.

Any ideas?

From the TWRP page:
This device uses dm-verity!
This means that swiping to allow system modifications will prevent you from being able to boot if you are using the stock kernel. In order to bypass dm-verity's boot prevention, you will have to install a kernel that has dm-verity disabled in the fstab.

If you're on stock MIUI/using stock kernel, you might need to flash this first: https://forum.xda-developers.com/showpost.php?p=71508559&postcount=3


New member
Feb 22, 2016
Touchscreen on TWRP doesn't work

I've been using stock MIUI till now, upgraded to the latest MIUI Global I've just unlocked my device using the Mi Unlock Tool and flashed the latest TWRP (twrp-3.3.1-0-rolex).
While I am able to boot into TWRP, the touchscreen refuses to respond, so I am unable to flash anything. I am able to verify that this is not a fault of the touchscreen, since I am still able to boot into MIUI, and that works fine.
What could the issue be?


Senior Member
Edit: looks like the problem was not related to the /data partition.
Data partition unreadable was caused by QUOTA feature of ext4 which seems to be used in Android 9 Pie. I solved the problem by DD zeros into the partition, then formatting it manually to ext2, afterwards formatting to ext4 using TWRP. TWRP still does not show a screen. I installed PBRP again through fastboot. Everything fine now

But still: wiping or formatting DATA should *NOT* depend on TWRP able to mount it.

original post:

TWRP does not show a screen, only vertical bars.
Phone: Redmi 4A (rolex)
OS: PixelExperience 9
TWRP: 3.3.1

I had PBRP installed, but this messed up the data partition somehow and is not able to wipe or format the /data partition.
Since the PBRP logs are rather messed up (all the time trying to mount data) I went back to TWRP.
But TWRP shows only vertical bars.
I installed TWRP twice, once from PBRP through install image, then via fastboot as shown in this thread.
System still boots fine, /data is not encrypted.

any idea?

BTW: TWRP version shown in first post is outdated.


I attached to ADB and fetched /tmp/recovery.log:
ro.bootimage.build.date=Tue May 21 05:16:42 UTC 2019

SELinux contexts loaded from /file_contexts
Full SELinux support is present.
tw_get_context failed to get selinux context
I:Failed to get default contexts and file mode for storage files.
I:Copying file /cache/recovery/log to /cache/recovery/last_log
I:Unable to mount '/data'
I:Actual block device: '/dev/block/mmcblk0p49', current file system: 'ext4'
I:Unable to mount '/data'
I:Actual block device: '/dev/block/mmcblk0p49', current file system: 'ext4'
Unable to mount /data/media/TWRP/.twrps
I:Attempt to load settings from settings file...
I:InfoManager file '/data/media/TWRP/.twrps' not found.
I:Backup folder set to '/data/media/TWRP/BACKUPS/67c1c2b47d24'
I:Copying file /etc/recovery.fstab to /cache/recovery/recovery.fstab
I:Version number saved to '/cache/recovery/.version'
I:Unable to mount '/data'
I:Actual block device: '/dev/block/mmcblk0p49', current file system: 'ext4'
I:Unable to mount '/usb-otg'
I:Actual block device: '', current file system: 'auto'
I:TWFunc::Set_Brightness: Setting brightness control to 255
I:PageManager::LoadFileToBuffer loading filename: '/twres/languages/en.xml' directly
parsing languageFile
parsing languageFile done
I:Translating partition display names
I:Backup folder set to '/data/media/TWRP/BACKUPS/67c1c2b47d24'
I:Check_Lifetime_Writes result: '42669'
I:Switching packages (TWRP)
I:Starting Adb Backup FIFO
I:Set page: 'main'
I:Set page: 'clear_vars'
I:Set page: 'main2'
I:TWFunc::Set_Brightness: Setting brightness control to 5
I:TWFunc::Set_Brightness: Setting brightness control to 0
Last edited:


Oct 18, 2014
i have a problem

hi, i flashed twrp and when i enter in recovery it shows internal storage 0mb (cant access to storage via twrp)

Top Liked Posts

  • There are no posts matching your filters.
  • 19
    Team Win Recovery Project 3.x, or twrp3 for short, is a custom recovery built with ease of use and customization in mind. Its a fully touch driven user interface no more volume rocker or power buttons to mash. The GUI is also fully XML driven and completely theme-able. You can change just about every aspect of the look and feel.

    CHANGELOG for 3.2.1-0:
    • minui fixes (cryptomilk)
    • Better android-8.0 compatibility in ROM trees (Dees_Troy)
    • Fix missing library in android-8.0 (nkk71)
    • Fix inconsistent SDCard naming (DevUt)
    • Default to TWRP restore instead of adb backup restore to fix restore on fresh TWRP boot (jlask)

    CHANGELOG for 3.1.1-0:
    • Backups will now include adopted storage keys (Dees_Troy)
    • Fixed an adb restore issue (bigbiff)
    • Fixed rebooting when no OS is present (Dees_Troy)
    • Fixed line wrapping in the GUI terminal (_that)
    • Updated TWRP source code to AOSP 7.1.2 (Dees_Troy)Updated TWRP source code to AOSP 7.1.2

    CHANGELOG for 3.1.0-0:
    • vold decrypt on a few select HTC devices, TWRP will now attempt to use the system partition's vold and vdc binaries and libraries to decrypt the data partition (nkk71 and CaptainThrowback)
    • adb backup to stream a backup directly to or from your PC, see documentation here (bigbiff)
    • tweak MTP startup routines (mdmower)
    • support new Android 7.x xattrs for backup and restore to fix loss of data after a restore (Dees_Troy)
    • support POSIX file capabilities backup and restore to fix VoLTE on HTC devices and possibly other issues (Dees_Troy)
    • better indicate to users that internal storage is not backed up (Dees_Troy)
    • improve automatic determination of TW_THEME (mdmower)
    • minimal getcap and setcap support (_that)
    • try mounting both ext4 and f2fs during decrypt (jcadduono and Dees_Troy)
    • shut off backlight with power key (mdmower)
    • timeout during FDE decrypt (Dees_Troy and nkk71)
    • support for FBE decrypt and backing up and restoring FBE policies (Dees_Troy)
    • boot slot support (Dees_Troy)
    • TWRP app install prompt during reboot (Dees_Troy)
    • support for AB OTA zips (Dees_Troy)
    • support new Android 7.x log command (Dees_Troy)
    • update recovery sources to AOSP 7.1 (Dees_Troy)
    • numerous bugfixes and improvements by too many people to mention

    DOWNLOADS: twrp-3.2.1-0-rolex.img

    • Fastboot Method :
      fastboot flash recovery twrp-3.2.1-0-rolex.img
    • Boot to OLD TWRP > INSTALL > Select Image > Navigate to twrp-3.2.1-0-rolex.img > Select it & Swipe to Flash

    • TeamWin
    • CyanogenMod/Lineage Android
    • Hyper

    XDA:DevDB Information
    [RECOVERY] [OFFICIAL] TWRP 3.2.1-0 for Xiaomi Redmi 4A [rolex] [20171210], Tool/Utility for the Android General

    Source Code: http://github.com/omnirom

    Version Information
    Status: Stable

    Created 2017-03-20
    Last Updated 2017-12-10

    Change log:
    • Backups will now include adopted storage keys (Dees_Troy)
    • Fixed an adb restore issue (bigbiff)
    • Fixed rebooting when no OS is present (Dees_Troy)
    • Fixed line wrapping in the GUI terminal (_that)
    • Updated TWRP source code to AOSP 7.1.2 (Dees_Troy)Updated TWRP source code to AOSP 7.1.2
    • Official branding :p

    Download links in Post #1
    TWRP updated!

    * Update to N kernel.

    Downloads: https://twrp.me/xiaomi/xiaomiredmi4a.html

    Note: Use twrp-3.1.1-1-rolex.img for MIUI N or Custom Roms based on it & use twrp-3.1.1-0-rolex.img for MIUI M or Custom Roms based on it.