[RECOVERY] [OFFICIAL] TWRP for Shield Android TV

Search This thread

Rey3000

Member
Feb 21, 2020
29
2
hi, I rooted the NVS Pro 2019. I used image 8.2.2 and vbmeta_skip from 8.1.0.
Worked fine, Magsikhide showed up under settings and it passed the safetynet test.

However, I let it upgrade to 8.2.3 and now there is no more Magiskhide under settings and it's not passing the safetynet test.

What can I do? thank you!!
 

justwantrootonce

New member
Sep 6, 2021
2
0
I'll try to make it more clear lol...

1) Reboot to bootloader to start fresh...
a) fastboot flash staging blob
b) fastboot flash boot boot.img
c) fastboot flash recovery recovery.img
d) fastboot flash system system.img
e) fastboot flash vendor vendor.img
f) fastboot flash dtb mdarcy.dtb.img
g) fastboot flash vbmeta vbmeta_skip.img
h) fastboot -w
i) fastboot reboot bootloader

2) Now we will boot to twrp and install magisk...
a) fastboot boot twrp.img
b) select mount and mount everything it lets you (usually data, system_root, vendor, cache)
c) adb remount all
d) adb shell
e) rm /system (removes symlinked folder)
f) mkdir /system
f) mount -o bind /system_root/system /system
g) exit
h) adb push magisk-debug.zip /data/media
i) In twrp press install and navigate to magisk zip and flash it
j) adb reboot bootloader
k) fastboot -w
l) fastboot reboot bootloader
m) fastboot flash dtb mdarcy.dtb.img
n) fastboot flash vbmeta vbmeta_skip.img
o) fastboot reboot

3) Device might reboot a few times but eventually loads.. when it does follow these steps
a) Enable usb debugging
b) make sure its authorized and connected
c) adb install -g magisk.apk
d) adb shell
e) su (grant root to shell when it pops up)
f) mount -o rw,remount /
g) Open magisk.apk on the device
h) When it pops up telling you it needs to install stuff select ok and install it.. device will reboot in 5 seconds...

4) When device tries to boot you should now be stuck at the android boot ani (NOT the nvidia logo).. then follow these steps..
a) adb shell
b) su
c) resetprop ro.boot.verifiedbootstate orange
d) after device boots run: resetprop ro.boot.verifiedbootstate green

After all this, you should be good to go finally lol.. it seems like a lot but its not really.. then eventually we will get proper stuff goin..

let me kno if these steps dont work.. b sure to follow to the T.. once to this point u only need to set bootstate to orange for it to boot all the way then u can set back to green.. i tried havin a script set to orange n works but so far havent found a way to set orange then after loads back to green automatically yet.. im sure theres a simple script with a pause or somethin that can be used tho
ok i have followed these steps but a few things are not happening quite the way you say they will:
1) adb install -g magisk.apk--- i get no directory found, so i have to take out the individual apk file out of the zip file and put it directly on my cmd folder, then it works, is this right?
2) after telling magisk to continue set up, you say it gets stuck on the android logo,,,,, mine didn't get stuck, it just loaded like normal.... why?

The thing is, adb shell, su seems to work, shell gets granted, so is this good enough am i rooted? whats a way to be sure that i am rooted once i am at the home screen?
Yes i am noob
 

justwantrootonce

New member
Sep 6, 2021
2
0
I'll try to make it more clear lol...

1) Reboot to bootloader to start fresh...
a) fastboot flash staging blob
b) fastboot flash boot boot.img
c) fastboot flash recovery recovery.img
d) fastboot flash system system.img
e) fastboot flash vendor vendor.img
f) fastboot flash dtb mdarcy.dtb.img
g) fastboot flash vbmeta vbmeta_skip.img
h) fastboot -w
i) fastboot reboot bootloader

2) Now we will boot to twrp and install magisk...
a) fastboot boot twrp.img
b) select mount and mount everything it lets you (usually data, system_root, vendor, cache)
c) adb remount all
d) adb shell
e) rm /system (removes symlinked folder)
f) mkdir /system
f) mount -o bind /system_root/system /system
g) exit
h) adb push magisk-debug.zip /data/media
i) In twrp press install and navigate to magisk zip and flash it
j) adb reboot bootloader
k) fastboot -w
l) fastboot reboot bootloader
m) fastboot flash dtb mdarcy.dtb.img
n) fastboot flash vbmeta vbmeta_skip.img
o) fastboot reboot

3) Device might reboot a few times but eventually loads.. when it does follow these steps
a) Enable usb debugging
b) make sure its authorized and connected
c) adb install -g magisk.apk
d) adb shell
e) su (grant root to shell when it pops up)
f) mount -o rw,remount /
g) Open magisk.apk on the device
h) When it pops up telling you it needs to install stuff select ok and install it.. device will reboot in 5 seconds...

4) When device tries to boot you should now be stuck at the android boot ani (NOT the nvidia logo).. then follow these steps..
a) adb shell
b) su
c) resetprop ro.boot.verifiedbootstate orange
d) after device boots run: resetprop ro.boot.verifiedbootstate green

After all this, you should be good to go finally lol.. it seems like a lot but its not really.. then eventually we will get proper stuff goin..

let me kno if these steps dont work.. b sure to follow to the T.. once to this point u only need to set bootstate to orange for it to boot all the way then u can set back to green.. i tried havin a script set to orange n works but so far havent found a way to set orange then after loads back to green automatically yet.. im sure theres a simple script with a pause or somethin that can be used tho
ok just found out that some of this stuff doesn't seem to be needed
that resetprop stuff i didn't do at all, i downloaded droidmote(root acces required, opened it and pop asked to grant su and i did so i don't understand why because i'll restart shield, let it just boot, at homescreen, do adb shell, su.... thats it
 

MuadDib6

Senior Member
hi, I rooted the NVS Pro 2019. I used image 8.2.2 and vbmeta_skip from 8.1.0.
Worked fine, Magsikhide showed up under settings and it passed the safetynet test.

However, I let it upgrade to 8.2.3 and now there is no more Magiskhide under settings and it's not passing the safetynet test.

What can I do? thank you!!
I believe this is why
 
  • Like
Reactions: Rey3000

C-Rooted

Member
Dec 28, 2015
9
2
Question:
https://www.reddit.com/r/nvidiashield/comments/ptpd7n/install_twrp_by_modifying_the_developer/
Would it be possible to modify the nv-recovery-image-sheild-2019-atv-x.x.x.zip from the nvidia devs website to install TWRP on the Nvidia Shield 2019 (Tube) to get around not having a usb port for fastboot.

Also if it works control TWRP using remote that came with my samsung tv using CEC or plug in a keyboard/mouse to the tv.

Asked this question on reddit got no reply.

Has anything like this method been attempted?
 

Adromir

Senior Member
Somehow I am not able to install TWRP on my Shield 2017 when I boot into it with

fastboot boot twrp-3.5.2_9-0-foster.img

it boots into it, but the screen flickers. When i try to flash it via

fastboot flash recovery twrp-3.5.2_9-0-foster.img

and reboot to recovery it always shows the nvidia recovery

The LineageOS Recovery seems to work though
 

Zer0_rulz

Senior Member
Dec 22, 2014
74
9
this guide will work on nvidia shield tv pro 2017?
sorry for a newbie question but i cant find answer to my question, ty
 

Shamoth

Member
Oct 4, 2014
9
3
What is wrong with twrp-3.6.0_9-0-foster.img ?
twrp-3.5.2_9-0-foster.img works fine, can access and format memory/data while twrp-3.6.0_9-0-foster.img have no access to it.
 

masset12

Member
Oct 9, 2021
14
5
Hi,

I have mdarcy running 9.0.0 (android 11)

I debloated the rom and have set it up with no google account.
Twrp, Magisk, Afwall, MicroG, Adaway and Vpn fully working

I made a Twrp Backup as usual (with no error) but I can't have the shield booting after restoring it.
I have tried with several backups, I can restore them fine on 8.2.3 but on 9.0.0, the shield bootloop after the nvidia logo.

I also tried different ways of restoring : after just a factory reset, after a full wipe, after format data and even dirty restore without wiping anything.

I tried to fastboot flash mdarcy.dtb + vbmeta_skip after resrtoring but didn't help.

Does someone know what I should do to make my shield booting after restoring my Twrp backup ?
(I'm using twrp-3.6.0_9-0-mdarcy)

Many thanks for help :)

Edit : I figured out I have to restore everything but Sytem and System Image in Twrp, then reboot bootloader, fastboot flash system.img + mdarcydtb.img + vbmeta_skip.img then reboot
(just have to debloat/remove google crap once again)
 
Last edited:
  • Like
Reactions: mrhamed

Steel01

Recognized Developer
Dec 14, 2008
1,313
2,862
What is wrong with twrp-3.6.0_9-0-foster.img ?
twrp-3.5.2_9-0-foster.img works fine, can access and format memory/data while twrp-3.6.0_9-0-foster.img have no access to it.
The first 3.6.0 build had build system issues. Those have been resolved and foster has been re-built. Should be good now.
 
  • Like
Reactions: Mogster2K

mrhamed

Senior Member
Apr 19, 2014
440
41
Hi,

I have mdarcy running 9.0.0 (android 11)

I debloated the rom and have set it up with no google account.
Twrp, Magisk, Afwall, MicroG, Adaway and Vpn fully working

I made a Twrp Backup as usual (with no error) but I can't have the shield booting after restoring it.
I have tried with several backups, I can restore them fine on 8.2.3 but on 9.0.0, the shield bootloop after the nvidia logo.

I also tried different ways of restoring : after just a factory reset, after a full wipe, after format data and even dirty restore without wiping anything.

I tried to fastboot flash mdarcy.dtb + vbmeta_skip after resrtoring but didn't help.

Does someone know what I should do to make my shield booting after restoring my Twrp backup ?
(I'm using twrp-3.6.0_9-0-mdarcy)

Many thanks for help :)

Edit : I figured out I have to restore everything but Sytem and System Image in Twrp, then reboot bootloader, fastboot flash system.img + mdarcydtb.img + vbmeta_skip.img then reboot
(just have to debloat/remove google crap once again)
Thank you for sharing your experience, I have some questions:
- which vbmeta_skip.img file? as I know the v9.0.0 does not contains "vbmeta_skip.img" file, right? can you share file here please?
- how debloat/remove google on v9.0.0? can you explain detail more? can you skip google sign in? ( I tried by modifying build.prop but not success )
- how install Magisk? I install Magisk and device no boot! did you flash "vbmeta_skip.img" file?
- how install microg? I install microg magisk module on LineageOS 17 but I encountered black screen!
- also I install official microG release: https://download.lineage.microg.org/mdarcy/lineage-17.1-20220110-microG-mdarcy.zip but I encountered black screen too!
 

madmacc

Member
Jan 31, 2018
6
1
HI Guys , I would like to install twrp recovery, I have a 2017 Shield 16gb, with this boot loader currently,
What version twrp should I use: shield model P2897
 

Attachments

  • sh1.PNG
    sh1.PNG
    323 KB · Views: 21
Last edited:

rchris494

Senior Member
May 7, 2011
208
48
Reboot to twrp and adb sideload magisk.apk

HI Guys , I would like to install twrp recovery, I have a 2017 Shield 16gb, with this boot loader currently,
What version twrp should I use: shield model P2897
i use twrp-3.6.1_9-0-foster.img for experience 9.0. i don't install it. no real reason to. i just fastboot boot twrp-3.6.1_9-0-foster.img then do what i need to do. then reboot my nvidia 2017 16gb. if your looking to root. magisk 24.3.apk works just fine. i boot twrp set it to sideload then adb sideload magisk.zip i renamed the .apk to .zip but you don't really need to. i am using the developer image from nvidia. i use to install twrp on all my devices but you can do everything you need to do just by booting it. so i stopped trying to install it. then getting caught into a bootloop, no boot or twrp just wont stay as recovery.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 16
    Team Win Recovery Project 3.x, or twrp3 for short, is a custom recovery built with ease of use and customization in mind. Its a fully touch driven user interface no more volume rocker or power buttons to mash. The GUI is also fully XML driven and completely theme-able. You can change just about every aspect of the look and feel.



    DOWNLOAD:
    Most devices can be updated quickly and easily within TWRP if you already have version 2.8.4.0 or higher installed
    1) Download the latest version from our website on your device
    2) Reboot to TWRP
    3) Hit Install and tap the "Images..." button in the lower right
    4) Browse to the location of the TWRP image on your device and select it
    5) Select recovery from the partition list and swipe to flash
    OR:
    You can find more information and download links on our website.
    SHIELD Android TV 2015/2017 direct link
    SHIELD Android TV 2019 direct link

    BUGS:
    If you have found a bug, please consider posting it to our github issues log. It's pretty much impossible for us to keep up with the more than 40 threads that we have for the devices that we "directly" support. If you have a significant problem that cannot be answered in this thread, contact us via our website, or find us in our IRC channel below. If you see someone that's struggling, feel free to point it out to us. We need your help to help us keep track of all of our devices! Thanks!

    SUPPORT:
    Live support is available via #twrp on Freenode with your IRC client or just click this link.
    7
    So we *finally* got kernel source (but not vendor prebuilts, go figure... ><). Spent a while tonight getting stuff together and have an experimental build working on the newer bootloader. Do note that I've only tested this on foster_e_hdd, but it should work on all variants that actually got the newer bootloader. Namely foster_e, foster_e_hdd, and darcy. I haven't even got the new bootloader to boot on the Jetson TX1, unfortunately. As normal, since this is an experimental build, use at your own risk, report problems, blah blah.

    twrp-20190201-foster-experimental.img
    5
    I'll try to make it more clear lol...

    1) Reboot to bootloader to start fresh...
    a) fastboot flash staging blob
    b) fastboot flash boot boot.img
    c) fastboot flash recovery recovery.img
    d) fastboot flash system system.img
    e) fastboot flash vendor vendor.img
    f) fastboot flash dtb mdarcy.dtb.img
    g) fastboot flash vbmeta vbmeta_skip.img
    h) fastboot -w
    i) fastboot reboot bootloader

    2) Now we will boot to twrp and install magisk...
    a) fastboot boot twrp.img
    b) select mount and mount everything it lets you (usually data, system_root, vendor, cache)
    c) adb remount all
    d) adb shell
    e) rm /system (removes symlinked folder)
    f) mkdir /system
    f) mount -o bind /system_root/system /system
    g) exit
    h) adb push magisk-debug.zip /data/media
    i) In twrp press install and navigate to magisk zip and flash it
    j) adb reboot bootloader
    k) fastboot -w
    l) fastboot reboot bootloader
    m) fastboot flash dtb mdarcy.dtb.img
    n) fastboot flash vbmeta vbmeta_skip.img
    o) fastboot reboot

    3) Device might reboot a few times but eventually loads.. when it does follow these steps
    a) Enable usb debugging
    b) make sure its authorized and connected
    c) adb install -g magisk.apk
    d) adb shell
    e) su (grant root to shell when it pops up)
    f) mount -o rw,remount /
    g) Open magisk.apk on the device
    h) When it pops up telling you it needs to install stuff select ok and install it.. device will reboot in 5 seconds...

    4) When device tries to boot you should now be stuck at the android boot ani (NOT the nvidia logo).. then follow these steps..
    a) adb shell
    b) su
    c) resetprop ro.boot.verifiedbootstate orange
    d) after device boots run: resetprop ro.boot.verifiedbootstate green

    After all this, you should be good to go finally lol.. it seems like a lot but its not really.. then eventually we will get proper stuff goin..

    let me kno if these steps dont work.. b sure to follow to the T.. once to this point u only need to set bootstate to orange for it to boot all the way then u can set back to green.. i tried havin a script set to orange n works but so far havent found a way to set orange then after loads back to green automatically yet.. im sure theres a simple script with a pause or somethin that can be used tho
    5
    Can you please detail your workaround method to use magisk?

    Thanks

    1) download the developer/stock OS from nvidia
    2) unpack .zip and find boot.img
    3) use the NSTV or another android device and install the magisk manager app
    4) in the app: click install
    5) in the app: choose patch boot.img
    6) in the app: remember the outpot path from the terminal log to the patched_boot.img
    7) boot to recovery (TWRP) and install/flash the patched_boot.img to boot partition
    5
    I also have a working configuration, run into a loop again but so tried some extra steps 2q trough 2w. Also I had registered for the hotfix and installed that, after that I had to do some extra steps to get root back again. After that I was fully able to use root with all it's magic. And disabling Dolby processing solved the glitchy Netflix, which doesn't matter since you don't lose Dolby sound anyway.

    Thank you @elliwigy for all your guiding in this process and @rootfan for the magisk version, now I have root and the wife still has Netflix, look like a win-win to me.

    Below are the steps I used based on your guide for the Shield 2019 PRO

    1) Reboot to bootloader to start fresh...(you will need a keyboard)
    a) fastboot oem unlock and confirm by pressing A
    b) fastboot flash staging blob
    c) fastboot flash boot boot.img
    d) fastboot flash recovery recovery.img
    e) fastboot flash system system.img
    f) fastboot flash vendor vendor.img
    g) fastboot flash dtb mdarcy.dtb.img
    h) fastboot flash vbmeta vbmeta_skip.img
    i) fastboot -w
    j) fastboot reboot bootloader

    2) Now we will boot to twrp and install magisk...
    a) fastboot boot twrp.img (you will need a mouse for this)
    b) select mount and mount everything it lets you (usually data, system_root, vendor, cache)
    c) adb remount all
    d) adb shell
    e) rm /system (removes symlinked folder)
    f) mkdir /system
    g) mount -o bind /system_root/system /system
    h) exit
    i) adb push magisk-debug.zip /data/media
    j) In twrp press install and navigate to magisk zip and flash it
    k) adb reboot bootloader
    l) fastboot -w
    m) fastboot reboot bootloader
    n) fastboot flash dtb mdarcy.dtb.img
    o) fastboot flash vbmeta vbmeta_skip.img
    p) fastboot reboot

    ------------------------------------------
    q) let it reboot a couple of times, after Nvidia blinks and then reboots).
    r) start shield with A+B pressed to get in fastboot
    s) in fastboot menu select reset factory default.
    t) fastboot flash dtb mdarcy.dtb.img
    u) fastboot flash vbmeta vbmeta_skip.img
    v) fastboot reboot
    w) let it reboot a couple of time
    --------------------------------------------

    3) Device eventually loads.. when it does follow these steps
    a) Enable usb debugging
    b) make sure its authorized and connected
    c) adb install -g magisk.apk
    d) adb shell
    e) su (grant root to shell when it pops up)
    f) mount -o rw,remount /
    g) Go to apps (trough settings), show all apps, start/open magisk manager
    h) When it pops up telling you it needs to install stuff select ok and install it.. device will reboot in 5 seconds...

    4) When device tries to boot you should now be stuck at the android boot ani (NOT the nvidia logo).. then follow these steps..
    a) adb shell
    b) su
    c) resetprop ro.boot.verifiedbootstate orange
    d) after device boots run: resetprop ro.boot.verifiedbootstate green

    5) If you have registerd for the hotfix (32.7.301.43) then you can start the upgrade now. The device will reboot and starts the upgrade, after that you lost root again.
    a) adb reboot bootloader
    b) fastboot boot twrp.img (you will need a mouse for this)
    c) select mount and mount everything it lets you (usually data, system_root, vendor, cache)
    d) adb remount all
    e) adb shell
    f) rm /system (removes symlinked folder)
    g) mkdir /system
    h) mount -o bind /system_root/system /system
    i) exit
    j) adb push magisk-debug.zip /data/media
    k) In twrp press install and navigate to magisk zip and flash it
    l) adb reboot bootloader
    m) fastboot flash dtb mdarcy.dtb.img
    n) fastboot flash vbmeta vbmeta_skip.img
    o) fastboot reboot
    p) When device tries to boot you should now be stuck at the android boot ani (NOT the nvidia logo).. then follow these steps..
    q) adb shell
    r) su
    s) resetprop ro.boot.verifiedbootstate orange
    t) after device boots run: resetprop ro.boot.verifiedbootstate green

    For others, we used to images mentioned in this post.
    https://forum.xda-developers.com/shield-tv-pro/help/nvidia-shield-2019-pro-developer-images-t4012147

    All file from nv-recovery-image-shield-atv-pro-2019-8.1.0.zip expect vbmeta_skip.img that is from nv-recovery-image-shield-atv-pro-2019-8.1.0-dev-rooted.zip

    Experimental TWRP is from https://forum.xda-developers.com/showpost.php?p=80769929&postcount=312

    Magisk is from https://forum.xda-developers.com/showpost.php?p=81067077&postcount=352

    All the credits are for @elliwigy and @rootfan