[RECOVERY] [OFFICIAL] TWRP for Shield Tablet

Search This thread

Steel01

Recognized Developer
Dec 14, 2008
1,337
2,892
Oh, the adopted storage issue again. :meh: Well, that *should* have worked on 3.2.3-0. There had been some issues with a few of the twrp releases using older versions of my device tree, so that's where I would have assumed the problem came from. But 3.2.3-0 should have had that fixed. I don't personally use adopted storage, so I have to go out of my way to test it. I'll try to find some time over the weekend to set that up on one of my test tablets and see what's going on.
 

Adai0

Senior Member
Mar 8, 2010
89
22
Nexus 7 (2013)
Google Nexus 5
Oh, the adopted storage issue again. :meh: Well, that *should* have worked on 3.2.3-0. There had been some issues with a few of the twrp releases using older versions of my device tree, so that's where I would have assumed the problem came from. But 3.2.3-0 should have had that fixed. I don't personally use adopted storage, so I have to go out of my way to test it. I'll try to find some time over the weekend to set that up on one of my test tablets and see what's going on.

Any chance to help you? I'd be ready to do a test :) Also, is there a version known to be working so that it is possible to compare the sources? I've found a working version from BitO BSessiOn (TWRP_3.1.0-0_multirom_shieldtablet_20170324-02_BitO BSessiOn.img) though no sources. Although I've never been built TWRP yet, but I'd be willing to learn something new and give it a try ;)
 

gullkhan0

Senior Member
Aug 29, 2011
79
23
Vienna
I tried the latest version twrp-3.2.3-0-shieldtablet.img but the adopted storage is not detected, is this right? I'm looking for a versione higher than 3.1.0.0 to use with TWRP backup tool to backup directly to PC. I found a modified 3.1.0.2 version that works but I would like to use an official and updated version.

Do you mean you can't access various folders or some are missing in TWRP? If that's so, I'm having same trouble as you. Could you please post the link to the modified recovery you mentioned, thank you.
 

skorpiodav

Member
Jul 26, 2017
10
0
Do you mean you can't access various folders or some are missing in TWRP? If that's so, I'm having same trouble as you. Could you please post the link to the modified recovery you mentioned, thank you.

The issue is TWRP can't see the external SD so is not possible to access its content.
Sadly I'm not able to find the source but it was a post from Xda, the version I'm using is named: TWRP_3.1.0-2_multirom_shieldtablet_20170415-01.img can't attach it because it is too big but probably you can find it online or maybe you can find the original post (I'll try to find it again when I have more time).
 

gullkhan0

Senior Member
Aug 29, 2011
79
23
Vienna
The issue is TWRP can't see the external SD so is not possible to access its content.
Sadly I'm not able to find the source but it was a post from Xda, the version I'm using is named: TWRP_3.1.0-2_multirom_shieldtablet_20170415-01.img can't attach it because it is too big but probably you can find it online or maybe you can find the original post (I'll try to find it again when I have more time).

Thanks. I tried it and it gets stuck at the splash screen whenever I try to run it. Gonna flash back the official version.
 

kbeezie

Senior Member
Feb 23, 2010
1,932
394
Grand Rapids, Mi
karlblessing.com
The issue is TWRP can't see the external SD so is not possible to access its content.
Sadly I'm not able to find the source but it was a post from Xda, the version I'm using is named: TWRP_3.1.0-2_multirom_shieldtablet_20170415-01.img can't attach it because it is too big but probably you can find it online or maybe you can find the original post (I'll try to find it again when I have more time).

I can choose MicroSD as a storage option, but course it's only going to show 15MB free, but that is because I've used my SD card formatted as internal/adopted storage. So I wouldn't expect TWRP to treat it as anything other than internal data (like how can you make a backup of "data" to a volume that's treated as a part of it).

I just assumed that if I had it as portable storage, TWRP would be able to see it.

I just been using an OTG cable and backing to an external 64GB or 128GB thumbdrive formated as exFat without any issues.
 

drewski_1

Senior Member
Jul 20, 2012
3,828
1,602
SF Bay Area, CA
I can choose MicroSD as a storage option, but course it's only going to show 15MB free, but that is because I've used my SD card formatted as internal/adopted storage. So I wouldn't expect TWRP to treat it as anything other than internal data (like how can you make a backup of "data" to a volume that's treated as a part of it).

I just assumed that if I had it as portable storage, TWRP would be able to see it.

I just been using an OTG cable and backing to an external 64GB or 128GB thumbdrive formated as exFat without any issues.

This is a couple months old post, but wanted to confirm that I can access my "portable storage" formatted SDCard for backups in TWRP with no issues.

Sent from my taimen using XDA Labs
 
Hey all - I have a bit of a problem, it's not TWRP caused, but wondered if there's a way to run a 'low level / non quick' format data on this device in twrp? I have three shield tabs and 2 of them format data within a few seconds, but one has always taken 15 minutes or longer. Format data finally completes on that device, but it seems like the regular format data command in twrp's gui isn't scrubbing deep enough (I assume it's just wiping the fat tablet or the android equivalent of quick format in the windows system) and I wanted to see if a low-level format might clear the error. Wasn't sure if toggling -rm vs -rf formatting in settings would be the key or not.
 
Last edited:

0mad

Member
Dec 1, 2015
13
3
East Coast, AUS
Hi team,
I've broken something and can't, for the life of me, figure out how to fix it.
I've got 2 Shield Tablets, one I tried to update TWRP via the app and the other in recovery mode (they were different versions of TWRP on each tablet). The one via recovery mode worked fine, the one via the app didn't. I now can't boot in recovery mode at all. I then reflashed the latest TWRP via PC, ADB said it was successful, but still won't reboot into recovery, just hangs on the NVIDIA logo.
Any ideas?
It still boots into the OS, but I wanted to update the OS to Lineage, hence doing TWRP first.

EDIT: 2 hrs later (such a waste of time)... I used the Play Store app to attempt to reflash the oldest image available for my device (v2.8.7.0) and it worked. Never using the app again.
 
Last edited:
  • Like
Reactions: fro03

Lorby87

New member
Aug 20, 2015
1
0
Hi team,
I've broken something and can't, for the life of me, figure out how to fix it.
I've got 2 Shield Tablets, one I tried to update TWRP via the app and the other in recovery mode (they were different versions of TWRP on each tablet). The one via recovery mode worked fine, the one via the app didn't. I now can't boot in recovery mode at all. I then reflashed the latest TWRP via PC, ADB said it was successful, but still won't reboot into recovery, just hangs on the NVIDIA logo.
Any ideas?
It still boots into the OS, but I wanted to update the OS to Lineage, hence doing TWRP first.

EDIT: 2 hrs later (such a waste of time)... I used the Play Store app to attempt to reflash the oldest image available for my device (v2.8.7.0) and it worked. Never using the app again.


I have the same issue! Installed TWRP from app to recovery and boot and it hans on the logo screen....Now I cannot access the OS. I can boot to fastboot and status of Device shows unlocked.
I tried to flash through PC with ADB but in the command prompt says "waiting for device". In device manager in Windows I can see the tablet as Other Devices--> Fastboot.
Can pleases someone help to resolve my issue?

Thank you

EDIT: Managed to flash TWRP version twrp-2.8.7.0-shieldtablet. The issue was whit drivers on PC in Device Manager. I installed then manually "Android Composite ADB Interface" and then did fastboot devices command in CMD and it found the device.
Then I flashed the 2.8.7.0 to recovery and it loaded. Now just have to figure out how to remove it from boot so I can load the OS.
EDIT 2: Still haven't been able to find the right boot.img. Downloaded the original Nvidia boot.img but still hang on logo screen. Does anyone know if I instal a new ROM (OS) will it override the boot img?
EDIT 3: Downloaded [ROM][UNOFFICIAL] Lineage 15.1 for Nvidia Shield Tablet OMX Fixed Camera Fixed and tried to flash with no success. Fund an issue with Updater process ended with ERROR: 7. I tried to fix the problem with updating TWRP to twrp-3.3.1-0 but it hang on logo screen.
Then I went from bottom to up and the only stable version of TWRP that loaded in recovery is twrp-3.1.1-0-shieldtablet. I tried to flash the ROM and the same error apered ERROR: 7. Any ideas what to do?
 
Last edited:

BenG7

Senior Member
Jun 24, 2009
549
70
Hi @Steel01
Hmmm... Boots fine for me. Which bootloader are you on? My fastboot screen lists 4.00.2016.04-8b2413b7. That should be the one I posted with my Lineage 14.1 builds, available on my AFH account.
Can you please tel me wich specific fastboot command you issue to get the bootloader version of the shield?
Thanks

[EDIT] found it at the top of the screen after rebooting to bootloader (adb reboot-bootloader)
 
Last edited:

john_matrix

Senior Member
Nov 22, 2008
424
108
France
Hello @Steel01,
There are some updates in your Gitlab repo concerning the Shield Tablet (and in the LOS17.1 & LOS18 branches).
Does it mean we can compile a build from it? or the HW acceleration is still broken for these LOS versions?

Thanks in advance!
 

Steel01

Recognized Developer
Dec 14, 2008
1,337
2,892
I still mess with the tablet from time to time. Another Lineage dev took a shot at getting 17.1 to boot, but with no more success than I had. 16.0 is mostly usable, but not completely stable. Nvmm (which provides hw audio/video acceleration) does work on 16.0, there have been unofficial builds of that for a while now.

As for twrp, the actually topic here... Twrp does not compile in Lineage 17.1 as of right now. So I can't update the tablet (or any other device I support) to the android-10.0 branch. The android-9.0 builds from a Lineage 16.0 tree work very well, though. Once some stuff settles on the Lineage gerrit, I'll be looking to push updated official builds. No guarantees on the timeline for that, though.
 

nuovagrafica

Senior Member
Sep 3, 2008
63
2
hello I need an old zipped version of TWRP for Nvidia Shield Tablet K1 because I'm not be able to flash img files
 

nuovagrafica

Senior Member
Sep 3, 2008
63
2
ok let's see if I can explain my issue in another way...

some time ago I had android 5.2 with TWRP and root permissions
now I'm on Android 7 and I'm not able to install TWRP and root permissions anymore

if I go in fastboot in my nvidia shield tablet K1 I have the first picture .
if from fastboot I go in recovery mode I have the second picture. the green robot.
if from the green robot I press volume up and power button I have the third image Android Recovey

does the green robot means TWRP is missed?

now if I try to flash twrp.img (4th picture) it says waiting for device and the tablet reboots in Android OS but TWRP is always missed

I'm sure if you can send me an old TWRP version in zip format I can solve or if you are able to convert TWRP.img into TWRP.zip

what do you suggest?

Can I at least have root permissions what file must I to install? can you provide me the correct link please?
 

Attachments

  • fastboot.jpg
    fastboot.jpg
    62.7 KB · Views: 47
  • green robot.jpg
    green robot.jpg
    29.8 KB · Views: 40
  • android recovery.jpg
    android recovery.jpg
    104.8 KB · Views: 42
  • twrp.jpg
    twrp.jpg
    107.3 KB · Views: 47

Top Liked Posts

  • There are no posts matching your filters.
  • 21
    Team Win Recovery Project 3.x, or twrp3 for short, is a custom recovery built with ease of use and customization in mind. Its a fully touch driven user interface no more volume rocker or power buttons to mash. The GUI is also fully XML driven and completely theme-able. You can change just about every aspect of the look and feel.



    DOWNLOAD:
    Most devices can be updated quickly and easily within TWRP if you already have version 2.8.4.0 or higher installed
    1) Download the latest version from our website on your device
    2) Reboot to TWRP
    3) Hit Install and tap the "Images..." button in the lower right
    4) Browse to the location of the TWRP image on your device and select it
    5) Select recovery from the partition list and swipe to flash
    OR:
    You can find more information and download links on our website.
    Direct device link

    BUGS:
    If you have found a bug, please consider posting it to our github issues log. It's pretty much impossible for us to keep up with the more than 40 threads that we have for the devices that we "directly" support. If you have a significant problem that cannot be answered in this thread, contact us via our website, or find us in our IRC channel below. If you see someone that's struggling, feel free to point it out to us. We need your help to help us keep track of all of our devices! Thanks!

    SUPPORT:
    Live support is available via #twrp on Freenode with your IRC client or just click this link.
    7
    The new version has been released with the adopted storage fix.
    7
    Here is twrp 3.0.0-1 for the shield tablet running the L bootloader ...

    I will update the OP later on today... :)

    https://www.androidfilehost.com/?fid=24411628330025347

    Thx Josh
    6
    Well, since @lj50036 now has a holey tablet, I finally bit the bullet and took maintainership. Got things sorted and we now have a new release. 3.0.2-1 has all the latest discoveries and changes merged in. It will boot on both bootloaders, all features should work, etc. We've requested the xda mods to transfer the thread to me. Once that happens, I'll get the OP updated with the new info. For now, just go to twrps website to pull the new release. And if there are any problems at all, please let me know.
    6
    New builds are up as of a few hours ago. And some issues should be fixed finally. Like, adopted storage should actually work. If any issues are found, new or old, please report them. I'm more easily able to push in updates and fixes now.