[RECOVERY][oneplus3] Unofficial TWRP 3.0.3-0 touch recovery for OnePlus 3

JohnHorus

Senior Member
Aug 26, 2012
387
88
0
Barrie
I haaate to post issues on xda but I'm desperate. I was just enjoying how my phone has been running for the past 3 months and I decided to make a twrp backup. Looked like all went well. I went to boot afterwards and it took forever, and gave me system force close issue. I tried restoring my backup and it looks like it's a permanant issue on that backup. I can restore to a backup from months ago but I get tons of crashes and google apps just don't work at all. I updated from twrp 3.0.2.0 to 3.0.3.0 and now I can see it tells me "E:Unable to find file system (first period)." and I've been searching through forums for hours, no luck. I really didn't wanna lose my perfect setup. I was running blissrom 6.3 (marshmallow based) and hadn't had any previous issues. I'm willing to do anything to get back my phone just how it was yesterday. If anyone has absolutely any experience it would be so greatly appreciated. Thank you!!!!
are you using this unofficial twrp? it uses a different kernel than the official, which handles F2FS differently
 

JohnHorus

Senior Member
Aug 26, 2012
387
88
0
Barrie
I've tried 3.0.2.0, 3.0.3.0, and 3.0.4.0 in combinations of official and unofficial, no luck so far.
that's weird that it happened after backing up. I guess just make sure to try 3.0.2 like you used to have, and restore backups. I couldn't tell you why it broke, you might just have to clean install. It will be faster than fighting with some obscure error if you just get it over with
 

f2bacon

Senior Member
Oct 20, 2011
429
79
0
Brooklyn NY
you might just have to clean install.
I was really really really trying to avoid that, I spent the last 3 months getting stuff set up so it's perfect I really didnt wanna start from scratch

---------- Post added 3rd February 2017 at 12:03 AM ---------- Previous post was 2nd February 2017 at 11:07 PM ----------

Update; I can get into the phone but it's very very slow, and I can only use apps (no settings, quick toggles, anything of that sort)
 
Last edited:

dianlujitao

Recognized Developer
Jan 27, 2013
721
4,722
133
Chengdu
www.dianlujitao.com
@dianlujitao Something weird happened for me while testing some unrelated issues I was having with recent builds of open gapps.
I'm usually not prompted to set encryption during setup, but when installing official lineage from 01-31 along with 02-02 gapps and the recent EX kernel update(2.0), I was. On entering TWRP, however, it failed to decrypt data!

I tried to test this without EX kernel installed, but I was unable to get it to prompt me to encrypt at setup again.

I know you can't support a custom kernel, but EX Kernel was just rebased on the latest Lineage kernel yesterday, and I remember you saying something about a new kernel in the lineage thread.

I was just wondering if you might know what the issue is, I thought perhaps the new lineage kernel is incompatible with the custom kernel you put in this TWRP.

Thanks for all your work on TWRP and Lineage, it's all very confusing right now and I appreciate you keeping our devices working! = )
No idea, kernel won't break decryption in theory.
 

JohnHorus

Senior Member
Aug 26, 2012
387
88
0
Barrie
No idea, kernel won't break decryption in theory.
Hmm. It decrypts with 3.0.4 installed, EX 2.0 and everything else the same. I would try to get some logs or something for you, but I finally got everything I needed working, so I don't want to wipe again. Perhaps there was something I overlooked that was causing it. Do you know if 3.0.4 from the official thread fixes the problems that your build addressed?
 

BRiANj64

Senior Member
Apr 28, 2012
347
90
0
Maassluis
Hmm. It decrypts with 3.0.4 installed, EX 2.0 and everything else the same. I would try to get some logs or something for you, but I finally got everything I needed working, so I don't want to wipe again. Perhaps there was something I overlooked that was causing it. Do you know if 3.0.4 from the official thread fixes the problems that your build addressed?
There's a bug with ext4 decryption in TWRP 3.0.4 atm, there's a zip file to flash over it.
 
Last edited:

JohnHorus

Senior Member
Aug 26, 2012
387
88
0
Barrie
There's a bug with ext4 decryption in TWRP 3.0.4 atm, there's a zip file to flash over it.
My data partition was f2fs. I should only need the zip if my data partition is ext4, right? My system and cache are still ext4, I had understood those weren't supposed to be f2fs. It's only the data partition that gets encrypted, right?
 

laupuy

Senior Member
Jul 26, 2015
1,854
2,058
153
dans tes 22
which better this one or the unofficial from eng.stk? anyonye have latest twrp from the eng.stk too? thanks
Hi,
this one is ok for lineageOS, be careful f2fs:
->The 2017/1/15 update uses F2FS backported from 4.10 kernel, you may meet compatibility problems with f2fs partitions made by older version of f2fs, if this happened to you, format(NOT wipe) /data in this TWRP, it should be fixed. (cf OP)

twrp_eng.stk here (blu_spark kernel thread): https://forum.xda-developers.com/devdb/project/?id=15934#downloads

@+
 

f2bacon

Senior Member
Oct 20, 2011
429
79
0
Brooklyn NY
I hate to be weird like this but I don't have much money I'd give like $10 or $20 to someone who could help me get my twrp backup restored successfully. I'm scared to make another backup and lose it all again. Feel free to DM me if you don't wanna leave a bunch of comments on the thread
 

luxandroid

Senior Member
Feb 5, 2011
1,456
688
143
Osijek
I hate to be weird like this but I don't have much money I'd give like $10 or $20 to someone who could help me get my twrp backup restored successfully. I'm scared to make another backup and lose it all again. Feel free to DM me if you don't wanna leave a bunch of comments on the thread
If you haven't solved your issue send me detailed PM ,what firmware,Android version,TWRP ,ext4 or f2fs data, recovery etc . I'll try to help you out
 

Th3DaRk_Vampire

Senior Member
Dec 7, 2012
340
70
0
San Pedro Sula
Gentlemen I would like to try lineage in my OP3, somebody help me with a doubt? Can I install the rom with the official TWRP? And what version of gapps can I use? Anyone for Android 7.X?

Sent from my ONEPLUS A3000 using Tapatalk
 

laupuy

Senior Member
Jul 26, 2015
1,854
2,058
153
dans tes 22
  • Like
Reactions: Th3DaRk_Vampire