• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[RECOVERY][pioneer] TWRP Touch Recovery [OFFICIAL]

Search This thread

steveglowplunk

Senior Member
Sep 15, 2015
273
100
Shutdown your device &
wait a few seconds.
Now press power + volume down button at the same time till sony logo shows up,
now release power button &
hold volume dowm till twrp is booted
Just installed TWRP (twrp-3.5.0_9-0) via the installer zip. But when I press power + volume down button at the same time, I get one vibration followed by three more vibrations. The screen stays blank. Thankfully I can still boot into android normally so the phone isn't bricked.
 

Ksix007

Member
Jul 13, 2014
19
2
I found a big bug on latest version (3.5.2_9). I maked backup before update my LineageOS, after, i needed restore the backup where always freezes on ''restoring system image''. During all weekend i tried for many times and ways but no avail. So, i decided donwload an old TWRP version (3.3.1-6) and finally restore my backup successfull!
 

Top Liked Posts

  • There are no posts matching your filters.
  • 21
    Team Win Recovery Project 3.x, or twrp3 for short, is a custom recovery built with ease of use and customization in mind. Its a fully touch driven user interface no more volume rocker or power buttons to mash. The GUI is also fully XML driven and completely theme-able. You can change just about every aspect of the look and feel.



    DOWNLOAD: https://twrp.me/sony/sonyxperiaxa2.html

    BUGS:
    If you have found a bug, please consider posting it to our github issues log and then I'll report to Dess_Troy. If you have a significant problem that cannot be answered in this thread, your best bet is to PM Dees_Troy directly, contact us via our website, or find us in our IRC channel below. If you see someone that's struggling, feel free to point it out to us. We need your help to help us keep track of all of our devices! Thanks!

    SUPPORT:
    Live support is available via #twrp on Freenode with your IRC client or just click this link.

    XDA:DevDB Information
    [RECOVERY][pioneer] TWRP Touch Recovery [OFFICIAL], ROM for the Sony XA2 Ultra

    Contributors
    LuK1337
    Source Code: https://github.com/TeamWin

    ROM OS Version: 8.x Oreo

    Version Information
    Status: Testing

    Created 2018-04-06
    Last Updated 2020-06-25
    3
    Right, so "only" fastboot boot *.img, thx
    I wonder where the inbuilt Sony recovery is stored then ?
    In /boot.
    3
    Hello. I'd like to root my Xperia XA2 Ultra, and I would like to backup TA partition (Sony DRM etc.) so I can restore it after rooting. If someone can tell me how to do it, I would appreciate it.
    Thanks.
    You can't back them up, you don't really need them though. The camera works fine without them on tue XA2

    ---------- Post added at 08:09 PM ---------- Previous post was at 08:01 PM ----------

    Wait what. I've held off on rooting until the kinks get worked out. That and I haven't ever done it with a Sony device before. My understanding is that Sony DRM can be lost forever if not done correctly. What exact functionality would I lose?

    So how would I go about keeping (saving for later) the drm if possible? I'm assuming unlocking bootloader, twrp, rooting and installing xposed is normal.

    I just don't want to mess up to the point of no return. Sony drm, tremble, a/b system and google pay are anomalies I haven't dealt with before. My device is the XA2 Ultra H3223 on build 50.1.A.5.59 (latest), which means I should hold off on xposed :(. It automatically updated on me.
    Google Pay works as long as Xposed isn't installed which would be the case given the firmware you've updated to.

    Basically, you lose absolutely no functionality... Camera, Google Pay are working.

    On older Sony devices the Camera functionality was lost with the DRM info, but not on this device.
    3
    How do I install 3.2.1-1 if there is only 3.2.1-0 install zip available?
    I'm in process of getting new installer package so you just got to wait.
    2
    @LuK1337
    How does it work then, since it's an a/b device (first for Sony) i mean will twrp be booted in slot _b or how? And the Same fastboot flash, will it also flash to slot _b, meaning the inbuilt Sony recovery won't be touched (vol- + power on bootup)
    Anyway interesting, I will try it on my spare H4313
    BTW the xposed issue is related to March sec patch https://github.com/rovo89/Xposed/issues/339
    1. Fastboot boot boots as your current slot
    2. You can't fastboot flash it as there is no recovery partition.