[RECOVERY][pme] TWRP touch recovery

Search This thread


New member
Jun 5, 2018
You can fostboot to bootloader then to recovery from there

Thanks for not leaving me alone.

The phone is "new" to me, thus no data is in danger and I'm ready to do any wipe.
I can boot up the phone to download mode via vol- and power and boot into bootloader from there as well.
Booting into bootloader is NOT the problem.
When booting into recovery from the bootloader, I get the same bootloop as in "normal" boot.

I was on oreo before installing LeeDroid, with OS
That is the reason I can't simply flash an ruu. I don't have a current .206. RUU with the o2___ CID, and older RUUs won't work because of the oreo firmware, as the signature keys are hardcoded in the firmware. Firmware rollback to nougat requires a working twrp.

I did not flash a RUU via fastboot but via zip-on-sd, getting the signature error mentioned before.
I did flash several twrp versions (, 3.21.3, since the bootloop occured without success.
I also did flash the boot.img I extracted and renamed from the twrp backup.



Senior Member
Nov 30, 2017
Well actually the latest on the download tab is still showing 321-4
there is a tiny note on top that says 322 is now available.
No matter. Downloaded through official TWRP app without issue.
Later y'all.

The Downloads tab is for unofficial releases. The official site is for official releases, which, according to the OP, the new version is. There's the announcement you're referring to, the Change log in the OP, and the update of the Stable version at the bottom of the OP. The FAQ also says that the version that should be used is the latest official version, listed as 3.2.2-0. Seems pretty straightforward to me, so I'm not sure where the confusion was.

  • Like
Reactions: Captain_Throwback


Senior Member
Sep 4, 2011
hey all,

i am getting this in twrp: "
could not mount /data and unable to find crypto"
and many
"unable to mount storage"
under that.

i get this in TWRP if i try to do a `restore`. it has been like this ever since i received my Verizon 10 back from the mail-in rooting service. what steps should i take to fix this? The mail-in service did root it, but i need to install ROMs! i'm a little rusty on all this stuff so pardon if it's been covered.

Any insight would be great!
i am Verizon HTC 10, TWRP 3.1.1-0.

---------- Post added at 09:22 PM ---------- Previous post was at 08:36 PM ----------

hey all,

i am getting this in twrp: "
could not mount /data and unable to find crypto"
and many
"unable to mount storage"
under that.

i get this in TWRP if i try to do a `restore`. it has been like this ever since i received my Verizon 10 back from the mail-in rooting service. what steps should i take to fix this? The mail-in service did root it, but i need to install ROMs! i'm a little rusty on all this stuff so pardon if it's been covered.

Any insight would be great!
i am Verizon HTC 10, TWRP 3.1.1-0.

UPDATE! in case this helps anyone else, i updated TWRP and that fixed it! **Face-Palm Emoji**


Senior Member
Feb 26, 2012


Senior Member
Jan 5, 2010
Just to let you know that the latest version can decrypt LineageOS 14 (Nougat) as well.

Captain Throwback requested confirmation of this, so here it is!

Captain_Throwback, you wanted a recovery log of decryption, so here it is.

This is LineageOS 14 (Nougat) where it works fine.

And thanks so much for updating TWRP for us: made a big difference for me. Cheers!



  • recovery.log
    24 KB · Views: 16
Last edited:


Senior Member
Nov 30, 2017
  • Like
Reactions: flowtec

Top Liked Posts

  • There are no posts matching your filters.
  • 126
    [CENTER]*** Disclaimer ***
    All flashing is done at your own risk!
    While nothing from this thread should break your device,
    don't come back here blaming anyone if it does![/CENTER]

    Team Win Recovery Project 3.x, or twrp3 for short, is a custom recovery built with ease of use and customization in mind. Its a fully touch driven user interface no more volume rocker or power buttons to mash. The GUI is also fully XML driven and completely theme-able. You can change just about every aspect of the look and feel.


    Installation instructions
    NOTE: Read the FAQ from Post #2 to ensure that you're installing the correct version of TWRP!!

    TWRP Image Install method:
    Most devices can be updated quickly and easily within TWRP if you already have version or higher installed.
    1. Download the latest version of TWRP appropriate for your device/firmware
    2. Reboot to TWRP
    3. Hit Install and tap the "Install Image" button in the lower right
    4. Browse to the location of the TWRP image on your device and select it
    5. Select recovery from the partition list and swipe to flash

    Alternate Installation Method:
    Fastboot Install Method:
    You will need the platform-tools from the Android SDK on your computer. Find the Android command line tools section on the page linked and install the SDK tools package. From the SDK Manager, download only the platform-tools to get adb and fastboot binaries.

    Windows users will need proper drivers installed on their computer. You can try the Naked ADB drivers or the Universal ADB drivers if you don't already have a working driver installed

    On your device, go into Settings -> About and find the Build Number and tap on it 7 times to enable developer settings. Press back and go into Developer Options and enable USB debugging. From your computer, open a command prompt and type:
    adb reboot download
    You should now be in fastboot mode.

    Download the correct image file and copy the file into the same folder as your adb and fastboot binaries. Rename the image to twrp.img and type:
    fastboot flash recovery twrp.img
    fastboot reboot

    Device Changelog
    Current version: 3.4.0-0:
    [LIST][URL="https://github.com/TeamWin/android_device_htc_pme/commit/f168dc3cd98bb8778e12b14716e3015b9b873256"]Add vendor init[/URL]
    [*][URL="https://github.com/TeamWin/android_device_htc_pme/commit/4b4e1c14b65aa3d974e99d08ad0851b5ec24e0c5"]Decryption updates & cleanup[/URL][/LIST]
    Older Device-specific versions:
    [LIST]Updates to support AOSP Pie decryption[/LIST]
    [LIST][update] Add support for AOSP Oreo decryption[/LIST]
    [LIST]Enable f2fs support
    - Fixed source so it compiles properly[/LIST]
    [LIST]Update kernel to custom Oreo built from 3.16.708.3_R HTC Dev source
    - Patched for proper working touch (reboot recovery now works as well)
    [*]Enable NTFS
    - f2fs remains disabled, as source won't compile with it enabled[/LIST]
    [LIST]Use /persist as Qualcomm time fix source during early boot
    - Fixes broken time issue on Oreo firmware[/LIST]
    [LIST]Updated kernel to US Unlocked Oreo (3.16.617.2) - patched for working touch
    [*]Added support for Oreo decryption (posthumous thanks to @nkk71 for all his hard work on decryption)
    [*]Disable f2fs & NTFS support until custom kernel can be built
    [*]Update vendor init to properly detect Verizon model by CID[/LIST]

    TWRP Official Changelog
    Current version: 3.4.0:
    System As Root (SAR)
    [LIST]Fix backup and restore using SAR - dianlujitao
    [*]System mount point - Chaosmaster
    [*]ORS - Chaosmaster
    [*]Zip install - Chaosmaster
    [*]system_root bind mount to /system - Chaosmaster
    [*]Autodetection of SAR - Chaosmaster[/LIST]
    [LIST]fix creation of digests for sub-partitions (was bugfix applied to many devices since last year) - Bigbiff[/LIST]
    [LIST]ext4Crypt Wrapped Key Update - Peter Cai
    [*]Fix upgrading encryption key if export fails - Peter Cai
    [*]Fix wrapped key support for devices without metadata partition - mauronofrio
    [*]Don't skip decryption when using block map file in order to write to /data in ORS - CaptainThrowback
    [*]FDE - Decrypt master key first - AndroidableDroid
    [*]vold_decrypt - set Android version and patch level automatically - CaptainThrowback
    [*]Set wrapped decrypt support by twrp flag - Peter Cai
    [*]Don't try wrapped support unless needed - mauronofrio
    [*]restore ext4 policy on /data/cache - Bigbiff
    [*]multiuser decryption - Noah Jacobson
    [*]FDE retry - AndroidableDroid[/LIST]
    TWRP App
    [LIST]unmount system after checking for app - Bigbiff[/LIST]
    Prebuilt updates
    [LIST][email protected] - cryptomilk[/LIST]
    Compilation Fixes
    [LIST]TW_EXFAT_FUSE compilation fixes - Bigbiff
    [*]libuuid - cryptomilk
    [*]'system/etc/ld.config.txt' not found error - Martin Dünkelmann[/LIST]
    Language Updates
    [LIST]Portugal - Vasco Machado
    [*]Dutch - Ian Macdonald
    [*]Turkish - Fatih Fırıncı
    [*]Localisation of Backup_Tar - Ian Macdonald[/LIST]
    [LIST]updates for 8.x trees - CaptainThrowback
    [*]fix search path for /sbin - CaptainThrowback
    [*]/sbin should come first in search path - Ian Macdonald[/LIST]
    General Bugs
    [LIST]Fix persistent log storage - SyberHexen
    [*]Compress Persistent Logs - Bigbiff
    [*]FB2PNG compilation errors - Bigbiff
    [*]exclude per_boot from backups - Darth9
    [*]Unmount all directories that point to same block device - AndroidableDroid
    [*]Blank screen fixes - Sean hoyt
    [*]Toolbox is default on android-9+ - mauronofrio[/LIST]
    [LIST]Typo fix in comment - VDavid003
    [*]newlines in ext4crypt - CaptainThrowback
    [*]TW_OEM_BUILD compilation issue - Patrick Zacharias
    [*]Fix Dependency requirements - Dees_Troy
    [*]Fix Symbolic links for BB and Toolbox - Dees_Troy[/LIST]
    Bootloader Message
    [LIST]cleanup - Alessandro Astone
    [*]add configurable offsets[/LIST]
    Error Cleanup
    [LIST]uevent errors and decryption error - mauronofrio
    [*]using copy_file to copy files from /etc - CaptainThrowback
    [*]ueventd access to /acct - early directory creation in init - cryptomilk[/LIST]
    [LIST]TSP Driver - LameMonster82
    [*]QTI Input - AndroidableDroid[/LIST]
    [LIST]read all asserts - Hernán Castañón[/LIST]
    [LIST]Add Resetprop from Magisk - CaptainThrowback & mauronofrio
    [*]compile from source - Chaosmaster
    [*]fix for android-7 and earlier - Chaosmaster
    [*]cleanup for spaces in properties - AndroidableDroid[/LIST]
    [LIST]Add Property override - Chaosmaster[/LIST]
    [LIST]mount system and vendor for A/B installs for backuptool - Chaosmaster[/LIST]
    [LIST]fix backup freezes when pigz and openaes are used - Fabrice Bellet[/LIST]
    Zip Installs
    [LIST]Info for A/B zip installing to inactive slot - Chaosmaster
    [*]Reboot to system button now allows to be rebooted to different partitions after zip install
    [*]progressbar rework - Chaosmaster[/LIST]
    Magisk updates
    [LIST]update binaries from source - AndroidableDroid[/LIST]
    A/B Updater Zip Template
    [LIST]rewrite A/B installer zip from scratch using a new generic template and latest magiskboot - osm0sis
    [*]installer zip support for recovery_a/recovery_b partition ramdisks on newer 2SI SAR A/B devices - osm0sis
    [*]generate installer zips for all prod A/B devices - bigbiff
    [*]improve installer zip dump/write speed and add more error catching - arter97 & osm0sis[/LIST]
    OZIP Encryption Support
    [LIST]add OZIP encryption - mauronofrio[/LIST]
    File Selector
    [LIST]Support for more extensions in File Selector - mauronofrio[/LIST]
    Older versions:
    [LIST]Fix selinux issues during formatting - dianlujitao
    [*]Various fixes for toybox and toolbox builds - CaptainThrowback and bigbiff
    [*]Flash both A and B partitions when installing a recovery ramdisk - Dees_Troy
    [*]Add option to uninstall TWRP app from /system - Dees_Troy
    [*]Create digest for subpartitions - bigbiff[/LIST]
    [LIST]Merge AOSP 9.0 r3 (Dees_Troy)
    [*]Use ANDROID_ROOT variable instead of hard coding to /system (CaptainThrowback)
    [*]Decrypt FBE on 9.0 and metadata decrypt (Dees_Troy)
    [*]vold decrypt updates (nijel8, CaptainThrowback)
    [*]Support vibration on LED class devices (notsyncing)
    [*]Metadata decrypt support for Pixel 3 (Dees_Troy)
    [*]Support rotating the display via build flag (vladimiroltean)
    [*]Reboot to EDL mode button (mauronofrio)
    [*]Support MTP on FFS devices (bigbiff)
    [*]Update FDE decrypt to support keymaster 3 and 4 (Dees_Troy)
    [*]Detect mkfs.f2fs version to properly format on f2fs partitions (Dees_Troy)
    [*]Allow TWRP to use md5 and sha256 checksums for zip installs (bigbiff)
    [*]TWRP can use /data/cache/recovery and /persist/cache/recovery on AB devices with no cache partition (bigbiff)
    [*]Switch part of advanced menus in TWRP to use a listbox of options (Dees_Troy)
    [*]Use magiskboot to allow repacking boot images for installing TWRP (Dees_Troy with thanks to topjohnwu of course)[/LIST]
    [LIST]Fix automatic installing of OTA zips on encrypted devices
    [*]Remove SuperSU from TWRP
    [*]Support both md5 and md5sum file extensions when doing MD5 checking for zip files[/LIST]
    [LIST]adb backup fixes
    [*]OTA style update zips will now install automatically without prompting for decrypt
    [*]minor tweaks to handling date/time on Qualcomm devices
    [*]updates to some language translations[/LIST]
    [LIST]minui fixes (cryptomilk)
    [*]Better android-8.0 compatibility in ROM trees (Dees_Troy)
    [*]Fix missing library in android-8.0 (nkk71)
    [*]Fix inconsistent SDCard naming (DevUt)
    [*]Default to TWRP restore instead of adb backup restore to fix restore on fresh TWRP boot (jlask)[/LIST]
    [LIST]Allow restoring adb backups in the TWRP GUI (bigbiff)
    [*]Fix gzip backup error in adb backups (bigbiff)
    [*]Fix a bug in TWRP's backup routines that occasionally corrupted backup files (nkk71)
    [*]Better support for installing Android 8.0 based zips due to legacy props (nkk71)
    [*]Support vold decrypt with keymaster 3.0 in 8.0 firmwares (nkk71)
    [*]Decrypt of synthetic passwords for Pixel 2 (Dees_Troy)
    [*]Support newer ext4 FBE policies for backup and restore in libtar (Dees_Troy)
    [*]v2 fstab support (Dees_Troy)
    [*]Bring TWRP forward to android 8.0 AOSP base (Dees_Troy)
    [*]Various other minor bugfixes and tweaks[/LIST]
    [LIST]Backups will now include adopted storage keys (Dees_Troy)
    [*]Fixed an adb restore issue (bigbiff)
    [*]Fixed rebooting when no OS is present (Dees_Troy)
    [*]Fixed line wrapping in the GUI terminal (_that)
    [*]Updated TWRP source code to AOSP 7.1.2 (Dees_Troy)[/LIST]
    [LIST]vold decrypt on a few select HTC devices, TWRP will now attempt to use the system partition's vold and vdc binaries and libraries to decrypt the data partition (nkk71 and CaptainThrowback)
    [*]adb backup to stream a backup directly to or from your PC, see documentation [URL="https://github.com/omnirom/android_bootable_recovery/commit/ce8f83c48d200106ff61ad530c863b15c16949d9"]here[/URL] (bigbiff)
    [*]tweak MTP startup routines (mdmower)
    [*]support new Android 7.x xattrs for backup and restore to fix loss of data after a restore (Dees_Troy)
    [*]support POSIX file capabilities backup and restore to fix VoLTE on HTC devices and possibly other issues (Dees_Troy)
    [*]better indicate to users that internal storage is not backed up (Dees_Troy)
    [*]improve automatic determination of TW_THEME (mdmower)
    [*]minimal getcap and setcap support (_that)
    [*]try mounting both ext4 and f2fs during decrypt (jcadduono and Dees_Troy)
    [*]shut off backlight with power key (mdmower)
    [*]timeout during FDE decrypt (Dees_Troy and nkk71)
    [*]support for FBE decrypt and backing up and restoring FBE policies (Dees_Troy)
    [*]boot slot support (Dees_Troy)
    [*]TWRP app install prompt during reboot (Dees_Troy)
    [*]support for AB OTA zips (Dees_Troy)
    [*]support new Android 7.x log command (Dees_Troy)
    [*]update recovery sources to AOSP 7.1 (Dees_Troy)
    [*]numerous bugfixes and improvements by too many people to mention[/LIST]
    [LIST]Partial release to help support the release of the [URL="https://www.xda-developers.com/team-win-releases-their-first-official-twrp-app-in-the-play-store/"]Official TWRP app[/URL][/LIST]
    [LIST]Fix a bug with the input box that affected masked inputs (passwords). This fixes decrypt of full device encryption on devices that support decrypt. This bug also impacts encrypted backups. Users are highly encouraged to stop using 3.0.1 if you use encrypted backups or if you need decrypt of data in TWRP.
    [*]Add Greek translation to some builds.[/LIST]
    [LIST]support new CM 13.0 pattern encryption (sultanqasim)
    [*]fix slow flashing issue due to modprobe (present on only some devices) (#twrp)
    [*]libtar updated to latest upstream and fixes (jcadduono)
    [*]fixes for loading custom themes (_that)
    [*]TWRP will now detect and install TWRP themes automatically through the normal zip install process (Dees_Troy)
    [*]translation updates - added Italian, Czech and Polish and significant updates to Dutch
    [*]progress bar improvements - progress bar updates during image flashing and better tracks progress during file system backups (tar) (Dees_Troy)
    [*]fix input box text display (Dees_Troy)
    [*]reboot option after zip install complete (bigbiff)
    [*]other mostly invisible bug fixes and improvements[/LIST]
    [LIST]Completely new theme - Much more modern and much nicer looking (by z31s1g)
    [*]True Terminal Emulator - Includes arrow keys, tab and tab completion, etc. (by _that)
    [*]Language translation - It won’t be perfect and especially some languages that require large font files like Chinese & Japanese won’t be availble on most devices. Also some languages may only be partially translated at this time. Feel free to submit more translations to OmniROM’s Gerrit. (mostly by Dees_Troy)
    [*]Flashing of sparse images - On select devices you will be able to flash some parts of factory images via the TWRP GUI (by HashBang173)
    [*]Adopted storage support for select devices - TWRP can now decrypt adopted storage partitions from Marshmallow
    [*]Reworked graphics to bring us more up to date with AOSP - includes support for adf and drm graphics (by Dees_Troy)
    [*]SuperSU prompt will no longer display if a Marshmallow ROM is installed
    [*]Update exfat, exfat fuse, dosfstools (by mdmower)
    [*]Update AOSP base to 6.0
    [*]A huge laundry list of other minor fixes and tweaks[/LIST]
    [U]Additional Notes[/U]
    [LIST]WARNING: This is our first release in a long time. We have a lot of new and somewhat aggressive changes in this new release. The changes to the graphics back-end may cause some devices to not boot up properly or have other display-related issues. If you are not in a position to reflash an older build of TWRP, then wait until you are or at least wait until others have tried the new version for your specific device. You don’t want to end up with a non-working recovery and have to wait several hours or days to get to a computer to be able to fix it.
    [*]Notes for themers: In addition to the updated theme, we have introduced a theme version variable to the TWRP theme system. If the theme version does not match the version that TWRP expects, TWRP will reject the custom theme and load its stock theme. This change will ensure that people who update TWRP without updating their theme will still have a workable recovery. We have removed libjpeg support. The stock theme was only using a jpeg image for the splash / curtain. This change means that any custom themes will no longer be able to use jpeg images. It also means that tools used to repack recovery images with a different curtain / splash will need to be updated to use the new method.
    [*]Version number notes: For a while we’ve been using a 4 digit version number and reserved the 4th digit for device-specific updates. For instance, we find and fix a device-specific issue like decryption of data on Nexus 5, we would release that as a After a while, some people would start asking where was for other devices. So, going forward we have decided to change the numbering scheme to 3.0.0-2, etc. Our hope is that this version numbering scheme will more clearly identify that the 4th digit does not indicate a version change for the code base.
    [*]We need your help! The bulk of TWRP work is done by 3 people on a volunteer basis. We have pushed most of our device files to our github and we have a gerrit instance. If you have the ability, please help us maintain our official devices and/or add your device to our official device list. Thanks in advance![/LIST]
    [LIST]Initial ground work for software drawn keyboard (_that)
    [*]Fix handling of wiping internal storage on datamedia devices (xuefer)
    [*]Allow DataManager to set and read values from the system properties (xuefer)
    [*]Fix crash when taking screenshots on arm64 devices (xuefer)
    [*]Fix error message after an ORS script completes (Dees_Troy)
    [*]Fix crashes / error when creating encrypted backups (_that, Dees_Troy)
    [*]Add system read only option – more details below (Dees_Troy)
    [*]Add resize2fs and GUI option to run resize2fs (Dees_Troy)
    [*]Fix crash loop caused by empty lines in AOSP recovery command file (_that)
    [*]Prevent duplicate page overlays such as multiple lock screens (mdmower)[/LIST]
    [U]Additional Notes[/U]
    [LIST]Note: As always, be sure your custom theme is up to date (or remove your custom theme) before updating TWRP.
    [*]System read only option: Devices that ship with 5.0 and higher as their initial OS are using block level OTA updates. With this style of OTA update, the update script checks to see if the system partition has ever been mounted read/write. Further, the script also usually runs an SHA sum of the entire system partition to detect if any changes have been made. If any changes have been made, the OTA update will refuse to install. Since not all OEMs and devices have factory images available, we have created a new feature in TWRP that detects if the system partition has ever been mounted read/write. If not, you will be prompted asking if you want TWRP to mount system as read/write. If you choose not to allow TWRP to mount as read/write, TWRP won’t prompt to install SuperSU and TWRP won’t try to patch the stock ROM to prevent TWRP from being replaced by stock recovery. The goal of this option is to hopefully allow the user to make a raw system image backup that they can use to get back to a state where they can take OTA updates again.
    [*]resize2fs feature: On some devices like the Nexus 6, the factory images include a userdata image that is the proper size only for the 32GB units. If you flash the factory image to a 64GB Nexus 6, the data partition will appear as if it only has the free space of a 32GB device. Using the resize2fs option, TWRP can resize your data partition to take up the full space available. The resize2fs may also be useful to resize system partitions on devices where custom ROM system images don’t take up the full partition space. Lastly, resize2fs may be useful in some cases to reserve the proper space at the end of a data partition for a full disk encryption key, should your partition be formatted incorrectly for some reason.
    [*]This new version also marks our first set of full builds using our new jenkins build server. You can track the progress of builds at [url]https://jenkins.twrp.me[/url] and we have taken additional steps to make it easier for device maintainers to step up and submit patches to our gerrit server at [url]https://gerrit.twrp.me[/url] to help us keep devices up to date and working.[/LIST]

    NOTE: Read the FAQ from Post #2 to ensure that you're installing the correct version of TWRP!!


    Latest Official versions
    Latest Unofficial versions

    Device tree
    Kernel source

    FAQ - Post #2

    Known Issues
    • As of version 3.3.0, stock Nougat can no longer be decrypted. Use 3.2.3 or older if you are still running stock Nougat.
    • Encrypted backups are broken - DO NOT USE THIS FEATURE!!
    • 3.2.1-1 through 3.2.1-2: Reboot recovery is broken (due to patching stock kernel for touch - requires kernel source and custom kernel build to fix) - UPDATE: Fixed with 3.2.1-3

    We need your help!
    Join the TWRP Testing group on Slack to help us test TWRP prior to official releases!

    Bug Reporting
    If you have an issue, the first step is to post a recovery log so we can determine the cause of the issue. This is done in recovery using Advanced -> Copy Log, or adb pull /tmp/recovery.log. Once a log is uploaded we can determine how best to proceed. NOTE: Posts that are reporting bugs or issues without an accompanying recovery log will be ignored! Additionally, providing details about your device setup, including variant, firmware version, and exact steps to reproduce your issue will also be helpful in diagnosing the problem.

    If your issue is determined to be a bug by the device maintainer, please consider posting it to our github issues log. It's pretty much impossible for us to keep up with the more than 40 threads that we have for the devices that we "directly" support. If you have a significant problem that cannot be answered in this thread, your best bet is to contact us via our website, or find us in our IRC channel below. If you see someone that's struggling, feel free to point it out to us. We need your help to help us keep track of all of our devices! Thanks!

    Additional Help/Support:
    Live support is available via #twrp on Freenode with your IRC client or just click this link.

    XDA:DevDB Information
    TeamWin Recovery Project (TWRP), Tool/Utility for the HTC 10

    Captain_Throwback, Dees_Troy, bigbiff, _that, nkk71
    Source Code: https://github.com/TeamWin/android_bootable_recovery

    Version Information
    Current Stable Version: 3.4.0-0
    Stable Release Date: 2020-06-24

    Created 2016-04-13
    Last Updated 2020-06-25
    Added 3.0.3-0-UNOFFICIAL to the Downloads Tab. This version will replace all previous versions.

    With this release, TWRP has been updated to be backwards compatible with Marshmallow/CM encryption, so it should work regardless of what firmware/software/Android version/whatever you're running. As always, @nkk71 and I have been working tirelessly to fix the issues people were facing with TWRP, including the AROMA freezing issues some people were facing. That seemed to be a result of /system getting locked up due to the method we were using to mount it and subsequently decrypt with vold. Some adjustments have been made, and everything seems to be working much better.

    So please, give this latest version a try and let us know if you have any issues. As always, please heap thanks and praise upon nkk71 for all his hard work on this!

    P.S. If you have issues with this latest version, don't forget to post a recovery log, as described in the "BUGS" section of the OP :).
    Well decryption does not work, but

    coming soon to an HTC 10 on 2.xx.xxx.x firmware near you:

    So, I posted a debug version of 3.0.2-7 to the Downloads tab. Thanks to @nkk71, we now have a GUI. What isn't working is decryption. That'll take some more time. And please, no ETA requests.

    The issue I described previously with gunzip was still present with the Busybox built into TWRP, so I borrowed @topjohnwu's Busybox from Magisk (thanks @YashdSaraf) and included that in the build so everything *should* flash okay.

    Additionally, like previously when decryption didn't work, TWRP Settings won't be saved, and time will be off in recovery and on any backup files produced. But it's good enough to flash kernels and custom ROMs with, so enjoy, and we'll keep working.

    And also thanks to the people that have donated to both myself, topjohnwu and nkk71. Working on this stuff can be very time consuming and stressful, so a little monetary appreciation really does help us keep going. Thanks for all the support, and happy flashing!! :D

    Dirty changelog for 3.0.2-7 DEBUG:
    - Updated kernel source to 2.28.617.8 from HTC Dev (Nougat)
    - Removed HTC_DEBUG flags from kernel (thanks @crpalmer)
    - Enabled f2fs support (but no real reason why, since there's no encryption support - that's a future project)
    - Moved build to OmniROM android-7.1 tree (where many things appear to be broken)
    Thanks to @Captain_Throwback who continues to do amazing things, and all of you guys support, motivation, and positive reactions

    we're still at it, and the story continues, so today's screenshots


    I've taken Captain's work, and moved it directly into TWRP code... this should also work with PIN/password once ready, and the system issue in the screenshot will also be addressed.

    By the way, the screenshots were taken without needing to "Refresh Sizes" :)

    Small recovery log section (for those that like logs ;) ):
    I:Can't probe device /dev/block/mmcblk0p63
    I:Unable to mount '/data'
    I:Actual block device: '/dev/block/mmcblk0p63', current file system: 'ext4'
    get_crypt_ftr_info crypto key location: '/dev/block/bootdevice/by-name/extra'
    I:Device is encrypted with the default password, attempting to decrypt.
    Data successfully decrypted, new block device: '/dev/block/dm-0'
    /data | /dev/block/mmcblk0p63 | Size: 25056MB Used: 25056MB Free: 0MB Backup Size: 25056MB
       Flags: Can_Be_Mounted Can_Be_Wiped Can_Be_Backed_Up Wipe_During_Factory_Reset Wipe_Available_in_GUI IsPresent Can_Be_Encrypted Is_Encrypted Is_Decrypted Has_Data_Media Can_Encrypt_Backup Use_Userdata_Encryption Is_Storage Is_Settings_Storage 
       Symlink_Path: /data/media/0
       Symlink_Mount_Point: /sdcard
       Primary_Block_Device: /dev/block/mmcblk0p63
       Decrypted_Block_Device: /dev/block/dm-0
       Crypto_Key_Location: /dev/block/bootdevice/by-name/extra
       Display_Name: data
       Storage_Name: Internal Storage
       Backup_Path: /data
       Backup_Name: data
       Backup_Display_Name: Data
       Storage_Path: /data/media/0
       Current_File_System: ext4
       Fstab_File_System: ext4
       Backup_Method: files
       MTP_Storage_ID: 65539
    Updating partition details...
    I:mount -o bind '/data/media/0' '/sdcard' process ended with RC=0
    I:Data backup size is 10131MB, free: 5355MB.
    /data | /dev/block/dm-0 | Size: 24534MB Used: 10131MB Free: 5355MB Backup Size: 10131MB
       Flags: Can_Be_Mounted Can_Be_Wiped Can_Be_Backed_Up Wipe_During_Factory_Reset Wipe_Available_in_GUI IsPresent Can_Be_Encrypted Is_Encrypted Is_Decrypted Has_Data_Media Can_Encrypt_Backup Use_Userdata_Encryption Is_Storage Is_Settings_Storage 
       Symlink_Path: /data/media/0
       Symlink_Mount_Point: /sdcard
       Primary_Block_Device: /dev/block/mmcblk0p63
       Decrypted_Block_Device: /dev/block/dm-0
       Crypto_Key_Location: /dev/block/bootdevice/by-name/extra
       Display_Name: data
       Storage_Name: Internal Storage
       Backup_Path: /data
       Backup_Name: data
       Backup_Display_Name: Data
       Storage_Path: /data/media/0
       Current_File_System: ext4
       Fstab_File_System: ext4
       Backup_Method: files
       MTP_Storage_ID: 65539

    So conclusion: the decryption was done by TWRP, exactly where it expects it to be done :)