• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[RECOVERY][ROOT][TWRP 3.2.1-1][Magisk v14] Samsung Galaxy Tab A6 SM-T280/SM-T285

Search This thread

nicht

Member
Jun 5, 2012
11
1
i installed twrp like in op, everything works fine for me. But the magiskv14 link seems to be dead. i tryed to install the latest magiskv18 via twrp, but the installation got an error...

How can i install magisk?
 
  • Like
Reactions: zippzYT

vpkumar

New member
Feb 3, 2015
4
1
custom ROM

teamwin-recovery-project-twrp-logo.jpg


TWRP custom recovery for the Tab A SM-T280/T285. Latest build is 3.2.1-1

Disclaimer: you flash these at your own risk. Knox counter will be tripped. Having the stock firmware to hand is also advised.

NOTE: BEFORE MAKING MODIFICATIONS, ON SOME ANDROID 5.1.1/6.0 DEVICES IT IS NECESSARY TO GO TO:
Settings -> Developer Options -> OEM unlocking
AND ENABLE OEM UNLOCK FIRST OR YOU MAY ENCOUNTER 'BLOCKED BY FRP LOCK' WHEN FLASHING.



UPDATE 08/01/2018 - TWRP updated to version 3.2.1-1

UPDATE 21/11/2017 - Magisk updated to v14

UPDATE 26/10/2016: GUI lag fix - Lag in the GUI should now be fixed
MTP fix - MTP should now be working



To install TWRP:

1. Flash with ODIN 3.10.7 in the AP slot.
Uncheck Auto reboot.

2. Load the respective file below into the AP slot and hit start.

3. After flashing when ODIN says PASS immediately reboot to recovery by holding POWER + HOME + VOL DOWN.
As soon as the screen goes blank change to VOL UP whilst still holding the other buttons.
You should now see TWRP recovery.

DOWNLOAD:
TWRP_3.0.2-1_SM-T280_261016

twrp_3.2.1-1_sm-t280_080118

twrp_3.2.1-1_sm-t285_080118


NOTE: at the moment there seems to be a bug which causes the GUI to get a little laggy. If things stop responding just be patient and wait for the GUI to respond. I'm looking into this.
(FIXED)


For Systemless Root with SuperSu.

1. Install Supersu via TWRP
SR1-SuperSU-v2.78-SR1-20160915123031

This step only required for the SM-T280
2 . Flash the PRE-ROOTED boot image below with ODIN(AP slot) or TWRP(extract boot.img first from tar file). Current version is [SR1-SuperSU-v2.78-SR1-20160915123031].
supersu_2.78_SR1_systemless_boot_t280

3. Reboot

4. Check you have root


To install Magisk v14:


1. Download Magisk v14 to your device
Magisk v14

2. Install the Magisk v14 zip with TWRP

This step only required for the T280
3. Flash the patched boot image below with TWRP.
magiskv14_boot_aqd1

4. Reboot

5. Install Magisk manager
Magisk Manager


PLEASE LEAVE FEEDBACK IF YOU FIND MY WORK USEFUL. THANKS.


DONATE ME HERE IF YOU WANT TO BUY ME A BEER OR HIT THE THANKS BUTTON IF I HELPED YOU


Thanks a lot. I got my Tab A7 sm T 285 rootes with your instructions. I did not use Magisk.
Now I need a working Custom ROM. I have tries Lineage, CRM and OMNI but always got into a loop.
Could you suggest me a worjking ROM to upgrade my Android from Lollipo to at least 6.1 or above.
Thanks in advance.
 

Krisidious

Member
Nov 16, 2017
5
0
Hey guys... having issues with my tab. it's a SM-T280 A6... when I boot into download mode it will not let me use the volume up or down to continue. volume up and down work fine every where else... just not in download mode. however it works getting into download mode and I have to use power+volume down+ home to levae download mode.

any ideas what I can do to get around it?

droid version is 5.1.1

view
 

ashyx

Inactive Recognized Contributor
Oct 14, 2012
15,110
9,892
Hey guys... having issues with my tab. it's a SM-T280 A6... when I boot into download mode it will not let me use the volume up or down to continue. volume up and down work fine every where else... just not in download mode. however it works getting into download mode and I have to use power+volume down+ home to levae download mode.

any ideas what I can do to get around it?

droid version is 5.1.1
Boot to download mode from recovery.
 

Jouros

Senior Member
Aug 22, 2014
75
55
I keep getting a Secure Check Fail: (recovery) on the tablet screen Odin says everything is fine I get a PASS! and sucseed1. The Tablet I have is the SM-280 WiFi Only so I don't know if that matters (not sure why it would) but just got this thing new and would love root so I can speed it up a bit and be able to move any app I want to the SD card. any help would be awesome. Id also like to know if its at all possible (or worth it) to update to at least android 6.0 for a little more stability.
 

ashyx

Inactive Recognized Contributor
Oct 14, 2012
15,110
9,892
I keep getting a Secure Check Fail: (recovery) on the tablet screen Odin says everything is fine I get a PASS! and sucseed1. The Tablet I have is the SM-280 WiFi Only so I don't know if that matters (not sure why it would) but just got this thing new and would love root so I can speed it up a bit and be able to move any app I want to the SD card. any help would be awesome. Id also like to know if its at all possible (or worth it) to update to at least android 6.0 for a little more stability.
Ignore the secure check message.
Also there is no update beyond Android 5.1.
 

Jouros

Senior Member
Aug 22, 2014
75
55
Have you enabled OEM_UNLOCK?
Yeah. I got it figured out about 20 minutes ago. Not sure what was going on but its working now. I had everything enabled and I was following the guide but it wasnt loading the TWRP at first for some reason. I did a factory reset (even though its brand new) took out the sd card and tried again and this time it work. Not sure what changed but not gonna complain lol. Just wish Disney+ would work on rooted devices. The tablets a Christmas present for my daughter and wanted to have that on there for the movies for her. Oh well she'll just need to live with the movies we own on amazon prime.

Sent from my SM-N950U using Tapatalk
 

khenkis

New member
Dec 14, 2019
4
0
I got the same problem too but a hard reset didn't work in my case. Also bought the SM-T280 (runs on 5.1.1) as a gift and am looking to root it so as to cut down on the bloatware and add some Xposed mods. Followed the instructions to a T: OEM unlock and USB debugging enabled, Odin 3.10.7 flashes TWRP with a PASS, BUT "Secure Check Fail: (recovery)" says otherwise. Hmm guessing I'm SOL with the:
Also there is no update beyond Android 5.1."
 

ashyx

Inactive Recognized Contributor
Oct 14, 2012
15,110
9,892
I got the same problem too but a hard reset didn't work in my case. Also bought the SM-T280 (runs on 5.1.1) as a gift and am looking to root it so as to cut down on the bloatware and add some Xposed mods. Followed the instructions to a T: OEM unlock and USB debugging enabled, Odin 3.10.7 flashes TWRP with a PASS, BUT "Secure Check Fail: (recovery)" says otherwise. Hmm guessing I'm SOL with the:
I don't understand what you guys are doing. I have just checked and it installs fine.
Ignore the secure check fail message.
Are you booting immediately to Recovery from odin after odin says pass?
 
  • Like
Reactions: khenkis

khenkis

New member
Dec 14, 2019
4
0
I don't understand what you guys are doing. I have just checked and it installs fine.
Ignore the secure check fail message.
Are you booting immediately to Recovery from odin after odin says pass?

Yes, I am booting to recovery mode right from ODIN after a passing TWRP flash. Anyway, just tried a hard reset again and for some reason it works now. :eek: Freakin' weird but recovery finally boots into TWRP now instead of stock. Thanks for everything TWRP Jedi!!! :good:
 

steadfasterX

Recognized Developer
Nov 13, 2013
5,766
15,065
127.0.0.1
hey @ashyx thx for your TWRP builds ! :)

could you provide the sources for the kernel used and your TWRP device tree?
I cannot find both on your github (searched for gtexslte, T280,285..)

thanks in advance !
sfX
 

ycarmo

Member
Jun 5, 2015
5
1
I rooted my tab following your method. Later is used link2sd to link apps to second partition(EXT2) of sd card. it worked but after restart apps disappear and i get mount error. Sreenshot is attached. Please help me with this problem or give som other solution to move aal apps to sd card. Btw I believe this root method does not give right root. Link2sd blamed root and i cant use /system /app mover app also(second screenshot).

Secondly, can i install su v 2.82 by this method?

I've also rooted my SM-T280 following this method, and can confirm it works fine with Link2SD. Thanks, @ashyx! Only difference is that I've used Heimdall instead of Odin (Ubuntu user here).

After some failed attempts to install the Link2SD script on my sdcard and reformatting the second partition as ext4 the app managed to install the script successfully and it's still working after shutdowns and reboots. Maybe I've made a mistake when formatting the first time.

ext4 is recommended by Link2SD FAQ. Maybe your issue was caused by formatting your second sdcard partition as ext2.
 
Last edited:
I have a tablet here that no matter what I do, whether its via Recovery Mode or button combos of all kinds, even ADB reboot attempts, I can not get to download mode. It just boots to normal android, can not get into download mode. I've encountered this before, but its been a very long time and I don't remember if I found a work around.

OEM Unlock is enabled, just no sense of recovery mode/button combos or ADB reboot to get into the correct mode works

edit, literally 30 seconds after I hit post, I tried adb reboot download and it worked
 

Top Liked Posts

  • There are no posts matching your filters.
  • 55
    teamwin-recovery-project-twrp-logo.jpg


    TWRP custom recovery for the Tab A SM-T280/T285. Latest build is 3.2.1-1

    Disclaimer: you flash these at your own risk. Knox counter will be tripped. Having the stock firmware to hand is also advised.

    NOTE: BEFORE MAKING MODIFICATIONS, ON SOME ANDROID 5.1.1/6.0 DEVICES IT IS NECESSARY TO GO TO:
    Settings -> Developer Options -> OEM unlocking
    AND ENABLE OEM UNLOCK FIRST OR YOU MAY ENCOUNTER 'BLOCKED BY FRP LOCK' WHEN FLASHING.



    UPDATE 08/01/2018 - TWRP updated to version 3.2.1-1

    UPDATE 21/11/2017 - Magisk updated to v14

    UPDATE 26/10/2016: GUI lag fix - Lag in the GUI should now be fixed
    MTP fix - MTP should now be working



    To install TWRP:

    1. Flash with ODIN 3.10.7 in the AP slot.
    Uncheck Auto reboot.

    2. Load the respective file below into the AP slot and hit start.

    3. After flashing when ODIN says PASS immediately reboot to recovery by holding POWER + HOME + VOL DOWN.
    As soon as the screen goes blank change to VOL UP whilst still holding the other buttons.
    You should now see TWRP recovery.

    DOWNLOAD:
    TWRP_3.0.2-1_SM-T280_261016

    twrp_3.2.1-1_sm-t280_080118

    twrp_3.2.1-1_sm-t285_080118


    NOTE: at the moment there seems to be a bug which causes the GUI to get a little laggy. If things stop responding just be patient and wait for the GUI to respond. I'm looking into this.
    (FIXED)


    For Systemless Root with SuperSu.

    1. Install Supersu via TWRP
    SR1-SuperSU-v2.78-SR1-20160915123031

    This step only required for the SM-T280
    2 . Flash the PRE-ROOTED boot image below with ODIN(AP slot) or TWRP(extract boot.img first from tar file). Current version is [SR1-SuperSU-v2.78-SR1-20160915123031].
    supersu_2.78_SR1_systemless_boot_t280

    3. Reboot

    4. Check you have root


    To install Magisk v14:


    1. Download Magisk v14 to your device
    Magisk v14

    2. Install the Magisk v14 zip with TWRP

    This step only required for the T280
    3. Flash the patched boot image below with TWRP.
    magiskv14_boot_aqd1

    4. Reboot

    5. Install Magisk manager
    Magisk Manager


    PLEASE LEAVE FEEDBACK IF YOU FIND MY WORK USEFUL. THANKS.


    DONATE ME HERE IF YOU WANT TO BUY ME A BEER OR HIT THE THANKS BUTTON IF I HELPED YOU

    10
    GUI lag fix - Lag in the GUI should now be fixed
    MTP fix
    5
    interesting, what caused the lag to happen? I initially suspected it to be gpu clock throttling but didn't have time to figure it out
    Hi Jed, after trying various different configs in twrp and even modifying the graphics source code it made no difference.
    Using the the touch debugger in twrp it was apparent that the touch was responding fine.

    So I turned my attention to the kernel.
    After several builds of modifying the cpu config making no difference, it turns out TWRP only supports double buffering, but the kernel was forcing triple buffering.
    It seems this was causing an extra frame to be displayed causing what seemed like lag and explains why when pressing the screen a second time would cause the frame to update.

    The page that was in ram had changed when tapping a button, but the wrong frame in the buffer was displayed until the next touch which then updated the display.

    Disabling triple buffering in the kernel fixed the issue.
    3
    I hope the patched boot image for Magisk v14 come soon. I have been preparing my SM-T280 for this. Backing up everything on it, stocking up the stock images for emergency, etc.

    (BTW, a noob question, I thought Magisk is doing the patch on boot.img when it is installed. SM-T280 is different?)
    Magisk updated to v14.
    2
    Long story short, is it currently safe to flash magisk v14 on this device, or do I need to go down to v7, and also, what is the difference between them?

    Do not update to V14.
    Install patched kernel will result in bootloop.