• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[RECOVERY][ROOT]TWRP 3.2.1-1 Samsung Galaxy Tab S3 SM-T820/T825

Search This thread

Alex20137

Member
Feb 4, 2018
37
17
OK I've fixed everything. PATCH REQUIRED ANDROID 9 SM-t825 universal DM verify / force encrypt patch (search XDA)


edit just to clarify it wouldnt boot without a patch on latest android 9 firmware
 
Last edited:
  • Like
Reactions: wuerfel

ivanox1972

Senior Member
Sep 26, 2011
2,050
215
Strange issue. I installed all without problems. Root stock rom, got data mount, installed lineage and one ui rom... Backup both, restored, changed...
All normal. But now I wanted to back again from lineage to oneui rom. And somehow I lost data mount, can't wipe, can't see internal of course.
I have few backups on sd card, how to regain data mount, wipe and restore oneui rom?
Thanks
 

NullCode

Senior Member

Heya @ashyx, it would be incredible if you could provide the device tree for the Tab S3s. I have tried to make a recovery tree from scratch and its SO DIFFICULT for tablets than phones. I started the sky hawk project hoping it would be as easy as the phone I compiled for [from scratch] and oh my, it wasn't. So please, give.

Well I am not going to over praise you by saying dumb stuff but you have the real deal, and this recovery works like a CHARM, like there is NOTHING that doesn't work. So yeah please.

Edit: Literally noticed alex also asking for the device tree, so pls man, there are 2 people asking for the tree now.

Edit: Day 2 of me begging @ashyx for the device tree
 
Last edited:

BenG7

Senior Member
Jun 24, 2009
539
68
Hi
I have a SM-T820, I flashed the latest tweaked rom (twrp 3.2.1-1_ashyx) but to achieve a leaner OS i decided to flash the lineageOS 17.1, unfortunately I missed the full wipe and went for a facory reset --> boot loop on restart
but now when I go back to twrp and try to do the full wipe i get:
unable to mount storage
failed to mount '/data' (Invalid argument)
leaving me with no access to my storage.
Does anyone know what I should do next please?
Thanks

[EDIT] SOLVED, I could sort it out following these instructions.
 
Last edited:

BenG7

Senior Member
Jun 24, 2009
539
68
Hi
I have a SM-T820, I flashed the latest tweaked rom (twrp 3.2.1-1_ashyx) but to achieve a leaner OS i decided to flash the lineageOS 17.1, unfortunately I missed the full wipe and went for a facory reset --> boot loop on restart
but now when I go back to twrp and try to do the full wipe i get:

leaving me with no access to my storage.
Does anyone know what I should do next please?
Thanks

[EDIT] SOLVED, I could sort it out following these instructions.

[EDIT2] following the above steps, TWRP won't let me flash magisk anymore as it does not mount data (where magisk & the rom to be flashed are saved) + it does not record any of my settings (e.g. vibration) and I need to reset them each time I reboot into recovery...

I planned on reflashing twrp + running the dm verify again but my boot loader is now pie and dm verify provided is for Oreo...

any help please?
 
Last edited:

BenG7

Senior Member
Jun 24, 2009
539
68
@BenG7 already thought of starting from scratch by flashing stock?

Thanks @bmwdroid, I will try it but first, could you please confirm these are the steps I should go thru given the idea is I want to run a rooted LineageOS 17.1 (no GApps whatsoever) and a working TWRP as opposed to what I currently have (see final lines at the end); as you will see, this is a compilation of steps that can be found across the TWRP, LineageOS threads but I must be getting it wrong somewhere... well, first I didn't do it from a stock rom - that is noted!):

  • put my t820 in DOWNLOAD mode
  • flash latest stock (T820XXU3CTD5 for me) with odin
  • reboot to latest stock
  • Go into system and click seven times on build to get to show the Developpers options
  • in the developper options allow OEM unlock & USB debugging
  • put my t820 device in DOWNLOAD mode again.
  • uncheck Auto reboot in Odin's Options tab
  • Load the latest twrp available twrp_3.2.1-1_T820_28518.tar into the AP slot in the Log tab
  • hit start
  • after ODIN reports PASS, press POWER + HOME + VOL DOWN to reboot to recovery - as soon as the screen goes blank, change to VOL UP whilst still holding POWER + HOME --> this will get me into TWRP recovery
  • to disable forced encryption, mount internal storage (DATA) and disable dm-verity I will then flash (thru Install in TWRP) the Forced encryption patch: Tabs3_oreo_forced encryption_disabler (previously copied from laptop to internal storage in TWRP)
  • once this is done, without rebooting (please confirm), I shall format DATA using the *FORMAT DATA button* / "yes" under the wipe options (this will WIPE ALL INTERNAL STORAGE!)
  • once this is done, without rebooting (please confirm), I shall then flash (thru Install in TWRP) Magisk 20.4 (also previously copied from laptop to internal storage in TWRP)
  • reboot and check DATA is mountable (Please confirm this is a reboot to System or to Recovery)
  • backup all partitions (at least efs) and store somewhere (in order not to lose IMEI)
  • full wipe all = factory reset + format data thru dedicated button + "yes" under the wipe options in TWRP
  • flash (thru Install in TWRP) LineageOS 17.1 (also previously copied from laptop to internal storage in TWRP)
  • reboot to system which should now be a rooted LineageOS
  • go into system and click seven times on build to get to show the Developpers options, allow USB debugging.
In my previous attempts, I noticed at the end of the lineageOS flash, the process tells me it couldn't find the magisk addon so I assumed it was not rooted and I flashed magisk again
+ when I rebooted into recovery:
- I still need to allow modifications
- my twrp settings (time zone + vibration) are not saved
- data is not mounted

Thanks a lot in advance for your help.
 
Last edited:
Thanks @bmwdroid, I will try it but first, could you please confirm these are the steps I should go thru given the idea is I want to run a rooted LineageOS 17.1 (no GApps whatsoever) and a working TWRP as opposed to what I currently have (see final lines at the end); as you will see, this is a compilation of steps that can be found across the TWRP, LineageOS threads but I must be getting it wrong somewhere... well, first I didn't do it from a stock rom - that is noted!):

  • put my t820 in DOWNLOAD mode
  • flash latest stock (T820XXU3CTD5 for me) with odin
  • reboot to latest stock
  • Go into system and click seven times on build to get to show the Developpers options
  • in the developper options allow OEM unlock & USB debugging
  • put my t820 device in DOWNLOAD mode again.
  • uncheck Auto reboot in Odin's Options tab
  • Load the latest twrp available twrp_3.2.1-1_T820_28518.tar into the AP slot in the Log tab
  • hit start
  • after ODIN reports PASS, press POWER + HOME + VOL DOWN to reboot to recovery - as soon as the screen goes blank, change to VOL UP whilst still holding POWER + HOME --> this will get me into TWRP recovery
    Up to here I agree although I'm not sure about getting into stock recovery as on all my samsungs I access first screen with three button combo and carry on only with Vol + without holding the others further on.

  • < to disable forced encryption, mount internal storage (DATA) and disable dm-verity I will then flash (thru Install in TWRP) the Forced encryption patch: Tabs3_oreo_forced encryption_disabler (previously copied from laptop to internal storage in TWRP) Wasn't needed for me (see below)
  • once this is done, without rebooting (please confirm), Yes I shall format DATA using the *FORMAT DATA button* / "yes" under the wipe options (this will WIPE ALL INTERNAL STORAGE!)
  • once this is done, without rebooting (please confirm) Yes, I shall then flash (thru Install in TWRP) Magisk 20.4 (also previously copied from laptop to internal storage Better use a SD-card to store all neccessary files onto or an USB stick as OTG should work in TWRP)
  • reboot and check DATA is mountable (Please confirm this is a reboot to System or to Recovery) I didn't do any of this except formating data and flashing Magisk but see bottom.

  • backup all partitions (at least efs) and store somewhere (in order not to lose IMEI)
    After flashing recovery I recommend to save EFS, if possible, before doing anything else.
  • full wipe all = factory reset + format data thru dedicated button + "yes" under the wipe options in TWRP
  • flash (thru Install in TWRP) LineageOS 17.1 (also previously copied from laptop to internal storage in TWRP)
  • reboot to system which should now be a rooted LineageOS
  • go into system and click seven times on build to get to show the Developpers options, allow USB debugging.
In my previous attempts, I noticed at the end of the lineageOS flash, the process tells me it couldn't find the magisk addon so I assumed it was not rooted and I flashed magisk again
+ when I rebooted into recovery:
- I still need to allow modifications
- my twrp settings (time zone + vibration) are not saved
- data is not mounted

Thanks a lot in advance for your help.

Expand the quote as I edited your post.

Gotta admit I'm using rorys tweaked ROM which is debloated and I deleted even bloats more before flashing.

I replaced the mentioned TWRP with twrp_3.2.1-1_T825_ashyx_Valera1978_repack.img.

Exchange Magisk to the newer one.

Might be possible, that OEM setting will not be displayed directly after turning on dev options because some time most pass after dev option is set.
To bypass this try to set time manually one month back before connecting to the internet.
That worked for mine several times.

On all my devices I've flashed Magisk either directliy after the custom ROM or after a first reboot but never before flashing the ROM.

On my devices I do the following:
Unlocking if necessary or flashing ch-autoroot.
TWRP flash in AP with Odin (auto reboot unchecked)
rebooting to new TWRP recovery
Backing up everything wanted or needed
Wiping all partitions and additionally formating data.
Custom ROM (with or without Gapps) flashed
either reboot to flash Magisk while on some devices it works to flash directly.

Never had problems with not mounting Data or encryption so I don't now much about this
 
Last edited:
  • Like
Reactions: BenG7

BenG7

Senior Member
Jun 24, 2009
539
68
@bmwdroid Thanks A LOT for your help.
Your device is the the SM-T825, right?

[EDIT] actually the issue is with TWRP NOT LineageOS:
LineageOS 17.1 is properly installed and running but I cannot root it as, each time I reboot into recovery:
- I still need to allow modifications
- my twrp settings (time zone + vibration) are not saved
- data is not mounted (and therefore cannot access the magisk 20.4 zip previously copied from my laptop to the internal storage of the tablet while running LOS) - will try to copy magisk 20.4 zip to an SD card...

[EDIT2] TWRP won't even let me mount external SD.

Please see my additional comments, after your own, below (expand quote again):

  • put my t820 in DOWNLOAD mode
  • flash latest stock (T820XXU3CTD5 for me) with odin
  • reboot to latest stock
  • Go into system and click seven times on build to get to show the Developpers options
  • in the developper options allow OEM unlock & USB debugging
  • put my t820 device in DOWNLOAD mode again.
  • uncheck Auto reboot in Odin's Options tab
  • Load the latest twrp available twrp_3.2.1-1_T820_28518.tar into the AP slot in the Log tab
  • hit start
  • after ODIN reports PASS, press POWER + HOME + VOL DOWN to reboot to recovery - as soon as the screen goes blank, change to VOL UP whilst still holding POWER + HOME --> this will get me into TWRP recovery
    Up to here I agree although I'm not sure about getting into stock recovery as on all my samsungs I access first screen with three button combo and carry on only with Vol + without holding the others further on. Confused here: as I described I just flashed TWRP, I get into TWRP recovery, not stock recovery, I take it this is a mistake?
  • < to disable forced encryption, mount internal storage (DATA) and disable dm-verity I will then flash (thru Install in TWRP) the Forced encryption patch: Tabs3_oreo_forced encryption_disabler (previously copied from laptop to internal storage in TWRP) Wasn't needed for me (see below) I take it you mean it wasn't necessary for you to copy the disabler from laptop to internal storage as you use an sd card NOT it wasn't necessary for you to flash the disabler ?
  • once this is done, without rebooting (please confirm), Yes I shall format DATA using the *FORMAT DATA button* / "yes" under the wipe options (this will WIPE ALL INTERNAL STORAGE!)
  • once this is done, without rebooting (please confirm) Yes, I shall then flash (thru Install in TWRP) Magisk 20.4 (also previously copied from laptop to internal storage Better use a SD-card to store all neccessary files onto or an USB stick as OTG should work in TWRP); I will use an SD card (I wanted to save myself the hassle of putting the card in)
  • reboot and check DATA is mountable (Please confirm this is a reboot to System or to Recovery) I didn't do any of this except formating data and flashing Magisk but see bottom. OK

  • backup all partitions (at least efs) and store somewhere (in order not to lose IMEI)
    After flashing recovery I recommend to save EFS, if possible, before doing anything else. OK
  • full wipe all = factory reset + format data thru dedicated button + "yes" under the wipe options in TWRP
  • flash (thru Install in TWRP) LineageOS 17.1 (also previously copied from laptop to internal storage in TWRP)
  • reboot to system which should now be a rooted LineageOS
  • go into system and click seven times on build to get to show the Developpers options, allow USB debugging.
In my previous attempts, I noticed at the end of the lineageOS flash, the process tells me it couldn't find the magisk addon so I assumed it was not rooted and I flashed magisk again
+ when I rebooted into recovery:
- I still need to allow modifications
- my twrp settings (time zone + vibration) are not saved
- data is not mounted

Thanks a lot in advance for your help.

Expand the quote as I edited your post.

Gotta admit I'm using rorys tweaked ROM which is debloated and I deleted even bloats more before flashing. I came from rorys tweaked ROM which is still too bloated in my opinion (and that's why I decided to move on to LineageOS 17 even though I had further debloated Rory's rom with Titanium Backup)

I replaced the mentioned TWRP with twrp_3.2.1-1_T825_ashyx_Valera1978_repack.img. Arf, I take it you have an SM-T825 as twrp_3.2.1-1_T825_ashyx_Valera1978_repack.img is for T825 given its name (where did you get it? I couldn't find it); I have the SM-T820 model; and i suspect the issue is with twrp_3.2.1-1_T820_28518.tar not being able to mount /data properly…

Exchange Magisk to the newer one. I am already using Magisk 20.4.

Might be possible, that OEM setting will not be displayed directly after turning on dev options because some time most pass after dev option is set. I noticed the OEM unlock does not show anymore in the Developer options now, it only showed the first time I rooted the tablet prior to the installation of Rory's rom
To bypass this try to set time manually one month back before connecting to the internet.
That worked for mine several times.

On all my devices I've flashed Magisk either directliy after the custom ROM or after a first reboot but never before flashing the ROM.

On my devices I do the following:
Unlocking if necessary or flashing ch-autoroot.
TWRP flash in AP with Odin (auto reboot unchecked)
rebooting to new TWRP recovery
Backing up everything wanted or needed
Wiping all partitions and additionally formating data.
Custom ROM (with or without Gapps) flashed
either reboot to flash Magisk while on some devices it works to flash directly.
Except for this latest buy of the SM-T820 at a now reasonable price, it's been a while since I dealt with samsung devices (I switched to LG phones following samsung taking on apple style price policy for their own devices…), but this is indeed what I used to do and at the time there was no encryption / partition A& B business…

Never had problems with not mounting Data or encryption so I don't now much about this
 
Last edited:
@BenG7 to not enlarge the post to much I start newly here.
Yes, mine is T825.
TWRP I got from here and I assumed @Valera1978 made it for both models as he didn't quote differenty, but you may be right that it's only for mine. Did you try 3.1.0-1 as well?
I do have some devices on which TWRP doesn't save Time settings either.

I got confused with accessing TWRP after Odin flash as well as I only boot with button combo and it starts TWRP without any further buttons need to be pressed. Just a blue note appears on top saying "recovery booting" then you can release the buttons.

Magisk 21.1 from here.

I wonder why you bother about encryption problems at all as (acc. to what the dev wrote it's only relevant for Oreo) and you were either flashing debloated Pie or LOS17 =Q, or do I misunderstand something?

Hope I didn't miss a point.
 

BenG7

Senior Member
Jun 24, 2009
539
68
@BenG7 to not enlarge the post to much I start newly here.
Yes, mine is T825.
TWRP I got from here and I assumed @Valera1978 made it for both models as he didn't quote differenty, but you may be right that it's only for mine. Did you try 3.1.0-1 as well?
I do have some devices on which TWRP doesn't save Time settings either.

I got confused with accessing TWRP after Odin flash as well as I only boot with button combo and it starts TWRP without any further buttons need to be pressed. Just a blue note appears on top saying "recovery booting" then you can release the buttons.

Magisk 21.1 from here.

I wonder why you bother about encryption problems at all as (acc. to what the dev wrote it's only relevant for Oreo) and you were either flashing debloated Pie or LOS17 =Q, or do I misunderstand something?

Hope I didn't miss a point.
Thanks again, it's probably me getting all mixed up to be honest!
the repack by Valera1978 clearly states T825 in its name...

So I flashed twrp again.
After it was flashed, I rebooted into recovery: data (nor anything else is mounted) so I repaired data from ext2 to ext4 to be able to gain access to data on the next reboot (the process erases everything on the data partition).

On rebooting again data is mounted (with a TWRP folder inbside) (only data is mounted, external sd is not mounted / mountable) so I could copy LOS rom + magisk (21.1) to data.

Once both copied, I flashed LOS, when finished I also flashed magisk
Then I rebooted to system.

LOS starts no pb, LOS is rooted but each time I reboot into recovery:
- I still need to allow modifications
- my twrp settings (time zone + vibration) are not saved
- data / Micro SD card / USB OTG (all reporting 0 MB BTW) are not mounted / mountable
- & when selecting storage, only internal storage (0mb) is selectable

meaning that if I need to flash anything, I will first need to repair the data again (as explained above) to get access to it, erasing everyhting in the process and I will need to reinstall eveything...
It sounds like this is how it is intended to work; FAR from ideal really...

Thanks A LOT for your help anyway.
 
Last edited:

BenG7

Senior Member
Jun 24, 2009
539
68
@BenG7 sorry that I couldn't help.
Seems to be a problem with TWRP for T820.
Perhaps you want to try this one.

OK, from reading the whole thread, I'm going to give it another try after I re-flashed the latest stock (pie); instructions on how to root the SM-T82x under Pie are not provided in the OP so I'm providing them here for reference:
@ashyx / @rorymc928 / @LedgendaryEpics: please correct me if I'm wrong (will do this tomorrow as it is pretty late now here)

Flash with ODIN using the AP slot.

1. Put your device in DOWNLOAD mode,
2. Uncheck Auto reboot,
3. Load the adequate twrp_3.2.1-1_T820_28518 / twrp_3.2.1-1_T825_29518 into the AP slot and hit start,
4. After flashing and ODIN reports PASS immediately reboot to recovery by holding POWER + HOME + VOL DOWN.
As soon as the screen goes blank change to VOL UP whilst still holding POWER + HOME --> You should now be in TWRP recovery.
5. Install the RMM V3 bypass
6. Install the Dmverity and encryption patch
7. Format DATA using the *FORMAT DATA button* under the wipe options.
(NOTE - THIS WILL WIPE ALL INTERNAL STORAGE!)
8. Install Magisk
8. Reboot and check DATA is mountable --> Done.
 

LedgendaryEpics

Senior Member
Jun 14, 2018
51
18
OK, from reading the whole thread, I'm going to give it another try after I re-flashed the latest stock (pie); instructions on how to root the SM-T82x under Pie are not provided in the OP so I'm providing them here for reference:
@ashyx / @rorymc928 / @LedgendaryEpics: please correct me if I'm wrong (will do this tomorrow as it is pretty late now here)

Flash with ODIN using the AP slot.

1. Put your device in DOWNLOAD mode,
2. Uncheck Auto reboot,
3. Load the adequate twrp_3.2.1-1_T820_28518 / twrp_3.2.1-1_T825_29518 into the AP slot and hit start,
4. After flashing and ODIN reports PASS immediately reboot to recovery by holding POWER + HOME + VOL DOWN.
As soon as the screen goes blank change to VOL UP whilst still holding POWER + HOME --> You should now be in TWRP recovery.
5. Install the RMM V3 bypass
6. Install the Dmverity and encryption patch
7. Format DATA using the *FORMAT DATA button* under the wipe options.
(NOTE - THIS WILL WIPE ALL INTERNAL STORAGE!)
8. Install Magisk
8. Reboot and check DATA is mountable --> Done.


i think you have to reboot manually, havent rooted stock pie in years...
 
  • Like
Reactions: BenG7

Top Liked Posts

  • There are no posts matching your filters.
  • 87
    Unofficial release -TWRP recovery for the Samsung Galaxy Tab S3 - SM-T820/T825, Qualcomm MSM8996

    teamwin-recovery-project-twrp-logo.jpg



    TWRP 3.2.1-0 Released
    Dec 9, 2017

    TWRP 3.2.1-0 is out now for most currently supported devices.

    What's new in 3.2.1-0:


    What's new in 3.2.1-0:

    * minui fixes (cryptomilk)
    * Better android-8.0 compatibility in ROM trees (Dees_Troy)
    * Fix missing library in android-8.0 (nkk71)
    * Fix inconsistent SDCard naming (DevUt)
    * Default to TWRP restore instead of adb backup restore to fix restore on fresh TWRP boot (jlask)



    Update 18/5/2018
    TWRP 3.2.1-1 build released.

    Current status: BETA

    Features:

    MTP working
    ADB working
    SEANDROID warning fix
    TWRP and Kernel built from latest source
    Factory Image flashing(see below) >> to be added
    NTFS support
    F2FS support >> To be added
    Twrp app support


    IMPORTANT:
    PLEASE READ ALL OF THIS POST BEFORE FLASHING ANYTHING TO YOUR DEVICE.



    WHATEVER YOU DO BEFORE FLASHING ANYTHING MAKE A BACKUP OF YOUR DEVICE AND HAVE THE STOCK FIRMWARE TO HAND JUST IN CASE, DOWNLOADED FROM SAMMOBILE OR UPDATO.
    THIS WILL TRIP KNOX AND MAY VOID YOUR WARRANTY!




    Instructions:


    Flash with ODIN using the AP slot.

    1. Put your device in DOWNLOAD mode.
    2. Uncheck Auto reboot.
    3. Load the respective file below into the AP slot and hit start.
    4. After flashing and ODIN reports PASS immediately reboot to recovery by holding POWER + HOME + VOL DOWN.
    As soon as the screen goes blank change to VOL UP whilst still holding POWER + HOME.
    You should now see TWRP recovery.
    Failure to implicitly comply with step 4 will result in stock recovery replacing TWRP at first boot


    NOTE: Since android 5.1.1 it is necessary to enable OEM Unlock.
    Settings -> Developer Options -> OEM unlocking
    ENABLE OEM UNLOCK FIRST OR YOU MAY ENCOUNTER 'BLOCKED BY FRP LOCK' WHEN FLASHING.



    DOWNLOAD -
    Device must be running at least AQD6 or later firmware. Earlier firmware may need the previous builds:


    UPDATE: 18/5/2018 TWRP 3.2.1-1

    twrp_3.2.1-1_T820_28518

    twrp_3.2.1-1_T825_29518


    UPDATE: 8/5/2017 TWRP 3.1.0-1

    twrp_3.1.0-1_sm-t820_AQD6

    twrp_3.1.0-1_sm-t825_AQD6

    Previous builds:

    SM-T820:
    https://www.androidfilehost.com/?fid=745425885120721426

    SM-T825:
    https://www.androidfilehost.com/?fid=673368273298945058



    IMPORTANT! This device enforces dm-verity. ANY modifications or even mounting system will put the device into a bootloop. To prevent this TWRP will ask at first boot if you want to keep system 'Read only' or 'Allow modifications to system'. If you choose to keep 'Read only' you will have to flash TWRP at every boot to recovery.
    If you choose to 'Allow' then Magisk needs flashing below to disable dm-verity.







    Follow the instructions below to disable dmverity, forced encryption and mount internal storage(DATA):

    MARSHMALLOW AND NOUGAT ONLY!:
    To disable forced encryption, mount internal storage(DATA) and disable dm-verity:


    1. Boot to Twrp
    2. Format Data partition using FORMAT DATA button under Wipe options.
    (Note: This will wipe the internal storage)
    3. Check DATA is mountable.
    4. Install Magisk
    5. Reboot


    OREO ONLY!:
    To disable forced encryption, mount internal storage(DATA) and disable dm-verity:


    1. Boot to TWRP

    2. Install the Forced encryption patch: Tabs3_oreo_forced encryption_disabler

    3. Format DATA using the *FORMAT DATA button* under the wipe options.
    (NOTE - THIS WILL WIPE ALL INTERNAL STORAGE!)

    4. Install Magisk

    5. Reboot and check DATA is mountable

    Done.

    Magisk: https://forum.xda-developers.com/apps/magisk/official-magisk-v7-universal-systemless-t3473445


    INSTRUCTIONS TO USE ADB BACKUP:
    https://www.droidorigin.com/take-adb-backup-using-twrp-v3-1-0-0/







    DEVICE TREE: soon


    PLEASE DO *NOT* DIRECT LINK TO THESE FILES. PLEASE LINK TO THIS POST


    Screenshot_2016_03_05_08_13_44_1.png


    DnoCrqh.png


    VAm49c4.png


    ytBFf13.png


    ONLSkMi.png



    Credits: Me, my testers @suzook, @jonathonalexander, Teamwin
    Please note I don't own this device and spend a lot of my free time bringing these builds for you to use and benefit from.

    FEEDBACK IS APPRECIATED PLEASE.
    THANKS.


    DONATE ME HERE IF YOU WANT TO BUY ME A BEER OR HIT THE THANKS BUTTON IF I HELPED YOU



    .
    7
    Ok, just tried the AQB9 Bootloader with your first and second permissive boot.img, but didn't worked. Stucked at first boot logo with the yellow writing in the upper left corner like before. Do you maybe have a AQBB, AQC1 or AQD6 permissive boot.img?

    Edit:
    Just to be sure that the error lies in your kernel source, I downgraded the firmware to AQB9. Ended up with the same errors for both permissive boot images like before.
    Looks like the kernel source is fubarred. It's not the first time Sammy source code has been unbootable and it always Qualcomm source code.
    Samsung have just contacted me with confirmation of an updated source code release, so hopefully this one boots
    7
    Try reading the OP instead of posting pointless questions. Ciao.

    You have far more patience than I do when it comes to dealing with some of these posters:rolleyes: How people can so quickly lose sight of the fact that you are donating your time to help us with a device that you don't even own is beyond me :confused:
    Thanks again for everything that you do - we really do appreciate it! :good:
    6
    UPDATE: SM-T820 and SM-T825 fixed builds up.
    SuperSU compatibility fixed.
    6
    Data mount works!!! I think we(you) have a winner! Camera works, rotate works,an supersu works,and flashes in twrp as it should. Great job, curious as to what the issue was.
    The issue, as I suspected, the kernel version was mismatched to the base firmware on the device.

    This is why it was important to get supersu working correctly, so the stock boot.img on the device could be patched rather than providing pre-patched boot images. That would have turned into a real nightmare to provide for every device.

    Anyway this is all fixed now on the latest posted TWRP and Chainfire is also implementing a fix to SuperSU.
    Chainfire has also implemented my Encryption fix into SuperSU.

    You've been a great help in all this, to me and Chainfire. Hope your wife understands ;)

    Chainfire has another request you may be able to help with in the Beta SuperSU thread.