[RECOVERY][T813] TWRP 3.3.0-0 Touch Recovery [OFFICIAL]

Search This thread

Top Liked Posts

  • There are no posts matching your filters.
  • 19
    Team Win Recovery Project 3.x, or twrp3 for short, is a custom recovery built with ease of use and customization in mind. Its a fully touch driven user interface no more volume rocker or power buttons to mash. The GUI is also fully XML driven and completely theme-able. You can change just about every aspect of the look and feel.

    DOWNLOAD: https://dl.twrp.me/gts210vewifi

    If you have found a bug, please consider posting it to our github issues log and then I'll report to Dess_Troy. If you have a significant problem that cannot be answered in this thread, your best bet is to PM Dees_Troy directly, contact us via our website, or find us in our IRC channel below. If you see someone that's struggling, feel free to point it out to us. We need your help to help us keep track of all of our devices! Thanks!

    Live support is available via #twrp on Freenode with your IRC client or just click this link.

    XDA:DevDB Information
    [RECOVERY][T813] TWRP 3.3.0-0 Touch Recovery [OFFICIAL], ROM for the Samsung Galaxy Tab S2

    LuK1337, luca020400, Olivier
    Source Code: https://github.com/TeamWin

    ROM OS Version: 6.0.x Marshmallow
    ROM Kernel: Linux 3.10.x

    Version Information
    Status: Testing

    Created 2017-01-24
    Last Updated 2019-04-15
    Hello everyone :)

    I just finished modifying TWRP from the official device tree. It is now based on Android 9.0, TWRP 3.3.1 and can decrypt (tested with LineageOS 16.0 and f2fs on /data) + some other changes.

    For now the only thing I can't get working is restarting in Download mode from the TWRP interface. I haven't tested everything so it may be that there are other errors >>> if you can do tests and get back to me with logs it would be great ;) once I have enough positive feedback I will propose to integrate my changes into the official TWRP device tree.


    • Download v3.6.0_9 BETA08 : img / tar / tar.md5
      • Changelog to write, and I have to update the repo
    • Download v3.3.1 "BETA07"
      • Fix modules survival when ota update with encryption
    • Download v3.3.1 "BETA06"
      • rewrite the script who fix date
      • now activate property and build debug tools only when build twrp with eng variant (no more with userdebug)
      • little change for encrypt footer in fstab (need test and review)
      • change usb init.rc rules, it should work better (need test and review)
    • Download v3.3.1 "BETA05"
      • fix color flipp
      • fix time_daemon dependencies
    • Download v3.3.1 "BETA04"
      • disable vibration
      • fix wrong pixel format
      • active more debug message
      • fix timezone data and wrong date
      • various minor update
    • Download v3.3.1 "BETA03"
      • fix reboot to dowload (use now reboot to bootloader)
    • Download v3.3.1 "BETA02"
      • use prebuilt kernel
      • add tools for debug (debuggerd, strace & twrpdec)
    • Download v3.3.1 "BETA01"
      • initial release
      • based on Android 9.0
      • support decrypt

    What's not working :
    • Need test & review : format data, then try encrypt / decrypt, post you ROM, partition data type (ext4 or f2fs), and other information.
    • Need test & review : verify if survival modules are keep after ota update with encryption.

    Device tree sources :
    Thats awesome I will gladly wait until your out of work. I have been looking for another rom to try on this tablet for pie. Just let me know thanks.
    crdroid: https://www.androidfilehost.com/?w=files&flid=293541

    Same warning as before, it's working seemingly fine on my tablet but who knows, I'm the only user, so you're doing this at your own risk. Make a nandroid backup for sure. Clean flash since it's a new ROM. Backup your internal storage. Be safe. I'm going to make myself updates for the monthly security patches at the very least. Can do weeklies or something if there's interest. Also if I'm allowed to be sharing these, these aren't my device trees or code or anything, I just sync & build.

    I'm also working on collecting all (and I mean ALL) the Odin(/Heimdall) firmware files. So far I have all of the latest build from last year, and I'm working on the one that just dropped this year. Nice to have in case of a soft brick:


    Marshmallow (lower priority unless someone needs something)
    How to Install TWRP, LineageOS 16.0 and Root Samsung Tab S2 9.7 (2016) SM-T813

    How to Install TWRP, LineageOS 16.0 and Root Samsung Tab S2 9.7 (2016) SM-T813

    1. Fresh install of Windows 7 x64 with all the correct chipset and other drivers installed. (I tried this in Windows 10 x64 and Centos 8.0 Linux and FWUL Linux v4.0 and all 3 failed for me, so ONLY a fresh install of Windows 7 x64 worked for me).

    2. Install Samsung Drivers on the Windows 7 x64 PC (Samsung-Usb-Driver-v1.5.63.0).

    3. Download Odin (Odin3 v3.13.1).

    4. Copy your LineageOS ROM (lineage-16.0 nightly.zip), TWRP Recovery (twrp-3.3.1-0-gts210vewifi.img.tar and also twrp-3.3.1-BETA07-gts210vewifi.img by Akipe from XDA-Developers) and Magisk (Magisk-v20.1.zip and also MagiskManager-v7.4.0.apk) and GAPPS (MindTheGapps-9.0.0-arm64-20190615_031441.zip) files on a micro SD card.

    Actual installation of TWRP, LineageOS 16.0 and Rooting using Magisk:
    1. Connect the USB cable to the PC ONLY first. Then on the tablet go into Download mode by first switching off the tablet, then when off, press Power, Volume UP and Home buttons. Then you will have to press the volume up key to accept the warning. When it says 'Downloading', THEN connect the USB cable into the tablet.

    2. Flash TWRP recovery using Odin (Odin3 v3.13.1). Make sure to select 'AP' and choose the TWRP image (twrp-3.3.1-0-gts210vewifi.img.tar), and in options, do NOT select 'Auto Reboot', instead ONLY select 'F.Reset Time' Click on 'Start', to start flashing and read the log until it says 'success'. Once done installing successfully, disconnect the USB cable, DO NOT reboot back into System

    3. After TWRP flashing is finished in Odin, DO NOT reboot back into System - Press Power, Volume DOWN and Home buttons, when the screen goes black, then immediately change to Power, Volume UP and Home, then it will go into TWRP Recovery again.

    4. Make sure to go to Wipe, Advanced Wipe and wipe ALL partitions (EXCEPT micro SD and USB OTG) for a clean install, but ALSO go back to wipe the '/Data' partition to F2FS by going into 'Advance Wipe' and selecting 'Data', then say 'Change File System', then select F2FS. If you don't format to F2FS, you will keep getting a Failed to mount '/Data' error and the tablet will go into a reboot loop to reset the encryption because it cannot mount '/Data'. This is important.

    5. After wiping all the partitions, Reboot back into recovery (DO NOT reboot back into system yet) go back to TWRP home screen and select 'Install' then 'Select Storage' and select the micro SD, then select the other TWRP file by Akipe (twrp-3.3.1-BETA07-gts210vewifi.img) this has some improvements as mentioned earlier in this post by Akipe himself (Thanks Akipe :D). Then again reboot back into recovery (NOT System) and it should be 'twrp-3.3.1-BETA07-Akipe'.

    6. When In recovery again select 'Install' then 'Select Storage' and select the micro SD, then select first the 'lineage-16.0 nightly.zip' then add 'Magisk-v20.1.zip' then flash. This should flash successfully, if there are no ERRORS, you can reboot back into the system and continue to set up the tablet. If there are errors about 'Failed to mount '/Data'' then you need to repeat step 4 above making sure 'Data' partition is formatted to F2FS.

    7. If LineageOS boots up successfully, Reboot back into recovery and 'Install', 'Select Storage' then select the Gapps file (MindTheGapps-9.0.0-arm64-20190615_031441.zip) and flash it, then reboot back into the System.

    8. You should be OK to start using Google Play to install the apps you need. Also while in LineageOS you can access the micro SD and install MagiskManager-v7.4.0.apk and don't forget to install stericsson busybox to xbin (from Google Play)

    I Hope that helps someone as I had a lot of frustrations trying to figure this out as nothing was working for me, with all the guides that are on the internet. All the best! :D
    You say that there's a crdroid 5.3 pie for the Samsung Galaxy T813? Could you please point to a link or tell where to find it.
    Built it myself. As far as I know I'm the only one using it, so it's working fine for me but you'll have to use at your own risk. I'll upload and share the link, but might have to wait until after work