[RECOVERY][TWRP 3.2.x][n2awifi]Unofficial TWRP recovery for SM-T520

Search This thread

LaCruz

Senior Member
Oct 3, 2008
140
274
TWRP is an open source, community project. A custom recovery is used for installing custom software on your device. This custom software can include smaller modifications like rooting your device or even replacing the firmware of the device with a completely custom “ROM” like LineageOS or OmniROM.
This thread is for Unofficial TWRP builds for picassowifi/n2awifi (SM-T520).

Code:
#include <std_disclaimer.h>
/*
 *
 * We are not responsible for bricked devices, dead SD cards,
 * thermonuclear war, or you getting fired because the alarm app failed. Please
 * do some research if you have any concerns about features included in this ROM
 * before flashing it! YOU are choosing to make these modifications, and if
 * you point the finger at us for messing up your device, we will laugh at you.
 *
 */

Downloads
TWRP 3.2.1-0 (first build - just try - Release Date: 2020-06-07)
TWRP 3.2.3-0 - Version 1 (Beta Release Date: 2020-06-08)
TWRP 3.2.3-0 - Version 2 (Beta Release Date: 2020-06-11 / Brightness setting & USB OTG might work)

Issues
Just try - on my device everything seems fine.

Source code:
https://github.com/omnirom/android_bootable_recovery
https://github.com/exynos5420/androi...amsung_n2awifi

Credits:
Exynos5420 Dev Team (@deadman96385 @thompatry @ZakooZ @Orion116 @mosimchah @joshndroid @Andmoreagain @thermskin, @javelinanddart )
@awidawad for his first picassowifi builds. Thanks to TWRP team for there dev!

Version Information
Status: Beta

Created 2020-06-07
Last Updated 2020-06-11
 
Last edited:

karabanoff

New member
Feb 23, 2016
4
1
Everything seems to be working fine, thanks guys, great job!
UPD: Have an Error when i tried to wipe cache
 
Last edited:

LaCruz

Senior Member
Oct 3, 2008
140
274
TWRP rebooted during file system changing and then the same error during wiping (faild to mount '/cache' (invalid argument))
UPD: now i have firmware boot loop :(

Strange... I am sorry for that.
I got similar thing yesterday. But just set 'cache' to ext4 and format let it boot again. Which ROM do you use?
 

karabanoff

New member
Feb 23, 2016
4
1
Strange... I am sorry for that.
I got similar thing yesterday. But just set 'cache' to ext4 and format let it boot again. Which ROM do you use?

I use lineageos 14.1 unofficial, latest build vanilla version

I am very sorry. This is my mistake, I formated cache together with dalvik to ext4, when I have only cache to ext4 formated, all bigin working fine
 
Last edited:
  • Like
Reactions: LaCruz
TWRP is an open source, community project. A custom recovery is used for installing custom software on your device. This custom software can include smaller modifications like rooting your device or even replacing the firmware of the device with a completely custom “ROM” like LineageOS or OmniROM.
This thread is for Unofficial TWRP builds for picassowifi/n2awifi (SM-T520).

Code:
#include <std_disclaimer.h>
/*
 *
 * We are not responsible for bricked devices, dead SD cards,
 * thermonuclear war, or you getting fired because the alarm app failed. Please
 * do some research if you have any concerns about features included in this ROM
 * before flashing it! YOU are choosing to make these modifications, and if
 * you point the finger at us for messing up your device, we will laugh at you.
 *
 */

Downloads
TWRP 3.2.1-0 (first build - just try - Release Date: 2020-06-07)
TWRP 3.2.3-0 - Version 1 (Beta Release Date: 2020-06-08)
TWRP 3.2.3-0 - Version 2 (Beta Release Date: 2020-06-11 / Brightness setting & USB OTG might work)

Issues
Just try - on my device everything seems fine.

Source code:
https://github.com/omnirom/android_bootable_recovery
https://github.com/exynos5420/androi...amsung_n2awifi

Credits:
Exynos5420 Dev Team (@deadman96385 @thompatry @ZakooZ @Orion116 @mosimchah @joshndroid @Andmoreagain @thermskin, @javelinanddart )
@awidawad for his first picassowifi builds. Thanks to TWRP team for there dev!

Version Information
Status: Beta

Created 2020-06-07
Last Updated 2020-06-11
These TWRP files are IMG files. Odin requires TAR files. Are there TAR files available?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    TWRP is an open source, community project. A custom recovery is used for installing custom software on your device. This custom software can include smaller modifications like rooting your device or even replacing the firmware of the device with a completely custom “ROM” like LineageOS or OmniROM.
    This thread is for Unofficial TWRP builds for picassowifi/n2awifi (SM-T520).

    Code:
    #include <std_disclaimer.h>
    /*
     *
     * We are not responsible for bricked devices, dead SD cards,
     * thermonuclear war, or you getting fired because the alarm app failed. Please
     * do some research if you have any concerns about features included in this ROM
     * before flashing it! YOU are choosing to make these modifications, and if
     * you point the finger at us for messing up your device, we will laugh at you.
     *
     */

    Downloads
    TWRP 3.2.1-0 (first build - just try - Release Date: 2020-06-07)
    TWRP 3.2.3-0 - Version 1 (Beta Release Date: 2020-06-08)
    TWRP 3.2.3-0 - Version 2 (Beta Release Date: 2020-06-11 / Brightness setting & USB OTG might work)

    Issues
    Just try - on my device everything seems fine.

    Source code:
    https://github.com/omnirom/android_bootable_recovery
    https://github.com/exynos5420/androi...amsung_n2awifi

    Credits:
    Exynos5420 Dev Team (@deadman96385 @thompatry @ZakooZ @Orion116 @mosimchah @joshndroid @Andmoreagain @thermskin, @javelinanddart )
    @awidawad for his first picassowifi builds. Thanks to TWRP team for there dev!

    Version Information
    Status: Beta

    Created 2020-06-07
    Last Updated 2020-06-11
    2
    Thanks, @LaCruz! I have been using TWRP 3.0.2-0 with the Deathly Version of LOS 14.2 for years w/o issue. Are there specific feature improvements in this latest TWRP to encourage the change?

    New builds are based on LOS 15 and LOS 15.1.

    Changes can be found in TWRP Changelog and Changelog
    1
    Your alpha seems to work without issues. Just made a nand, external sd is found and writeable and I had no random reboots or other hichups.
    1
    Strange... I am sorry for that.
    I got similar thing yesterday. But just set 'cache' to ext4 and format let it boot again. Which ROM do you use?

    I use lineageos 14.1 unofficial, latest build vanilla version

    I am very sorry. This is my mistake, I formated cache together with dalvik to ext4, when I have only cache to ext4 formated, all bigin working fine