• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[Recovery][TWRP][Root] TWRP and Root for Moto E5 Play (James)

Search This thread

bubba1601

Senior Member
Aug 23, 2016
1,886
1,191
49
man i no i have to be getting on ur nerves and i sincerely apologize...but i have the correct firmware DL but nothing will flash it...and no on my dev manager is comes up as a moto 4 for some reason...if u can point me one last time, if i dnt get it this time ill put it in a drawer..srry

---------- Post added at 06:25 AM ---------- Previous post was at 06:23 AM ----------


an i no i have to be getting on ur nerves and i sincerely apologize...but i have the correct firmware DL but nothing will flash it...and no on my dev manager is comes up as a moto 4 for some reason...if u can point me one last time, if i dnt get it this time ill put it in a drawer..srry


I cannot and will not help you any further, as I explained in my last comment, because I don't have the James device.
I have the Pettyl device.

I don't go searching for device firmwares and reading flashing instructions for a different devices to one I have.
The XT1920-15 (Pettyl) that I have has android 8.1 Go edition and its own set of flashing instructions that are mostly different to your James XT1921-2 that has android 8.0.

I'm going to skip offering you anymore advice or assistance, because I have no experience of using the James device - it would be very foolish and very wrong of me to try and help you and possibly cause you even more problems.
That is why I said in my last comment I cannot help you any further - not to be mean to you - because I don't know what to do to get your device working, especially of you say it's showing Moto E4......:eek:

Xda is full of people who claim they are "experts" and know everything - the problem with that is if you was to follow one of these self proclaimed "experts" advice, I'm sure your James would end up a useless paperweight - and I don't want that just as much as you don't want that.

I'm not about to jump on that bandwagon and try, I'm afraid.

All I can suggest you do is goto the E5 firmware thread

https://forum.xda-developers.com/moto-e5/how-to/firmware-moto-e5-xt1944-4-dual-sim-t3820901

Read all the comments from James users or search James using the XDA search function, as I'm sure you will find what you need there, not here.

Sorry.
 
Last edited:
  • Like
Reactions: GOOGLE_USER
Dec 22, 2016
29
3
I cannot and will not help you any further, as I explained in my last comment, because I don't have the James device.
I have the Pettyl device.

I don't go searching for device firmwares and reading flashing instructions for a different devices to one I have.
The XT1920-15 (Pettyl) that I have has android 8.1 Go edition and its own set of flashing instructions that are mostly different to your James XT1921-2 that has android 8.0.

I'm going to skip offering you anymore advice or assistance, because I have no experience of using the James device - it would be very foolish and very wrong of me to try and help you and possibly cause you even more problems.
That is why I said in my last comment I cannot help you any further - not to be mean to you - because I don't know what to do to get your device working, especially of you say it's showing Moto E4......:eek:

Xda is full of people who claim they are "experts" and know everything - the problem with that is if you was to follow one of these self proclaimed "experts" advice, I'm sure your James would end up a useless paperweight - and I don't want that just as much as you don't want that.

I'm not about to jump on that bandwagon and try, I'm afraid.

All I can suggest you do is goto the E5 firmware thread

https://forum.xda-developers.com/moto-e5/how-to/firmware-moto-e5-xt1944-4-dual-sim-t3820901

Read all the comments from James users or search James using the XDA search function, as I'm sure you will find what you need there, not here.

Sorry.
no need to be sorry guy, u def put in alot work along with me...i appreciate the time u did take to help tho man...
 

GOOGLE_USER

Senior Member
Jul 8, 2016
406
643
101
where I go, there I've been.
  • Like
Reactions: bubba1601

Starkiller2

Senior Member
May 2, 2018
306
150
phoenix
Yeah, YIKES!
I am taking a few minutes to appreciate your forthright acknowledgement of your limitations and contrasting observations of what other members all to often offer. :rolleyes: @ them.
Ah, refreshing honesty.




ALL posts on XDA must be in English please.
Search for methods of translation.

It says Moto e4 because it was a repack of a twrp from an e4 since at the time there were no twrps for the device
 
  • Like
Reactions: GOOGLE_USER

AeonFlux1603

Senior Member
Feb 1, 2019
188
164
Any luck of rooting the Cricket variant (E5 Cruise)?
The Moto E5 Cruise by Cricket has a perma-locked bootloader. Unless by the billion-to-one chance an exploit or hack is discovered to circumvent the bootloader encryption, there is no chance of the device ever being rooted. The same goes for the Verizon variants of the Moto E5, E5 Play & E5 Plus. Verizon & Cricket have long been notorious for opting out of Motorola's bootloader unlocking support protocol.
 

debownbey90

New member
Dec 28, 2014
1
0
Help

I did not understand what you mean in step 2 and 3 I've been trying everything I can think of to root and nothing. I get na when i boot and get stuck at blue moto screen
 

Apologia2u

New member
Jun 10, 2019
1
0
Hey... I'm a novice and I've been have/controlled since 4/16/18 (time of the Russian home wife warning). I have no control over and device, public or supposed secure WiFi... Apps, device ownership etc. Devices are impacted at the moment if purchase. UNREAL... Tracked, etc. Including various options on my 2015 Lexus GX460... After 15-20 phones (Android and iPhone... Contact and prepaid. . Nothing works.
 

LinuxPusher

Member
Jan 19, 2018
36
6
ok well i ended up getting it to boot twrp in fastboot but it wouldnt flash twrp...says its coruppted...but then it said i had no OS i installed...so u used the moto assistant to try and flash stick firmware and it took away the logo i had flashed to replsce the bad key when it boots...but now it just stays at the moto logo and wont go past that.. any ideas as to what i can do to fix this?
" it just stays at the moto logo and wont go past that "
I had this happen on my Moto G4 Plus, the fix that worked for me was to force shut down then boot to Fastboot scroll through all the options then pick start.
I don't know if this will work for you, TRY AT YOUR OWN RISK.
 

Vlad Gogo

Member
May 31, 2017
6
2
Hello. I have pushed and booted to twrp_james.img from adb, but it freezes at the enter decrypt screen and doesn't accept any touch input (though there is a mouse cursor on the screen). I'm on an XT1920-19 and am guessing that this twrp isn't entirely compatible. Or the installed security patch (Nov. 1, 2018) or build number (opg28.54-53) is interfering.

Edit. And it updated itself to Android 8.1.0 when I wasn't looking. Will I need to roll that back?
 
Last edited:

jeffhutch.412

Senior Member
Jun 27, 2012
62
16
36
pittsburgh
I've looked and can't find exactly what to do here, I have a twrp that has the password thing (twrp works, but I'm trying to have the most updated and get rid of that annoying PW screen), but fast boot won't flash twrp over twrp I think? I tried --force and thought it worked but no dice.
Is there a zip? I have James (metro)
Thanks

*edit*
I'm not sure if running the adb decrypt commands + adding an external SD is what worked exactly bit regardless I seem to have normal working twrp now.

BUTTTTTTT

I'm going nuts with magisk hide and Google verification.
Can't sign in, what's the proper procedure??

And my WiFi tether broke. Just says error ?
Could use some thoughts here!
 
Last edited:

jeffhutch.412

Senior Member
Jun 27, 2012
62
16
36
pittsburgh
anybody?
i flashed back to bone stock via fastboot, and started over to just try rooted stock (NEED my hotspot atm)
after flashing twrp, no v, and adb commands i flash magisk and end in bootloop.
i flashed back to stock TWICE and boot loop twice.
actually, i think thats the reason i flashed lineage to begin with was i bootlooped the first time

any idears???
 

Starkiller2

Senior Member
May 2, 2018
306
150
phoenix
anybody?
i flashed back to bone stock via fastboot, and started over to just try rooted stock (NEED my hotspot atm)
after flashing twrp, no v, and adb commands i flash magisk and end in bootloop.
i flashed back to stock TWICE and boot loop twice.
actually, i think thats the reason i flashed lineage to begin with was i bootlooped the first time

any idears???

If you try decrypting with the disabler, it might help. It will definitely get rid of the PW screen in twrp. Flash stock
Flash twrp with fastboot.
Go to twrp, format data, reboot directly to twrp
Flash disabler then magisk, reboot. See if that combo works

https://redirect.viglink.com/?key=&...rypt-t3817389/amp/&ref=https://www.google.com
 

jeffhutch.412

Senior Member
Jun 27, 2012
62
16
36
pittsburgh
If you try decrypting with the disabler, it might help. It will definitely get rid of the PW screen in twrp. Flash stock
Flash twrp with fastboot.
Go to twrp, format data, reboot directly to twrp
Flash disabler then magisk, reboot. See if that combo works

https://redirect.viglink.com/?key=&...rypt-t3817389/amp/&ref=https://www.google.com
Thanks I'll give it a try right now ?

*Edit
That link is a 404 but I'll look it up. I haven't seen anything about a disabler yet
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 19
    Take a backup. :)

    How-to root & disable encrypted /data:

    1. (Fastboot) flash the no-verity kernel
    2. (TWRP) adb shell mount -o,rw /dev/block/platform/soc/7824900.sdhci/by-name/vendor /vendor
    3. (TWRP) adb push fstab.qcom /vendor/etc/fstab.qcom
    4. (TWRP) format data
    5. (TWRP) flash magisk beta

    Wifi / Unlimited Tethering
    1. (TWRP) adb shell mount -o,rw /dev/block/platform/soc/7824900.sdhci/by-name/vendor /vendor
    2. (TWRP) adb pull /vendor/default.prop .
    3. Add net.tethering.noprovisioning=true to default.prop
    4. (TWRP) adb push default.prop /vendor/default.prop

    TWRP 3.2.1 E5 Play
    E5 Play DM-Verity Disabled Kernel
    E5 Plus DM-Verity Disabled Kernel
    fstab.qcom (no-encrypt)
    3
    So next question being is it time to build lineage is 15.1.

    Me thinks so says the guy running the build environment currently

    Sent from my [device_name] using XDA-Developers Legacy app
    3
    OP updated with instruction on how to disable /data encryption.
    3
    Guys it's never appropriate and is in fact strictly forbidden by XDA guidelines to ask for ETAs, updates, etc. Devs like the OP have busy lives outside of XDA and sacrifice their free time and resources to development for the Android community. I'm just saying, please be a bit more considerate and respectful. Thank you.
    It is completely understandable, considering that the Moto E5 series of smartphone is relatively new, to anxiously await development for the device. I'm in high hopes that more devs such as the OP take a developmental interest in the Moto E5 and its many variants, and that we start seeing custom ROMs, custom kernels, mods, custom recoveries, and root tutorials for this great device. I'm only asking that we give our devs respect, be thankful for their time and contributions, and refrain from asking for updates, ETAs, etc. One thing is for certain -- devs love to develop. They just don't always have an abundance of free time to do so outside their sometimes hectic personal lives. OK I've ranted enough. Thanks to all members and devs alike who support the Moto E5 series.