[RECOVERY][UNOFFICIAL][3.5.0][apollo]TWRP for Mi 10T/Mi 10T Pro/Redmi K30S Ultra

Search This thread

Top Liked Posts

  • There are no posts matching your filters.
  • 21
    3.4.0_0 (07.11.2020)
    - Init twrp recovery
    - Decryption data
    - Vibration

    3.4.0_1 (08.11.2020)
    - Can flash twrp in recovery partition.

    3.4.0_2 (20.11.2020)
    - Fix permission denied on mount
    - Fix mtp not work after install ROM. (For me seem work)

    3.4.0_3 (21.11.2020)
    - Fix f2fs file system
    - Fix screenshots(in TWRP folder)
    - Adjust MTP device name
    - Resize GUI measures
    after wipe, I suggest you change filesystem to f2fs.


    - /data filesystem to f2fs
    - Fix mtp after factory reset
    - Add some partition (flash .img)
    After working on TWRP for 2 weeks (without configuring the system), I finally found solution to resolve it.
    Now you can flash all roms as you have done usually

    - Android 11 support
    - Android 11 data decryption
    - Add-on zips
    (install > select storage)
    - Add prevent twrp replace
    - Add OTA fingerprint
    Notice: in some case a11 data decryption won't work, i will fix it as soon as possible.

    Tips: after wipe data, I was set the default mtp directory to /data/media and after boot, the mtp directory will set /data/media/0.
    Thanks every testers:
    @xingdu @GabSam @kimbo_985

    give me yours right id.
    If you like my hard works, please buy me a coffee to keep me alive.:cry:
    Blocking checks
    - [✔] Correct screen/recovery size
    - [✔] Working Touch, screen
    - [✔] Backup to internal/microSD
    - [✔] Restore from internal/microSD
    - [✔] reboot to system
    - [✔] ADB

    Medium checks
    - [❌] update.zip sideload
    - [✔] UI colors (red/blue inversions)
    - [✔] Screen goes off and on
    - [✔] F2FS/EXT4 Support, exFAT/NTFS where supported
    - [✔] all important partitions listed in mount/backup lists
    - [✔] backup/restore to/from external (USB-OTG) storage (not supported by the device)
    - [❌] backup/restore to/from adb (https://gerrit.omnirom.org/#/c/15943/)
    - [✔] decrypt /data
    - [✔] Correct date

    Minor checks
    - [✔] MTP export
    - [✔] reboot to bootloader
    - [✔] reboot to recovery
    - [✔] poweroff
    - [✔] battery level
    - [✔] temperature
    - [❓] encrypted backups
    - [❓] input devices via USB (USB-OTG) - keyboard, mouse and disks (not supported by the device)
    - [✔] set brightness
    - [✔] vibrate
    - [✔] screenshot
    * Your warranty is now void.
    * We are not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at us for messing up your device, we will laugh at you.

    • Boot
    • Decryption data
    • Vibration
    • flash zip
    • Android 11 support
    • Ota update
    continue in #2 post

    Not working:
    • ADB sideload

    Supported devices:
    • Mi 10T (apollo)
    • Mi 10T PRO (apollopro)
    • Redmi K30S Ultra (apollo)
    I haven't tested on Mi 10T and K30S, but it should work

    We couldn't modify /system /vendor /product and /odm, caused by new type of partition, so if you want modify them, use magisk module instead.​

    Install guide:
    To boot (Reccomended):
    fastboot boot <twrp.img>

    To recovery (Not Reccomended):
    fastboot flash recovery <twrp.img>

    How can I pass file to device, if mtp not work s?
    You can use adb command, to push them.
    adb push C:\<file>.zip /sdcard

    Where are the files, which i copied with mtp?
    Maybe you can find them in /data/media

    Can i flash twrp in recovery partition?
    Yes, you can flash since 3.5.0_10-beta 1. I provided prevent-twrp-replace (to keep twrp after reboot) and stock-fingerprint (for ota update).





    Code source:
    @mauronofrio and other twrp developer.
    My brother installed the newest 3.5.0 beta on his mi 10t pro but the system Partition doesn't show up. Flashing the newest xiaomi EU fails. (Unable to mount/unable to open block device)

    Any ideas ?

    Edit: he managed to boot the rom after a few attempts. Seems like it was a recovery bootloop. But still weird, that the system Partition does not show up in twrp
    It's because google introduced dynamic partitioning a while ago. And TWRP just added support for it in 3.5 - basically super is a "master partition" containing system, vendor, and bunch of other partitions, and instructions on where is what. Without supported software such as magisk you can't really see those partitions. TWRP just added that few days ago, so expect it to work after a while...
    For those who are trying to flash xiaomi.eu roms, here is what I did using this twrp:
    (I flashed this twrp)

    **i'm from global rom mi 10t (apollo)
    **Weekly eu rom is what I installed
    **Since I cannot format the system, I tried to dirty flashed the rom.

    1. Format data only (advance format)
    2. Flash rom zip file and wait until it's done.
    *You will notice that after flashing, if you will reboot into system, you will be stucked in bootlooping into twrp.
    *In twrp, go to "mount", you will also notice that you cannot mount data and system.
    Next step...
    3. Format data (not in advance format) and wait until it's successful
    4. Go back to "mount" and you will notice now that data was already mounted.
    5. Mount system and reboot. First boot will take at least 5 minutes to load.

    *Data decryption is working when you successfully flashed the eu rom.

    This worked for me like a charm. Hope this helps.
    What have you done?

    I face the same problem because I update full zip recovery from MIUI (A10) to (A11). I simply do backup and then flash the zip and flash magisk. Got this problem.

    After I flash back original boot.img (extracted from recovery/fastboot rom) from fastboot, then it boot normally, but lose the root (and magisk). Someone told me that it is because I don't disable magisk module before flashing, causing the partition to be dirty when updating.

    I don't know that yet, so I ended up flashing fastboot rom A10 (still can't boot) and factory reset data to clear all the dirty partition. In your case, you probably stucked also. You can only flash original boot.img to boot normally. Backup your data as needed, then do a factory reset (probably have to reset from original recovery) to clear all the partition. Then you can try to boot TWRP and root again using magisk, and then restore your data as needed.

    MTP is working as long as your partition is not stuck just like above. It seems you have to wipe data after flashing any ROM, as the remnant from previous ROM will get it to bootloop.