• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[RECOVERY][UNOFFICIAL] TWRP 3.1.1-0

Search This thread

meskafonas

Member
Apr 8, 2014
24
5
Few hours ago i have fixed phone and now everything is updated as suppose to be. Just forgot to post here ;)
Yeah i installed rolback rom with dload from 4pda russian site and when jumped for newer version b381. After that i used FF via proxy and now i have latest version ;)

Also i decided not to install twrp anymore because i had problems with installing busybox for luckypatcher. Probably due encryption and didnt want to format data again.
 

Ben3344

Senior Member
May 29, 2016
57
15
hello, I can not mount the usb OTG, and i can not manually select it in the mount menu

Is there a way to solve this problem. I really need it to directly store my 10GB backup.

for info my cle usb works well, moreover it is mounted on the android aospex

hello, I finally solved the problem of USB OTG.
in fact, it was because of the file system NTFS, when I reformatted my usb key in EXFAT in the TWRP, it worked, I am very happy.
thank you again Mr HENKATE for your ROMs and your TWRP.
 
  • Like
Reactions: #Henkate

rintintin78

Senior Member
Oct 5, 2011
52
3
Hi,
I have L01C55 (wich is TIM branded Huawei Nova). I would Debrand my phone.
I would change the custom.bin and oeminfo.img for Europe.
Have you got custom.bin and oeminfo.img for Europe?
Thanks
 
Last edited:

belgarion5555

New member
May 9, 2018
3
0
Hi guys,

I've just received thé Huawei nova 4gb ram and 64gb rom Can-l12 and it work really good !

It run with emui 4.1 and i don't like it... I was wondering if this twrp work with m'y Phone and (sorry wrong topic) if there is any custom rom out there ?

Third and final question : anyone got an official update for emui 5.0 ? I like this version ^^.

Have a Nice day ! :)
 

#Henkate

Senior Member
Feb 1, 2012
3,485
3,120
25
フェアリーテイル
Hi guys,

I've just received thé Huawei nova 4gb ram and 64gb rom Can-l12 and it work really good !

It run with emui 4.1 and i don't like it... I was wondering if this twrp work with m'y Phone and (sorry wrong topic) if there is any custom rom out there ?

Have a Nice day ! :)

Hello!

This TWRP and the ROMs were initially built for CAN-L11 (the model I've owned), but people confirmed that's working on the other models too. I don't remember if there was a feedback from a CAN-L12 user, but it's supposed to work on the all models.

Have a nice day as well!
 

belgarion5555

New member
May 9, 2018
3
0
Thanks for your answer ! I juste found what i searched for one week : FIRMWARE FINDER HUAWEI !!!!!!!!! Thank god i got emui 5.0 and android 7.0.1 !!!!! Those guys are the best. I'll try this twrp later. ^^
 

#Henkate

Senior Member
Feb 1, 2012
3,485
3,120
25
フェアリーテイル
Thanks for your answer ! I juste found what i searched for one week : FIRMWARE FINDER HUAWEI !!!!!!!!! Thank god i got emui 5.0 and android 7.0.1 !!!!! Those guys are the best. I'll try this twrp later. ^^

You'll have to format /data in TWRP (format, not wipe!) on EMUI 5 because decryption isn't working in this TWRP (didn't try to fix it and my phone is broken anyway). If you format /data, your internal memory will be wiped, so you better backup your stuff before. Keep this in mind.

As a side note, there is (or was) a recovery posted by @Temanyan in the other TWRP thread which supports decryption on EMUI 5 and you don't have to format /data. Check that thread or his posts.
 

SamBurger

Member
Jul 20, 2013
5
0
You'll have to format /data in TWRP (format, not wipe!) on EMUI 5 because decryption isn't working in this TWRP (didn't try to fix it and my phone is broken anyway). If you format /data, your internal memory will be wiped, so you better backup your stuff before. Keep this in mind.

As a side note, there is (or was) a recovery posted by @Temanyan in the other TWRP thread which supports decryption on EMUI 5 and you don't have to format /data. Check that thread or his posts.
hey folks,

do i need the gapps when i flash just the recovery or don't i?
would you recommendnthe flash it on a clean (after factory reset) device?

thank you
 

#Henkate

Senior Member
Feb 1, 2012
3,485
3,120
25
フェアリーテイル
hey folks,

do i need the gapps when i flash just the recovery or don't i?
would you recommendnthe flash it on a clean (after factory reset) device?

thank you

You can flash only the recovery and it doesn't matter if you flash it on a clean device or not. Keep in mind the message you've quoted.

You can use TWRP 3.2.3-0 too, which is newer and supports Oreo.
 

cahsobo

Senior Member
Jan 23, 2011
51
2
Help @#Henkate I flashed this on my CAN-L01 and it returns to error everytime I flash zip or magisk module
I can't even wipe data :(
It was normal when I used your 3.0.3 version of TWRP

Recovery.log says like this:
Code:
Formatting Data using mkfs.f2fs...
CANNOT LINK EXECUTABLE "mkfs.f2fs": library "libf2fs.so" not found
mkfs.f2fs -t 0 /dev/block/mmcblk0p54 process ended with signal: 6
Unable to wipe Data.
Unable to format to remove encryption.
I:mount -o bind '/data/media/0' '/sdcard' process ended with RC=0
I:sending message to add 65537 '/data/media/0' 'Internal Storage'
I:Message sent, add storage ID: 65537
Updating partition details...
mtppipe add storage 65537 '/data/media/0'
MtpStorage id: 65537 path: /data/media/0
I:Data backup size is 4MB, free: 23801MB.
I:Unable to mount '/external_sd'
I:Actual block device: '', current file system: 'vfat'
I:Unable to mount '/usbotg'
I:Actual block device: '', current file system: 'vfat'
...done
I:Set page: 'action_complete'
I:operation_end - status=1
I:Set page: 'clear_vars'
I:Set page: 'formatdata'
I:Set page: 'wipe'
I:Set page: 'main'
I:Set page: 'clear_vars'
I:Set page: 'main2'
I:Set page: 'advanced'
I:Set page: 'copylog'
I:Set page: 'action_page'
I:operation_start: 'Copy Log'
I:Copying file /tmp/recovery.log to /data/media/0/recovery.log
 
Last edited:

#Henkate

Senior Member
Feb 1, 2012
3,485
3,120
25
フェアリーテイル
Help @#Henkate I flashed this on my CAN-L01 and it returns to error everytime I flash zip or magisk module
I can't even wipe data :(
It was normal when I used your 3.0.3 version of TWRP

Recovery.log says like this:
Code:
Formatting Data using mkfs.f2fs...
CANNOT LINK EXECUTABLE "mkfs.f2fs": library "libf2fs.so" not found
mkfs.f2fs -t 0 /dev/block/mmcblk0p54 process ended with signal: 6
Unable to wipe Data.
Unable to format to remove encryption.
I:mount -o bind '/data/media/0' '/sdcard' process ended with RC=0
I:sending message to add 65537 '/data/media/0' 'Internal Storage'
I:Message sent, add storage ID: 65537
Updating partition details...
mtppipe add storage 65537 '/data/media/0'
MtpStorage id: 65537 path: /data/media/0
I:Data backup size is 4MB, free: 23801MB.
I:Unable to mount '/external_sd'
I:Actual block device: '', current file system: 'vfat'
I:Unable to mount '/usbotg'
I:Actual block device: '', current file system: 'vfat'
...done
I:Set page: 'action_complete'
I:operation_end - status=1
I:Set page: 'clear_vars'
I:Set page: 'formatdata'
I:Set page: 'wipe'
I:Set page: 'main'
I:Set page: 'clear_vars'
I:Set page: 'main2'
I:Set page: 'advanced'
I:Set page: 'copylog'
I:Set page: 'action_page'
I:operation_start: 'Copy Log'
I:Copying file /tmp/recovery.log to /data/media/0/recovery.log

Try to flash the TWRP you've used before, format /data, then flash the new TWRP.

I'll fix the decryption of TWRP soon.

EDIT: @cahsobo i didn't build any 3.0.3 recovery before, so you've probably used the one left by Grarak (I don't remember if it had the same version though). Also, you can use TWRP 3.2.3 made for Oreo too.
 
Last edited:

cahsobo

Senior Member
Jan 23, 2011
51
2
Try to flash the TWRP you've used before, format /data, then flash the new TWRP.

I'll fix the decryption of TWRP soon.

EDIT: @cahsobo i didn't build any 3.0.3 recovery before, so you've probably used the one left by Grarak (I don't remember if it had the same version though). Also, you can use TWRP 3.2.3 made for Oreo too.

Ah.. I See.. The one that delete his post. Unfortunately I don't have the original file. Any mirror?
 

cahsobo

Senior Member
Jan 23, 2011
51
2
what option from twrp are you using?

at first I flashed TWRP 3.1.1-0 by @#Henkate from inside TWRP 3.0.3 (if I'm not mistaken)
it says failed to mount /product and sometimes /vendor
then I tried to install magisk module and failed. I went back to 3.0.3 by @Xelfmade and even 3.0.2 by @Grarak
still couldn't install magisk module in either TWRP or magisk manager
then I found out the internal memory was encrypted..
I can go back to 3.0.2 and wipe data, and the internal went back normal (/data 90%++ free space. It was only 30%ish when it was still encrypted)
But still, magisk broken.. can't install any module..
 

Vinnom

Senior Member
Jun 21, 2012
1,705
1,143
Campinas
Xiaomi Poco F1
at first I flashed TWRP 3.1.1-0 by @#Henkate from inside TWRP 3.0.3 (if I'm not mistaken)
it says failed to mount /product and sometimes /vendor
then I tried to install magisk module and failed. I went back to 3.0.3 by @Xelfmade and even 3.0.2 by @Grarak
still couldn't install magisk module in either TWRP or magisk manager
then I found out the internal memory was encrypted..
I can go back to 3.0.2 and wipe data, and the internal went back normal (/data 90%++ free space. It was only 30%ish when it was still encrypted)
But still, magisk broken.. can't install any module..
first, to remove encryption, you have to use the option format data. See, it is not a wipe data, or wipe internal data, or factory reset. Is format data. It will ask you to type "yes" to confirm you want to format it.
This is to solve the encryption part. Secondly, magisk doesn't deal well with f2fs. You will have to change data to ext4, so magisk will work. Use the later version of it (the one he built for oreo) or this one, it will do the same job.
In case you be some sort of: "damn, I'll lose performance", well I did tests comparing f2fs and ext4 and besides f2fs is faster, it is not so much. See the screenshot. The best result was when I had f2fs, the others where different cenarios of ext4 but I can't remember well what were those cenarios xD

tl;dr version
change to ext4, magisk won't work with f2fs
 

Attachments

  • Screenshot_PCMark_20181008-061114.png
    Screenshot_PCMark_20181008-061114.png
    207.6 KB · Views: 86

SamBurger

Member
Jul 20, 2013
5
0
first, to remove encryption, you have to use the option format data. See, it is not a wipe data, or wipe internal data, or factory reset. Is format data. It will ask you to type "yes" to confirm you want to format it.
This is to solve the encryption part. Secondly, magisk doesn't deal well with f2fs. You will have to change data to ext4, so magisk will work. Use the later version of it (the one he built for oreo) or this one, it will do the same job.
In case you be some sort of: "damn, I'll lose performance", well I did tests comparing f2fs and ext4 and besides f2fs is faster, it is not so much. See the screenshot. The best result was when I had f2fs, the others where different cenarios of ext4 but I can't remember well what were those cenarios xD

tl;dr version
change to ext4, magisk won't work with f2fs
hey folks,

my question does not apply about magisk. when i flash supersu.zip in twrp at the part where it says " boot.img patcher........" (will add screenshot later...sry) it's aborting, then fails.
any solution, advive?

i appreciate any help
 

wangdaning

Senior Member
Sep 17, 2012
1,377
571
Wuxi
hey folks,

my question does not apply about magisk. when i flash supersu.zip in twrp at the part where it says " boot.img patcher........" (will add screenshot later...sry) it's aborting, then fails.
any solution, advive?

i appreciate any help

I always use magisk to root. You can use other root management apps on top of that, but magisk works for root access.
 

Top Liked Posts