[RECOVERY][UNOFFICIAL] TWRP 3.1.1-1 (+legacy) for v400/v410 aka LG G Pad 7.0

Adam Myczkowski

Senior Member
Aug 29, 2015
451
373
83
Code:
#include "twrp302.h"
/*
 * Your warranty is now void.
 *
 * I am not responsible for bricked devices, dead SD cards,
 * thermonuclear war, or you getting fired because the alarm app failed. Please
 * do some research if you have any concerns about features included in this Recovery
 * before flashing it! YOU are choosing to make these modifications, and if
 * you point the finger at me for messing up your device, I will laugh at you.
 */
Known Bugs:
You tell me...

Download:

New download (v400/v410)


OLD


Change Log is here


Sources:
Device tree: MyczkowskiAdam/android_device_lge_v4xx-common branch cm-14.1-twrp
Kernel: https://github.com/LineageOS/android_kernel_lge_v4xx branch cm-14.1

XDA:DevDB Information
TWRP 3.1.1-1 for v400/v410 aka LG G Pad 7.0, Tool/Utility for the LG G Pad 10.1

Contributors
Adam Myczkowski
Source Code: https://github.com/omnirom/android_bootable_recovery


Version Information
Status: Stable
Current Stable Version: 3.1.1-1
Stable Release Date: 2017-10-07
Current Beta Version: 3.0.3-1

Created 2016-07-29
Last Updated 2017-10-07
 

Attachments

Last edited:

icebergz12

Senior Member
Jan 3, 2014
277
38
0
Sure, what do you need help with?
I can pm if better, but I am kinda stuck.. I have a v700 running lollipop I am trying to kdz back to stock because from what I've read I need to be on kk to install a recovery. I am currently trying to use the v400 method with no luck.. I'm trying it again in a bit when I get home.. Need to make sure I had the right driver installed.. Does it sound like I'm on the right track?? I'm also a little confused by "bump",but I will cross that road if I ever get to it.. Many thanks.
 

Adam Myczkowski

Senior Member
Aug 29, 2015
451
373
83
I can pm if better, but I am kinda stuck.. I have a v700 running lollipop I am trying to kdz back to stock because from what I've read I need to be on kk to install a recovery. I am currently trying to use the v400 method with no luck.. I'm trying it again in a bit when I get home.. Need to make sure I had the right driver installed.. Does it sound like I'm on the right track?? I'm also a little confused by "bump",but I will cross that road if I ever get to it.. Many thanks.
Yes from what I've you need to be on kitkat bootloader as well, which driver did u install by the way? Back in the time I wrote a tutorial on how to downgrade it, its probs the same for v700 but with different kdz file. Here's the tutrial: http://forum.xda-developers.com/android/development/stock-t3297045 , you might want to try this tool to get kdz, unelss you have it already. http://forum.xda-developers.com/showthread.php?t=1073827
 
  • Like
Reactions: icebergz12

rahimali

Senior Member
Jul 25, 2007
1,573
774
143
forum.xda-developers.com
Last edited:
  • Like
Reactions: icebergz12

jrk190

Senior Member
Sep 4, 2012
1,395
167
0
McLeansville
So, I'm reading around the forums since I'm picking a V410 off of a buddy today, and I'm trying to figure out if I can flash v400 recoveries and Roms on it. I don't plan on using the LTE. Just curious, thanks
 

rahimali

Senior Member
Jul 25, 2007
1,573
774
143
forum.xda-developers.com
So, I'm reading around the forums since I'm picking a V410 off of a buddy today, and I'm trying to figure out if I can flash v400 recoveries and Roms on it. I don't plan on using the LTE. Just curious, thanks
No you can't. V410 has different hardware not compatible with V400. You can find TWRP and ROMs for the V410 in these forums, just don't use the ones intended for V400.
 

heliox

Senior Member
Aug 16, 2010
68
26
48
Thanks a lot for your work. After reverting back to stock KK from stock LP using this : Return to Stock [V400], and rooting with Towelroot I managed to flash (adb) your TWRP in to order to try Custom ROMs. Everything works great, except my hardware WIFI issue, no matter stock or other ROMs.
 

BeeWall

Senior Member
Jun 29, 2016
631
234
53
FlashFire might be able to work for Lollipop stock roms to flash stuff. Not sure though. Plus, FlashFire can be more dangerous than TWRP.

Sent from my Amazon Fire using XDA Labs
 

BeeWall

Senior Member
Jun 29, 2016
631
234
53
As I said, lollipop firmware is not supported.
Thanks. Sorry for being stubborn about it. Just curious, do you know why FlashFire might work with some locked bootloaders and not others? Is it just general device differences or something specific? Because if it is just a bootloader change. I'm shocked Amazon hasn't implemented it on my device yet ☺
(Knocks on wood)

Sent from my Amazon Fire using XDA Labs
 

Adam Myczkowski

Senior Member
Aug 29, 2015
451
373
83
Thanks. Sorry for being stubborn about it. Just curious, do you know why FlashFire might work with some locked bootloaders and not others? Is it just general device differences or something specific? Because if it is just a bootloader change. I'm shocked Amazon hasn't implemented it on my device yet
(Knocks on wood)

Sent from my Amazon Fire using XDA Labs
It has nothing to do with FlashFire. Lollipop firmware is not supported by any ROM/recovery