[RECOVERY][UNOFFICIAL] TWRP 3.5.2 for 2019 Galaxy Tab A 8.0 [SM-T290]

Search This thread

themace51

New member
Aug 22, 2020
4
0
Will try and explain.

My firmware is on T290XXU3BUC1

I can successfully installed twrp via Odin.

I reboot, instantly blank screen. I have rebooted into twrp with blank screen.

I was able to install the nexus rom, with adb twrp command line and works but all is blank screen.

I go back to stock and the display is back.

I have tried another twrp on this forum but that gives me security error.

I have also tried to patch ap tar with Magiskt but that flashes but when restart get security error.

Twrp is the only thing that works but complete blank screen with back light.

Tab is unlocked bootloader and oem unlocking on.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    hello, same issue with version 3.5.2_9_0
    i got a black screen, tablet is ok but no screen !
    is there a way to boot in TWRP ?
    I'm going to need some steps to reproduce, since it's been working fine for me.
    1
    Tried to install TWRP from the OP, the process in Odin went fine, upon rebooting into recovery I get this (and I've made about 7-8 attempts to hard reset / reinstall / reboot to recovery). Does the message at the very bottom mean anything to anyone? Any help is appreciated.
    So, it looks like you let the device reboot to the OEM firmware after flashing TWRP, which allowed it to restore the original OEM recovery...yet another useful Samsung security "feature" that makes life difficult for custom ROM enthusiasts.

    Try to flash in Odin again, but hold the Power + Vol Up during the reboot to force it to enter TWRP, then run the MultiDisabler to disable the automatic OEM recovery rollback. It's a little tricky through the bootloader unlock warning, where you have to hit Power to proceed, but get right back on Power + Vol ASAP and hold it for another 5 seconds or so.
  • 2
    are there any custom roms for sm-t290?
    I'll have a release of my Nexus Stock custom ROM shortly. It's basically the same as what I've been releasing for the 10.1" version of this tablet over the past year. I'm basically just waiting for Samsung to post the latest kernel source.
    1
    twrp-featured.jpg

    What's posted below is a work in progress, but it should suffice to unblock efforts to build custom ROMs for this low-cost tablet. My thanks to @mehanik6 for blazing this trail on 4PDA.

    Notes:
    • The current process requires you to reset to factory defaults to remove file-based encryption. Remember to backup your data!
    • This is unofficial and unsupported, so the usual caveats apply. Since we don't flash the bootloader, you should be able recover from any problems...but nothing is guaranteed.

    Not working:
    • Support for file-based encryption

    Downloads:
    Build Archives:
    Change Log:
    v3.5.2_9-0: (2021-05-16)
    • Updated to T290XXU3BUC1 posted kernel source.
    • Updated to TWRP 3.5.2 release built from android-9.0 branch.
    v3.5.1_9-0: (2021-03-30)
    • Updated to T290XXU3BUB2 posted kernel source.
    • Updated to TWRP 3.5.1 release built from android-9.0 branch.
    v3.5.0_9-0: (2021-01-02)
    • Updated to T290XXU3BTI2 posted kernel source.
    • Updated to TWRP 3.5.0 release built from android-9.0 branch.
    v3.4.0-1: (2000-12-09)
    • New custom T290XXS3ATC1 kernel that actually fixes MTP support.
    v3.4.0-0: (2000-12-04)
    • Included legacy aboot and vaultkeeper in tarball to allow Odin flash on Android 10 OEM firmware.
    v3.4.0-0:
    • Initial release based on @mehanik6's device tree and T290UES3ATC1 kernel.
    • Fixed MTP
    • Default language is now English

    Instructions:
    From OEM stock firmware:
    From existing TWRP install: (No need for data wipe.)
    • Hold Power & Vol Up during restart to enter TWRP recovery
    • Tap Install->Install Image, select your image (.img) file, pick Recovery partition, and then swipe to install
    • Reboot to system

    What about rooting with Magisk?
    These images are not supplied pre-rooted with Magisk, since it's against the terms of use laid out by Magisk's developer, John Wu. To root the TWRP image yourself, simply use Magisk Manager to Select and Patch a File. More details on this process are available from @ianmacd's topic for the Galaxy S10 series here.

    Source:

    Donations:
    • Your support is always appreciated! Just click here.
    1
    New release posted...

    Downloads:

    Change Log:
    v3.5.1_9-0: (2021-03-30)

    • Updated to T290XXU3BUB2 posted kernel source.
    • Updated to TWRP 3.5.1 release built from android-9.0 branch.
    1
    Do we need to update the underlying stock ROM first if TWRP is already installed? Or is it sufficient to flash TWRP from the existing TWRP?
    You can just flash the new .img file from an existing TWRP install. The version of the kernel is only important if you're using Magisk (which boots through the recovery partition).
    1
    But did it happen to someone else, after successful flash, the tablet only displays black screen no image, but in the background it works, as normal operation but displays no image.