• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[RECOVERY][UNOFFICIAL] TWRP 3.5.2_10 for Moto G 5G (kiev)

Search This thread

Skel40

Senior Member
Dec 27, 2019
207
100
Moto G 5G
Do I flash recovery a and b with the same image posted here for TWRP?

I'm unfamiliar with a and b. Is that supposed to be two recovery modes?
 
Last edited:

h3xmind

Senior Member
Oct 20, 2015
69
26
Moto G 5G
Do I flash recovery a and b with the same image posted here for TWRP?

I'm unfamiliar with a and b. Is that supposed to be two recovery modes?
Basically, the phone has two copies of the recovery (and of other important partitions), namely A and B. A and B are called slots. Only one slot is active. This allows for the phone to be updated without interrupting your phone usage. Let’s say your phone is currently using slot A and Motorola releases an update. The system will update partitions on slot B while the system is running on A. Once the update is done, it will ask you to reboot. After rebooting, slot A becomes inactive and your system starts running on B. If the update fails, the system just switches back to A.

So to answer your question. You can flash this twrp on both recovery partitions.
 

clintongsan

Senior Member
Jun 5, 2019
77
11
34
Fort Smith, Arkansas, US
I’m really sorry you have issues but I have to ask: would you mind explainin what does the recovery have to do with SMS or phone number entries? Your’s are some serious allegations. I’m really sorry you have issues but it is not fair to throw mud on other’s work
ike this. Are you absolutely sure that the source of your issues is in the twrp? Could you recount the whole story please? What exactly did you do with your phone? Could you provide the steps? Did you install anything after flashing the recovery? Did you visit any dubious websites? This would be helpful to see what can be done to solve those issues.

Developer’s here are not paid for any of the work. We sacrifice time and efforts to help the community. Bugs will always exist and feedback is welcome. Constructive feedback, not unfounded allegations.
I was hoping you could tell me. I cannot use texts/SMS. I have to disable Mobile Data to receive and send texts. I have tried a completely erase/manual flash as well as LMSA rescue flash and my SMS issue persists. This issue did not ever occur before I booted the TWRP and I wouldn't have associated the two issues had no one else also reported the same problem. I am awaiting a new SIM card. I've never had something like this happen, especially in the field of having to disable Mobile Data to receive texts. I have unrooted my phone completely, restored all software back to stock using LMSA and still...no luck. If the new SIM card doesn't fix it and if there's nothing that you know of that could've happened associated with just flashing a recovery, then I will just have to buy a new device. If you'd like to see any information I would be happy to pull data or logs off and share them with you in hopes of resolving this issue but again, if you truly feel or know that the two can't be related perhaps it was just the timing and somehow I have a way more complicated issue going on that has nothing to do with your recovery and in which case I am sincerely sorry for assuming that it might have been part of the problem. I will delete my posts but I just want to let you know that I am unsure of the root cause of this issue and I would at least look into it on your end, or request info from my device if you'd like, to ensure that there's absolutely positively no way any other users will run into the same issue in the future. I mean no disrespect or harm to your reputation; I just hoped this would be an easy fix but if you haven't anymore idea than I do than perhaps the two are not, in fact, related.
 
  • Like
Reactions: h3xmind

clintongsan

Senior Member
Jun 5, 2019
77
11
34
Fort Smith, Arkansas, US
I was hoping you could tell me. I cannot use texts/SMS. I have to disable Mobile Data to receive and send texts. I have tried a completely erase/manual flash as well as LMSA rescue flash and my SMS issue persists. This issue did not ever occur before I booted the TWRP and I wouldn't have associated the two issues had no one else also reported the same problem. I am awaiting a new SIM card. I've never had something like this happen, especially in the field of having to disable Mobile Data to receive texts. I have unrooted my phone completely, restored all software back to stock using LMSA and still...no luck. If the new SIM card doesn't fix it and if there's nothing that you know of that could've happened associated with just flashing a recovery, then I will just have to buy a new device. If you'd like to see any information I would be happy to pull data or logs off and share them with you in hopes of resolving this issue but again, if you truly feel or know that the two can't be related perhaps it was just the timing and somehow I have a way more complicated issue going on that has nothing to do with your recovery and in which case I am sincerely sorry for assuming that it might have been part of the problem. I will delete my posts but I just want to let you know that I am unsure of the root cause of this issue and I would at least look into it on your end, or request info from my device if you'd like, to ensure that there's absolutely positively no way any other users will run into the same issue in the future. I mean no disrespect or harm to your reputation; I just hoped this would be an easy fix but if you haven't anymore idea than I do than perhaps the two are not, in fact, related.

Umm, so how does one delete a post they've created here? Is it permanent once posted?
 

h3xmind

Senior Member
Oct 20, 2015
69
26
Moto G 5G
I was hoping you could tell me. I cannot use texts/SMS. I have to disable Mobile Data to receive and send texts. I have tried a completely erase/manual flash as well as LMSA rescue flash and my SMS issue persists. This issue did not ever occur before I booted the TWRP and I wouldn't have associated the two issues had no one else also reported the same problem. I am awaiting a new SIM card. I've never had something like this happen, especially in the field of having to disable Mobile Data to receive texts. I have unrooted my phone completely, restored all software back to stock using LMSA and still...no luck. If the new SIM card doesn't fix it and if there's nothing that you know of that could've happened associated with just flashing a recovery, then I will just have to buy a new device. If you'd like to see any information I would be happy to pull data or logs off and share them with you in hopes of resolving this issue but again, if you truly feel or know that the two can't be related perhaps it was just the timing and somehow I have a way more complicated issue going on that has nothing to do with your recovery and in which case I am sincerely sorry for assuming that it might have been part of the problem. I will delete my posts but I just want to let you know that I am unsure of the root cause of this issue and I would at least look into it on your end, or request info from my device if you'd like, to ensure that there's absolutely positively no way any other users will run into the same issue in the future. I mean no disrespect or harm to your reputation; I just hoped this would be an easy fix but if you haven't anymore idea than I do than perhaps the two are not, in fact, related.
Don't worry. No hurt feelings. I hope we can find a solution to your problem.

I think there is something wrong in some hidden setting, maybe even on the carrier's side. The fact that you CAN send and receive text when you disable data means that your phone is physically working. If you restored everything with LMSA it means your phone is identical as when you received it. This makes me think that the carrier must solve the issue on it's side.

I read in some comments on this youtube video that this happens sometime with moto devices with verizon. I'm not sure though if you are located in US and use verizon services. Did you speak with your carrier or you just ordered a new sim?

Of course you can post the logs (prior to posting, please, make sure that there is no private information inside that you would not like to publish). Maybe something useful pops up.

I really hope we can find a solution to this.
 
Last edited:

h3xmind

Senior Member
Oct 20, 2015
69
26
Moto G 5G
@clintongsan Once solved the problem, if you feel more comfortable using Hexen's recovery, don't hesitate to do so. I wouldn't even spent time building this recovery in the first place if I knew there was already one. I learned that later. If you encounter issues with the touchscreen, here's a short guide I wrote that shows you how to fix it in two minutes.

 

codeOps64

Member
Jun 10, 2021
8
4
@clintongsan Once solved the problem, if you feel more comfortable using Hexen's recovery, don't hesitate to do so. I wouldn't even spent time building this recovery in the first place if I knew there was already one. I learned that later. If you encounter issues with the touchscreen, here's a short guide I wrote that shows you how to fix it in two minutes.

hi. I rooted my phone successfully. But how do I pass SafetyNet check? I tried installing some modules, it didn't work. Netflix and bank application wont work. Please give me a solution. Thanks for your help.
 
Last edited:

Tomspector

Member
Oct 14, 2018
39
5
Thanks for the hard work to get twrp to work on this phone!

Also for the one who has text messages send issues reflash your rom with the latest ver from here.

Here is the proper fastboot flash commands
Just select all and past into terminal




fastboot getvar max-sparse-size
fastboot oem fb_mode_set
fastboot flash partition gpt.bin
fastboot flash bootloader bootloader.img
fastboot flash vbmeta vbmeta.img
fastboot flash radio radio.img
fastboot flash bluetooth BTFM.bin
fastboot flash dsp dspso.bin
fastboot flash logo logo.bin
fastboot flash boot boot.img
fastboot flash dtbo dtbo.img
fastboot flash recovery recovery.img
fastboot flash super super.img_sparsechunk.0
fastboot flash super super.img_sparsechunk.1
fastboot flash super super.img_sparsechunk.2
fastboot flash super super.img_sparsechunk.3
fastboot flash super super.img_sparsechunk.4
fastboot flash super super.img_sparsechunk.5
fastboot flash super super.img_sparsechunk.6
fastboot flash super super.img_sparsechunk.7
fastboot flash super super.img_sparsechunk.8
fastboot flash super super.img_sparsechunk.9
fastboot erase carrier
fastboot erase userdata
fastboot erase metadata
fastboot erase ddr
fastboot oem fb_mode_clear
fastboot reboot

I went through the text sms not working.
This fixed it
Hope this helps.
 
I tried Hexen's recovery. It's easily fixable to make the touch work. It took me two minutes. I'll let the guys working on it know how to do it. But first I have to figure out why does the touch screen stop working once you flash the recovery.
This is the issue I had with the recovery I made. It has something to do with the modules.
 
  • Like
Reactions: h3xmind
Great to hear it worked. Do you have password or PIN protection on your phone? If yes, when you booted to recovery did the touchscreen work? Because yesterday I tried to flash and the touchscreen didn't work. So, if I flash it doesn't work, if I just boot into it, it works. I already have an idea what could be the problem and if I'm right it's easily fixable. I'm just curious to know if you had the same issues.

EDIT: the touchscreen issue was solved. It never existed. I flashed the wrong file :D
I have flashed this on a fresh stock rom RETBRAZIL. Touchscreen is NOT working. Not working on the recovery boot either. Neither is using the 2minute method. Phone is original MetroPCS version.


UPDATE: It does WORK. Apologies. Unplug the phone from the computer and reboot without it being connected after flashing.

Good job bro!
 
  • Like
Reactions: h3xmind

fosgate3

Member
Aug 16, 2013
40
5
Moto G 5G
Check my debloat guide.
Thanks! My phone is still working well but I am not happy with switching from a Samsung to a Motorola. Maybe I'm too set in my ways, I don't know. I very, very much miss having the led light that blinks when I have a message or email. I feel like I have to constantly pick up the phone in order to see if someone's texting me. I also don't like how turning off the location services is more of a multistep process compared to my old Note 4 where I can just pull the menu down and press on the location button. And with that, I have found instances where certain apps have "turned on" location services on their own even though I had settings specifying which apps can use location services and when (i.e. only when the app is in use). In fact, I even tried to go back to using the old Note 4 until I had no other option but to upgrade to a 5G phone but I no longer had service on the phone using my existing SIM card. I'm guessing by having Verizon enable the CDMA-less option, it made my SIM card inoperable with my Note4? I don't know. I'd go with a Note 20 Ultra 5G but so far, I haven't found a successful method of rooting. Another XDA member (Krazzieboy) posted a guide to doing it but based on the replies to his thread, it doesn't work (the thread is here).

Do you know of any custom ROMs I can use with this Motorola---something other than the stock Motorola ROM that seems to be on it now? Thanks for all your help. I'd buy you a beer if you lived nearby.
 

Top Liked Posts

  • 1
    I have two questions about this:
    1. Has anyone tested whether one can flash magisk 23 just fine with this twrp?
    2. Is there a risk I'll brick the device by flashing this? I am asking bc I never had a phone that required this process to flash recovery, just a regular "fastboot flash recovery twrp.img"
    I can't answer your questions. It should work. I know that the fastboot command works. If you want twrp on both a and b, you need to use the appropriate fastboot commands.
  • 1
    I'm confirming the XT2113-2 128 GB version won't work with the touchscreen. It does boot into TWRP just fine but the touchscreen just won't work. Any thoughts?
    Sorry to hear that. Did you try SyberHexen's recovery. He fixed the touchscreen now so that might work for you. Additionally, he successfully built Android 11 so you might try that as well.
    1
    I have two questions about this:
    1. Has anyone tested whether one can flash magisk 23 just fine with this twrp?
    2. Is there a risk I'll brick the device by flashing this? I am asking bc I never had a phone that required this process to flash recovery, just a regular "fastboot flash recovery twrp.img"
    I can't answer your questions. It should work. I know that the fastboot command works. If you want twrp on both a and b, you need to use the appropriate fastboot commands.
  • 3
    DISCLAIMER: I'm not responsible if you brick or damage your phone in any way by using this recovery. It is always advisable to fully backup your phone before playing around with recoveries, custom roms and similar stuff.

    What has been tested and works:

    - Touchscreen
    - Installing flashable zips
    - Flashing images
    - Flashing the recovery itself
    - Creating backups (to internal storage, sdcard or OTG)
    - Restoring from backups
    - Terminal
    - adb
    - Rebooting to system, recovery, bootloader, ...

    That doesn't mean that other things don't work. It just means they weren't tested yet. As I proceed with testing I will update the above list.

    Usage (without flashing)
    Bash:
    # boot to bootloader
    adb reboot bootloader
    
    # boot to recovery
    fastboot boot twrp-3.5.2_10-kiev.img

    If you want to flash you have 2 options
    Bash:
    # boot to bootloader
    adb reboot bootloader
    
    # ********* OPTION 1  *********
    # Flash to active slot (replace <slot> with either a or b, depending on the current active slot).
    # Of course, you can flash to both by first specifying a and then b.
    fastboot flash recovery_<slot> twrp-3.5.2_10-kiev.img
    
    # ********* OPTION 2  *********
    # boot to recovery
    fastboot boot twrp-3.5.2_10-kiev.img
    
    # Once in the recovery, copy the twrp image file to your internal storage
    adb push twrp-3.5.2_10-kiev.img /sdcard/Download
    
    # Then go to Install, then Install image, select the twrp image you pushed before.
    # Then select the Recovery partition and swipe to confirm.
    # Before swiping you will have the option to decide if you want to flash to both slots.

    Download: google drive

    Sources will be posted in due time and this post will be updated accordingly.

    Built for: Motorola Moto G 5G (Motorla One 5G Ace)
    My model: XT2113-3 (kiev)

    Credits 👏🙏
    To the guys over here for the device tree, especially to SyberHexen for providing me with useful information.
    2
    Why's it seem like some people make it so hard?

    I did
    adb reboot bootloader
    fastboot devices
    fastboot flash recovery_a twrp.img
    fastboot flash recovery_b twrp.img
    Fastboot reboot recovery

    Flashed find everything works! At least that I've noticed and ran through as of yet. Great work thank you
    2
    I use LTE/4G sim only and i recieve texts fine. Altough it might be because of sim as you said.

    Here are the few sites i gathered and read that might help you solve this :

    Link 1
    Link 2
    Link 3

    It looks like it has something to do with your carrier settings/CDMA-less when you change your phone.Try contacting your carrier.
    If nothing works, replace your sim with new one i guess.
    This fixed my problem. I contacted Verizon and they enabled the setting. Did it all through their chat feature on their website. Off to root it again.
    2
    I still did not have texting after using LMSA and I think I may know why: My previous phone is not 5G so I am using the standard LTE SIM card. This new phone, the XT2113-2, is 5G and I'm thinking I may need a new SIM card in order to use it. Does this make sense to anyone else? (and I apologize in advance if I am late to the parade with this info)
    I use LTE/4G sim only and i recieve texts fine. Altough it might be because of sim as you said.

    Here are the few sites i gathered and read that might help you solve this :

    Link 1
    Link 2
    Link 3

    It looks like it has something to do with your carrier settings/CDMA-less when you change your phone.Try contacting your carrier.
    If nothing works, replace your sim with new one i guess.
    1
    Tested on my Moto G 5G XT2113-3. Seems to work properly. Good job. Awaiting to flash it.