[RECOVERY][UNOFFICIAL] TWRP for Galaxy A40

Search This thread
D

Deleted member 10377367

Guest

YES! Thank you so much! Worked like a charm! I now have it installed, but sadly there is now a new problem.
It says that I need to root with Magisk to prevent it from being removed. Now, I would normally make a thread about this, but I don't have enough posts.
Anyways, I tried rooting with Magisk with a video I found on youtube (https://www.youtube.com/watch?v=xHBDF9ErLkw&t=217s). I was unable to get it into download mode, am I missing something?

EDIT: Will try some other methods as well.
EDIT: Got it working! Thank you very much, fellow Scandinavian!
 
Last edited by a moderator:
D

Deleted member 10377367

Guest
I got it installed, but everytime I try to flash disable DM-Verity it just goes into a bootloop. Here is what I did:

1. Formatted the system after installing TWRP
2. Installing it again
3. Booting into TWRP and clicking install and then choosing the disable DM-Verity zip file.
4. When it is finished, I boot back into system

Then there is a boot-loop that just continues. Turns on, gets past the first screen, then turns off again.
Is there a way to disable DM-Verity another way, or am I just doing it wrong?
I heard that flashing SuperSU or Magisk could also do this, is that right?
 
D

Deleted member 10377367

Guest
Is there someone with the October's update installed (A405FNXXU2ASJ1) that could test this new version I built?
Download here.

This was built from source using the kernel source files from Samsung's Open Source platform and TWRP's repo.
Thank you!

Yeah this works wondering. Was able to flash it with no problems.
 

centaurium

Senior Member
Mar 7, 2013
93
24
Budapest
OnePlus 8
Hello

A have a problem with flashing. A405FNXXU2ASJ1 firmware installed, OEM unlocked, but the updated TWRP_A40_A405FN_V1_ASJ1.tar flash is undone in the flashing procedure. Just stopped and not continuing. Any ideas?

<ID:0/009> Added!!
<ID:0/009> Odin engine v(ID:3.1301)..
<ID:0/009> File analysis..
<ID:0/009> Total Binary size: 70 M
<ID:0/009> SetupConnection..
<ID:0/009> Initialzation..
<ID:0/009> Get PIT for mapping..
<ID:0/009> Firmware update start..
<ID:0/009> NAND Write Start!!
<ID:0/009> SingleDownload.
<ID:0/009> boot.img
<ID:0/009> recovery.img
<ID:0/009> Complete(Write) operation failed.
<OSM> All threads completed. (succeed 0 / failed 1)
 
Last edited:

ruloes

Member
Aug 18, 2010
36
1
Samsung Galaxy A40
HELPPPPP
I need you help!!!
I was followed to root my new A40 and now it ´s rebooting randonly.
I opened the phone and disconneted the baterry but when i´m connecting again repeat this rebooting.
Please !!!!!!!!!!!!!!!!!
 

dnaa4

New member
Dec 30, 2019
1
0
HELPPPPP
I need you help!!!
I was followed to root my new A40 and now it ´s rebooting randonly.
I opened the phone and disconneted the baterry but when i´m connecting again repeat this rebooting.
Please !!!!!!!!!!!!!!!!!

I hope I'm not too late but I'm sure I can help you. first, you'll loose all off your data.

1. make sure you charged your phone for a while
2. while the phone is starting, press all three buttons at the same time (power + vol up + vol down). If you see a black screen, quickly release and press only vol up + vol down.
3. your phone should start in Download Mode. If the phone wants you to confirm, press vol up
4. download the firmware for your phone. It depends on the model number you have for your a40, but you should be able to download your Samsung firmware from sammobile . com . just type in your model number and download the firmware. you need a dammobile account to do that and the download will be very slow so you have to wait.
5. If you downloaded the .zip file, extract it using 7zip or any zip extracting tool. You should now have files beginning with BL, AP, CP, CSC, HOME_CSC.
6. now open odin. if you haven't downloaded it yet, just google: odin 3
7. connect your phone to the computer. select the BL button and open the BL file. then tap AP button and select the AP file. do the same for CP and CSC (important: if you pressed the CSC button, you have to select the HOME_CSC file!)
8. if you selected all 4 files, tap start.
9. the process may take a few minutes. If odin says "PASS!", you're almost done. you should be able to boot the phone. there may be warning that the phone wasn't able to boot (that's normal!). Just select the option "wipe data/factory reset" and confirm with yes using the power button to confirm and the vol up / vol down button to select.
10. your phone should start normally and you have to start the setup process.

I hope I was able to help you. If not, contact me and we will be able to solve the problem together.
 

xeroin82

Senior Member
May 29, 2014
52
5
Dark side of the Liguria
I solved it with nfc. Once rooted, I flashed twrp by deleting the internal memory then I restarted in recovery and deleted data and cache without flashing any files (original rom use). Now it works best.
 

fredapied

Senior Member
Sep 28, 2010
73
2
I had problems with nfc not turning on earlier, when I flashed multidisabler.
Last time I updated and re-rooted (still on october patch) I used only dm-verity/forced encryption disabler and nfc is working fine after that.
I Didn't noticed that before Reading you.
And right, same issue about NFC ..
The button wasn't usable.
And i noticed another issue with smart Switch.
I think it's not fully compatible sj1 with sk2

Envoyé de mon SM-A405FN en utilisant Tapatalk
 

kiprock

New member
Jan 13, 2020
1
0
No option for A40 in TWRP App

Hello,

I followed all your instructions. Thank you for posting this!
I updated the TWRP stub app that was installed to the OS, but when I start it, it asks to choose which phone I have, of course the A40 is not in the list. Any suggestions?
 

hpolimar

Senior Member
Feb 18, 2007
70
6
Rome
i was able to root phone only using magisk. but it resized the phone to 8gb. so i started to try to install twrp so i could be able to format data partition and root the phone, but i am not able to enter recovery once i flash twrp, both on offical firmware then on magisk patched one. it just goes on bootloop
 

bartsam

Senior Member
Apr 14, 2007
59
3
Hi there,
I think there is another issue visible after twrp/root - a40's storage and also uSD card is probably in read-only mode, so it's not possible copy files from PC to phone over the USB-C cable.
Or may be there is a workaround or a fix?
Regards!
 

Top Liked Posts

  • There are no posts matching your filters.
  • 15
    Team Win Recovery Project 3.3.1

    https%3A%2F%2Fwww.maketecheasier.com%2Fassets%2Fuploads%2F2019%2F01%2Ftwrp-featured.jpg

    Exynos ONLY.
    In NO way it is compatible with Snapdragon variants including but not limited to American(U/A/T/P/V), Chinese(0/8/6), Hong Kong(0), Japanese(SC-*), Canadian(W) variants.


    Special Notes:
    1. DON'T FORGET TO ENABLE "OEM UNLOCK" (located in Developers options).
    2. KNOX will be tripped once you flashed custom binaries to your phone.
    (Your warranty may be voided. However this may not affect you if your country forces Samsung to provide hardware warranty regardless of software status.)
    3. Samsung Firmware OTA (aka System Updates) will no longer work once you flashed custom binaries.
    (You can flash custom ROMs if you want to keep the OS up-to-date.)
    4. All apps that use KNOX like Samsung pay, Secure Folder and maybe more will no more work


    Download: A40(Exynos variant - A405F)

    TWRP

    A40 MultiDisabler

    DM-VerityDisabler&ForceEncrypt

    GSI_MTP_Enabler

    Sources:

    TWRP


    Guide:

    1. Go to developer settings and enable OEM unlocking
    2. Reboot the device into download mode
    3. Follow instructions in download mode to UNLOCK your bootloader
    4. This will wipe your data partition so beware , boot phone to system and let it connect to internet after bootloader unlock.
    5. Reboot into download mode and FLASH included TWRP tar file
    6. Boot into twrp
    7. Format Internal storage in TWRP
    8. Flash the multidisabler zip *Copy this to your SDCARD before wiping internal etc* this is for disabling all checks ( HUGE thanks to @geiti94)
    9. Make sure you are rooted with latest Magisk otherwise you will lose twrp
    Bugs:

    - USB OTG mount for the moment

    [/YOUTUBE]​

    NOTE: I don't own the device myself , but i do have A305F which is pretty similar to this device so building should be fairly similar

    Thanks to @DerGraf1997 for testing blindly for me
    6
    PERFECT ! WORKS excellent now. I'm writing this small noob-friendly tutorial so people can follow, I hope it's fool proof.

    Step 0: Prereq
    Download all the zip files from the main page on your phone and put them in the external SD card.

    How to enable developer
    Goto settings -> About Phone -> Software Information -> Tap "build number" 5 times

    Enable OEM unlocking
    Go back to Settings -> Developer options -> Enable "Oem unlocking" (if you do not see this option OR its grayed out try to connect your phone to internet, or follow this https://forum.xda-developers.com/ga...-to-skip-oem-lock-waiting-7-days-100-t3823361)

    Note: Enabling OEM unlock here does not mean your OEM is unlocked! This switch only allows you to unlock it..Also enable USB debugging.

    Turn off your phone.

    Next: hold UP + Power until you will see a green screen. It must say "Hold long up to OEM/bootloader unlock." Follow those steps, to unlock it.
    Congrats, now your OEM is unlocked. Turn off your phone.

    Install TWRP
    Hold UP + Power again. In the screen select "wipe data (factory reset). Then select Turn off Phone (should be one of the lower options)

    While phone is off, hold UP + DOWN volume and attach USB cable to your phone. It should go into download mode.

    In Odin, put the TWRP_A40 image in AP
    Un-tick Auto reboot in the options tab.

    Remove usb cable.

    Tricky part: hold 7 seconds down+power. As soon as screen goes black hold UP + power!
    Now you should be in TWRP!!

    Once inside TWRP
    Flash all the zip files you downloaded to your SD card
    Go back to main menu, select reboot -> Recovery. Then reboot normally.

    Enjoy =) Android must now boot up normally.
    5
    Twrp updated 3.3.1-2
    - Fixed MTP for GSI roms included GSI_MTP_PATCH.zip to get it working on Gsi properly
    - For data backup to work , flash whole samsung firmware with odin , flash twrp and flash DM-Verity , force encryption fix linked in OP
    Dont flash Multidisabler if you want data backup to work.
    4
    Telegram:

    https://t.me/GalaxyA2019


    Changelog:

    22.09.2019

    - Fixed MTP for GSI roms
    included also GSI_MTP_PATCH.zip to get it working on Gsi properly
    - For data backup to work , flash whole samsung firmware with odin , flash twrp and flash DM-Verity , force encryption fix linked in OP .Dont flash Multidisabler if you want data backup to work

    17.09.2019

    - Based on latest kernel sources available ASE4
    - Initial Release



    More instructions & differences between disablers

    1. If you intend to flash twrp only & keep OneUi intact
    Flash A40 multidisabler after flashing twrp, this will disable all samsung checks
    Note : You will have to wipe your internal storage to get encryption fixed

    2. If you plan on flashing some rom that has security checks disabled like GSI or custom roms. Then just flash twrp & flash Dmverity fix after rom. (data backup will only work with this)
    Note: If you flash multidisabler and later on wish to flash gsi & dm verity . Your data partition wont backup in twrp.
    3
    As from screenshot our partition is a only hope that's helps
    Use A/B .

    Follow the link for more information
    Link to Phh

    PS. Working GSIs on A30/A40 right now are

    Lineage OS 16.0 build by AndyVan
    Havoc OS GSI
    Phh Aosp 9/10

    More maybe. But these are the most stable ones.