[RECOVERY][UNOFFICIAL] TWRP for Galaxy Note 20/Note 20 Ultra

Search This thread

Brava27

Senior Member
Sep 7, 2012
3,477
884
Toronto
Am trying to install custom rom, using this twrp, but no matter how many times I've tried, am unable to get the phone to boot correctly after flashing rom, it keeps going into bootloop. Does anyone know how to fix?
What model is your phone?

Sent from my BlackBerry Bold 9900
 

TheMadScientist

Recognized Contributor
Mar 5, 2014
8,236
4,045
VT
Wonder if any of you guys might be able to help me out. Not really mentioned any where. I got a note 20. Exy. For the life of me I cannot get oem unlock to show up. I've tried the date trick. Kg status shows as normal. I'm trying to wait the 7 days I got a system update today and it rebooted. So now that's started over as I'm led to believe. If that's what's up.
 

AboodySahhaf

Member
Dec 14, 2017
42
0
I did twrp step by step, but when i do format data it did delete all my files then i cant flash Encryption disabler , already tried flash through USB but didn't success and the files didn't appears
 

sweick_dev

New member
Oct 15, 2020
4
0
I tried to flash the TWRP but I get stuck in the bootloop.
i can do the root without TWRP but when i flash it together (TWRP at user data)
i get stuck in a bootloop and i need flash the rom again to come back.

My phone is a SM-N981B/DS (note 20 5g - not ultra)
also i'm wating to use dr.ketan but i dont know if will works at my model.
 

usitaly

Senior Member
Oct 11, 2010
443
288
avellino
I tried to flash the TWRP but I get stuck in the bootloop.
i can do the root without TWRP but when i flash it together (TWRP at user data)
i get stuck in a bootloop and i need flash the rom again to come back.

My phone is a SM-N981B/DS (note 20 5g - not ultra)
also i'm wating to use dr.ketan but i dont know if will works at my model.

same device, same problem... how to solve?

tnx
 

keyboardhouse

Senior Member
Feb 25, 2017
57
14
edit : I finally managed to installed it but when I wiped the data or installing the rom there is a red message keep coming into the log anyway I cannot transfel files thru TWRP does anyone having the same issue?
 
Last edited:

dominick_7

Senior Member
Feb 4, 2007
138
9
Hi, i was able to flash just the patched magisk to get into custom recovery, but it seems no matter what combination i try, patched magisk + patched kernal, patched magisk + twrp, twrp in ap alone, patched magisk, patched boot, patched twrp etc, i cannot get it to boot into twrp and can no longer get into the android custom recovery because it always goes to the DID screen w bar code on the bottom or right just after rooting it'll just reboot into the os.. i believe it pretty much always passes, but it seems when i do patched magisk + patched kernal, this is only way i can get into the android custom recovery is if its plugged in.. every other time with twrp itll just boot into the DID screen.. so maybe im just unable to do the buttons/cable plug right where i have to plug unplug in a second scenario or something.. but what am i missing?
 
  • Like
Reactions: Tommasavas

IFireflyl

Senior Member
Feb 23, 2009
147
18
Springfield
I'm stuck in a Bootloop on my SM-N986U1. I created a full backup in TWRP because I was going to flash stuff with Magisk. After creating the full backup I tried to reboot into System and it wouldn't get past the initial Samsung Logo screen (the one that tells you the phone is running unofficial software and has the Knox logo).

I tried rebooting back into TWRP and flashing my backup (even though I didn't change anything), but I can't for the life of me get back into my phone. TWRP is showing three lines at the top of the Restore that says:

E:unable to update logical partition: /system_image
E:unable to update logical partition: /vendor_image
E:unable to update logical partition: /product_image

When it gets to "Restoring System Image..." it never says that it completes, but it then offers the "Back" or "Reboot System" prompts below it. So the system image is obviously screwed up somehow and I have no idea what I am supposed to do to fix this.

If anyone can help me I would be extremely grateful as my phone is little more than a paperweight right now, and if I don't have it fixed by tomorrow I'm going to be in some hot water with my job.
 
Last edited:

Chandrogema

New member
Mar 23, 2019
1
0
Hello,

When will it be updated? I have had problems using this TWRP.

I tried to install Magisk, but TWRP was blinking all the time and it was impossible, even ADB was impossible to use.
Another problem I've had, is that when I tried to go to the System, it's like the files no longer exist... all the time it was restarted to TWRP.

In case there is any doubt, my model is the: sm-n986b/ds

Thanks.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    just had to reflash the stock firmware to start from scratch again. root the device with Magisk, move the AP file back on the device and patch it using Magisk, then flash the device with the patched AP file. after that, I used Dr. Ketan's recovery on his website.
    I got the same problem and still not working with me
    1
    Hello, link in 1st post to download doesn't work. Does anyone has a workaround?
    You can get TWRP from here
  • 17
    Team Win Recovery Project 3.4.0

    https%3A%2F%2Fwww.maketecheasier.com%2Fassets%2Fuploads%2F2019%2F01%2Ftwrp-featured.jpg

    Exynos ONLY.
    In NO way it is compatible with Snapdragon variants including but not limited to American(U/A/T/P/V), Chinese(0/8/6), Hong Kong(0), Japanese(SC-*), Canadian(W) variants.


    Special Notes:
    1. DON'T FORGET TO ENABLE "OEM UNLOCK" (located in Developers options).
    2. KNOX will be tripped once you flashed custom binaries to your phone.
    (Your warranty may be voided. However this may not affect you if your country forces Samsung to provide hardware warranty regardless of software status.)
    3. Samsung Firmware OTA (aka System Updates) will no longer work once you flashed custom binaries.
    (You can flash custom ROMs if you want to keep the OS up-to-date.)
    4. All apps that use KNOX like Samsung pay, Secure Folder and maybe more will no more work


    Download: Note 20/Note 20 Ultra(Exynos variants)
    Download

    Sources:
    Kernel source
    TWRP source
    Device Tree: Sorry are not under GPL License since are my own so they will not get released :(

    Changelog:

    03.09.2020
    - V4 Release
    - Twrp boots now without nulled Vbmeta.img

    03.09.2020
    - V3 Release
    - Fixed Optics and Prism Backup and Restore
    - Brightness is now no more at max
    - CPEFS error is gone
    - Sec-EFS added in the FStab

    26.08.2020
    - V2 Release that fixes Problems booting in TWRP (RKP was not disabled in kernel config)

    24.08.2020
    -Initial Release

    Discord server for support:
    https://discord.gg/BCHTXSQ

    Bugs:
    -MTP and Encryption (ADB PUSH WORKS when you disable mtp in TWRP mount settings!)

    XDA:DevDB Information
    [RECOVERY] TWRP for Galaxy Note 20/Note 20 Ultra, Kernel for the Samsung Galaxy Note 20 Ultra

    Contributors
    geiti94
    Kernel Special Features:

    Version Information
    Status: Stable
    Stable Release Date: 2020-09-03

    Created 2020-08-24
    Last Updated 2020-10-18
    9
    Guide:
    1. Go to Developer settings and enable oem unlock
    2. power off the device and boot in download mode with vol up+ vol down buttons and plug in the usb (make sure usb cable is connected to the pc)
    3. in download mode you see the long press vol up option for unlock bl
    4. unlock the bootloader (that will wipe your device so be sure you made a backup of your data)
    5. after bootloader unlock boot up the phone and make sure it is connected to the internet or he triggers rmm prenormal
    6. setup the phone without google account etc
    7. reboot in download mode and flash twrp tar for your device with odin in the AP field
    8. hold vol up + power button while odin is flashing until you are in twrp.
    9. format data in twrp and disable encryption! (Encryption disabler is in download folder!)
    10. Flash Latest Magisk
    11. press reboot to system in twrp.
    9
    Kudos to you!
    Will test tomorrow when get my device. Fun begins!
    8
    so twrp is fixed. thx to @dr.ketan for testing it since i dont got the n20 since is like a downgrade for me (i still love the 5000mah battery of my s20 ultra:eek:). i see next month if get it or not. was my fault that twrp dont booted because on n20 kernel config i forgot to disable rkp :eek:
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone