• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

Red Magic 3 Root Guide

Search This thread

pandjie24

New member
Mar 7, 2016
3
0
Hello. . currently my RM3 at - CN v5.11 - ROM. . and the problem is, after I flash "MAGISK_PATCHED.IMG", seems like I can't boot the phone. it just show blank black screen after boot logo. anybody have any ideas what happen??

FYI the root works well for me in CN-3.34
 

John_Ryan

New member
Dec 25, 2020
4
0
I command shell commands in adb where i was able to saw that the charger and the aboot file is missing i think, here's the problem start i think so we need a fresh softwere which have this files inbuilt.
Could more specifict,, I'm at CN V5.11 now,,
And my phone still not detected to PC while phone in fastboot mode,,
Please help me,, Please,,
CN V5.11 i've downloaded at official page of Nubia RM3 software,,
I think this file CN V5.11 is complete built,, But why my phone cannot be detected by PC in fastboot mode,,
 

RoseRahman

Member
Dec 23, 2020
18
1
Could more specifict,, I'm at CN V5.11 now,,
And my phone still not detected to PC while phone in fastboot mode,,
Please help me,, Please,,
CN V5.11 i've downloaded at official page of Nubia RM3 software,,
I think this file CN V5.11 is complete built,, But why my phone cannot be detected by PC in fastboot mode,,
That's a softwere issue and the only solution of that problem is a fresh reinstall of bootloader command in kernal or get it via an softwere update.
 

John_Ryan

New member
Dec 25, 2020
4
0
That's a softwere issue and the only solution of that problem is a fresh reinstall of bootloader command in kernal or get it via an softwere update.
Maybe i should go back to GLOBAL to that's it works or not,, I've tried downgrade from CN V5.11 to CN V3.34 and downgrade again to CN V3.30 and last to CN V3.29
After do that several downgrade, the problem still appear,,
 

Chakson

Member
Dec 14, 2012
35
6
Sarajevo
I tried the guide to flash my red magic 3s, and as ramdisk is no, I patched the recovery.img and flashed it but it didn't root my phone.

Though I have installed
nx629j_v1s_encommon_v2.12
But couldn't find the exact image anywhere do download
Anyone knows where I can find it?

Update:
Flashed CN rom 5.11, took the recovery.img, patched it with magisk, fastboot flash recovery, still not rooted.
WHAT AM I DOING WRONG?
 
Last edited:

danishajaz

Senior Member
Sep 26, 2014
176
20
ZTE nubia Red Magic 3
I tried the guide to flash my red magic 3s, and as ramdisk is no, I patched the recovery.img and flashed it but it didn't root my phone.

Though I have installed
nx629j_v1s_encommon_v2.12
But couldn't find the exact image anywhere do download
Anyone knows where I can find it?

Update:
Flashed CN rom 5.11, took the recovery.img, patched it with magisk, fastboot flash recovery, still not rooted.
WHAT AM I DOING WRONG?
U need to patch boot.img not recovery.img. For android 11 u need to flash android 11 root fix and then magisk through twrp. Check https://forum.xda-developers.com/t/android-11-red-magic-rom-flashguide.4195699/post-84520503
 

chinosan

Member
Jan 27, 2013
19
2
after flashing patched_boot.img, i get stuck in the boot logo!!
im on build nx629j_v1s_encommon_v1.07 please help!!!
i downloaded my current rom (1.07) from here
and used the latest magisk (22.0) to patch boot.img
what am i doing wrong??
 
Last edited:

chinosan

Member
Jan 27, 2013
19
2
after flashing patched_boot.img, i get stuck in the boot logo!!
im on build nx629j_v1s_encommon_v1.07 please help!!!
i downloaded my current rom (1.07) from here
and used the latest magisk (22.0) to patch boot.img
what am i doing wrong??
Dudes, I even flashed TWRP with no problems, and tried to root my rm3s by flashing magisk through TWRP, everything went correctly and when I tried to boot, got stuck on boot logo, wtf man???
 

chinosan

Member
Jan 27, 2013
19
2
Dudes, I even flashed TWRP with no problems, and tried to root my rm3s by flashing magisk through TWRP, everything went correctly and when I tried to boot, got stuck on boot logo, wtf man???
after much thought, i decided that the only variable for me right now was the Magisk version i was using, so i tried the procedure with magisk 19.4, and everything worked fine, im rooted now.
But i have one last question, do i dare to update magisk???
 
Last edited:

Top Liked Posts