• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

redmi 7a, bootloop after installing treble roms

Search This thread

xarvox

Member
Aug 6, 2009
46
1
Hello everybody!

Im trying to ditch the spywareOS that came with my phone, but i seem to be unable to find a replacement.
The only thing that actually boots after install is a lineageOS 17.zip installation, but thats incredibly unstable and has deal-breaking bugs.

So im trying desperately to get treble roms to work and i belive ive tried "them all" already, none of them actually boots up or shows the custom boot animation, its in a loop, the redmi logo shows up, then screen goes black (reboot?) and then the redmi logo shows up again.

Ive been trying both 32bit and 64bit roms, both Aonly and A/B varations, with no difference what so ever, so i figure i must be doing something wrong, missing a step somewhere..

Ive been following THIS TUTORIAL mostly, but the Permissiver_v4.zip install always failed with a error (cant remember exactly) but i found a version 5 witch does install.

I did downgrade MIUI to 10.2.5 before starting the procedure and i did find the corresponding boot-image witch im using, along with the vbmeta.img file listed in the tutorial, so i do belive i have done everything by the book, but still no cigar...

Ive tried (gsi treble roms): Descendant X, Quack Phh-Treble, Havoc-OS-3.5, LineageOS 17.x aswell as googles own GSI.
I also made sure to vacuum the forum topic for each of the ROM´s, in case there´s a hint or suggestion that i might find useful, but theyre all pretty much the same:
Wipe dalvik, System, Data and cache, install rom, reboot.
Some have suggested to clear dalvik and cache after install (sometimes with a reboot in between) and some have hinted that the magisk is mandatory in order to fix boot issues, but still no go..

So, does anybody have any suggestions?