• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

Redmi note 6 pro self-bricked overnight - EDL flashing fails

Search This thread

Talix

New member
Nov 2, 2018
3
0
Hey guys

I'll just let you know first up, this is the second time I've had this issue with this particular phone being hard-bricked, but this time I can't seem to fix it.

It doesn't turn on, can't be hard-reset, can't go to recovery/fastboot, only EDL mode via test points. Last time (April 2019) it also happened overnight, but I was able to restore it to proper function by EDL flashing it using QFIL and a modified programmer (prog_emmc_firehose_Sdm660_ddr.mbn). The rom I flashed back then was the most recent at the time, Redmi Note 6 Pro Global V10.3.2.0.

This time was a bit different in that I was actually able to hard-reset it at first (it vibrated and seemed to boot), but it then got stuck on the mi-logo during startup. I wasn't able to get it into recovery, but the fastboot screen came on ok. However, the phone didn't register on the pc and I wasn't able to actually send any fastboot commands to the phone, nor flash roms. I don't think fastboot was actually working which might be pointing to chip issues... Unfortunately...

After a few attempts at hard-resetting and failing recovery, I think the battery actually ran flat. Now it is dead-dead. Doesn't react at all, doesn't do anything, just like back in April last year. When I plug it in to my pc it delays for about 10 seconds and then shows up as if it's in EDL mode (Qualcomm HS-USB QDLoader 9008) but it's not really flashable - it doesn't react to QFIL correctly.

I then pulled the phone apart, shorted the EDL points and got it into 9008 mode immediately after plugging in the usb cable, no 10 sec delay doing it this way. However, when trying to flash the phone now it fails and reports a generic 'Firehose FHLoader error'... Please see log attached in this google drive link: drive.google[dot]com/file/d/1nj_0f95qLnLHqIgTEODmilY9ObmAkowz/view
Apologies for the link - I don't have 10 posts yet...

The most recent miui rom for the phone now is "tulip_global_images_V11.0.4.0.PEKMIXM_20200514.0000.00_9.0_global" and that's the one I primarily tried flashing. I also tried the one I had success with last year (fearing though it might re-brick due to the roll-back protection) but that didn't work either, same error. I also tried flashing using different USB cables, all high quality, but the error remains. I also tried it using a laptop, just to rule out windows issues. I've also tried the tips for resolving QFIL errors mentioned on the hovatek forum: forum.hovatek[dot]com/thread-30141.html but with no luck there either.

Have you guys got any ideas how I might proceed? Any tips I could try?

I am kind of resigned to this perhaps being a hardware issue, perhaps this particular chip has failed and that is why not even EDL mode is working properly. But I just wanted to ask the community if you had any ideas. If not, then it's not an expensive phone. However, I would love fixing it if I could, my wife loves it...
 

Nitin Rai

Senior Member
Apr 19, 2015
88
17
Xiaomi Redmi Note 6 Pro
I suggest to first short the pins then open the flash tool and try to flash the factory rom. The programmer file will be inside the extracted rom directory, select that and proceed. If it does not work try installing Qualcomm driver and retry .
 

Gh_Racer

Member
Dec 12, 2018
43
3
Italy
Hey guys

I'll just let you know first up, this is the second time I've had this issue with this particular phone being hard-bricked, but this time I can't seem to fix it.
I'm sorry for re-opening an old thread, but I'm in a really similar situation.

My Redmi self-bricked, and I don't have any ideas since I have already tried a flash in ELD mode but the Flash Tool says that it's not able to receive the hello packet from the phone.

Have you been able to solve the issue in some ways?

Ps. Here's my post, in case you need further informations