Redmi note 7 stuck in a bootloop. Can only access stock recovery, is it fixable?

Search This thread

avatoxico

Member
Jan 14, 2015
16
1
Good morning!

While attempting to flash a stock MIUI 10 ROM into my Xiaomi Redmi Note 7, to downgrade back to Android 9.0 due to some app compatilibty issue, I messed up big time and my phone is now stuck in a loop where the screen turns on, nothing shows up, then it restarts, going off for a few seconds and turning on again.

Power Button + Volume UP successfully brings me to the stock recovery 3.0 from xiaomi.

Power Button + Volume DOWN fails to bring me to the fastboot mode.

If I select the Connect with MIAssistant in the recovery the phone will show up as "sideloaded" after using the command adb devices, but the MIPCSuite app does not see it and the command adb restart bootloader also fails to bring up the fastboot mode, it just gets stuck in the loop again.

More context on what went wrong and caused this: I followed an online tutorial to flash a rom using the MIFlash app, so I unlocked the bootloader and tried to flash the rom usin xiaomi's tool. I got a failed to check sparse crc error code and it went downhill from there when I tried to fix things reading multiple threads on the issue. I tried deleting some lines from the flash_all.bat file and tried to flash it again but then the flashing process went seemingly forever so I aborted the operation and now this loop happens. I tried a few more times but with no success.

The first time I tried to use the tool I used the clean all and lock option so I'm not certain if the miflash tool locked the bootloader regardless of the outcome of the flashing attempt.

Is there hope? Can I fix this phone if I only have access to stock recovery and nothing else (although it shows up in adb devices but can't get into fastbootmode) ?

Thanks a lot to anyone who took the time to read and possibly help.
 

jwoegerbauer

Senior Member
Jul 11, 2009
4,950
4
1,215
European Union
Both ADB and Fastboot are Android-side launched by device's bootloader. If you can't enter Fastboot mode then my guess is there is something is wrong with curently installed Android.
BTW: If you lock device's bootloader then bootloader attempts to load device's Stock ROM.