[REF] Mako hybrid modem collection [UPDATED: 6/5/2014]

Search This thread

morrislee

Senior Member
Aug 24, 2010
974
1,071
Edmonton
Uh... I think I have fixed the camcorder auto focus on .33 radio, here is the hybrid 84 and 33.

T-Mobile users, you should not need to do anything else from a fresh ROM install other than flashing hybrid and the EnableNexus4LTE.zip, voice should work fine now.

LTE working with camcorder autofocus

Let me know what else is fixed or what else is broken instead.

Releases:
Version 2

Requested versions:
Requested (Click here to see details)


Change log:

New modem radio-mako-m9615a-cefwmazm-2.0.1701.02:
- released based on new modem with "02" using "33" and the two versions of "27" cell components. they have been tested and works fine

V2:
- updated WiFi what believed to be WiFi Modules, seems to fix suspend_backoff so far
- added 33-54 as .54 seems to have better 5.0GHz WiFi handlding.

Original Release:
- jibber-jabber


Instructions:

1. Flash EnableNexus4LTE.zip to "enable" LTE in the build.prop
2. Flash one of these Hybrid Modem
3. Use these instructions or full wipe your ROM

Remarks:
- If you are experiencing GPS locking issues, make sure you are not downvolting (after putting your voltage back, it also takes about good 10-20 minutes before it is fully "normal" again"
- If you have a combination of the hybrid you would like me to build, give me a shout and I will try and create one and post it here.
 
Last edited:

morrislee

Senior Member
Aug 24, 2010
974
1,071
Edmonton
There are some issues with 97 by the looks of it (with WiFi and slow boot)

Noticed the modem.img is smaller than usual, and it is actually missing quite a few items.

so I made a few varients:

W97C27MO97 - 0.97 based with 0.27 cell radio
W97C33O97 - 0.97 based with 0.33 cell radio
W97C33O97FULL - 0.33 based with updates from 0.97 keeping 0.33 cell radio

I am too scared to test right now, going back to work to tomorrow - need my phone working, who wants to be a guinea pig? Go HERE

Let me know how it goes :D
 
Last edited:

morrislee

Senior Member
Aug 24, 2010
974
1,071
Edmonton
Requested hybrid modems are here:

http://www.mediafire.com/folder/tsriokg43m9s8/Requested

W54C24O84.zip contains:

WiFi: 0.54
Cell: 0.24
Other: 0.84

for some of the cell 0.27 ones that did not get specified whether it was the November or the March one (where you see "N" or "M" behind the 27 for November or March respectively), you will see variants like:

W54C27MO84.zip

WiFi: 0.54
Cell: 0.27 March 2013
Other: 0.84

W54C27NO84.zip

WiFi: 0.54
Cell: 0.27 November 2012
Other: 0.84
 
Last edited:

morrislee

Senior Member
Aug 24, 2010
974
1,071
Edmonton
I'm on T-Mobile running 4.2.2 stock/rooted with LTE mods/hacks and it seems to be working well. Have in call audio. Not sure if this was meant for 4.3 also. I haven't tried that since the in call audio issue is the only thing keeping me from 4.3 at the moment.

I thought people who were on t mobile using .33 has voice problems or something. So i thought that was the next thing to look for. Not just meant for 4.3, for all ;) thanks!
 
  • Like
Reactions: AsesinoQc

VidMan

Senior Member
May 9, 2007
113
6
Ithaca, NY
Uh... I think I have fixed the camcorder auto focus on .33 radio, here is the hybrid 84 and 33.

LTE working with camcorder autofocus

Let me know what else is fixed or what else is broken instead.

running it now, so far no issues. Use it at your own risk

Flashable ZIP

Would it be possible for you to create a hybrid .27/.84 radio? Thanks. I ask only because I get better battery life on .27.
 

Juggalotus

Member
Apr 29, 2010
44
6
Uh... I think I have fixed the camcorder auto focus on .33 radio, here is the hybrid 84 and 33.

LTE working with camcorder autofocus

Let me know what else is fixed or what else is broken instead.

running it now, so far no issues. Use it at your own risk

Flashable ZIP

I have been staying away from. 33 cuz it broke my continuous focus on every rom. You sir are awesome cuz it now works! I'm in 4.2.2 btw. I'll report back if I see any wonkyness. Excellent work!

Sent from my Nexus 4 using Tapatalk 2
 
  • Like
Reactions: Scallywag1

pchtc

Senior Member
Sep 13, 2007
807
274
Ottawa
Uh... I think I have fixed the camcorder auto focus on .33 radio, here is the hybrid 84 and 33.

LTE working with camcorder autofocus

Let me know what else is fixed or what else is broken instead.

running it now, so far no issues. Use it at your own risk

Flashable ZIP

Thats great
how did you make the hybrid radio
i was under the impression that radio files were closed source
i think what you did is great, just wondering how you did it?
 

BRKotucs

Senior Member
Feb 3, 2011
5,896
13,951
Houston, Tx
Uh... I think I have fixed the camcorder auto focus on .33 radio, here is the hybrid 84 and 33.

LTE working with camcorder autofocus

Let me know what else is fixed or what else is broken instead.

running it now, so far no issues. Use it at your own risk

Just flashed this and it's working great. I have a question though.... in settings / about phone, does it supposed to show as .33 or .84?

Mine shows as .33

Just wondering! Thank you for this mod.

Sent from my Nexus 4 using Tapatalk 2
 

dcd1182

Senior Member
May 7, 2007
1,822
183
Denver
Uh... I think I have fixed the camcorder auto focus on .33 radio, here is the hybrid 84 and 33.

LTE working with camcorder autofocus

Let me know what else is fixed or what else is broken instead.

running it now, so far no issues. Use it at your own risk

Flashable ZIP

yes, it works
no LAC though :(
would you mind sharing your process?
I thought modem had to be signed?
 

morrislee

Senior Member
Aug 24, 2010
974
1,071
Edmonton
Would it be possible for you to create a hybrid .27/.84 radio? Thanks. I ask only because I get better battery life on .27.

here you go sir :) (not tested, good luck!)

Thats great
how did you make the hybrid radio
i was under the impression that radio files were closed source
i think what you did is great, just wondering how you did it?

It is closed source lol, I sat there mounting img (it is really just a partition in a file) swapping each files and flashing each build until I got LTE working and create a new one to only swap that one. As far as I can tell, using this method kept the modem, but the power management from 84, that is probably why autofocus works? XD

Just flashed this and it's working great. I have a question though.... in settings / about phone, does it supposed to show as .33 or .84?

Mine shows as .33

Just wondering! Thank you for this mod.

Sent from my Nexus 4 using Tapatalk 2

suppose to show .33, .33 is the core, the remainder are all .84's components :)

yes, it works
no LAC though :(
would you mind sharing your process?
I thought modem had to be signed?

It was broken since beginning of time :( cant fix it just yet - not a huge deal, look at here for location fix by GPS.

I am looking for a fix for it though for the perfect modem, mixing and matching from e973 might be a start. This will take time, and I am going to be very busy the next month.

happy modding guys =D
morrisle
 
Last edited:

lazer155

Senior Member
Sep 20, 2012
729
60
It is closed source lol, I sat there mounting img (it is really just a partition in a file) swapping each files and flashing each build until I got LTE working and create a new one to only swap that one. As far as I can tell, using this method kept the modem, but the power management from 84, that is probably why autofocus works? XD

suppose to show .33, .33 is the core, the remainder are all .84's components :)

Are you saying that the power management from .84 is included in the hybrid?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 159
    Uh... I think I have fixed the camcorder auto focus on .33 radio, here is the hybrid 84 and 33.

    T-Mobile users, you should not need to do anything else from a fresh ROM install other than flashing hybrid and the EnableNexus4LTE.zip, voice should work fine now.

    LTE working with camcorder autofocus

    Let me know what else is fixed or what else is broken instead.

    Releases:
    Version 2

    Requested versions:
    Requested (Click here to see details)


    Change log:

    New modem radio-mako-m9615a-cefwmazm-2.0.1701.02:
    - released based on new modem with "02" using "33" and the two versions of "27" cell components. they have been tested and works fine

    V2:
    - updated WiFi what believed to be WiFi Modules, seems to fix suspend_backoff so far
    - added 33-54 as .54 seems to have better 5.0GHz WiFi handlding.

    Original Release:
    - jibber-jabber


    Instructions:

    1. Flash EnableNexus4LTE.zip to "enable" LTE in the build.prop
    2. Flash one of these Hybrid Modem
    3. Use these instructions or full wipe your ROM

    Remarks:
    - If you are experiencing GPS locking issues, make sure you are not downvolting (after putting your voltage back, it also takes about good 10-20 minutes before it is fully "normal" again"
    - If you have a combination of the hybrid you would like me to build, give me a shout and I will try and create one and post it here.
    47
    Would it be possible for you to create a hybrid .27/.84 radio? Thanks. I ask only because I get better battery life on .27.

    here you go sir :) (not tested, good luck!)

    Thats great
    how did you make the hybrid radio
    i was under the impression that radio files were closed source
    i think what you did is great, just wondering how you did it?

    It is closed source lol, I sat there mounting img (it is really just a partition in a file) swapping each files and flashing each build until I got LTE working and create a new one to only swap that one. As far as I can tell, using this method kept the modem, but the power management from 84, that is probably why autofocus works? XD

    Just flashed this and it's working great. I have a question though.... in settings / about phone, does it supposed to show as .33 or .84?

    Mine shows as .33

    Just wondering! Thank you for this mod.

    Sent from my Nexus 4 using Tapatalk 2

    suppose to show .33, .33 is the core, the remainder are all .84's components :)

    yes, it works
    no LAC though :(
    would you mind sharing your process?
    I thought modem had to be signed?

    It was broken since beginning of time :( cant fix it just yet - not a huge deal, look at here for location fix by GPS.

    I am looking for a fix for it though for the perfect modem, mixing and matching from e973 might be a start. This will take time, and I am going to be very busy the next month.

    happy modding guys =D
    morrisle
    44
    Just updated my phone to 4.4.1. Here's the new hybrid radios. Flash at your own risk.

    98-27M
    http://d-h.st/jt8

    98-33
    http://d-h.st/z3h
    33
    Don't suppose someone can do a 33/104 hybrid? .27 sucks on AT&T here... TIA

    This is a working 33/104 I made, I flashed it using fastboot, but this should flash using recovery as well

    https://drive.google.com/file/d/0B6TD-KNgpMu-eUtKQjB0ZXFDdGM/view?usp=sharing
    32
    I will get on it once i get home from work, I have limited access to my stuff at the camp provided by work