• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[REF] Mako hybrid modem collection [UPDATED: 6/5/2014]

Search This thread

mriss

New member
Jan 26, 2017
1
0
Tell as, does the hd voice already work for You? Or for someone else? I am just curious, because it works for me but I didn't use Your LTE enabler, because I can't use LTE :p
Hi mkmck,
I'm also from Poland. I'd like to know how did you manage to get HD Voice working on Nexus 4.
PS. My network is T-Mobile, which also provides HD Voice.
 

Zestar

Senior Member
Jan 12, 2012
60
13

therealsniper69

Senior Member
Sep 16, 2013
66
21
I have the mako 104 33 hybrid modem and the nexus 4 lte fix v 1.6 - as well as the 1.41 lte fix. Also I have nexus 4 lte enabler v 2.14. The lte fix and enabler show a modem .img but am not sure which version the modem file is.
Also I have twrp, multirom, chroma, and I think ubuntu for the nexus 4/mako. Let me know if you're interested and I'll see what needs to be done to get you the file(s).
 

pbfy0

New member
Jul 8, 2014
3
0
I have the mako 104 33 hybrid modem and the nexus 4 lte fix v 1.6 - as well as the 1.41 lte fix. Also I have nexus 4 lte enabler v 2.14. The lte fix and enabler show a modem .img but am not sure which version the modem file is.
Also I have twrp, multirom, chroma, and I think ubuntu for the nexus 4/mako. Let me know if you're interested and I'll see what needs to be done to get you the file(s).

Could you send me the 104/33 modem file? Thanks.
 

acejavelin

Recognized Contributor
Sep 3, 2009
6,835
3,321
Lincoln, ND
dear friends i need lte band 40, 41 enabler.. for my htc one m8, i m using in india with developer edition rom.
I think you are asking in the wrong place my friend... This thread is about modems for the Nexus 4, which originally had LTE then it was removed... We combine part of an old modem with a new one to enable one band. If your device had that we can't just "enable" it.
 
  • Like
Reactions: GKFLASH81

pfederighi

Senior Member
Nov 22, 2012
263
283
Seattle
Last edited:

brandonabandon

Senior Member
Nov 17, 2013
283
299
hi dev. ben on hiatus since early nougat-era. long story short, i decided to nab a new mako since oreo is compatible. my issue is with lte. ive flashed the 3 hybrids provided by @morrislee, as well the 33/27 107's. the method is clean install, flash modem, flash lteenabler.zip, edit apn, *# into testing and select lte, wait, reboot, no dice.
ive tried the method on 5,6,7,8 android versions, multiple roms. im on metropcs. i had nougat with lte running fine about this time last year. it was a cm-based rom it was a different phone than i am using now. when i activated my mako it was running oreo with the latest stock radio. i remember seeing the lte icon and not thinking anything of it. (i forgot about having to flash custom radio with mako) it seems impossible now. im thinking the zip i flashed last year is no longer available for download. i have yet to see an lte icon since leaving the metropcs store. i even tried the latest stock image using v12enabler. my area definetly has 4band coverage as my previous phone (metropcs) had no issue lte. sorry to revive old thread. i didnt want to hijack or start a new thread. any advice?
 
Last edited:
  • Like
Reactions: alexalp777

Top Liked Posts

  • There are no posts matching your filters.
  • 159
    Uh... I think I have fixed the camcorder auto focus on .33 radio, here is the hybrid 84 and 33.

    T-Mobile users, you should not need to do anything else from a fresh ROM install other than flashing hybrid and the EnableNexus4LTE.zip, voice should work fine now.

    LTE working with camcorder autofocus

    Let me know what else is fixed or what else is broken instead.

    Releases:
    Version 2

    Requested versions:
    Requested (Click here to see details)


    Change log:

    New modem radio-mako-m9615a-cefwmazm-2.0.1701.02:
    - released based on new modem with "02" using "33" and the two versions of "27" cell components. they have been tested and works fine

    V2:
    - updated WiFi what believed to be WiFi Modules, seems to fix suspend_backoff so far
    - added 33-54 as .54 seems to have better 5.0GHz WiFi handlding.

    Original Release:
    - jibber-jabber


    Instructions:

    1. Flash EnableNexus4LTE.zip to "enable" LTE in the build.prop
    2. Flash one of these Hybrid Modem
    3. Use these instructions or full wipe your ROM

    Remarks:
    - If you are experiencing GPS locking issues, make sure you are not downvolting (after putting your voltage back, it also takes about good 10-20 minutes before it is fully "normal" again"
    - If you have a combination of the hybrid you would like me to build, give me a shout and I will try and create one and post it here.
    47
    Would it be possible for you to create a hybrid .27/.84 radio? Thanks. I ask only because I get better battery life on .27.

    here you go sir :) (not tested, good luck!)

    Thats great
    how did you make the hybrid radio
    i was under the impression that radio files were closed source
    i think what you did is great, just wondering how you did it?

    It is closed source lol, I sat there mounting img (it is really just a partition in a file) swapping each files and flashing each build until I got LTE working and create a new one to only swap that one. As far as I can tell, using this method kept the modem, but the power management from 84, that is probably why autofocus works? XD

    Just flashed this and it's working great. I have a question though.... in settings / about phone, does it supposed to show as .33 or .84?

    Mine shows as .33

    Just wondering! Thank you for this mod.

    Sent from my Nexus 4 using Tapatalk 2

    suppose to show .33, .33 is the core, the remainder are all .84's components :)

    yes, it works
    no LAC though :(
    would you mind sharing your process?
    I thought modem had to be signed?

    It was broken since beginning of time :( cant fix it just yet - not a huge deal, look at here for location fix by GPS.

    I am looking for a fix for it though for the perfect modem, mixing and matching from e973 might be a start. This will take time, and I am going to be very busy the next month.

    happy modding guys =D
    morrisle
    44
    Just updated my phone to 4.4.1. Here's the new hybrid radios. Flash at your own risk.

    98-27M
    http://d-h.st/jt8

    98-33
    http://d-h.st/z3h
    33
    Don't suppose someone can do a 33/104 hybrid? .27 sucks on AT&T here... TIA

    This is a working 33/104 I made, I flashed it using fastboot, but this should flash using recovery as well

    https://drive.google.com/file/d/0B6TD-KNgpMu-eUtKQjB0ZXFDdGM/view?usp=sharing
    32
    I will get on it once i get home from work, I have limited access to my stuff at the camp provided by work