[Release] JOdin3 CASUAL Cross Platform and Web-Based Flashing For Samsung Phones

Search This thread


New member
Jun 14, 2020
Probably not. It's to old to run on a current system (at least, it doesn't run on any fairly recent version of Linux).
Better to use the latest Odin (without J). If you need, set up a virtual machine. Or you could use heimdal (command line tool on Linux, Mac). That's more complicated for a full ROM but more convenient for a single partition.
Jodin works fine with Ubuntu 20.04 after Updating heimdall to latest version 1.4.2 using "sud apt install heimdall-flash" .
  • Like
Reactions: Frosty888


New member
Jun 14, 2020
On Manjaro , you need to get the latest Heimdall version (1.4.2 ) from Arch Packages . The Heimdall version given in its official site seems to be old and not working with any modern linux . Installing latest Heimdall from the distro's official respiratory will solve the issues .


Apr 26, 2015
umm,wow this tools still work, successfully flash TWRP for Samsung a3 2016
archlinux 5.8.rc2 kernel, all you need is installing Heimdall and android-udev packages
Last edited:


Senior Member
Apr 11, 2014
Cannot convert the stock firmware file into tar.md5 on myacbook air. After unzip, tar.md5 suddenly appear as a folder containing 6 files.

Sent from my IN2010 using Tapatalk


New member
Nov 26, 2020
In linux I have an error when try to use a full stock ROM
java.lang.OutOfMemoryError: Requested array size exceeds VM limit


Mar 1, 2007
Look it up on Google. There are some cli arguments you could use to fix that, but I'm no expert at Java arguments.

I'm currently suffering the same problem.

Have used JAVA_OPTIONS and _JAVA_OPTIONS and neither seem to have any effect.

It picks them up because I see in the console:
Picked up _JAVA_OPTIONS: -Xmx8096m                                                                                                            
[DEBUG]Diagnostics OS:Linux Version:5.4.78-1-MANJARO Architecture:amd64 Separator:/ | Java:eek:racle Corporation Version:1.8.0_20 Website:http://
java.oracle.com/ | WorkingDir: /home/jezm/Downloads/android/flashing/JOdin3CASUAL-r1142-dist/app CASUALDir:/tmp/CASUALroot-2020-11-30-08.02.52
/ | CASUAL is handling this system as:Linux 32 bit, Linux -- End Diag

However, as you can also see it seems to detect the system as 32bit, which I suspect won't allow the memory to be set above 1024m

It is a 64 bit system with 32gb RAM, but I wonder if having multilib libraries installed (mainly for wine) confuses it.

I have downloaded different versions of java as well, then set them at start of PATH as well as set JAVA_HOME, _JAVA_HOME, JAVA_OPTS to values to match, everything still detects as 32 bit.

java is showing as 64bit:

Picked up _JAVA_OPTIONS: -Xmx8096m
java version "1.8.0_60"
Java(TM) SE Runtime Environment (build 1.8.0_60-b27)
Java HotSpot(TM) 64-Bit Server VM (build 25.60-b23, mixed mode)

That was the downloaded version but get the same with the installed java 14 too.

I've also tried running direct as a jar file but still detects as linux 32 bit.

I'd look in the source to find out what it's doing, but can't seem to find the source anywhere.

Also tried flashing with heimdall (and frontend) after extracting the tarballs (I'm trying to flash stock 6.0 firmware) but can't seem to get the magic right. Keep getting errors in the bootloader screen when it starts.


Senior Member
May 21, 2010
on catalina i get

A corrupted file was detected. In order to continue, you must select a valid Odin File

Last edited:
I'm using Linux Mint 20 (5.8.0-28-generic),
After using libusb-dev and manually setting USB udev-rules, I finally managed to get PIT using Heimdal, but JOdin fails with this;
CASUALroot-2021-05-22-18.44.14/ElevateScript.sh: 2: flash: not found
Device Connected

Any advice on that? Thanks


Senior Member
Oct 27, 2011
Is JOdin3 stll live? The links to google drive seem all gone ("Access denied"). And the website is dead.


Senior Member
Jun 19, 2011
I am very happy jOdin3 does work on arch linux. I am suprised that even have an active AUR package which does work well. However i am having a problem but i do not know what is causing. i am having an old Nokia cable as original Samsung cable lost long time ago. On Windows10&11 does work odin after Samsung driver succesfully installed. But jodin3 does not. It does recognize the phone com however it does not give com number. meaning for me jodin did not recognized the usb port properly. if i plug or remove the cable- added or removed- does work. But every flashing attempt will Fail. Same cable i use on windows and jodin3. Any idea why does not work on jodin3 ?
Last edited:
  • Like
Reactions: mrrocketdog


Senior Member
Oct 27, 2013
@AdamOutler , dang ; still here ? i'm going to have to put you on my "follow" list.
glad youre still hanging out. thanks for your help in many many ways/things/projects.:good:
  • Like
Reactions: AdamOutler


New member
May 2, 2022
Possibly a dumb question, but I haven't found any documentation for JOdin3, or posts explaining this.

Odin3 allows one to specify files to be loaded to BL, AP, CP, CSC, and USERDATA. JOdin3 gives me choices of Bootloader, PDA, Phone, CSC and UMS (which is greyed out). What do these mean, and why are they different? More to the point, which do I use to install TWRP to my tablet (Galaxy Tab A, SM-T510)?

Top Liked Posts

  • There are no posts matching your filters.
  • 243
    bumpy bump

    I'm looking for the same installs and the links are not working for me either.


    Links for JOdin3 are not working, why?


    Hi guys, the links above are not working & I'm having a very hard time finding Jdoin3 for MAC OS X Can someone help me?

    I have re-upped my latest version I had for JOdin3 here

    As the above link sometimes seems to stop working (XDA wassup??) here a mirror: https://www.androidfilehost.com/?fid=673956719939825345

    20 downloads in 1 day. 0% clicked thanks. Can't believe that at least coming back to click on thanks is too much for you. I really understand why so many ppl decide to NOT help others if this one click is too much for you.
    Ok I don't care. suck as much and often as you like but don't cry again if some day no one will be here to answer or help.

    Thanks for all those given a proper thanks click in the meantime!
    Yea time goes by and JOdin is included since a long while even in FWUL ( https://bit.do/FWULatXDA ). Check it out ;)

    AFH mirror added (see above)

    JOdin3 Web Browser Based and Offline flashing tool
    This is the official support page for JOdin3, a CASUAL-X project. JOdin3 allows you to flash Odin files on Linux, Mac and Windows. It is powered by CASUAL and @Benjamin Dobell 's Heimdall tool. Using the power of CASUALcore, LibPit and Heimdall, it enables flashing of Odin files in the same manner you'd expect from the offical Samsung Odin tool.

    Read more: http://casual-dev.com/2014/01/04/jodin3-web-browser-or-offline-flashing-tool/
    Website: http://Jodin3.casual-dev.com

    Never download from anywhere except the link above. I won't have the CASUAL name tarnished with malware. Also, verify that your download has the proper signatures with the "jar-signer -verify" command.

    Easy flashing
    We expect this to be relatively trouble-free. However, there are some stumbling blocks. First, JOdin3 requires a PIT file, which can be automatically obtained, but it requires a device reboot. Jodin3 will walk you through this process. On windows, drivers should be auto-installed. On Mac, Heimdall will be auto-installed. On debian-based Linux, Heimdall will be automatically installed and you will receive in-app instructions on all platforms.

    With that said, 99.9999% of problems should be solvable with the simple troubleshooting guide below

    Troubleshooting Guide
    Mac: Visit the Heimdall Website and install the packages for your distribution, then reboot: http://glassechidna.com.au/heimdall/
    Linux: Visit the Heimdall Website and install the packages for your distribution: http://glassechidna.com.au/heimdall/
    Windows: Put your device into Download mode, install this driver and reboot. http://android-casual.googlecode.co...ALcore/src/CASUAL/resources/heimdall/CADI.exe




    Special instructions for Mac:

    This is a CASUAL-X project. CASUAL-X projects are based on or around CASUAL but not part of the main stream. This CASUAL-X project will be updated alongside of CASUALcore and will be available as long as our servers can handle the load. You can read more about CASUAL at http://casual-dev.com

    @Benjamin Dobell for creating Heimdall
    @jrloper for streamlining processes and creating drivers
    @Loglud for providing the server space and many helpful utilities which enable this
    @Ralekdev for analyzing PIT files helping me to gain a better understanding of how they function
    Neither download links or web links are working..
    This is well known just read the last few posts...

    if you like you can download the latest version here:


    As long as the developer Adam allows me to do so I will mirror the latest version I have

    first of all HAPPY NEW YEAR TO @AdamOutler

    i wanna ask that what is meant by web based flashing and then i wanna ask that what is the difference between this and simple odin

    Its exactly what it sounds like. You go to a website and flash your phone. If you want, you can download the app and use it like that.

    The difference: This works on Windows, Linux and Mac. This works from a website or a download. This will auto-install drivers on all platforms except Mac ( @Benjamin Dobell needs a Mac Developer ID signer). This is a self-contained single-file executable. This provides better errors and will troubleshoot and fix problems for you. This is a single file rather than multiple ones. This provides way more detailed logs rather than a simple failure like Odin. And its open source.

    Its not all roses though.. This can only flash a single device per-start-button-press and not 8 like Odin. Heimdall also has a problem with extremely large files like Note III system images.
    Unfortunately, Jodin can not be downloaded for a very long time. I'm trying to download jodin3 but the official download link keeps timing out.

    Why is that so? Why does the developer not offer the last version for download? Other developers, for example Chainfire, offer the latest version for download at XDA

    I don't know why Adam is ignoring us but in the meanwhile you could download the latest file here (if you like);