[RELEASE] OpenVPN for Nexus S

Some_Person

Member
Aug 19, 2010
14
6
0
This belongs in Development, but I'm not allowed to post it there because I have fewer than 10 posts.

Anyway, I have compiled together a nice package for putting OpenVPN on the Nexus S. It includes all the files necessary to use OpenVPN, including the tun kernel module, the OpenVPN binary, a dependency of it (liblzo.so), and a nice GUI to configure it. This should work on any rom that uses the stock 2.3.4 kernel.

Instructions:
1. Install the attached package via clockwork recovery.
2. Go to the OpenVPN Settings, and under Advanced Settings, check the box that says "Load tun kernel module".
3. Under "TUN module settings", set it up so that it loads with "insmod", and the path to the tun module is "/system/modules/tun.ko".

That's it! I tried to make this as simple as I could.

Thanks to the following people:
*NielDK for the tun.ko kernel module
*cyanogen for the openvpn binary and liblzo.so file
*Friedrich Schaeuffelhut for the GUI
 

Attachments

ttcrew

Senior Member
May 18, 2011
136
46
0
Denver Area
Hi SomePerson - I just installed your openvpn client and it works great!!

I've been meaning to get my openvpn server up and running and this was just the excuse I needed.

I installed, followed the instructions you posted above and dropped the keys and configuration in the appropriate folder and everything worked - first time CONNECTED.

Any plans to add a widget for the homescreen or "notification power widget" to make it easier to turn on/off?? That is my only critique for the moment - REALLY nice work - and Thanks!!

I'm running a Nexus S (i9020a) on the ZeRoXs Custom ROM (based on 2.3.4) on AT&T and connecting to an openvpn server hosted on a Linksys 610N running DD-WRT.

Oh - also needed is a notification bar icon to show when you are connected...I connected this afternoon and forgot about it all afternoon and wondered why my internet was so confused when I got home and on WiFi (and on my vpn network directly).

Thanks for the great app...works WAY better than the bundled VPN solutions in android...

Sent from my Nexus S using XDA Premium App
 
Last edited:

autoprime

Recognized Developer / Inactive Recognized Contrib
Jun 23, 2010
2,638
11,895
203
i have the nexus s 4g.. on 2.3.5.

is having 2.3.4 and stock kernel a requirement? im running stock 2.3.5 and the matr1x kernel. im a VPN n00b and this looks like just what i needed.. everyone had good results :)
 

sinatosk

Senior Member
Oct 5, 2009
154
3
0
Works for me too but the only problem... this version of the OpenVPN client keeps saying in the notification bar

"Username/Password required for configuration vpnname"

so I can't tell if it's connect or not...

I also noticed this version is 0.4.8test1 where as the one on the market is 0.4.7

did you modify this? because I also looked on the official site and only version I can see there is 0.4.7

thanks
 

bmwbmw1

New member
Nov 4, 2009
2
0
0
Hi! This is my first message, sorry for my English :)

I have got a problem with this file.

I have Nexus S with ClockWork mod by Superatmel and ROM SuperOSR Gingerbread:

Android version is 2.3.5

I have flashed succesfully this OpenVPN .ZIP, the instalation was succesfully, the configuration is correct.

OpenVPN correctly connects to my OpenVPN server but I have not internet, DNS doesn't work.

Anyone have this problem??

THANKS!!

Solution:

Click on client.CONF, PREFERENCES, USE VPN DNS and on DNS Server put: 8.8.8.8 (Google DNS).

Enjoy!!
 
Last edited: