How To Guide Repair ROG Phone 5S through edl firmware, no need to unlock Bootloader to modify COUNTRY CN to WW

Search This thread

treicktk

New member
Jun 25, 2011
2
0
Guys please help me

I need to restore the phone's IMEI because it lost

It is not clear how to do !!!!
""""
Include these 10 files:“persist.img factory.img modemst1 modemst2 asuskey4 fsg fsgCA fsc fsgCA2 fsgCA3”

Normally, you don’t need to restore these files. If your fingerprint or imei is lost and you need to restore these files to your phone,

please flash the ENG firmware, then put these 10 files into the ROG 5S folder, and double-click to open " Restore.bat" can be restored to your phone.""""

Did anyone need to restore the backup? as you did? i really need help
 

treicktk

New member
Jun 25, 2011
2
0
Guys please help me

I need to restore the phone's IMEI because it lost

It is not clear how to do !!!!
""""
Include these 10 files:“persist.img factory.img modemst1 modemst2 asuskey4 fsg fsgCA fsc fsgCA2 fsgCA3”

Normally, you don’t need to restore these files. If your fingerprint or imei is lost and you need to restore these files to your phone,

please flash the ENG firmware, then put these 10 files into the ROG 5S folder, and double-click to open " Restore.bat" can be restored to your phone.""""

Did anyone need to restore the backup? as you did? i really need help
Another thing I noticed is that when the cell phone turns on. I put it in debug.
But restoring backup is not allowed
1647882522890.png
 

RT3K

Member
May 14, 2022
6
1
I have successfully completed the tutorial, but I cannot install the latest firmware from Asus. I have packed the downloaded firmware into the internal memory of the device, but I always get an error message. Everything else works without problems.
 

proven122

Member
Mar 25, 2014
19
0
*problem solve*
another problem is the hardware stub service because my phone are cn > ww .. any idea to bypass or disable the notification?
 

pelmen_naemnik

New member
Mar 26, 2014
1
0
I have completely restored the phone, which was in EDL mode only, but now I see message, "The installed firmware does not match the device origin. lease note that you may not receive any FOTA udate"
What step I missed? How to reair it?
 

Attachments

  • Screenshot_20220529-150847654.jpg
    Screenshot_20220529-150847654.jpg
    179.2 KB · Views: 26
Apr 15, 2022
5
0
When I try to flash the ENG version of the firmware, I get the following error
 

Attachments

  • image_2022-07-24_11-39-21.png
    image_2022-07-24_11-39-21.png
    428.2 KB · Views: 16

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    HI everyone, i have reuploaded the ROG5S edl archive and i have added driver files and CN raw firmware, nothing has been modified, you can reupload if you want, i reuploaded this because it was removed and this is useful for ROG 5s users.

    link:https://drive.google.com/file/d/1U0NEIR6Tc_vLmQUZ2NQde3vOgSX05gVb/view?usp=sharing
  • 3
    Success is disgusted by some people, and will not share any files for free in the future.
    2
    HI everyone, i have reuploaded the ROG5S edl archive and i have added driver files and CN raw firmware, nothing has been modified, you can reupload if you want, i reuploaded this because it was removed and this is useful for ROG 5s users.

    link:https://drive.google.com/file/d/1U0NEIR6Tc_vLmQUZ2NQde3vOgSX05gVb/view?usp=sharing
    1
    Hi,
    I don't reboot to edl
    FAILED (remote: 'Command not supported in default implementation')
    fastboot: error: Command failed

    no root,
    no unlock bl.
    CN rog5s

    Thanks

    Wrong fastboot. Reboot to the bootloader, not fastbootd
    1
    It seems like I am always finding something new, even when I have access to my phone now.

    My storage is only 64 gb out of the 256 gb it normally has. Any idea how to fix this issue?


    Edit, found the fix.

    Step 1. I had to ensure that I made a back up of the 10 files stated in the instructions. This is important as not having these files will probably brick a phone.

    Step 2. I deleted the extra partitions by setting the "erase all before download" and "reset after download" under "configuration" in the qfil app. Then I did the installation process using qfil.

    It did not install correctly, but it was not the point of the process, the point was to delete all hidden partitions.
    This deletes the 10 files from the phone as well (I think) and this is why the 10 files are important.

    Step 3. I put my phone into edl mode via the reboot to edl .bat file you provided.

    Step 4. I used the 0-update_image_edl.bat file to do the first part of the firmware installation process.

    It rebooted and showed the page of the phones information. I thought this meant it kept all it's information, but this is a lie.

    Step 5. At this point I placed all 10 files in the same folder as the restore.bat file

    Step 6. I pressed the restore.bat file and it installed the 10 files.

    Step 7. I then proceeded to do the second part of the installation by pressing the "flash_raw_and_wipe_data" file under "ww"

    This installed the firmware and rebooted my phone. Now I have all my storage back.


    //////////////////////////////
    Note:

    If the process above doesn't work for someone else. The thing that might have fix my phone could have been changing the setting in the "partition setting" under "configuration" in the "qfil app" that actually deleted the other partitions.
    I think I set "customize physical partition" and "active partition number" to 1.

    I did this right after saving my 10 files and before using the qfil app to attempt to install the first part of the firmware installation to my phone. This process would replace step 2. on this post.
    1
    Wrong fastboot. Reboot to the bootloader, not fastbootd
    Thank you very much. I successfully swiped into ww and now I am trying to change COUNTRY. thx :)