• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[Resolved] ADB No Longer Working on Android 4.2.2? - Update your ADB!

Is your ADB working with the stock kernel after the 4.2.2 update?

  • Working fine, no issues

    Votes: 23 20.7%
  • Can no longer use adb

    Votes: 88 79.3%

  • Total voters
    111
  • Poll closed .
Search This thread

xaueious

Senior Member
Dec 17, 2009
981
176
Toronto
4.2.2 now enforces RSA authentication via ADB. This is only supported in later versions of ADB.

On Windows, you can see your local user profile folder's .android folder and see if there's a file called 'adbkey'.

Or use 'adb version' to see if you have the latest version. ADB version 1.0.31 is working.



Google just added this in the ADB protocol last November, so you need the NEWEST ADB:
https://github.com/android/platform_system_core/commit/d5fcafaf41f8ec90986c813f75ec78402096af2d

The keys for your hosts are stored at /data/misc/adb/adb_keys, I believe.


If your ADB works correctly, you will see this when you plug in for the first time. You may still have to reseat your cable.
2fGhRXXl.jpg

(Pic credit to rickbosch)

* * *

This will not affect all of you.

But on the stock Android 4.2.2 kernel from Google, I cannot get adb to work (always shows 'adb offline') on the stock kernel. This is with my laptop (a Lenovo Thinkpad), and I never had issues with this before with the same setup.

My current workaround is to use a custom kernel for 4.2.2 (thanks to renaud for delivering)


A custom Fugumod kernel that works with 4.2.2 and does not have this issue with ADB:
http://forum.xda-developers.com/showpost.php?p=37892325&postcount=2167

Stable builds (future?):
http://fugumod.org/galaxy_nexus/stable-4.2.2/


Please report back with the PC/Mac and possibly the cable you are using, thanks.
 

Attachments

  • android-adb_fastboot-16.01.zip
    539.1 KB · Views: 53,462
Last edited:

rickbosch

Senior Member
Mar 3, 2011
1,210
723
Cape Town
It'll ask you to give ADB permission if you're all set up correctly. Mine did...Seems it's a whitelist system now where you can allow or not allow individual PCs to use ADB on your device.

sa8anema.jpg
 
  • Like
Reactions: kmdangi

xaueious

Senior Member
Dec 17, 2009
981
176
Toronto
In default.prop is new line!

That is ro.adb.secure=1 or something like that, I think this is the issue! changing it to 0 may let you to use ADB!

I gonna test it out in 5 minutes.

That's default.

I resolved my issue swapping my kernel, not the ramdisk (that's where default.prop is in anyway). Hm...

It'll ask you to give ADB permission if you're all set up correctly. Mine did...Seems it's a whitelist system now where you can allow or not allow individual PCs to use ADB on your device.

sa8anema.jpg


This never came up for me o_O. Didn't wipe though.

How do you manage devices?
 
Last edited:
  • Like
Reactions: spiderio

xaueious

Senior Member
Dec 17, 2009
981
176
Toronto
You shouldn't have to make ro.adb.secure=0 default. I think something is definitely wrong with this OTA lol.


Or maybe this is a new feature. Was the screenshot taken with Linux? How the heck do I get a RSA key with ADB on Windows?
 
Last edited:

Carlos_Manuel

Senior Member
Apr 28, 2011
4,092
5,368
24
Kuressaare
You shouldn't have to make ro.adb.secure=0 default. I think something is definitely wrong with this OTA lol.


Or maybe this is a new feature. Was the screenshot taken with Linux? How the heck do I get a RSA key with ADB on Windows?

Why not!
It lets to use ADB then, now I can use ADB without any issues, before editing default.prop I wasn't able to use ADB!
 

xaueious

Senior Member
Dec 17, 2009
981
176
Toronto
Never changed anything on the phone. Fixed the issue though. I was using an older version of ADB: 1.0.31

Older versions don't support key RSA authentication.
 

met67

Senior Member
Apr 16, 2007
209
35
I also had this problem.
Then I deleted some spare copy of adb.exe and its dlls that where installed under \windows\ by some "do-it-all" tool and updated the adb tools with SDK-Manager.
After connecting to the PC, my GNexus asked for confirmation before allowing USB debugging and since then everything is fine :victory:
 
M

m.kochan10

Guest
I updated android sdk tools on my mac today (before that I couldn't launch abd sideload update.zip) and haven't noticed any issues with adb/fastboot commands.
 

HaZTuga

New member
Jul 10, 2010
2
0
It may seem obvious for some, but wasn't for me.
I flashed the upgrade, with the cable always connected then couldn't get adb to work. Just need to re-plug the cable for the prompt to show up
 

Top Liked Posts

  • There are no posts matching your filters.
  • 22
    4.2.2 now enforces RSA authentication via ADB. This is only supported in later versions of ADB.

    On Windows, you can see your local user profile folder's .android folder and see if there's a file called 'adbkey'.

    Or use 'adb version' to see if you have the latest version. ADB version 1.0.31 is working.



    Google just added this in the ADB protocol last November, so you need the NEWEST ADB:
    https://github.com/android/platform_system_core/commit/d5fcafaf41f8ec90986c813f75ec78402096af2d

    The keys for your hosts are stored at /data/misc/adb/adb_keys, I believe.


    If your ADB works correctly, you will see this when you plug in for the first time. You may still have to reseat your cable.
    2fGhRXXl.jpg

    (Pic credit to rickbosch)

    * * *

    This will not affect all of you.

    But on the stock Android 4.2.2 kernel from Google, I cannot get adb to work (always shows 'adb offline') on the stock kernel. This is with my laptop (a Lenovo Thinkpad), and I never had issues with this before with the same setup.

    My current workaround is to use a custom kernel for 4.2.2 (thanks to renaud for delivering)


    A custom Fugumod kernel that works with 4.2.2 and does not have this issue with ADB:
    http://forum.xda-developers.com/showpost.php?p=37892325&postcount=2167

    Stable builds (future?):
    http://fugumod.org/galaxy_nexus/stable-4.2.2/


    Please report back with the PC/Mac and possibly the cable you are using, thanks.
    8
    Can someone put together a nice little package with updated ADB so we don't have to download the entire SDK? :)

    I guess this is the advantage of having fast internetz!

    ADB (and fastboot, might as well but I don't think its updated) from the 64bit windows SDK.
    Just the barebones files for people who hate clutter!
    3
    In default.prop is new line!

    That is ro.adb.secure=1 or something like that, I think this is the issue! changing it to 0 may let you to use ADB!

    I gonna test it out in 5 minutes.
    1
    It'll ask you to give ADB permission if you're all set up correctly. Mine did...Seems it's a whitelist system now where you can allow or not allow individual PCs to use ADB on your device.

    sa8anema.jpg
    1
    I have windows 7 64bit, and stock OTA 4.2.2 and I've tried to root the device as per this tutorial
    Code:
    4) The Galaxy Nexus should be factory unlocked.
    
    5) The battery of the phone should have more than 80 per cent of charge.
    
    6) Make a Nandroid backup of the previous phone set up before proceeding.
    
    Steps to root Galaxy Nexus I9250 on Android 4.2.2 JDQ39 Jelly Bean firmware 
    
    1) Download and install Android SDK from the Android Developers site. Then set it up with downloading platform-tools and USB drivers package in SDK
    
    2) Enable USB Debugging Mode on the Galaxy Nexus
    
    3) Download Fastboot (Link 1/2) and extract it in android-sdk-windowsplatform-tools directory (Create a directory in case it is not there)  
    
    4) Download SuperSU v1.04 (UPDATE-SuperSU-v1.04.zip) for Galaxy Nexus to the computer
    
    5) Connect the Galaxy Nexus to the computer using USB cable and copy the downloaded UPDATE-SuperSU-v1.04.zip file to the SD card of the phone
    
    6) Switch off the phone
    
    7) Download CWM 6.0.2.3 (recovery-clockwork-touch-6.0.2.3-maguro.img) and save to the android-sdk-windowsplatform-tools directory on the computer
    
    8) Enter into Fastboot/Bootloader Mode on the Galaxy Nexus. Press and hold the Volume Down , Volume Up and Power buttons together for a few seconds until some text on the screen appears. This is Bootloader Mode
    
    9) Browse to android-sdk-windowsplatform-tools directory and open command prompt (Shift + Right Click>> Open Command Prompt)
    
    10) Type the below mentioned command and press Enter
    
    fastboot flash recovery recovery-clockwork-touch-6.0.2.3-magu
    
    11) Now choose RECOVERY from the Fastboot menu and enter Recovery Mode
    
    12) In CWM Recovery, scroll down to 'flash zip from SD card' then press the Power button to select it. Again press the Power button to select 'Choose zip from SD card'
    
    13) Use the Volume buttons and navigate to UPDATE-SuperSU-v1.04.zip and select it using the Power button and confirm installation on the next screen. The installation should start now
    
    14) Once the installation is completed, return to the Recovery menu and select 'Reboot System Now' to reboot the phone. The device will take about five minutes to reboot for the first time
    
    The Galaxy Nexus I9250 running on Android 4.2.2 JDQ39 Jelly Bean firmware is now successfully rooted. Check for the SuperSU app in the app list

    The phonw has the USB Debug activated and with adb version 1.031 and "adb devices'' shows me the serial number (and it did ask me at first to confirm the RSA key)
    But when I switch the phone in fastboot mode I can't do nothing ... the "adb devices" doesn't see my phone and the
    command "fastboot flash recovery recovery-clockwork-touch-6.0.2.3-magu"
    is not working it just shows me "Waiting for devices" but nothing happens .

    What am I doing wrong ?