[Resolved] Auto-rotation doesn't work

Search This thread
D

DarkSwanKnight

Guest
I got a Galaxy S3 Mini I8190 running 4.1.1 XXALJL (rooted) and the auto rotation doesn't work. I tried full wipe and calibration but nothing happens. And before you ask, yes, the auto rotation option is obviously enabled.

Any ideas?
 
Last edited:

kicker63

Senior Member
Apr 15, 2012
723
251
Cardiff, South Wales
Re: [Q] Auto-rotation doesn't work

Have you got auto rotate box ticked in the display setting, or pull down bar on top of display and see if screen rotation is green. Or maybe you upgrade your firmware to 4.1.2,or could be some App turning it off.

Sent from my GT-I8190 using xda premium
 
Last edited:

aspot72

Senior Member
I'm gonna try to upgrade to 4.1.2 using I8190XXAMA1_I8190OXAAMA1_4.1.2 V3 by infected_ and see how it goes.

Be carefull what are you flashing. If your Mini is 8190N (means NFC enabled), you'll need NFC ROM. I just flashed 4.1.2. and all works fine. However, the phone keep most of the time on G/E instead of 3G/H...

---------- Post added at 02:29 PM ---------- Previous post was at 02:28 PM ----------

When u upgrade to 4.1.2 u should have screen rotation.Mine works fine


Sent from my GT-I8190 using xda premium

Mine as well. So far so good.
 
D

DarkSwanKnight

Guest
Be carefull what are you flashing. If your Mini is 8190N (means NFC enabled), you'll need NFC ROM. I just flashed 4.1.2. and all works fine. However, the phone keep most of the time on G/E instead of 3G/H...


AFAIK my device is I8190. I flashed the rom I mentioned earlier and it didn't work out as planned. It stopped after flashing at CWM asking if I wanted to flash and untrusted image which didn't work anyways. After continuing the device boots normally but the problem is the same (rotation doesn't work) and worse is the capacitive buttons didn't work at all.

I downloaded my stock rom and gonna flash it now but I will lose the root though.

Edit: just finished flasing the stock rom I8190XXALJL_I8190OJVALJ9 and the rotation problem is still there. Also I noticed the auto brightness doesn't work as well. I'm wondering if it's a defect or just a bug in 4.1.1.
 
Last edited:

ppero196

Senior Member
Apr 14, 2012
3,187
1,213
Up north!
Re: [Q] Auto-rotation doesn't work

AFAIK my device is I8190. I flashed the rom I mentioned earlier and it didn't work out as planned. It stopped after flashing at CWM asking if I wanted to flash and untrusted image which didn't work anyways. After continuing the device boots normally but the problem is the same (rotation doesn't work) and worse is the capacitive buttons didn't work at all.

I downloaded my stock rom and gonna flash it now but I will lose the root though.

Edit: just finished flasing the stock rom I8190XXALJL_I8190OJVALJ9 and the rotation problem is still there. Also I noticed the auto brightness doesn't work as well. I'm wondering if it's a defect or just a bug in 4.1.1.

?
We don't have auto brightness sensor.
Dfaq did you flash?
Possible faulty accelerometer?

Sent from my GT-I8190 using xda app-developers app
 
D

DarkSwanKnight

Guest
?
We don't have auto brightness sensor.
Dfaq did you flash?
Possible faulty accelerometer?

Sent from my GT-I8190 using xda app-developers app

Yeah, I found out about the whole light sensor thing later, kinda pisses me off though.
I too have a feeling it's a problem with accelerometer. Especially since upgrading to 4.1.2 didn't help.
Anyways, I took it today to the service center and I'm waiting for them to call me and tell me what they'll do. I just hope it doesn't take long, it's frustrating as it is.

Edit: I got it back from the service shop, they said it was a hardware issue, but it's fixed now and working fine.
 
Last edited: