• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[RESOLVED] Nabi SE bricked, need help

Search This thread

blakegriplingph

Senior Member
May 13, 2011
977
146
Amazon Fire
Realme C3
Anyone have any idea on how to at least somewhat revive this thing? Tried flashing a retail ROM to this but it went a bit sour so I attempted to bring it back to stock by flashing back the stock demo ROM dump I made prior using SP Flash Tool's Write Memory feature. And it now refuses to budge at all (i.e. no screen activity, apart from the red battery indicator) as I couldn't get it to cooperate with SPFT - tried pressing volume up or down to force USB serial mode, but that didn't work either; it's just stuck at Preloader mode. I previously bricked a LeapFrog Epic before (which used the same MT8127 chip as this device), and reviving it fell through no thanks to the fact that I didn't have a backup of its security keys, but for the SE I was able to do the necessary precautions prior to flashing, it's that Write Memory killed it somehow, and I am at a loss as to how to bring this back to life. Am I SOL or is this still recoverable?

EDIT: NVM, turns out that converting ROM_0 into a scattered format and editing the scatter file for SPFT to load all images, and flashing it using SPFT v5.1532 did the trick for me. Glad I was able to make a backup this time around unlike what happened with the LeapFrog. :D
 
Last edited:

zaysxtun

Member
Jul 20, 2021
5
0
Moto G7 Play
Anyone have any idea on how to at least somewhat revive this thing? Tried flashing a retail ROM to this but it went a bit sour so I attempted to bring it back to stock by flashing back the stock demo ROM dump I made prior using SP Flash Tool's Write Memory feature. And it now refuses to budge at all (i.e. no screen activity, apart from the red battery indicator) as I couldn't get it to cooperate with SPFT - tried pressing volume up or down to force USB serial mode, but that didn't work either; it's just stuck at Preloader mode. I previously bricked a LeapFrog Epic before (which used the same MT8127 chip as this device), and reviving it fell through no thanks to the fact that I didn't have a backup of its security keys, but for the SE I was able to do the necessary precautions prior to flashing, it's that Write Memory killed it somehow, and I am at a loss as to how to bring this back to life. Am I SOL or is this still recoverable?

EDIT: NVM, turns out that converting ROM_0 into a scattered format and editing the scatter file for SPFT to load all images, and flashing it using SPFT v5.1532 did the trick for me. Glad I was able to make a backup this time around unlike what happened with the LeapFrog. :D
hi ! i have the same problem as you and i was wondering if i could fix stuff on my end ?
thank you in advance !

[I flashed the Nabi SE stock ROM and ended up with a black screen, unresponsive but was able to go into download mode with battery indicator.
The stock ROM flash was successful, but still didn’t turn on.]
 
Last edited:

blakegriplingph

Senior Member
May 13, 2011
977
146
Amazon Fire
Realme C3
hi ! i have the same problem as you and i was wondering if i could fix stuff on my end ?
thank you in advance !

[I flashed the Nabi SE stock ROM and ended up with a black screen, unresponsive but was able to go into download mode with battery indicator.
The stock ROM flash was successful, but still didn’t turn on.]
By battery indicator you mean the red LED light?

And did you perform a full ROM_0 backup first?
 

zaysxtun

Member
Jul 20, 2021
5
0
Moto G7 Play

zaysxtun

Member
Jul 20, 2021
5
0
Moto G7 Play
(bump) so my Nabi SE can enter download mode. but SP Flash Tool refuses to flash with the error code : 2004 DA_DOWNLOAD_FAIL.
on other days, it would actually flash on download mode. result = black screen on Nabi SE with RED battery indicator.
Is there a way I can fix the 2004 error?
(SP Flash Tool v5.1532)
 

zaysxtun

Member
Jul 20, 2021
5
0
Moto G7 Play
(bump, sorry for spam)
so i have finally managed to flash everything back :’) only thing is that… the Nabi is still unresponsive (red battery indicator only red, black screen)
i heard its “stuck in download mode”.
is there a fix ?