Riru core is not installed

Search This thread

stormy1777

Senior Member
Feb 12, 2016
159
44
Friends, need your help/ideas....

Redmi 7A, have Magisk 23 + EdXposed 5.2.2 4683 for long time, until updated riru to v26.1.0.r497 few days ago, since then, cannot get EdXposed Framework to be activated. Keep getting an error when trying to install "Riru - EdXposed" from Magisk (manager) or from Recovery, it claims that "riru is not installed".


Code:
! Is not installed
! Please install Riru from Magisk Manager

Riru v26.1.0.r497 IS installed , tried re-installing, and same error when trying to install Riru-EdXposed from Magisk or from recovery..

Any ideas? tips, most welcomed.
Thanks.
 

Attachments

  • Screenshot_2021-08-16-21-16-29.jpg
    Screenshot_2021-08-16-21-16-29.jpg
    99.9 KB · Views: 205
Last edited:

spawnlives

Senior Member
Jan 27, 2018
1,121
422
Samsung Galaxy S8
Samsung Galaxy S9
Friends, need your help/ideas....

Redmi 7A, have Magisk 23 + EdXposed 5.2.2 4683 for long time, until updated riru to v26.1.0.r497 few days ago, since then, cannot get EdXposed Framework to be activated. Keep getting an error when trying to install "Riru - EdXposed" from Magisk (manager) or from Recovery, it claims that "riru is not installed".


Code:
! Is not installed
! Please install Riru from Magisk Manager

Riru v26.1.0.r497 IS installed , tried re-installing, and same error when trying to install Riru-EdXposed from Magisk or from recovery..

Any ideas? tips, most welcomed.
Thanks.
Downgrade riru core or use lsposed
 
  • Like
Reactions: itllsendamsg

stormy1777

Senior Member
Feb 12, 2016
159
44
Downgrade riru core or use lsposed

Thanks will try soon, does that mean lsposed is "replacement" and EdXposed will not support newer riru?

also, Learned from:


RIRU_PATH="/data/misc/riru"

on my phone, at that location, is a file:

modules/a9f2/module.prop


id=riru_edxposed
name=Riru - EdXposed
version=v0.4.6.4 (4563) (YAHFA)
versionCode=4563
author=solohsu, MlgmXyysd, rk700
api=4

maybe that's the reason? this is the PRIOR version installed on this phone.. maybe somehow edit? or remove riru? or this directory?
 

spawnlives

Senior Member
Jan 27, 2018
1,121
422
Samsung Galaxy S8
Samsung Galaxy S9
Thanks will try soon, does that mean lsposed is "replacement" and EdXposed will not support newer riru?

also, Learned from:


RIRU_PATH="/data/misc/riru"

on my phone, at that location, is a file:

modules/a9f2/module.prop


id=riru_edxposed
name=Riru - EdXposed
version=v0.4.6.4 (4563) (YAHFA)
versionCode=4563
author=solohsu, MlgmXyysd, rk700
api=4

maybe that's the reason? this is the PRIOR version installed on this phone.. maybe somehow edit? or remove riru? or this directory?
If you want to use edxposed you have to downgrade the riru core module in magisk. Delete cuurent version reboot install lower version. Use riru core 25.4.4 or older. It won't work on 26+.
Isposed is an alterative to edxposed and works on latest riru core releases.
If you are going to use lsposed than delete edxposed from magisk than install lsposed.
 
  • Like
Reactions: stormy1777

gallegonovato

Senior Member
Feb 25, 2021
96
19
Good afternoon:

At the end if it influences Riru to update or install Riru Exposed.

What I did was to remove Riru and Riru Exposed from Magisk. I also uninstalled Exposed and XprivacyLua.

Then I rebooted the phone. Once booted, I ran lte cleanner from fdroid and sd maid. And clear all caches.

Abtes I had seen a video, of a Mr., I think he is Indian. That is
where you can see that the solution is to disable Riru. But it did not work at all. Xposed and XprivacyLua not hiban.

Then I checked that magisk and magisk manager were in their latest version. They were.

Then I went to https://github.com/RikkaApps/Riru/releases . And I looked for version 25.4.4 release (https://github.com/RikkaApps/Riru/releases/tag/v25.4.4)

Then from Riru Exposed I installed the one that comes up in the magisk module finder. Here I did tell it to reboot.

Then I downloaded the latest version of exposed https://github.com/ElderDrivers/EdXposedManager/releases

In exposed, it started fine, I checked the afwall+ module in my case. At the top of exposed you look for reboot, system. You are prompted by magisk to give you superuser permission. You accept it. Let it reboot.

Then install XprivacyLua. (In my case). Activate the module in Xposed.

And everything working.

A hug
 
  • Like
Reactions: sidneypolak

sidneypolak

Member
Jul 19, 2016
8
0
Good afternoon:

At the end if it influences Riru to update or install Riru Exposed.

What I did was to remove Riru and Riru Exposed from Magisk. I also uninstalled Exposed and XprivacyLua.

Then I rebooted the phone. Once booted, I ran lte cleanner from fdroid and sd maid. And clear all caches.

Abtes I had seen a video, of a Mr., I think he is Indian. That is
where you can see that the solution is to disable Riru. But it did not work at all. Xposed and XprivacyLua not hiban.

Then I checked that magisk and magisk manager were in their latest version. They were.

Then I went to https://github.com/RikkaApps/Riru/releases . And I looked for version 25.4.4 release (https://github.com/RikkaApps/Riru/releases/tag/v25.4.4)

Then from Riru Exposed I installed the one that comes up in the magisk module finder. Here I did tell it to reboot.

Then I downloaded the latest version of exposed https://github.com/ElderDrivers/EdXposedManager/releases

In exposed, it started fine, I checked the afwall+ module in my case. At the top of exposed you look for reboot, system. You are prompted by magisk to give you superuser permission. You accept it. Let it reboot.

Then install XprivacyLua. (In my case). Activate the module in Xposed.

And everything working.

A hug
Thanks man. That worked!
 

lubo777

Senior Member
The problem "Riru not found but it's installed" is easy to solve!
The problem is because the newer version of Riru have changed the way it is discovered from other Riru depended modules as the EdXposed Magisk module which exits with error that Riru is NOT installed.
To solve the problem you just have to install older version of Riru 23.9 and all problems with the EdXposed Magisk module ARE SOLVED!
 
Sep 10, 2014
5
0
38
Rybnik
Przyjaciele, potrzebujcie waszej pomocy/pomysłów....

Redmi 7A, ma Magisk 23 + EdXposed 5.2.2 4683 przez długi czas, dopóki nie zaktualizowano riru do v26.1.0.r497 kilka dni temu, od tego czasu nie można aktywować EdXposed Framework. Ciągle pojawia się błąd podczas próby instalacji „Riru - EdXposed” z Magisk (menedżer) lub z Recovery, twierdzi, że „riru nie jest zainstalowany”.


[kod]! Nie jest zainstalowany
! Proszę zainstalować Riru z Magisk Managera[/code]

Riru v26.1.0.r497 JEST zainstalowany, próbował ponownie zainstalować i ten sam błąd podczas próby zainstalowania Riru-EdXposed z Magisk lub z odzyskiwania ..

Jakieś pomysły? wskazówki, jak najbardziej mile widziane.
Dziękuję.
Screenshot_20210919-021245.png
 
Mar 25, 2020
34
9
nairobi
Like @spawnlives and @xk3v1lx say, install Riru Core 25.4.4, which is the last known compatible version that works with EdXposed.

Frankly, if I were you, I wouldn't consider doing any hacks just to use the latest version of Riru Core. These are apps that do things at a low level with full super user privileges. It's so easy to break something or unintentionally provide access to your phone's core functionality to some(one)thing. So, if you love your phone as much as I do mine, stay away from these types of hacks. The other alternative is to reach out to the developers of said apps and ask them to consider upgrading their apps, in a very very nice way.
 

Top Liked Posts