Rockchip PX6 with MCU STM32

Search This thread

turidachian

New member
Feb 17, 2021
3
0
11
Hello everybody, I have a radio with RK3399 STM32, I installed the lite version because I was hoping to be able to use the Google assistant to make a call but it still doesn't work. Does anyone know how to fix it, is there an apk to make voice calls?
 

silomgs

Member
Apr 3, 2014
18
6
23
Threecar sent me a new MCU for px6 stm32 with DSP

mcu-202102261001BD6-1423

Could this work on a eunavi with dsp?
CURRENT MCU
STM32-20200721-11-KC6-40
I have a problem that when answering a call from the HU i have to wait 3-4 seconds before i can hear the caller from the HU (bt phone application slow to open?)
Sometimes answering a call from the connected phone, phone application in HU is not waking up so call is answered but no sound from HU. have to manually change sound from phone to phone or speaker and then back to HU and then the sound works.
Tried different phones but same result.
asked eunavi for an update and they told me to wait.
 

Attachments

  • DSC_1513.JPG
    DSC_1513.JPG
    835.9 KB · Views: 53

Az Biker

Senior Moderator / RC- RT Committee / Semper Salty
Staff member
[QUOTE = "megatm, post: 84597685, membro: 2130271"]
Threecar mi ha inviato un nuovo MCU per px6 stm32 con DSP

mcu-202102261001BD6-1423

[URL unfurl = "true"] https://www114.zippyshare.com/v/N5rpJtCL/file.html [/ URL]
[/CITAZIONE]


Ciao. Non funziona il link, mi manderesti l'mcu? Grazie

Please comment in English. If a second language is required, post it below the English version as I have here. Thank you.

Si prega di commentare in inglese. Se è richiesta una seconda lingua, pubblicala sotto la versione inglese come ho qui. Grazie.
 

silomgs

Member
Apr 3, 2014
18
6
23
[QUOTE = "megatm, post: 84597685, membro: 2130271"]
Threecar mi ha inviato un nuovo MCU per px6 stm32 con DSP

mcu-202102261001BD6-1423

[URL unfurl = "true"] https://www114.zippyshare.com/v/N5rpJtCL/file.html [/ URL]
[/CITAZIONE]

Ciao. Il collegamento non funziona, mi mandi l'mcu? Grazie
The link works. U get a zip file with an update file and instructions. The update is performed OTA and not included in the file
 

sippy1912

Member
Jan 29, 2021
13
1
13
@silomgs
I tried again but the connection doesn't work. He tells me that 403 is prohibited




Ho provato di nuovo ma il collegamento non funziona. Mi dice che 403 è proibito
 
Last edited by a moderator:

silomgs

Member
Apr 3, 2014
18
6
23
I just get a lot of advertising pages, with all kind of ****.
But the download doesn't start

I got all these advertisements as well and closed the ones on the right corner first as they are over the one in the middle and the download started

[QUOTE = "silomgs, post: 84608415, membro: 5803393"]
Il collegamento funziona. Ottieni un file zip con un file di aggiornamento e le istruzioni. L'aggiornamento viene eseguito OTA e non è incluso nel file
[/CITAZIONE]

Ho provato di nuovo ma il collegamento non funziona. Mi dice che 403 è proibito
Please post in English... I don't understand Italian. I used Google translate to help you.
I don't know where you are getting the 403 error. I'm guessing If you are getting it while using the update maybe there is a serial check on the server to see if the unit can download the update.
 

unimatrix099

Member
Sep 30, 2020
6
0
1
Hi, I've updated my Bosion RK3399 STM32 unit with the Malaysk Lite DSP version, but after it restarted the screen was only black, no logo, nothing.
- had a dump of the flash and written it back, but nothing changed (I know weird...), black screen, no boot
- tried the SD boot method with the recovery image added in the Malaysk thread, the screen only flickers, no boot
- tried to upgrade by SD, now the unit when starts the screen only flickers, no boot and not even getting in loader mode (connecting the 2 circles near the USB 4pin 1mm SH connector)
- removed the RK3399 shield to connect EMMC TP to GND so to force it to maskrom mode, but it's not entering maskrom mode, no connection on the OTG USB (before it worked, I entered in loader mode and also maskrom mode, loaded RK3399MiniLoaderAll_V1.09.bin and dumped the flash to the hdd)
- also tried EMMC CLK to GND, no maskrom mode
- USB 5v pin is not powered, 0v on it
- STM32 MCU is powered, 3.3V
- the USB OTG cable I'm using has only GND, D+, D- connected to the PC (+5V is not connected), the unit is powered by 12V as normal, before the update the cable/connection worked

Any help in getting into maskrom mode will be greatly appreciated, I'm out of ideas... :(

What is the role of the MCU? Should I get a ST programmer and flash it? (I haven't flashed it, but can it interfere in getting into maskrom mode?)

I've attached pictures with the unit when it worked and with the lite version used for update, also the points where are the EMMC TP/CLK and for getting in loader mode, the circles near the white USB connector
9a201a03-becb-487d-b3e1-aa1ed7db8f6f.jpeg
IMG_20210110_194921 (1).jpg
IMG_20210306_132415 (1).jpg
IMG_20210306_121153 (1).jpg
IMG_20210306_121246.jpg
Ïîðò+USB+3+OTG.jpg
(the pictures are from the forums, but are exactly like my unit, including the D+/D- in the 6 pin connector that in the manual are "not connected")
 

Dragon49

New member
Mar 12, 2021
4
1
3
Hi, I've updated my Bosion RK3399 STM32 unit with the Malaysk Lite DSP version, but after it restarted the screen was only black, no logo, nothing.
- had a dump of the flash and written it back, but nothing changed (I know weird...), black screen, no boot
- tried the SD boot method with the recovery image added in the Malaysk thread, the screen only flickers, no boot
- tried to upgrade by SD, now the unit when starts the screen only flickers, no boot and not even getting in loader mode (connecting the 2 circles near the USB 4pin 1mm SH connector)
- removed the RK3399 shield to connect EMMC TP to GND so to force it to maskrom mode, but it's not entering maskrom mode, no connection on the OTG USB (before it worked, I entered in loader mode and also maskrom mode, loaded RK3399MiniLoaderAll_V1.09.bin and dumped the flash to the hdd)
- also tried EMMC CLK to GND, no maskrom mode
- USB 5v pin is not powered, 0v on it
- STM32 MCU is powered, 3.3V
- the USB OTG cable I'm using has only GND, D+, D- connected to the PC (+5V is not connected), the unit is powered by 12V as normal, before the update the cable/connection worked

Any help in getting into maskrom mode will be greatly appreciated, I'm out of ideas... :(

What is the role of the MCU? Should I get a ST programmer and flash it? (I haven't flashed it, but can it interfere in getting into maskrom mode?)

I've attached pictures with the unit when it worked and with the lite version used for update, also the points where are the EMMC TP/CLK and for getting in loader mode, the circles near the white USB connectorView attachment 5244207View attachment 5244209View attachment 5244211View attachment 5244213View attachment 5244215View attachment 5244217 (the pictures are from the forums, but are exactly like my unit, including the D+/D- in the 6 pin connector that in the manual are "not connected")
Post the real photo(side without component's) from your HU.
I can tell you which pin i grounded.
 

Dragon49

New member
Mar 12, 2021
4
1
3
Hi, I've updated my Bosion RK3399 STM32 unit with the Malaysk Lite DSP version, but after it restarted the screen was only black, no logo, nothing.
- had a dump of the flash and written it back, but nothing changed (I know weird...), black screen, no boot
- tried the SD boot method with the recovery image added in the Malaysk thread, the screen only flickers, no boot
- tried to upgrade by SD, now the unit when starts the screen only flickers, no boot and not even getting in loader mode (connecting the 2 circles near the USB 4pin 1mm SH connector)
- removed the RK3399 shield to connect EMMC TP to GND so to force it to maskrom mode, but it's not entering maskrom mode, no connection on the OTG USB (before it worked, I entered in loader mode and also maskrom mode, loaded RK3399MiniLoaderAll_V1.09.bin and dumped the flash to the hdd)
- also tried EMMC CLK to GND, no maskrom mode
- USB 5v pin is not powered, 0v on it
- STM32 MCU is powered, 3.3V
- the USB OTG cable I'm using has only GND, D+, D- connected to the PC (+5V is not connected), the unit is powered by 12V as normal, before the update the cable/connection worked

Any help in getting into maskrom mode will be greatly appreciated, I'm out of ideas... :(

What is the role of the MCU? Should I get a ST programmer and flash it? (I haven't flashed it, but can it interfere in getting into maskrom mode?)

I've attached pictures with the unit when it worked and with the lite version used for update, also the points where are the EMMC TP/CLK and for getting in loader mode, the circles near the white USB connectorView attachment 5244207View attachment 5244209View attachment 5244211View attachment 5244213View attachment 5244215View attachment 5244217 (the pictures are from the forums, but are exactly like my unit, including the D+/D- in the 6 pin connector that in the manual are "not connected")
Post the real photo from the downside of your HU.In some hardware of the reseller Eunavi the two pin near the inside usb connector doesn't have any function(at least for me)
 

unimatrix099

Member
Sep 30, 2020
6
0
1
Post the real photo from the downside of your HU.In some hardware of the reseller Eunavi the two pin near the inside usb connector doesn't have any function(at least for me)
Hi, I've added the photos, actually it should not work with EMMC TP to GND, for me it's not working and the other CLK pin is not actually for EMMC, it's for SPI, I will try to put both images with transparency, like in this blog post:
https://lurchi.wordpress.com/tag/rockchip/ (here with the design from this blog the EMMC CLK is on the back...)

Btw the 2 pin near the USB worked for me before I've had the issues with the update/flashing of EMMC.

Thanks.
 

Attachments

  • IMG_20210312_131522.jpg
    28 MB · Views: 32
  • IMG_20210312_131403.jpg
    28.2 MB · Views: 26

khldacosta

Member
Nov 3, 2020
9
1
3
Yep same, I get error 403 for the MCU update. Interested in what has changed in this new update. Anyone who already has file can share through other sites?
 

khldacosta

Member
Nov 3, 2020
9
1
3
Yep same, I get error 403 for the MCU update. Interested in what has changed in this new update. Anyone who already has file can share through other sites?
 

Dragon49

New member
Mar 12, 2021
4
1
3
Hi, I've added the photos, actually it should not work with EMMC TP to GND, for me it's not working and the other CLK pin is not actually for EMMC, it's for SPI, I will try to put both images with transparency, like in this blog post:
https://lurchi.wordpress.com/tag/rockchip/ (here with the design from this blog the EMMC CLK is on the back...)

Btw the 2 pin near the USB worked for me before I've had the issues with the update/flashing of EMMC.

Thanks.
The usb cable must connected to Pc.
Short the pin to ground.See my attached photo. Power on the HU. Wait the PC to recognize the rockchip in maskrom mode.
 

Attachments

  • Maskrom pin.png
    80.5 MB · Views: 65
  • Like
Reactions: unimatrix099

Top Liked Posts

  • There are no posts matching your filters.
  • 7
    we need custom firmware for models with and without dsp sound
    We are working on it ;)
    https://www.youtube.com/watch?v=IxIRMfDL5VM
    6
    All firmwares until now

    New Google Drive link
    Capture2.PNG
    Capture.PNG

    What is the content?

    Organized list of latest PX6 STM32 firmware:

    1. 19/08/2019 os_update_KC1E0101-P01-1.1.4.3.1_20190819_182727 - mcrw27 user
    2. 27/09/2019 os_update_KC1E0101-PA1-1.1.4.3.1_20190927_093454 - Bosion - NO DSP
      18/09/2019 mcu-201909181001KC6-1809.upd
    3. 29/11/2019 os_update_KC1E0112-PA1-1.1.4.3.1_20191129_103212 - Bosion - NO DSP
    4. 30/11/2019 os_update_HC1E0202-P0N-1.1.4.3.1_20191130_122815 - Erisin
    5. 12/12/2019 os_update_KC1E0113-PA1-1.1.4.3.1_20191212_104141.zip
      29/09/2019 KC1E0104-PA1-1.1.4.3.1_20190929_181347.img
      28/10/2019 mcu-201910281001KC6-1453.upd
    6. 21/12/2019 os_update_KC1E0112-P01-1.1.4.3.1_20191221_131058 - NO DSP
      28/10/2019 mcu-201910281001KC6-1453.upd
    7. 04/01/2020 os_update_KC1E0105-P0G-1.1.4.3.1_20200104_100113 - Treecar - NO DSP
    8. 23/03/2020 os_update_KC1E0110-P01-1.1.4.3.1_20200323_160300 - Bosion - EUNAVI - with DSP
      11/04/2020 os_update_KC1E0110-P01-1.1.4.3.1_20200411_110825.zip equalizer empty no flat rock etc
      03/01/2020 mcu-202001031001KC6-1027.upd
    • Factories APKS
    • Several Improvements
    • Manual
    • Photos
    • etc
    5
    While I uploaded the video, there are links to downloading firmware in the description of the video. Do not mistake! There are 2 types of firmware - with a DSP sound processor and WITHOUT DSP! In the archive along with firmware there is an instruction!
    Later I will make a finishing theme on the XDA!

    https://www.youtube.com/watch?v=8SbWdzGi9Wk
    4
    Project LAZARUS for a totally bricked STM32 MCU unit

    It has been a long adventure but I will sum it up in a few bullets:

    Disclaimer! I am in no case responsible for any damage that may be caused by the following method. Try at your own risk!

    1. Crime no 1: Flashed an Hal9k custom firmware on my unit straight out of the box. Though my unit was MTCx. It was an STM32
    2. Crime no 2: As if this was not enough, someone in the workshop cut power during first boot.
    3. Ended up with a totally bricked unit. Only black screen
    4. Contacted Erisin and they sent me stock firmware and instructions how to enter recovery and flash from there
    5. Could not enter recovery whatever I tried so I could not flash firmware
    6. Did research on Internet
    7. Learned that for totally bricked Rockchip devices, there is a chance to flash firmware in Maskrom mode using male to male USB cable. Some of them have 2 pins you need to bridge at power on to force Maskrom mode
    8. Downloaded DriverAssitant_v4.6.zip and installed driver
    9. Downloaded AndroidTool_Release_v2.52.zip and run software.
    10. I couldn't get direct access to the chipset in my unit since it had a very strongly attached shielding that I couldn't remove. I even tried with a dremel but I was afraid not to damage the board and stopped.
    11. Without direct access to the chipset, no documentation at hand and being totally desperate, I got kind of bold. I noticed two pinholes next to the usb connector that I bridged on power on and VOILA: the "found new hardware" chime sounded like music in my ears!!! I guess I was lucky!
    12. Unit was recognized in Loader mode
    13. Went to the advanced tab and selected go Maskrom. Unit got recognized in Maskrom mode
    14. Found this link to a Russian forum with STM32 firmware in .img format and downloaded
    15. Loaded .img firmware on AndroidTool second tab and flashed
    16. Unit came back to life but with a 800X480 desktop on my 1024X600 display. As per instructions in Russian forum, I had to apply the 2nd firmware (.zip format)
    17. Trying to apply 2nd firmware from within Android resulted in bricking the unit again. Had to start over (step 15)
    18. Trying to apply Erisin stock firmware (.zip format) from within Android resulted in bricking the unit again. Had to start over (step 15)
    19. Erisin method to enter recovery did not work. I used terminal command "reboot recovery" and entered recovery
    20. Flashing from USB was not a n option in recovery. Only SD and ADB
    21. Flashing from SD resulted in the following message:
      -- Install /mnt/extrernal_sd/os_update_KC1E0113-PA1-1.1.4.3.1_20191212_104141.zip
      E:Failed to unmount /mnt/extrernal_sd
      E:failed to set up expected mounts for install; aborting
      Installation aborted
    22. I was instructed to format an SD Card in FAT32 copy the firmware there, insert into unit and restart. In my unit that didn't work but another might work. With 2 new (fast) 8Gig and 16Gig cards the unit would normally boot to Android, where with an old (slow) 1Gig reboot resulted in black screen. In any case card was not big enough to fit the firmware.
    23. As a last resort, there was only one method left to try: apply update from ADB! Went to recovery, followed instructions to sideload the firmware and after a while there it was: LAZARUS WAS ALIVE!!! Fresh and fully functional! I even saw Android 10 in about page but I think this is falsely stated by some Chinese developer.
    4
    root

    root is very easy. Here is the instruction and the necessary files:
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone