Rockchip PX6 with MCU STM32

Search This thread

berrie60

Member
May 10, 2021
5
0
whenever I start the car, the EQ will be back to default.
I need to press the EQ button/app and then i custom EQ will be back.

I think likely is some setting i miss.??
 

r473r

Member
Aug 6, 2012
5
0
Hello guys, can anyone with a working back camera post the exported config file so i can patch mine ? Everything works except reverse camera since i've done a factory reset/flashed another software. I have no options for back camera except "camera: normal/mirrored" in factory settings. I've opened my own config file and i think this is the option i have to modify, but i don't know what to modify here.
Thanks
 

Attachments

  • config.jpg
    config.jpg
    265 KB · Views: 80

Lolo13010

Member
Apr 3, 2020
8
0
Narbonne
Hello guys, can anyone with a working back camera post the exported config file so i can patch mine ? Everything works except reverse camera since i've done a factory reset/flashed another software. I have no options for back camera except "camera: normal/mirrored" in factory settings. I've opened my own config file and i think this is the option i have to modify, but i don't know what to modify here.
Thanks
Hi.look this. Maybe reinstall Factory apk ?
 

Attachments

  • 20220918_103818.jpg
    20220918_103818.jpg
    4.5 MB · Views: 56
  • 20220918_103830.jpg
    20220918_103830.jpg
    4.5 MB · Views: 56

r473r

Member
Aug 6, 2012
5
0
can you share this file here ? anyway i see that in your config that the value is "0" for the camera thing, while mine has value "3"
 

geter712

New member
Jun 4, 2012
3
0
Hello! I've just got this unit from Eunavi for my BMW E39. My data is following:

Android Version: 10
Hardware Information: RK3399 - ROM 64GB - LPDDR4 4GB - 1024X600
CPU: 8 Core (Quad Cortex - [email protected] Quad Cortex - [email protected])
Kernel Version: Linux 4.4.167+ - Thu Aug 6 16:04:11 CST 2020
OS Version: KC1E0130-P01-11.1.4.8.1 - BLINK161 - 20200806 - N3
MCU: STM32 - 20200721 - 11 - KC6 - 40

The device works pretty good, except the following issues... There is almost no bass on whichever type of music it plays. Bluetooth, radio, youtube... Everything is flat at sounds terrible. DSP settings (EQ) helps a bit, but still very poor flat sound, much worse then my old android non-dsp unit... Then I discovered the settings screen for DELAY and I tried setting rear speaker values to more then 200 and BAM... Great and very clear bass is there... But whenever device resets, it loses the settings :( Actually it visually shows as its still set to previously selected value, but the effect of the value is not applies, up until I try to re-set the value again (playing around with the value restores the bass immediately)... Any ideas on how could I solve this, to avoid having to play around with the settings each time I start the car :( ?????????

1664414769235.png
 

MrSchlumpf

Member
Mar 29, 2022
42
6
Sony Xperia XZ1 Compact
My phone is always searching for it. But it doesn't work over WLAN or Bluetooth. But that's ok, because android auto can only use your phones GPS and that sucks in my case. I use Google maps on the headunit with a WiFi connection to the phone. Navigation works like a charm. What I miss is the hands free speech assistant.
You can use Android auto with the built in app "easy connect " or maybe it works by usb?
 

berrie60

Member
May 10, 2021
5
0
Thanx. I have to look at easy connect.
I dont know how to connect my phone wifi ti the head unit.
I google for it.
 

tvladan

Senior Member
Oct 23, 2012
307
110
Timisoara
Anyone has a solution for a whitelist app or mod? I'm in stock with root and need YouTube to resume playing after sleep. That option was available on my old mtcd with hal9k mod. This unit kills all proceses, even waze/maps... That is a real bugger.
 

tvladan

Senior Member
Oct 23, 2012
307
110
Timisoara
So... This thread seems kinda dead... Probably because this stm32 units are kinda crap. Still... Does anyone have a .img rom file with the latest updates? Preferably starting with os_update_KC1E0129-P01-1.1.4.9.1_20210812 or later?
I messed with mine and lost sound (again) and none of the img's I could find online solve my sound problem...
Maybe someone can make a rkdump file form an existing running board with dsp. I would really appreciate it.
Thanks.
 

tvladan

Senior Member
Oct 23, 2012
307
110
Timisoara
Thanks for the answer. In tried both 9 and 10 in that drive link a couple of days ago. No luck. Both boot up just fine but with no sound. I have an unbranded with DSP china 9 inch device. It came with fake 10 from the seller. (can't get a reply from the seller... So that's a dead end)

I backed up my partitions (via adb pull) but i missed the bhd one.

Flashing either img from that folder results in working system with no sound, than if i flash my backed up partitions one by one(rkdevtool via maskrom) the situation either remains the same or i get stuck at android logo.

Also those images seem to be from a boison device. I had the stock launcher with big tiles and a slightly newer model. (2021 build).
 

Aplaceinthesky

New member
Dec 28, 2017
3
0
hello this is my headunit I put the picture with the info in the attachment. Is there any firmware avialable to flash on this one? Since I had some really big trouble with the wifi and my mobile hotspot, I would like to know if there is any upgrade or better firmware. Also the radio is really slow as it open google maps it takes forever to load. Does anyone have a step by step guide to do flash upgraded firmware?
 

Attachments

  • IMG20230113180110.jpg
    IMG20230113180110.jpg
    2.9 MB · Views: 14
Dec 14, 2014
6
1
help!!! i installed supersu because it was not present in the malaysk rom and now the HU doesn't start...it stops on android screen and infinite loads...
 

Top Liked Posts

  • There are no posts matching your filters.
  • 7
    we need custom firmware for models with and without dsp sound
    We are working on it ;)
    https://www.youtube.com/watch?v=IxIRMfDL5VM
    7
    All firmwares until now

    New Google Drive link
    Capture2.PNG
    Capture.PNG

    What is the content?

    Organized list of latest PX6 STM32 firmware:

    1. 19/08/2019 os_update_KC1E0101-P01-1.1.4.3.1_20190819_182727 - mcrw27 user
    2. 27/09/2019 os_update_KC1E0101-PA1-1.1.4.3.1_20190927_093454 - Bosion - NO DSP
      18/09/2019 mcu-201909181001KC6-1809.upd
    3. 29/11/2019 os_update_KC1E0112-PA1-1.1.4.3.1_20191129_103212 - Bosion - NO DSP
    4. 30/11/2019 os_update_HC1E0202-P0N-1.1.4.3.1_20191130_122815 - Erisin
    5. 12/12/2019 os_update_KC1E0113-PA1-1.1.4.3.1_20191212_104141.zip
      29/09/2019 KC1E0104-PA1-1.1.4.3.1_20190929_181347.img
      28/10/2019 mcu-201910281001KC6-1453.upd
    6. 21/12/2019 os_update_KC1E0112-P01-1.1.4.3.1_20191221_131058 - NO DSP
      28/10/2019 mcu-201910281001KC6-1453.upd
    7. 04/01/2020 os_update_KC1E0105-P0G-1.1.4.3.1_20200104_100113 - Treecar - NO DSP
    8. 23/03/2020 os_update_KC1E0110-P01-1.1.4.3.1_20200323_160300 - Bosion - EUNAVI - with DSP
      11/04/2020 os_update_KC1E0110-P01-1.1.4.3.1_20200411_110825.zip equalizer empty no flat rock etc
      03/01/2020 mcu-202001031001KC6-1027.upd
    • Factories APKS
    • Several Improvements
    • Manual
    • Photos
    • etc
    5
    While I uploaded the video, there are links to downloading firmware in the description of the video. Do not mistake! There are 2 types of firmware - with a DSP sound processor and WITHOUT DSP! In the archive along with firmware there is an instruction!
    Later I will make a finishing theme on the XDA!

    https://www.youtube.com/watch?v=8SbWdzGi9Wk
    4
    Project LAZARUS for a totally bricked STM32 MCU unit

    It has been a long adventure but I will sum it up in a few bullets:

    Disclaimer! I am in no case responsible for any damage that may be caused by the following method. Try at your own risk!

    1. Crime no 1: Flashed an Hal9k custom firmware on my unit straight out of the box. Though my unit was MTCx. It was an STM32
    2. Crime no 2: As if this was not enough, someone in the workshop cut power during first boot.
    3. Ended up with a totally bricked unit. Only black screen
    4. Contacted Erisin and they sent me stock firmware and instructions how to enter recovery and flash from there
    5. Could not enter recovery whatever I tried so I could not flash firmware
    6. Did research on Internet
    7. Learned that for totally bricked Rockchip devices, there is a chance to flash firmware in Maskrom mode using male to male USB cable. Some of them have 2 pins you need to bridge at power on to force Maskrom mode
    8. Downloaded DriverAssitant_v4.6.zip and installed driver
    9. Downloaded AndroidTool_Release_v2.52.zip and run software.
    10. I couldn't get direct access to the chipset in my unit since it had a very strongly attached shielding that I couldn't remove. I even tried with a dremel but I was afraid not to damage the board and stopped.
    11. Without direct access to the chipset, no documentation at hand and being totally desperate, I got kind of bold. I noticed two pinholes next to the usb connector that I bridged on power on and VOILA: the "found new hardware" chime sounded like music in my ears!!! I guess I was lucky!
    12. Unit was recognized in Loader mode
    13. Went to the advanced tab and selected go Maskrom. Unit got recognized in Maskrom mode
    14. Found this link to a Russian forum with STM32 firmware in .img format and downloaded
    15. Loaded .img firmware on AndroidTool second tab and flashed
    16. Unit came back to life but with a 800X480 desktop on my 1024X600 display. As per instructions in Russian forum, I had to apply the 2nd firmware (.zip format)
    17. Trying to apply 2nd firmware from within Android resulted in bricking the unit again. Had to start over (step 15)
    18. Trying to apply Erisin stock firmware (.zip format) from within Android resulted in bricking the unit again. Had to start over (step 15)
    19. Erisin method to enter recovery did not work. I used terminal command "reboot recovery" and entered recovery
    20. Flashing from USB was not a n option in recovery. Only SD and ADB
    21. Flashing from SD resulted in the following message:
      -- Install /mnt/extrernal_sd/os_update_KC1E0113-PA1-1.1.4.3.1_20191212_104141.zip
      E:Failed to unmount /mnt/extrernal_sd
      E:failed to set up expected mounts for install; aborting
      Installation aborted
    22. I was instructed to format an SD Card in FAT32 copy the firmware there, insert into unit and restart. In my unit that didn't work but another might work. With 2 new (fast) 8Gig and 16Gig cards the unit would normally boot to Android, where with an old (slow) 1Gig reboot resulted in black screen. In any case card was not big enough to fit the firmware.
    23. As a last resort, there was only one method left to try: apply update from ADB! Went to recovery, followed instructions to sideload the firmware and after a while there it was: LAZARUS WAS ALIVE!!! Fresh and fully functional! I even saw Android 10 in about page but I think this is falsely stated by some Chinese developer.
    4
    root

    root is very easy. Here is the instruction and the necessary files: