• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Question Rog phone 5 stucked on fastboot

Search This thread

messhary

Member
Dec 1, 2021
14
2
i have rog 5 firmware WW-18.0840.2111.196

i was rooted the device morning and switching the fingerprint to WW after that i did factory reset and used wrong bootloader.img not for the firmware version

the problem that i locked the bootloader using (fastboot oem asus-csc_lk) when i turned the phone it's just stucked on fastboot





even when i tried to go to recovery mode will back again to fastmode

i tried eld not working at all

qualcom app not connected

the only way i think to flash it with stock fimware but the problem i got when i tried with WW_ZS673KS_18.0810.2101.95_M2.13.24.9-ASUS_1.1.46_Phone-user.raw

the fastboot.exe failed this is the message

"FAILED, fastboot.exe flash all WW_ZS673KS_18.0810.2101.95_M2.13.24.9-ASUS_1.1.46_Phone-user.raw failure, EXIT!"

if anyone has any idea i waste 12 hours without progress



even i tried to open the bootloader through adb but i can't


plz help
 

messhary

Member
Dec 1, 2021
14
2
fastboot flashing unlock
...
FAILED (remote: permission denied)
finished. total time: 0.006s
 

messhary

Member
Dec 1, 2021
14
2
still almost 16 hours working the new code is after flash_all

fastboot: error: CID () mapping the wrong XROM (0x1)
 

yurishouse

Senior Member
Currently it's likely that you'll never be able to unlock BL again after manual relock.... I suppose you can try extract the Bin file and fastboot sent each one of them over

Code:
fastboot flash <partition name> <partition file>

, it will be a long process but guaranteed to work
Flash all command is always sketchy in most cases....

If you want I can dump the fw for you
 

messhary

Member
Dec 1, 2021
14
2
thanks for repalying this is the code

sending 'c' (37614 KB) OKAY [ 1.143s]
[FB] Writing 'c' FAILED (remote: 'Flashing is not allowed in Lock State')
fastboot: error: Command failed


any possible way ?
 

messhary

Member
Dec 1, 2021
14
2
Finally after hard working it solves ، phone working well , thanks for @johnny886 who advised to me the code.



The code problem :

fastboot: error: CID () mapping the wrong XROM (0x1)



The fastboot works with this command



The working code is:

fastboot -v flash all xx.raw


Thanks to you @yurishouse for your help