[ROM] [05 JUL 2020] LineageOS-14.1

zolotiyeruki

Member
Dec 26, 2016
9
4
3
Many, many thanks to @ggow for maintaining this ROM for all of us!

For others who may run into the issue where the device will only boot into Fastboot after installing the Magisk zip, here's the procedure I used that finally worked. All of this was done within TWRP:

--wipe the various partitions
--install the ROM
--install the tweaked, Magisk-tolerant img to boot
--install Magisk zip
--install the ROM zip a second time
--install gapps
 
  • Like
Reactions: HDXgamer and ggow

cl-i

Senior Member
Dec 1, 2018
57
21
8
Essen
Hi All,

Just a quick note to say, that I will be discontinuing any updates to this ROM instead favouring working on the lineage-16.0 rom.

Thanks,
ggow
I'm very sorry to read this and would like to encourage you to stay with this rom, at least for google patches.

I tested the new rom and was not able to become a useable stable tablet out of it.

The WIFI is breaking much much more than with 14.1. And when it happens, only a reboot can repair this.

My router is the ASUS RT-AC86u (connected to 2.4 MHZ channel 11), and I reproduced the failures with a TENDA Nova 5G Mesh router.
My tablet remains on my couch, and the quality is good -69 dbm. The TENDA was only 2 meters away from the couch.

On 14.1 wifi is stable as long as the router is not restarted. Even when I switch to Airplane mode before restart, after that, auto-reconnect fails. After manually reconnecting, connection gets lost after some time. I guess, the reconnects appeared before the restart.

To all the readers: Please post your obervations. What's going, what fails. Which router is used, which channel. This can be usefull also (if not much more) for the next ROMSs!
 

stangri

Senior Member
Dec 19, 2009
1,148
824
133
Burnaby
I haven't used my apollo for a while, I do remember having WiFi issues with LOS 14, so I can't tell if LOS 16 brought more WiFi issues or not, but it feels that 16 is a bit slower.

I was unable to go back to 14 tho, I cleande cache, dalvik, data and system, flashed LOS 14 and magisk and upon reboot the tablet went into fastboot and I was unable to make it boot. Is there a trick to go back to 14 from this?
 

brainwash123

Senior Member
Jun 27, 2012
186
43
48
I can confirm the connection issues with several routers. Used Asus AC-xx, Fritz!Box, some D-Link, but they all have a 5GHz band. Anyway, I gave up on a final solution for this and anyway it's not critical. I especially like the really long standby times.

One argument for the 14.1 maintenance is that I sometimes use the tablet as a second screen, with AirScreen. There are other ways to do it (spacedesk, TwoMon) but with AirScreen (miracast) you don't need to install something on the host computer. Anyway, Miracast hosting is not supported anymore on Android >=8.

I wish there were other tablets in this size, with Android, that are at fast and have more RAM. Tried a few 10" and sent them all back.
 

DB126

Senior Member
Oct 15, 2013
15,244
10,033
253
Stepped away from (literally) thousands of hours of HDX use after a positive 7 year relationship that saw a handful of Thor's become my daily driver for content consumption. Never had much issue w/WiFi disconnects which only occurs in the presence of mixed 2.4/5 GHz networks. By the end of 2020 the path was obvious. Great device, notable support from @ggow and many others during the golden years. Time to move on as the 4th gen kernel has become too much of a liability.
 

mkraus81

Member
Feb 5, 2016
36
4
28
hi,

i dont know if this is the right thread for my question.
Today i updated my old hdx7 from 2013 with this LineageOS Rom.
Now i have a question, withe the old cynogenmod rom i had at lockscreen the amazon music controls.
With this Rom i dont have any controls at lockscreen. I dont found any option to set this...
I am blind or to stupid... can you please help me?
Because i use the hdx for my little daughter but she only should use it with lockscreen.

THX for your help!
 

stangri

Senior Member
Dec 19, 2009
1,148
824
133
Burnaby
@ggow I'd like to hang onto 14.1 based ROM because to me they feel snappier than 16. I'm trying to downgrade back to 14.1 after trying out 16 and I'm struggling with it.

If I use the apollo-twrp-3.5.0_9-1 recovery, I can flash your LOS 14.1 rom (lineage-14.1-20200705-UNOFFICIAL-apollo.zip) but then when I try to flash opengapps (I've tried both open_gapps-arm-7.1-nano-20210223.zip and open_gapps-arm-7.1-pico-20210223.zip), I get no errors but I don't see any Google software upon reboot. The debug archive contains a more verbose log complaining that the system partition is read-only. I can use the apollo_twrp-3.2.3-1 recovery to flah opengapps successfully, but then at some point of migrating my apps/settings it complains it cannot reach something and stalls.

If I use the apollo_twrp-3.2.3-1 to start with, after I try to flash lineage-14.1-20200705-UNOFFICIAL-apollo.zip I end up in fastboot.

Please advise what's the procedure to return to 14.1 from 16.