[ROM][10.0][ LineageOS 17.1 - For Huawei MediaPad M3 8.4 ][Update 13/02/2021]

Garry050

Senior Member
Jan 21, 2015
133
40
48
1. Install Termux from Play Store
2. Open Termux and type "su" and grant root permission (if you failed first startup, please change app data to internal storage)
3. type "props" and type "1" -> "f"
4. showing manufacturer. type "26" (it's example. if you want use other manufacturer, change number)
5. showing device names. type "78" (it's example. in this case should be "Samsung Galaxy Tab S3 LTE")
6. type "y" and "y" (rebooting)
7. check SafetyNet after reboot.

I can't help about Vanced. it working my tablet with my solution
 

MattP410

Senior Member
Oct 11, 2017
87
7
18
Texas
1. Install Termux from Play Store
2. Open Termux and type "su" and grant root permission (if you failed first startup, please change app data to internal storage)
3. type "props" and type "1" -> "f"
4. showing manufacturer. type "26" (it's example. if you want use other manufacturer, change number)
5. showing device names. type "78" (it's example. in this case should be "Samsung Galaxy Tab S3 LTE")
6. type "y" and "y" (rebooting)
7. check SafetyNet after reboot.

I can't help about Vanced. it working my tablet with my solution
Thank you.
 

MattP410

Senior Member
Oct 11, 2017
87
7
18
Texas
1. Install Termux from Play Store
2. Open Termux and type "su" and grant root permission (if you failed first startup, please change app data to internal storage)
3. type "props" and type "1" -> "f"
4. showing manufacturer. type "26" (it's example. if you want use other manufacturer, change number)
5. showing device names. type "78" (it's example. in this case should be "Samsung Galaxy Tab S3 LTE")
6. type "y" and "y" (rebooting)
7. check SafetyNet after reboot.

I can't help about Vanced. it working my tablet with my solution
Okay, so Mediapad M3 isn't showing up under device names. Can I pick another Huawei device, or am I screwed?
 

MattP410

Senior Member
Oct 11, 2017
87
7
18
Texas
1. Install Termux from Play Store
2. Open Termux and type "su" and grant root permission (if you failed first startup, please change app data to internal storage)
3. type "props" and type "1" -> "f"
4. showing manufacturer. type "26" (it's example. if you want use other manufacturer, change number)
5. showing device names. type "78" (it's example. in this case should be "Samsung Galaxy Tab S3 LTE")
6. type "y" and "y" (rebooting)
7. check SafetyNet after reboot.

I can't help about Vanced. it working my tablet with my solution
I also figured out Vanced. It wasn't automatically going to the option to install unknown apps, so I had to do it manually. Thanks again for all your help.
 
Jun 30, 2020
26
12
13
Battery Drain Issue?

Hi.
After using the device for an hour, the battery dropped from 100% to 77%.
Just after one hour of use, it was 89%, but during sleep, it drops a lot.
I don't usually carry my tablet and I charge it immediately after use, so I didn't notice this issue until recently.

Settings.jpg


Settings2.jpg


It's not rare for battery life to worsen after flashed a custom ROM, but I'd like to know your situation. Is this normal?

Yours sincerely.
 

hanamizukitoki

New member
Jul 27, 2013
4
1
23
Hi,surdu_petru
Connect to the WiFi Internet, if you turn off the screen to standby mode, the WiFi will not be automatically disconnected, but will remain connected, resulting in unnecessary power consumption.
version:13/02/2021
 

hanamizukitoki

New member
Jul 27, 2013
4
1
23
Battery Drain Issue?

Hi.
After using the device for an hour, the battery dropped from 100% to 77%.
Just after one hour of use, it was 89%, but during sleep, it drops a lot.
I don't usually carry my tablet and I charge it immediately after use, so I didn't notice this issue until recently.

View attachment 5230879

View attachment 5230881

It's not rare for battery life to worsen after flashed a custom ROM, but I'd like to know your situation. Is this normal?

Yours sincerely.
I have the same problem,drop fast
 
  • Like
Reactions: Me,You,and Daigorou

Incomtus

Senior Member
Apr 30, 2016
155
36
28
soundcloud.com
Battery Drain Issue?

Hi.
After using the device for an hour, the battery dropped from 100% to 77%.
Just after one hour of use, it was 89%, but during sleep, it drops a lot.
I don't usually carry my tablet and I charge it immediately after use, so I didn't notice this issue until recently.

View attachment 5230879

View attachment 5230881

It's not rare for battery life to worsen after flashed a custom ROM, but I'd like to know your situation. Is this normal?

Yours sincerely.
Did you check if there were google update for example or if you have a kind of wifi automatic update?
Also can you check the apps in battery usage stats per app? Click on the 3 dots and click in detail usage
 

surdu_petru

Recognized Contributor
Feb 3, 2010
6,708
22,457
263
Paris
Battery Drain Issue?

Hi.
After using the device for an hour, the battery dropped from 100% to 77%.
Just after one hour of use, it was 89%, but during sleep, it drops a lot.
I don't usually carry my tablet and I charge it immediately after use, so I didn't notice this issue until recently.

View attachment 5230879

View attachment 5230881

It's not rare for battery life to worsen after flashed a custom ROM, but I'd like to know your situation. Is this normal?

Yours sincerely.
I have the same problem,drop fast
I noticed a similar battery drain in my device. I left my tablet for a day on standby without charging and it went from 100% to 75%.
I have not this issue on my device, but as a workaround you can try to disable Wi-Fi & Bluetooth scanning !

 

friedsonjm

Senior Member
Oct 30, 2008
1,374
234
83
I wonder if there is a difference in battery usage between LTE and WiFi models? Mine is wifi only, and after three hours sitting it has not used even 1%
 

surdu_petru

Recognized Contributor
Feb 3, 2010
6,708
22,457
263
Paris
I wonder if there is a difference in battery usage between LTE and WiFi models? Mine is wifi only, and after three hours sitting it has not used even 1%
Due to the long experience on Huawei devices, (starting with Huawei Ascend P6) - this problem I have encountered frequently even on identical devices, but I suspect that it is different revisions of the same type of device where the hardware was slightly different - and most of users fixed thier issues by disabling WiFi/BT scanning !