[ROM][10.0][ LOS 17.1 - MediaPad M3 Lite 8/10 ][ Update 14/02/2021 ]

surdu_petru

Recognized Contributor
Feb 3, 2010
6,692
22,431
263
Paris
Hello Petru.
I' am new to forum but I want to thank you for excellent work on M3 Lite 10.
What about Photo Camera? Do you have news when will be fixed?
Is there an Update version to upgrade from 20 december release?

The problem on camera involve no use on Meet/Skype and so on.
Thanks again.
Unfortunately there is no hope in repairing the camera as long as Huawei will not release a fully working kernel source code !

I know that this request it's mandatory, but unfortunately they released a kernel source code that don't even boot on stock EMUI firmware.

Yes, sure, there is a new update !
 

Netsurfer$

Member
Jan 24, 2021
5
0
1
Thank you Petru. I hope for camera fixing as son as possible.

When I say "update" I mean "update with no full installation".
If so how can I do it to avoid full install?
 

surdu_petru

Recognized Contributor
Feb 3, 2010
6,692
22,431
263
Paris
Thank you Petru. I hope for camera fixing as son as possible.

When I say "update" I mean "update with no full installation".
If so how can I do it to avoid full install?
Yes, you can updated from previously version ... it's call "dirty flash" and require nothing special, only flash the new release ( without gapps ) and in the end just wipe cache/dalvik cache !
 

dannywo

New member
Nov 13, 2020
3
1
3
Enhanced ROM, thank you very much! Just something which could help.. the advised twrp version caused some issues after flashing (clean and no errors) the ROM: device stuck in bootloop-automatic restart. Twrp 3.3.1.-2 worked instead just fine. There's an app for the camera which is effectively working: hedgecamera 2 from the PlayStore. It is no the best app for the features but at least it's working. Once again thank you very much! I hope there will be an android 11 version of lineageos for this device.
 
  • Like
Reactions: arkadius41

dannywo

New member
Nov 13, 2020
3
1
3
Enhanced ROM, thank you very much! Just something which could help.. the advised twrp version caused some issues after flashing (clean and no errors) the ROM: device stuck in bootloop-automatic restart. Twrp 3.3.1.-2 worked instead just fine. There's an app for the camera which is effectively working: hedgecamera 2 from the PlayStore. It is no the best app for the features but at least it's working. Once again thank you very much! I hope there will be an android 11 version of lineageos for this device.
Actually.. the camera which comes already installed works on my device.. not sure why. I have also tried the camera with few apps now and it works perfectly fine.
 

Netsurfer$

Member
Jan 24, 2021
5
0
1
I dirty flashed (with last Gapps also) and all works fine. Thank you Petru.

@dannywo, How did you set the camera parameters? Did you tested with Skype/Meet (or other...)?
On my system, camer start but was locked when get a photo :cautious:
 

dannywo

New member
Nov 13, 2020
3
1
3
I dirty flashed (with last Gapps also) and all works fine. Thank you Petru.

@dannywo, How did you set the camera parameters? Did you tested with Skype/Meet (or other...)?
On my system, camer start but was locked when get a photo :cautious:
I haven't changed any default parameters and I have checked the camera with Google duo and Facebook messenger. I've also managed to take few shots. At a more extensive use I could determine that the camera sometimes crashes and I think it is just a matter of luck when it decides to work or not (the front facing camera crashes many more times compared with the back one), but it is not completely unusable. I mean..for me it's ok as the camera is my least used feature in a tablet, which mostly I need to automate and control some things of my smart home and watch videos and TV.
 

Netsurfer$

Member
Jan 24, 2021
5
0
1
I haven't changed any default parameters and I have checked the camera with Google duo and Facebook messenger. I've also managed to take few shots. At a more extensive use I could determine that the camera sometimes crashes and I think it is just a matter of luck when it decides to work or not (the front facing camera crashes many more times compared with the back one), but it is not completely unusable. I mean..for me it's ok as the camera is my least used feature in a tablet, which mostly I need to automate and control some things of my smart home and watch videos and TV.
OK, thank you.
I will check it more. We hope Petru fixes the issue as soon as possible (depending on Huawei... :D:D)
 

dariomicali

New member
Feb 2, 2021
1
0
1
Hi everyone i found this app in the play store that works and saves photos !!! unfortunately it is unusable for too much publicity ... I hope it will be useful to someone who can fix the camera
 

desful

New member
Feb 5, 2021
2
0
1
Hi, really need help from you guys...
First I was at EMUI 5.1.
I flashed TWRP 3.2.0, then perform ADVANCE WIPE cause shows read /data permission denied & etc when I Swipe to Factory Reset...
After that I install LINEAGE OS 17.1 and WIPE CACHE.
Reboot syatem now but stuck at Lineage OS boot animation...

What can I do...? 😰
 

surdu_petru

Recognized Contributor
Feb 3, 2010
6,692
22,431
263
Paris
Hi, really need help from you guys...
First I was at EMUI 5.1.
I flashed TWRP 3.2.0, then perform ADVANCE WIPE cause shows read /data permission denied & etc when I Swipe to Factory Reset...
After that I install LINEAGE OS 17.1 and WIPE CACHE.
Reboot syatem now but stuck at Lineage OS boot animation...

What can I do...? 😰
Please, read carefully all the installation instructions, you have to start with TWRP 3.2.0, & Format data into twrp after that you must install LOS 16.0 ....

Format data into TWRP when you come from stock EMUI & Install LOS 16.0, the both steps are mandatory !

I've seen a lot of people get into your situation just because they haven't documented enough before !


EDIT:
I'm just giving you an example of the fact that you haven't read anything carefully :

Into OP it's stated clearly what firmware required in order to flash/install LOS 17.1 !



I don't know why you flashed LOS 17.1 before to flash LOS 16.0 :unsure:
 
Last edited:

drgonzo7

New member
Feb 12, 2021
1
1
3
Hi there,
Just wanted to say thank you for getting this working - it's great to have Android 10 on my tablet, the stock rom was starting to get really slow at times, so this has breathed new life into my tablet! I initially struggled to get it installed - with LOS16 and mini Gapps, it kept crashing with Pixel Launcher, so in the end I stopped trying to install Gapps, and got the base rom installed. Next I flashed TWRP 3.3.1.3 and installed LOS17.1, but it kept going to the Lineage splash screen, then rebooting after a few mins. Eventually I tried TWRP 3.3.1.0 and this did the trick, LOS 17.1 installed and micro Gapps and no crashes any more! Will pop something in your Paypal to say thanks
 
  • Like
Reactions: surdu_petru

desful

New member
Feb 5, 2021
2
0
1
Please, read carefully all the installation instructions, you have to start with TWRP 3.2.0, & Format data into twrp after that you must install LOS 16.0 ....

Format data into TWRP when you come from stock EMUI & Install LOS 16.0, the both steps are mandatory !

I've seen a lot of people get into your situation just because they haven't documented enough before !


EDIT:
I'm just giving you an example of the fact that you haven't read anything carefully :

Into OP it's stated clearly what firmware required in order to flash/install LOS 17.1 !



I don't know why you flashed LOS 17.1 before to flash LOS 16.0 :unsure:
Hi!
Thank you very much for your guide! Once I format /data inside TWRP, then my tablet can boot into LINEAGE OS already. This rom so far so nice! Thank you very much for your work!!! (y):D
Support you! Thanks again for bringing new life to my tablet!
 
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone