[ROM][10.0][UNOFFICIAL][28/02/2020] Pixel Experience for Moto Z2 Force [Beta]

Search This thread

Twin.Twiggs

Senior Member
Oct 13, 2018
157
24
Hay, I'm back with new port rom my friend make for me. Pixel Experience
JUST FLASH AT OWN RISK, AND I DONT BE RESPONDSIBLE TO GET ANY BOOTLOOP ISSUE, IMEI LOST... FROM U

Features

- All of Pixel device feature
- Moto camera fully working, added MIUI Camera


Link in post 2


Bugs

-Moto Mod
- u can tell me
- Second sim working not really normally (i think bcz tree of nash, or something else)


Introduction

1. Wipe data, cache and system and make a fully backup :D
2. Flash Pixel Experience zip and twrp_installer
3. Reboot (u will face a bootloop) but just wait for 2-3 minutes and reboot to twrp again.
4. Flash Magisk 20.3 and fix_file
5. Reboot and Enjoy!
U can uninstall it after install.


Big Thanks To

Developers @Polanobi

Bug Fixer: @erfanobadi
And unknown devs that make device tree and source

PLEASE READ POST #3 TO KNOW HOW TO USE NORMALLY.
JUST A BETA BUILD, YOU CAN TEST ALL FEATURES AND FEEDBACK FOR BUGs.
 
Last edited:

Twin.Twiggs

Senior Member
Oct 13, 2018
157
24
Post #3
Some Notes After u Try
1. ROM dont have gapps, phone, messeage...
U need to flash gapps and download gboard or any keyboard from pc and install to phone. Grant full permissions (draw in other app, modify...) to call normally.
2. Sometimes popup Moto Mod Manager had stop working, just ignore it, or u can uninstall via adb
3. I dont have time to test nfc, gps, volte...u can test yourself and feedback for me.
4. Just use fingerprint-gesture, or u can find some navbar-app to get gesture
Update: Add qemu.hw.mainkeys=0 on build.prop to get Q gesture. Thanks for @Polanobi
5. U should flash PE from Lineage 17/17.1, 16.0 Not required
6. If You have problem like sim card appear and disappear(read post #5 to know), it's solution:
- Remove sim 2 and wait to signal
- Add sim 2 to sim tray again and wait to signal go back and feel the change [emoji16]
This is not an issue for pe only, i tried to install lineage, stock and bug disappear until i find the solutions. And know that sim 2 will be cut to fit perfectly :)

Sent from my Moto Z2 using Tapatalk
 
Last edited:
  • Like
Reactions: livefc

Twin.Twiggs

Senior Member
Oct 13, 2018
157
24
Post #4
Screenshots

Screenshot_20200229-194115.jpgScreenshot_20200229-194120.jpgScreenshot_20200229-194125.jpgScreenshot_20200229-194135.jpgScreenshot_20200229-194200.jpgScreenshot_20200229-194207.jpg

Sent from my Moto Z2 using Tapatalk
 
Last edited:

livefc

Member
Jan 2, 2014
14
0
In the screenshot you use 1 sim card. Try 2 SIM cards at the same time, and you will understand what it is about.
 
Last edited:

archnine

Member
Sep 21, 2011
6
0
Thanks guy, I flash the rom on my Z2f(XT1789-04, TMO), almost everything works well.
1 bug:
The camera cannot focus when I change from near to far or from far to near, just focus on the item on moment the camera open.

And it not have the long screenshot function, it a good thing on Pie, but I don't found on this rom.

Anyway, thanks for your good job.
 

Twin.Twiggs

Senior Member
Oct 13, 2018
157
24
Thanks guy, I flash the rom on my Z2f(XT1789-04, TMO), almost everything works well.

1 bug:

The camera cannot focus when I change from near to far or from far to near, just focus on the item on moment the camera open.



And it not have the long screenshot function, it a good thing on Pie, but I don't found on this rom.



Anyway, thanks for your good job.
Try both Miui Cam and Moto Cam? I used and everything work done. -03 Sprint

Sent from my Moto Z2 using Tapatalk
 

livefc

Member
Jan 2, 2014
14
0
Try to reflash rom (flash lineage 17 after that flash my rom) and take one sim only.

Sent from my Moto Z2 using Tapatalk

I did everything as you wrote. It worked, until it rebooted the phone. The problem with the simultaneous use of 2 SIM cards is not solved.
In addition, the same situation is observed on Lineage 17.1 firmware.
 

Twin.Twiggs

Senior Member
Oct 13, 2018
157
24
I did everything as you wrote. It worked, until it rebooted the phone. The problem with the simultaneous use of 2 SIM cards is not solved.

In addition, the same situation is observed on Lineage 17.1 firmware.
I think it belong your device. Long time ago i installed lineage 17.1 and 2 sim working normally. Just try flash stock and retry all.

Sent from my Moto Z2 using Tapatalk
 

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    Hay, I'm back with new port rom my friend make for me. Pixel Experience
    JUST FLASH AT OWN RISK, AND I DONT BE RESPONDSIBLE TO GET ANY BOOTLOOP ISSUE, IMEI LOST... FROM U

    Features

    - All of Pixel device feature
    - Moto camera fully working, added MIUI Camera


    Link in post 2


    Bugs

    -Moto Mod
    - u can tell me
    - Second sim working not really normally (i think bcz tree of nash, or something else)


    Introduction

    1. Wipe data, cache and system and make a fully backup :D
    2. Flash Pixel Experience zip and twrp_installer
    3. Reboot (u will face a bootloop) but just wait for 2-3 minutes and reboot to twrp again.
    4. Flash Magisk 20.3 and fix_file
    5. Reboot and Enjoy!
    U can uninstall it after install.


    Big Thanks To

    Developers @Polanobi

    Bug Fixer: @erfanobadi
    And unknown devs that make device tree and source

    PLEASE READ POST #3 TO KNOW HOW TO USE NORMALLY.
    JUST A BETA BUILD, YOU CAN TEST ALL FEATURES AND FEEDBACK FOR BUGs.
    1
    Post #3
    Some Notes After u Try
    1. ROM dont have gapps, phone, messeage...
    U need to flash gapps and download gboard or any keyboard from pc and install to phone. Grant full permissions (draw in other app, modify...) to call normally.
    2. Sometimes popup Moto Mod Manager had stop working, just ignore it, or u can uninstall via adb
    3. I dont have time to test nfc, gps, volte...u can test yourself and feedback for me.
    4. Just use fingerprint-gesture, or u can find some navbar-app to get gesture
    Update: Add qemu.hw.mainkeys=0 on build.prop to get Q gesture. Thanks for @Polanobi
    5. U should flash PE from Lineage 17/17.1, 16.0 Not required
    6. If You have problem like sim card appear and disappear(read post #5 to know), it's solution:
    - Remove sim 2 and wait to signal
    - Add sim 2 to sim tray again and wait to signal go back and feel the change [emoji16]
    This is not an issue for pe only, i tried to install lineage, stock and bug disappear until i find the solutions. And know that sim 2 will be cut to fit perfectly :)

    Sent from my Moto Z2 using Tapatalk
    1
    Thank you.
    It helps untill reboot. After It, the same bug.
    But the same problem after install lineage 17 and 17.1 too.

    I know, that moto Z4 have android 10.
    Could anyone port It to GSI?
    I think It would be excellent . With working moto mods and dual sim Mode.
    Use ErfanGSI Tools. If u are complaining about dual sim, try GSI, dual sim working normally.

    Sent from my Moto Z2 using Tapatalk
    1
    Keep working in this rom, we need a important rom like that in one of the best phones, with your work my z2 is going to have a new life, because in the stock rom i present errors.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone