[ROM] [10.0] [UNOFFICIAL] LineageOS 17.1 for S9 and S9+ (Snapdragon)

Search This thread

klabit87

Senior Member
Jul 11, 2011
2,995
2,246
Did you worked on a solution for the Nextel/Claro carrier or...? Kinda want to use but can't without the SIM card.
I've asked others that have used and are still using lineage and there are confirmed uses of lineage with claro provider. I really can't explain why yours isn't working.
 

Nanashii

Member
Mar 14, 2018
6
0
I've asked others that have used and are still using lineage and there are confirmed uses of lineage with claro provider. I really can't explain why yours isn't working.

Well, i'm going to try to use again, but mine is NEXTEL, Claro is the company that fusioned with the other one; sorry if i explained wrong. D:
 

ButterRhopa

New member
Mar 28, 2017
3
0
Great ROM and I have used it for a month. Everything works pretty well.
However Recently when I bought Galaxy Buds earphone, I find that there is a problem on phone call with bluetooth—— It sounds like a half-tuned AM radio station. But streaming audio from websites, Youtube, music and video apps all work fine.
It's pretty unLocky. Will this problem be solved in future? Thx a lot.
 

klabit87

Senior Member
Jul 11, 2011
2,995
2,246
Lineage os stuck in infinite loop,even havoc os does the same thing....Sm-G9600...help?
Sorry i did not see this until now. You are likely forceencrypted. you need to flash ForceEncrypt_remover_q.zip
and format data (do not wipe you must format where you have to type yes to confirm)
 

marcelo-cps

Senior Member
Jul 30, 2007
71
8
Hello,the rom runs very smoothly.
I have a problem :SIM Card 2 has no sound when calling.But this is not the case for SIM Card 1. I tried to exchange the two cards, but the problem still exists.So I believe there is no problem with my sim cards. What should I do to solve this problem?
Thank you very much!!
Same problem here.
Did you solve it?
Thanks!
 

slavehunter105

Senior Member
Nov 4, 2012
142
16
Dubai, UAE
Have been trying to successfully install LOS 17.1 ROM but it just keeps loading with the animation on the initial load. I've left it for hours and no progress. I've followed all the steps as was told and tried many times but no luck.

1. Flashed the TWRP 3.4 for S9 Snapdragon.
2. Wipe system, data, cache, dalvik etc
3. Flashed multi disabler klabut.zip and forceencrypt_remover_Q.zip, along with data format (the one we type yes).
4. Flashed LOS 17.1 of both the recent build that was released in November, and also tried the October build
5. Flashed Gapps for Android 10 Nano pack
6. Flashed Magisk 21.1 also, then finally cleared cache and reboot.

After all this, the device just keeps loading the LOS animation but doesn't finish. I've even tried the HAVOC ROM and the same issue is there. I even tried flashing stock ROM via Odin also and redoing all the same several times. Even disabling and enabling OEM Unlock. On download mode, OEM Unlock is off.

I know there are many who may have explained the same issues but I believe I've followed every essential step. I hope anyone would be able to assist me here on what went wrong.
 

jonatachampan

New member
Apr 4, 2014
3
1
Have been trying to successfully install LOS 17.1 ROM but it just keeps loading with the animation on the initial load. I've left it for hours and no progress. I've followed all the steps as was told and tried many times but no luck.

1. Flashed the TWRP 3.4 for S9 Snapdragon.
2. Wipe system, data, cache, dalvik etc
3. Flashed multi disabler klabut.zip and forceencrypt_remover_Q.zip, along with data format (the one we type yes).
4. Flashed LOS 17.1 of both the recent build that was released in November, and also tried the October build
5. Flashed Gapps for Android 10 Nano pack
6. Flashed Magisk 21.1 also, then finally cleared cache and reboot.

After all this, the device just keeps loading the LOS animation but doesn't finish. I've even tried the HAVOC ROM and the same issue is there. I even tried flashing stock ROM via Odin also and redoing all the same several times. Even disabling and enabling OEM Unlock. On download mode, OEM Unlock is off.

I know there are many who may have explained the same issues but I believe I've followed every essential step. I hope anyone would be able to assist me here on what went wrong.
as I understand it, when you stay in that loop after installing, you need to force the restart the first time.
 
  • Like
Reactions: slavehunter105

marcthas

New member
Jan 1, 2021
1
0
Installation was successful and I've used it for some days.

But there's still a problem with the SIM card (China Telecom). I can make calls and send SMS, but I can't use mobile data. Every attempt I made turned ERR_ADDRESS_UNREACHABLE. And the IMS registration in phone information (*#*#4636#*#*) keeps 'Not Registered'.
I had once flashed the package 'G9600_V5_NON_US_ADD_ROOT_ANDROID_10.zip' before installing los17.1.

Is there any way to solve this? Or should I flash through Odin and try again?

BTW, calls I received always have a annoying beeping sound throughout the call, and happens every time.
 
Feb 2, 2021
11
1
Hi.

Just flashed LOS17.1 on S9+ snapdragon and almost all working fine. I found a problem when connected to my car via bluetooth. Music sounds fine but in voice calls the other part cannot hear me (sound garbled).
I searched a lot and found that is a problem looks like similar to this and this.
As far as I understand, the problem is the transmision using 16khz but car supports only 8khz

Anyone with same problem and a solution?

Thanks!!
 

darklime

Senior Member
Oct 26, 2013
215
16
Not avaliable for S9+ snapdragon only for exynos.
I really want to flash this ROM on my snapdragon S9 but the one thing I'm concerned about is audio quality over bluetooth.
I updated to android 10 One UI 2.5 and while the performance is better the battery drain is atrocious.
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 23
    LineageOS is a free, community built, aftermarket firmware distribution of Android 10, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    What's not working:
    • IMS (no volte)
    • Need more testing (encrypted /data not supported)
    • Google Maps has a dpi/resolution bug. Use Google Maps Go version and it's fine.

    Instructions:


    • Make sure official twrp 3.4.0 has been installed and functional.
    • Download the latest build (and optionally gapps).
    • Reboot to recovery
    • Wipe system, data, and cache (required if you switch from other ROMs)
    • Flash the latest build, gapps, and magisk.
    • Reboot

    Downloads:

    Galaxy S9 Snapdragon (G9600): https://github.com/klabit87/OTA/rel...eage-17.1-20201113-UNOFFICIAL-starqltechn.zip
    Galaxy S9+ Snapdragon (G9650): https://github.com/klabit87/OTA/rel...age-17.1-20201113-UNOFFICIAL-star2qltechn.zip
    Google Apps: https://opengapps.org/

    Reporting Bugs:

    DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    Grab a logcat right after the problem has occurred.
    If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless).

    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. For now please report any bug below.

    Group:

    Join this group for contacting me and bug reporting (typically fast response )
    Samsung SDM845
    https://t.me/samsungsdm845

    Also dont forget to hit the thanks button! :D

    Contributors
    Thanks to @Vaughnn for the initial work on the oreo trees.
    Thanks to @iNeoxx for continuously testing for international carrier support.
    Thanks to @jrkruse , @Krog18 , @TheMadScientist , @biikman, and @stang5litre for testing for US carrier support.

    ROM Firmware Required: Minimum of Android 10 firmware
    Based On: LineageOS

    Version Information
    Status: Beta

    Source:
    https://github.com/klabit87/android_device_samsung_starqltechn
    https://github.com/klabit87/android_device_samsung_star2qltechn
    https://github.com/klabit87/android_device_samsung_sdm845-common
    https://github.com/klabit87/android_kernel_samsung_sdm845
    https://github.com/klabit87/proprietary_vendor_samsung_sdm845-common

    Created 2020-05-03
    Last Updated 2020-09-14
    4
    Just released an update with lots of stability and sepolicy fixes.
    I also implemented OTA in this build and will be using Github.
    4
    Just posted build update with July security patch. Some permission fixes are also included.
    4
    If you guys want ota via the lineage updater just add this line to your/system/build.prop

    For s9:
    Code:
    lineage.updater.uri=https://raw.githubusercontent.com/klabit87/OTA/master/starqltechn.json

    For s9+:
    Code:
    lineage.updater.uri=https://raw.githubusercontent.com/klabit87/OTA/master/star2qltechn.json

    In my tests, ota zip didn't want to auto install in twrp for some reason. Maybe that can resolve later but it's easy to navigate to /data/lineageos_updater and install the rom zip. My searches indicate it's a common issue sometimes?
    This will be included in future builds. This is for those that want to get ahead.

    I plan to upload an update/ota tomorrow.

    Sent from my Pixel 2 XL using Tapatalk
    3
    Alright, I'll keep testing and post what I did if I end up figuring it out.
    I have some notes for others that have trouble.

    This is exactly what I do when I update firmware.

    From clean upgrade (updating firmware from Odin), I flash twrp then flash multidisabler, forceencrypt remover, format data, reboot recovery, flash lineage, flash opengapps (nano), flash magisk. Boot up, force reboot after about 2 minutes and done. I boot up every single time with no issues

    Sent from my Pixel 2 XL using Tapatalk
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone