• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][10]Android Open Source Illusion Project[perseus][Official]

Search This thread

_JungleJohn

Member
Mar 14, 2018
18
3
Have had very poor battery life recently - anybody experienced similar following the last update? Thanks!
 

Caccu

Member
Nov 3, 2016
15
0
28
Pretty sure something is up with the gapp builds

Try non gapp and flash opengapp

Thanks for the info but I just flash everything from clean and restored everything back when I noticed the battery issue. If it would be fixed in the next update, it would be greatly appreciated. For now I just most time plugged in. Thanks for the ROM.
 

Jaitsu

Senior Member
Something I've figured out - OK Google doesn't work if I use a gapps build and flash gapps separately, but it works fine on the builds with gapps built in. ? Come to think of it, that's the same for any ROM I've used with gapps separate vs built in. All I'm doing is flashing the ROM, then gapps, then magisk, reboot, log in (doesn't matter if I restore backup or not), no OK Google. More details here, it's the same thing in the logcat.
 

alautz83

Member
Oct 16, 2010
19
1
Whatsapp Audio

I have some crackling sound on whatsapp audios. Is there a way to fix this?

Thanks!
 

rdhameja

Member
Apr 15, 2016
49
8
San Diego
Peculiar Bluetooth Issue

So this is happening on the latest build (Sept 12). There is a weird bluetooth issue I am facing where true wireless earbuds are constantly losing connection during a phone call.
- The true wireless earbuds remain connected without an issue when listening to music or podcasts.
- A standard bluetooth headset remains connected without an issue when listening to music or during phone calls.
- Car's bluetooth remains connected without an issue while listening to music or on a phone call.
- It is only the true wireless earbuds that don't remain connected to bluetooth only during a phonecall. (regular phone call or even whatsapp call)
- Tried this with 2 different brands earbuds if that matters.

Anyone else can confirm this please?
 

Caccu

Member
Nov 3, 2016
15
0
28
Something I've figured out - OK Google doesn't work if I use a gapps build and flash gapps separately, but it works fine on the builds with gapps built in. ? Come to think of it, that's the same for any ROM I've used with gapps separate vs built in. All I'm doing is flashing the ROM, then gapps, then magisk, reboot, log in (doesn't matter if I restore backup or not), no OK Google. More details here, it's the same thing in the logcat.
Update the firmware even after flashing. There us a thread with the official firmwares. It used to happen to me until I updated the firmware. Now it works like a champ:). Hope it helps
 
Last edited:

Jaitsu

Senior Member
Update the firmware even after flashing. There us a thread with the official firmwares. It used to happen to me until I updated the firmware. Now it works like a champ:). Hole it helps

Huh! What do you know, that actually did the trick. I swear I was already on the latest firmware, but somehow, flashing it again after installing the ROM fixed OK Google. Good to know, I'll remember that one, thanks!
 

Chosimise

Member
Jul 11, 2013
23
3
With regards to the led charging light, is there any way to just completely disable it? I don't really need it cuz my wireless charger lights up when its charging. So is there any way I can turn it off? I might have missed something...


Is it possible to lower the notification led Britghtness ? its so ****ing bright....


Great ROM, thanks so much. Everything seems solid, there is just one thing that spoils it for me - is it possible to add a toggle for the charging light? Keeps me awake at night.



First of all, thank you so much for the hard work and this ROM is amazing.

As mentioned by some members before, I too am a bit bothered by the LED on this device as its brightness cannot be changed due to hardware limitation, and I can't seem to find the option to disable it when charging. If it's not too much of a hassle, is it possible to provide an option to turn it off?
Thanks in advance and have a wonderful day
 

ambitiousButRubbish

Senior Member
Oct 29, 2017
196
45
Finally got round to flashing a custom ROM, decided this one (untill there's a havok os or rr build).

All good, but, I'm disappointed it's lacking face unlock, (I guess I'm one of the few people that actually used it). And I've noticed a few bugs in multi-window mode, chrome for example likes to cause a soft reboot randomly when going back, and resizing a window while a list is being drawn can sometimes cause this too.

Other than that, nice work.
 

rdhameja

Member
Apr 15, 2016
49
8
San Diego
So this is happening on the latest build (Sept 12). There is a weird bluetooth issue I am facing where true wireless earbuds are constantly losing connection during a phone call.
- The true wireless earbuds remain connected without an issue when listening to music or podcasts.
- A standard bluetooth headset remains connected without an issue when listening to music or during phone calls.
- Car's bluetooth remains connected without an issue while listening to music or on a phone call.
- It is only the true wireless earbuds that don't remain connected to bluetooth only during a phonecall. (regular phone call or even whatsapp call)
- Tried this with 2 different brands earbuds if that matters.

Anyone else can confirm this please?

Logcat for the issue in case anyone wants to look at


time: 1601754549832
msg: java.lang.IllegalStateException: setAudioServerStateCallback called with already registered callabck
stacktrace: java.lang.IllegalStateException: setAudioServerStateCallback called with already registered callabck
at android.media.AudioManager.setAudioServerStateCallback(AudioManager.java:5345)
at com.android.bluetooth.hfp.HeadsetStateMachine$AudioOn.enter(HeadsetStateMachine.java:1632)
at com.android.internal.util.StateMachine$SmHandler.invokeEnterMethods(StateMachine.java:1037)
at com.android.internal.util.StateMachine$SmHandler.performTransitions(StateMachine.java:879)
at com.android.internal.util.StateMachine$SmHandler.handleMessage(StateMachine.java:819)
at android.os.Handler.dispatchMessage(Handler.java:107)
at android.os.Looper.loop(Looper.java:214)
at android.os.HandlerThread.run(HandlerThread.java:67)
 

Niksior

Senior Member
Sep 23, 2012
74
18
After few commands and tricks everything is workig. GCam, ANX camera, payments by phone, ROM is stable (excepts some app freezes from time to time).
 
Last edited:

chromanju

Member
Dec 28, 2019
10
0
After few commands and tricks everything is workig. GCam, ANX camera, payments by phone, ROM is stable (excepts some app freezes from time to time).
There is just one thing bothering me, do you know why Adventure Sync in Pokemon GO is not working? Every permission and connection is set up. (I can't find any recent article about this issue)

Do you mind providing the "few commands and tricks" in order to make everything working (especially payments by phone) again?
Thanks!
 

Niksior

Senior Member
Sep 23, 2012
74
18
Do you mind providing the "few commands and tricks" in order to make everything working (especially payments by phone) again?
Thanks!

Payments

For AOSIP with gapps there is only one step needed. Read post aboce and make "Result: ctsProfile of fail and evalType of Hardware" (only Method To Force Basic Key Attestation and wipe google play) from "Pre Installation Checks". If it won't work for you do also "Method To Install A Fingerprint"
 

rdhameja

Member
Apr 15, 2016
49
8
San Diego
So this is happening on the latest build (Sept 12). There is a weird bluetooth issue I am facing where true wireless earbuds are constantly losing connection during a phone call.
- The true wireless earbuds remain connected without an issue when listening to music or podcasts.
- A standard bluetooth headset remains connected without an issue when listening to music or during phone calls.
- Car's bluetooth remains connected without an issue while listening to music or on a phone call.
- It is only the true wireless earbuds that don't remain connected to bluetooth only during a phonecall. (regular phone call or even whatsapp call)
- Tried this with 2 different brands earbuds if that matters.

Anyone else can confirm this please?

Hi everyone. Can someone please confirm if true wireless bluetooth works on phone calls?
 

Jaitsu

Senior Member
Just an FYI, the Straight Talk APN built into the ROM seems to be blocked from AT&T's network now. It used to work, but apparently starting this month I have to enter the APN to get data to work.

The APN the ROM is installing by default is "Straight Talk", but with the APN configured as follows:

APN: tfdata
Port: 80
MMSC: http://mms-tf.net
MMS proxy: mms3.tracfone.com
MMS port: 80
APN type: default,mms,supl

The following is what it needs to be set to to work with an AT&T SIM (not sure if the ROM can identify which of Straight Talk's carriers the SIM is for):

APN: ereseller
Port: (Not set)
MMSC: http://mmsc.mobile.att.net
MMS proxy: proxy.mobile.att.net
MMS port: 80
APN type: default,mms,supl

After correcting the APN I'm back to having access to LTE+ data.

EDIT: Maybe that wasn't the problem. A day later I'm back to having no data even with the correct APN. It's just strange considering it worked yesterday immediately after switching APNs.

EDIT 2: ...and now it's back to working only with the tfdata APN. I also tried rolling back to a ROM version where everything was fine before, and it's still acting up. Sooomething's messed up, and it's probably on my end, not the ROM, ignore me 🙄
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 7
    logo.png

    Code:
    [B][CENTER]**** Disclaimer: I'm not responsible if you destroy your device. Use at your own risk!!! ****[/CENTER][/B]
    Android Open Source illusion Project

    About us:
    AOSIP is a quality custom ROM based purely on AOSP. Twisted with the latest features and blended with stability. We strive for perfection and it shows.

    Team Illusion:

    Josh Fox (xlxfoxxlx)
    Akhil Narang
    Harsh Shandilya
    Anirudh Gupta

    Bug reporting:

    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab dmesg . (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    • Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues.


    Source code:


    Latest Downloads:


    Credit/Thanks:

    Mike Williams (founder and creator of AOSiP)
    Google for Android and AOSP
    LineageOS
    ABC ROM
    AquariOS
    BootleggersROM
    Dirty Unicorns
    PixelExperience
    OmniROM
    CarbonROM
    nathanchance
    ---------
    Other projects whose work helped us to create this
    And last but not the least, all our testers, who have helped us to squash many bugs so that we can try to release builds that as are flawless as possible


    Hosted and built on

    1
    INSTALLATION PROCEDURE:

    CLEAN (This is also solve Mi Logo Bootloops)
    1) In TWRP, Format Data
    2) Reboot TWRP
    3) Wipe System, Data, Cache and Dalvik
    4) Flash Xiaomi EU (Stable v11.0.2.0 or Weekly v20.5.7)
    5) Format Data
    6) Reboot TWRP
    7) Wipe System, Data, Cache and Dalvik
    6) Flash AOSiP
    7) (Optional) Flash Gapps & Magisk
    7b) Don't flash Gapps package if you chose to flash the Gapps AOSiP build
    8) Reboot into the system, and enjoy the illusion!

    DIRTY (At your own risk)
    1) In TWRP, flash AOSiP
    2) (Optional) Flash Gapps & Magisk
    2b) Don't flash Gapps package if you chose to flash the Gapps AOSiP build
    3) Wipe Dalvik & Cache only
    4) Reboot into the system, and enjoy the illusion!

    KNOWN ISSUES:
    NONE! All sensors, slider function, and AI button are all working!

    If you find an issue, please let me know. Either via Telegram or here.
    1
    FREQUENTLY ASKED QUESTIONS:

    COMMUNITY?
    We have a community of over 600 helpful Mix 3 users around the world.
    Join us on Telegram if you need help or want to chat: https://t.me/MiMix3Global

    FIRMWARE?
    AOSiP will not flash unless you are on any Android 10 based firmware.

    xiaomi.eu ROM includes firmware, so this is not needed if you flashed that during a clean install (unless you want to try a different firmware version).

    If you like to be on the latest firmware or try different versions, you can grab it here.
    Personally, I like the latest available global variant (stable or beta).

    You can flash firmware at any time, without affecting your current installation.

    WHICH GCAM WORKS BEST?
    Urnyx05 v1.7

    WHICH TWRP SHOULD I USE?
    Mauronofrio v3.3.1-17

    CLEAN OR DIRTY?
    If you're coming from unofficials, you'll need to clean flash since these builds are SIGNED.
    Once you're in, you can just take OTAs, no more need to clean flash.
    1
    Hey guys, happy to announce AOSiP 10 Stable officials!

    Please see the announcement on the Twitter post for changes and info about this release.
    1
    Hi everyone! been quietly following the community for quite some times already and I figured I could register and give you some insights on this rom.

    I've wiped everything, installed the latest firmware, rom, gapp and magisks.
    Everything went smoothly, except magisk giving me some headache about the ctsprofile... a ****ing nightmare... I've had custom rom for the last 10 years or so, I know my way around and always find the tricks to make things works... but this time I almost gave up.

    I ended up on youtube and found this gem.
    S-TaGmNfKMg

    Use termux and manually assign the fingerprint for the mix 3 and there you go.

    So far everything is working fine, Bluetooth, gps, selfie slider, dt2w, nfc.

    Now I'm monitoring for a battery drain. if the battery could last a typical day, that'l be great.

    And thank a lot for everyone involved!

    I'll keep you posted :)