[ROM][10]Android Open Source Illusion Project[perseus][Official]

Search This thread


Senior Member
Mar 30, 2012
Hy, the question i have isn't strictly aosip related but since this is the rom i 'm using i dare to ask here. :)

So i want to change slider behaviour. instead of opening camera it would be nice if it could answer and end calls. I asked around and got told i need to compile the rom again with the modification to slider.

This is what needs to be changed i have been told. But what i don't get is, on every corner i hear that Linux stuff is so great you can update everything without even restarting, but for this i have to nuke my phone? I mean after it gets compiled it has to live somewhere on the phone and that's accessible if rooted right?

So my questions are:
Where does KeyHandler.java end up in the compiled rom?
Is it possible to change just that file, compile it if necessary, and put it into my phone so the changed version handles the slider?


Jul 13, 2016
Xiaomi Mi Mix 3
Hi all,

In the last few days, I've had an issue - wondering if anyone can help.

I basically can't take incoming calls. If my phone is locked (screen off) when a call comes in, the phone rings, but nothing comes up on the screen. If I try to wake my phone up with either the power button or the fingerprint reader, either the phone all crashes (and I can't see any call details) despite the phone continuing to ring, or the phone reboots completely!

I haven't tried yet what happens when a call comes in and the screen is unlocked (phone screen on), but given that most of the time I get calls my phone is locked, I figure I need to work this out!

I upgraded to the latest global firmware and latest OTA update for AOSIP, issues still persists!

Any help / ideas?

(ok, I seem to have bigger issues - trying to open "setting/apps and notifications" is also causing my phone to reboot!)



Jul 13, 2016
Xiaomi Mi Mix 3
I don't know how much love this still gets...

I still use Mix 3 running AOSIP as my daily driver - it's great.

I want to install the latest magisk - which says I need to find the recovery.img for my phone. I can't find the recovery.img in the .zip for the latest version of AOSIP - where should I be looking?

Is this something that I need to find in TWRP?

EDIT: don't mind me - I answered my own question. I grabbed the version of twrp recovery I was using, and patched that. all working now!
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 7

    [B][CENTER]**** Disclaimer: I'm not responsible if you destroy your device. Use at your own risk!!! ****[/CENTER][/B]
    Android Open Source illusion Project

    About us:
    AOSIP is a quality custom ROM based purely on AOSP. Twisted with the latest features and blended with stability. We strive for perfection and it shows.

    Team Illusion:

    Josh Fox (xlxfoxxlx)
    Akhil Narang
    Harsh Shandilya
    Anirudh Gupta

    Bug reporting:

    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab dmesg . (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    • Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues.

    Source code:

    Latest Downloads:


    Mike Williams (founder and creator of AOSiP)
    Google for Android and AOSP
    Dirty Unicorns
    Other projects whose work helped us to create this
    And last but not the least, all our testers, who have helped us to squash many bugs so that we can try to release builds that as are flawless as possible

    Hosted and built on


    CLEAN (This is also solve Mi Logo Bootloops)
    1) In TWRP, Format Data
    2) Reboot TWRP
    3) Wipe System, Data, Cache and Dalvik
    4) Flash Xiaomi EU (Stable v11.0.2.0 or Weekly v20.5.7)
    5) Format Data
    6) Reboot TWRP
    7) Wipe System, Data, Cache and Dalvik
    6) Flash AOSiP
    7) (Optional) Flash Gapps & Magisk
    7b) Don't flash Gapps package if you chose to flash the Gapps AOSiP build
    8) Reboot into the system, and enjoy the illusion!

    DIRTY (At your own risk)
    1) In TWRP, flash AOSiP
    2) (Optional) Flash Gapps & Magisk
    2b) Don't flash Gapps package if you chose to flash the Gapps AOSiP build
    3) Wipe Dalvik & Cache only
    4) Reboot into the system, and enjoy the illusion!

    NONE! All sensors, slider function, and AI button are all working!

    If you find an issue, please let me know. Either via Telegram or here.

    We have a community of over 600 helpful Mix 3 users around the world.
    Join us on Telegram if you need help or want to chat: https://t.me/MiMix3Global

    AOSiP will not flash unless you are on any Android 10 based firmware.

    xiaomi.eu ROM includes firmware, so this is not needed if you flashed that during a clean install (unless you want to try a different firmware version).

    If you like to be on the latest firmware or try different versions, you can grab it here.
    Personally, I like the latest available global variant (stable or beta).

    You can flash firmware at any time, without affecting your current installation.

    Urnyx05 v1.7

    Mauronofrio v3.3.1-17

    If you're coming from unofficials, you'll need to clean flash since these builds are SIGNED.
    Once you're in, you can just take OTAs, no more need to clean flash.
    Hey guys, happy to announce AOSiP 10 Stable officials!

    Please see the announcement on the Twitter post for changes and info about this release.
    Hi everyone! been quietly following the community for quite some times already and I figured I could register and give you some insights on this rom.

    I've wiped everything, installed the latest firmware, rom, gapp and magisks.
    Everything went smoothly, except magisk giving me some headache about the ctsprofile... a ****ing nightmare... I've had custom rom for the last 10 years or so, I know my way around and always find the tricks to make things works... but this time I almost gave up.

    I ended up on youtube and found this gem.

    Use termux and manually assign the fingerprint for the mix 3 and there you go.

    So far everything is working fine, Bluetooth, gps, selfie slider, dt2w, nfc.

    Now I'm monitoring for a battery drain. if the battery could last a typical day, that'l be great.

    And thank a lot for everyone involved!

    I'll keep you posted :)