• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

ROM][10] LineageOS 17.1 for honor 6x

Search This thread

Djiban

Senior Member
Aug 22, 2014
761
185
Saint Remy les chevreuse
Is it possible to install the custom rom without a computer?
You'll need a computer with fastboot installed to flash twrp recovery! Also very difficult to upgrade to emui 8 first without it (as firmware finder database is offline, with it it would have been)

First of all you should try to unlock your bootloader and upgrade your emui to 8.0. If you are a beginner it' will be a good start, find a computer and follow the steps:

see requirements and point 3 here

Or initial step and "EMUI 5 to EMUI 8" there

Aks question in those threads, and be back here when you'll be in emui 8.


Do you now that also an android 11 well running rom exist? (see the fluid rom threat). Instead of this android 10 rom you are about to install?

Any way you have to be on emui 8 for any modern custom roms
 
Last edited:

Djiban

Senior Member
Aug 22, 2014
761
185
Saint Remy les chevreuse
One you'll have TWRP recovery installed, you'll be able to do a nandroid backup (google it), it is save to go back to your device in its previous state.

backup also on a computer or sd card all important data before doing anything

that's your choice to try to update or not your daily device !
 

VarianWrynn

Senior Member
Jun 21, 2021
57
6
Hello, today I went to see a technician to help me install the rom, but he asked me to reassure me that the rom reads the local GSM, I am in Cameroon,
 

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    I just find out that this rom https://forum.xda-developers.com/p8...m-lineageos-17-1-huawei-p8-lite-2017-t4064121 could be installed on our device wtih minor changes.After installing all things you will need to install stock recovery and wipe cache and try to do factory reset(i tried to but i got error massage) then you will successfully boot into rom







    Contributors
    @DarkJoker360
    3
    at first it says encryption unsuccessful then i was told to format the date from twrp, now it stuck on boot animation, i have left it overnight and it reboots to bootloader with code BFM_S_NATIVE_DATA_FAIL 211 NA
    reboot_panic_and_wdt_process_func

    finally i managed to get it work, so now i'm going to post every single thing i did to make this rom works and i will try to be as noob friendly as possible

    first thing first in case you mess everything up, i found out this guide to be some sort of remedy for all problems regarding honor 6x, because from here you will install stock emui 5 which you can use to upgrade to stock emui 8 from this guide

    use the guide above if you want to go back to stock rom because every single custom rom will require you to flash from the stock rom

    next i follow the guide provided here, after flashing the patch go back to stock oreo recovery which is available on the emui 8 folder you downloaded earlier

    do factory reset and wipe cache after that load to bootloader again

    finally flash huaweitwrp.img provided by lusci on the post #7

    boot to system and enjoy

    Ok let me make it simple for you.
    1. Flash stock Oreo Rom (no need to boot it)
    2. Flash TWRP by Dilemma in fastboot.
    3. Go to recovery and wipe data by typing yes to decrypt data partition (if not already decrypted)
    4. Go to fastboot and flash system.img
    5. Reboot to recovery and resize system partition
    6. Flash GApps
    7. Flash los patches zip
    8. Flash disable Dm verity patch
    9. Flash magisk-phh zip in the end.
    10. Reboot and wait.

    I used these steps to flash different GSIs/ROMs and it works perfectly.
    2
    I can confirm that this works like a charm, here I posted the instructions for those who want to install it!
    2
    Hi when I try to wipe data and cache... I have an error because the data is not mounted, I've trying to change the system file to ext2 and ext4 but nothing change. I also tried to repair system file. What can I do ? My device is already emui 8 and it's an Huawei gr5 2017 bll-l22. Thanks for your help
    Try the lastest TWRP in this thread
    https://forum.xda-developers.com/p8...wrp-3-3-1-0-huawei-p8-lite-2017-t3953122/amp/

    After installing system.img, u need to resize the system partition, until see the used space ~17xxmb and free ~18xx mb,
    after that flash gapps
    and MUST flash Magisk Phh 19.3
    the flash the patch file.

    After first boot, you need to, format data in erecovery
    Everything works smoothly except......can not make and receive calls, ooopss

    update, i try to roll back to emui8, and start the process again. it works now.
    recommend to update, lets teach the old dog new trick
    2
    Well I didn't quite try this ROM ...I did flash two other android 10 GSIs but they both have brightness issues, and I think its a problem with all android 10 gsi and our device... Calls worked on them tho.. Anyway, I flashed OmniROM GSI (pie) from openkirin website and currently driving it as a daily