• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][10][OFFICIAL] Lineage 17.1 NIGHTLY for MOTO G5. (Cedric)

Search This thread

Dapper2003

New member
Apr 14, 2016
1
4
OFFICIAL LINEAGE OS 17.1 NIGHTLIES

The most recent build was dated 25th Feb 2021. [Edit UPDATED to most recent build date].

The previous offerings were 2021-01-28; 2021-02-04 ; 2021-02-11; 2021-02-18.


Screenshot_20210219-151625_Settings.pngScreenshot_20210219-152937_Settings.png

CEDRIC WIKI
 
Last edited:

TheFixItMan

Senior Member
Jul 8, 2012
7,829
4,019
London
Hi, I tried to install it on OPP28.85-19-4-2 but the installation failed (infinite loop at start-up). According to this https://wiki.lineageos.org/devices/cedric/install the latest Android 8.1 firmware is required. Which one is it ? Thanks !

Any oero firmware will do as your base
Flash via fastboot - if you don't know which to choose use the latest retail version

How to flash rom

Go to twrp
Select wipe
Format data - option on the right (will format everything on phone including personal files so backup first!)
Restart to twrp
Wipe then advanced wipe
Wipe system data and cache
Select install from main menu
Install rom zip
Install gapps (you want arm64 android 10 nano)
Install magisk (optional for root access & to hide apps from detecting root/custom rom)
Wipe delvik cache
Restart
Encrypt phone again if required once booted from phone settings menu
 

QRXpMUvS

New member
Feb 27, 2021
4
0
Thanks, I did as you explained, but I am still stuck with a lineageos logo looping for a few dozens of minuts before the phone restarts and goes straight to TWRP.
 

TheFixItMan

Senior Member
Jul 8, 2012
7,829
4,019
London
Thanks, I did as you explained, but I am still stuck with a lineageos logo looping for a few dozens of minuts before the phone restarts and goes straight to TWRP.
Wipe system data cache and flash rom without gapps or magisk

Does it boot?

If yes wipe everything again and flash rom zip but flash gapps as well this time. And if it boots flash magisk (no need to wipe to flash magisk)

If magisk causes it to boot loop flash an older version

If none of the above works and you have the same issue trying to flash another rom eg lineage mint then its user error somewhere or an issue unrelated to the rom zip
 

PorkKnuckle

New member
Dec 28, 2019
3
0
munich
Hi,
i updated my G5 to the official LOS. Although VoWifi and VoLTE are enabled in settings, none of them are working (They didn't work on the unofficial version either).
According to my network operator, these functions are activated.
Unter Phone Info (*#*#4636#*#* in dialer's app) it says "IMS Registration: Not Registered"

Is there anything I can do about this?

Thanks!
 

QRXpMUvS

New member
Feb 27, 2021
4
0
Wipe system data cache and flash rom without gapps or magisk

Does it boot?

If yes wipe everything again and flash rom zip but flash gapps as well this time. And if it boots flash magisk (no need to wipe to flash magisk)

If magisk causes it to boot loop flash an older version

If none of the above works and you have the same issue trying to flash another rom eg lineage mint then its user error somewhere or an issue unrelated to the rom zip

I tried without gapps and magisk, it does not boot, same with Mint.
So if I understand well, the problem is probably on my side :)

What I did :

  • New firmware using fastboot following these commands.
  • At this stage, TWRP had disappear (!), I reinstalled it using fastboot. Is it normal ?
  • Then I installed lineageos.
 

HarpingOn

Senior Member
Oct 20, 2010
349
71
I tried without gapps and magisk, it does not boot, same with Mint.
So if I understand well, the problem is probably on my side :)

What I did :

  • New firmware using fastboot following these commands.
  • At this stage, TWRP had disappear (!), I reinstalled it using fastboot. Is it normal ?
  • Then I installed lineageos.

I have the same problem. I can't get Lineage or Mint to boot on my Cedric.

I've tried TWRP 3.4 , and 3.5 and neither made a difference. I have been through the instructions on the lineage site many times, and I'm sure I'm not missing a step

But every time the device sticks at lineage boot logo for a long time, before returning to fastboot mode.

If I re-flash 8.1 using fastboot, the phone works again, then go from the top with twrp and lineage, and we're back to logo and eventually fastboot again.

So, although I cannot help yet, you are not alone.

Edit:

My cedric is the 3GB RAM XT1676 model which I think might be somewhat rare version?
 

HarpingOn

Senior Member
Oct 20, 2010
349
71
I just realised, on the installation instructions it says to flash the recovery from the lineage download page, not twrp

So I tried:

motog5> fastboot flash recovery lineage-17.1-20210225-recovery-cedric.img
target reported max download size of 535822336 bytes
Sending 'recovery' (18390 KB)...
OKAY [ 0.586s]
Writing 'recovery'...
(bootloader) Image size exeeded partition limits
(bootloader) Preflash validation failed
FAILED (remote failure)

The cedric recovery image on the download page is about 2MB larger than the TWRP recovery.

So should I be using the lineage provided recovery to flash this?


edit:

I managed to get the cedric to boot the lineage supplied recovery by doing:

motog5> fastboot boot lineage-17.1-20210225-recovery-cedric.img

I then used that recovery (looks good by the way, smart looking recovery), but after flashing the matching lineage-17.1 image ( adb sideload lineage-17.1-20210225-nightly-cedric-signed.zip) , I still get the long running boot animation, and dumped back into bootloader after a while.

I think I should stop now, I'm getting tired
 
Last edited:

nift4

Senior Member
May 22, 2019
584
198
nift4.github.io
Moto G5
F(x)tec Pro1
I just realised, on the installation instructions it says to flash the recovery from the lineage download page, not twrp

So I tried:

motog5> fastboot flash recovery lineage-17.1-20210225-recovery-cedric.img
target reported max download size of 535822336 bytes
Sending 'recovery' (18390 KB)...
OKAY [ 0.586s]
Writing 'recovery'...
(bootloader) Image size exeeded partition limits
(bootloader) Preflash validation failed
FAILED (remote failure)

The cedric recovery image on the download page is about 2MB larger than the TWRP recovery.

So should I be using the lineage provided recovery to flash this?


edit:

I managed to get the cedric to boot the lineage supplied recovery by doing:

motog5> fastboot boot lineage-17.1-20210225-recovery-cedric.img

I then used that recovery (looks good by the way, smart looking recovery), but after flashing the matching lineage-17.1 image ( adb sideload lineage-17.1-20210225-nightly-cedric-signed.zip) , I still get the long running boot animation, and dumped back into bootloader after a while.

I think I should stop now, I'm getting tired
If you could give me logs, I'll check.
 

HarpingOn

Senior Member
Oct 20, 2010
349
71
If you could give me logs, I'll check.

My problem was that I was starting from the GB release of Cedric stock 8.1 as I'm in the UK. If I flashed the GB version, then no Lineage ROM would boot. Not this, and not the Mint one.

If you check out the Mint thread, what I did was use Fastboot to flash an international version of stock 8.1, then I could add TWRP and flash this successfully.

I ended up testing Lineage With microG, but actually successfully flashed this, and Mint as well.

So I'd say to anyone struggling to get a working flash of this ROM, try a different CEDRIC set of fastboot files.
 

Lighto97

Member
Sep 4, 2019
30
1
as im aware, you need to flash from stock 8.1 but sometimes if youre on pie you gotta flash nougat and then oreo to flash custom roms i tried flashing that rom before but got no succes with bootlop but i didnt knew this i have tried unnoficial los 17 but never though about trying again the one from los page, guess its Worth a try
 

Lighto97

Member
Sep 4, 2019
30
1
update: i got to flash and boot but the system reboots randomly, mostly when i open apps

also twitter doesnt login into my account for a weird reason dunno why. guess ill loke other roms around
 

TheFixItMan

Senior Member
Jul 8, 2012
7,829
4,019
London
update: i got to flash and boot but the system reboots randomly, mostly when i open apps

also twitter doesnt login into my account for a weird reason dunno why. guess ill loke other roms around
You need to been on oreo firmware to flash this rom - preferably the latest retail version

You also need gapps that are arm64 android 10 nano

See my instructions above for how to flash rom correctly (post #3)

Without any logs the devs will put it down to user error
 

Lighto97

Member
Sep 4, 2019
30
1
You need to been on oreo firmware to flash this rom - preferably the latest retail version

You also need gapps that are arm64 android 10 nano

See my instructions above for how to flash rom correctly (post #3)

Without any logs the devs will put it down to user error
oh damm i always forgot i have to send the log for them to track the issue, i already uninstaled anyway.

i did followed the steps the right way (thank you), right now im flashing stock nougat to try out LOS 14.1 (which i love and seems to be reeealy stable)
 

tfbb

Member
Aug 27, 2018
12
6
thank you very much to all involved for this … this gives a new lease of life to the moto g5. i tried both the official version and a microg4lineageos build - both work flawlessly afaict.

a few observations:
  • camera works, both photos and videos. the new camera app is quite usable.
  • coming from a build derived from codezeros 16.0-tree, i had to revert to the stock firmware to be able to install this. not doing so resulted in boot loops, wiping everything did not help
  • the los recovery cannot be flashed, it seems to be too big for the recovery partition. twrp works fine.
 

Lighto97

Member
Sep 4, 2019
30
1
thank you very much to all involved for this … this gives a new lease of life to the moto g5. i tried both the official version and a microg4lineageos build - both work flawlessly afaict.

a few observations:
  • camera works, both photos and videos. the new camera app is quite usable.
  • coming from a build derived from codezeros 16.0-tree, i had to revert to the stock firmware to be able to install this. not doing so resulted in boot loops, wiping everything did not help
  • the los recovery cannot be flashed, it seems to be too big for the recovery partition. twrp works fine.
i know how to boot with that LOS recovery, instead of flash comand you use boot command so the device will bot into recovery suing the image.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    OFFICIAL LINEAGE OS 17.1 NIGHTLIES

    The most recent build was dated 25th Feb 2021. [Edit UPDATED to most recent build date].

    The previous offerings were 2021-01-28; 2021-02-04 ; 2021-02-11; 2021-02-18.


    Screenshot_20210219-151625_Settings.pngScreenshot_20210219-152937_Settings.png

    CEDRIC WIKI
    2
    Hi, I tried to install it on OPP28.85-19-4-2 but the installation failed (infinite loop at start-up). According to this https://wiki.lineageos.org/devices/cedric/install the latest Android 8.1 firmware is required. Which one is it ? Thanks !

    Any oero firmware will do as your base
    Flash via fastboot - if you don't know which to choose use the latest retail version

    How to flash rom

    Go to twrp
    Select wipe
    Format data - option on the right (will format everything on phone including personal files so backup first!)
    Restart to twrp
    Wipe then advanced wipe
    Wipe system data and cache
    Select install from main menu
    Install rom zip
    Install gapps (you want arm64 android 10 nano)
    Install magisk (optional for root access & to hide apps from detecting root/custom rom)
    Wipe delvik cache
    Restart
    Encrypt phone again if required once booted from phone settings menu
    1
    It must be manually installed it via TWRP.

    This upgrade should be installed using ADB as stated in https://wiki.lineageos.org/devices/cedric/upgrade.

    If you want to install via recovery then better use the appropriate LOS-recovery from https://download.lineageos.org/cedric and not TWRP.
    It's not necessary to install this one on the phone. Just boot to bootloader and start by fastboot boot <LOS-recovery>.
    1
    Since the very first LOS 17.1 from mid February 2021 and even now on 18.1 I observe a strange behaviour of the Moto G (5) - cedric:
    Even if (particially - no GApps) using the "recipe" of posting #3 by @TheFixItMan the date and time of the phone is not correct when shut down and booted again.
    It's always the date and time of the flashed ROM build that shows up and must be adjusted manually in settings.

    Does anyone have a hint what to do or what I could have done wrong?
    I remember that last year the same issue appeared with another Motorola phone (Moto G4 Play - harpia). It vanished after a few months with one of the weekly nightly updates. So it could perhaps be a ROM issue?
    It can be an ROM issue, but not many users care simply because network time sync is fine.