[ROM][10][OFFICIAL][MATA] StatiXOS v3.2

Search This thread

63c

Senior Member
Aug 26, 2018
84
347
Florida
Essential Phone
OnePlus 6T

U5hlpIn.png

StatiXOS for Essential PH-1 (mata)

What is StatiXOS?
StatiXOS is a custom ROM based on the Android Open Source Project aiming to be minimal while providing quality of life improvements and up to date security patches.

CANARY MAGISK IS REQUIRED WITH BUILDS STARTING IN JULY

Known issues
Screen Casting

Features
Feature List

Download StatiXOS here
Download StatiXOS

GApps can be found here
GApps are included as of May 4th 2020/
Download GApps from OpenGapps

Flashing Instructions
Flash January Firmware, February Vendor(fastboot script)(BUILDS PRIOR TO 3/27/20)
Flash January Firmware, AOSP Vendor(fastboot script)(BUILDS AFTER 3/27/20)
Flash or boot into TWRP
Factory Reset in TWRP (format may be needed from stock)
Flash StatiXOS and the TWRP Installer
Reboot back to recovery
Flash GApps and Magisk (optional)

Stay in touch
Our Telegram channel
Changelog
Screenshots


XDA:DevDB Information
StatiXOS, ROM for the Essential Phone

Contributors
63c
ROM OS Version: Android 10
ROM Kernel: Linux 4.x
ROM Firmware Required: January Firmware
Based On: AOSP

Version Information
Status: Stable
Current Stable Version: v3.2

Created 2020-02-24
Last Updated 2020-08-06
 
Last edited:

venkatsrin

Senior Member
Mar 10, 2016
109
27
The link points to gapps 9.0 stock. Maybe the issue is we need 10.0, though only nano and pico available. I am looking into trying this in the next day or two. Anyone have a tip here? I know , only three days online! I will be patient!
Cheers
David
Try NikGapps or FlameGapps - I'm using the former and it's got stock packages and is stable
 

dragynbane222

Senior Member
  • Jul 2, 2012
    170
    58
    Google Pixel 4 XL
    The link points to gapps 9.0 stock. Maybe the issue is we need 10.0, though only nano and pico available. I am looking into trying this in the next day or two. Anyone have a tip here? I know , only three days online! I will be patient!
    Cheers
    David
    It only points like that because that's what the opengapps site details to, if you toggle the 10.0 button, it'll switch to what's available for 10.0
     

    panaderodc

    Senior Member
    Oct 27, 2011
    83
    21
    I followed all directions. gapps loaded fine, magisk, etc... all good. Only problem, sim card not seen. Tried a few times with no luck. I just reflashed january essential fastboot image and am restoring backup, but would like to try this, as every time I txt i need to shut off and turn on data. every time i plug in a battery I need to go to settings usb control... Getting sick of stock. Anyone else get around ( or have) this no sim problem?
    Thanks,
    David
     

    panaderodc

    Senior Member
    Oct 27, 2011
    83
    21
    The janfw-febvendor set doesnt have a boot.img or system.img file, though the flashall.bat calls for them. Could this be my problem? Not sure if the files aren't there does it just leave the old ones - which are January anyway.
    Thanks,
    David
     

    nilezon

    Senior Member
    Jan 30, 2008
    324
    191
    The janfw-febvendor set doesnt have a boot.img or system.img file, though the flashall.bat calls for them. Could this be my problem? Not sure if the files aren't there does it just leave the old ones - which are January anyway.
    Thanks,
    David

    The vendor package should not contain boot.img (boot partition for rom) and system.img (rom). These partitions are flashed by the rom you choose to install.
     

    Legitsu

    Senior Member
    Aug 30, 2013
    1,340
    430
    I followed all directions. gapps loaded fine, magisk, etc... all good. Only problem, sim card not seen. Tried a few times with no luck. I just reflashed january essential fastboot image and am restoring backup, but would like to try this, as every time I txt i need to shut off and turn on data. every time i plug in a battery I need to go to settings usb control... Getting sick of stock. Anyone else get around ( or have) this no sim problem?
    Thanks,
    David

    same rom is bugged
    @63c

    this seems to be the problem

    03-05 23:26:59.386 6233 6233 I android_os_HwBinder: HwBinder: Starting thread pool for getting: [email protected]::IRadio/slot1
    03-05 23:26:59.393 6233 6233 I android_os_HwBinder: HwBinder: Starting thread pool for getting: [email protected]::IOemHook/slot1
    03-05 23:26:59.581 628 628 I hwservicemanager: getTransport: Cannot find entry [email protected]::IRadioConfig/default in either framework or device manifest.

    VZW MVNO sim's see to be the affected
     

    Top Liked Posts