• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][10][YX/Y/M/H/G/F/FU]LineageOS 17.1 Unofficial for Samsung Galaxy A3 (2015)

Search This thread

AhmedPlayer

Member
Feb 11, 2017
7
0
source???? You read.. where? Fake news? There is no news about that on any official sites. Who are maintenances?
i even asked the official lineageos team on reddit for adding features on it and also asked about listing it on the official lineageos device list and they said they won't list the device as they didn't make that port and they don't provide support for a3 2015. it was ported from official lineageos roms by vl_w.
 

clarkson1234

New member
Jul 22, 2010
2
0
Works really great, I didn't expect that this phone is able to work so smoothly considering its weak hardware.
 
Wanted to say thankyou for the ROM. Just bought a A300Y (Australia with Telstra ROM) and flashed this 17.1 with no issues so far.
For others:

vol down + home + power
Recovery mode
Odin PDA - TWRP

vol up + home + power
TWRP mode
Wipe Data, Cache, Dalvik Cache and System
Install ROM
Install Magisk
Install Gapps - arm pico (nano wouldn't fit)


EDIT: Spoke too soon. On Lineage the Mobile Networks area is greyed out. Tried clearing cache, reapplying ROM etc, no good. Flashed stock firmware from a download, cellular is back and calls work. Formatted and flashed LineageOS again, no mobile networks. Maybe because it's the Australian frequencies or something? Different modem?

EDIT2: Tried with lineage-16.0-20181122-UNOFFICIAL-a3lte.zip and cellular works/detects just fine!
 
Last edited:
Hello,

I installed the new built without difficulty, but ...
> in order to get root again, I had to patch again the boot.img with Magisk, reboot... and then SIM card was no longer detected!
Restoring backup with previous ROM makes SIM foundable again.
Flashing (dirty) the new version, sim card is detected ... as long as I don't reinstall Magisk ! (tried 3x to verify )
Also tried installing on new built the patched boot.img from the previous built... without result :-( !
Magisk version: 22.1

[Edit]
> I have TWRP 3.3.1-1 (not 3.3.1-2) could it be a problem ?
> Should I completely reinstall Magisk - and not just patch boot.img ? (maybe then uninstall Magisk before upgrading the ROM, and reinstall after ?)
[Edit 2]
> last observation: when SIM card is not detected, the IMEI also disappears from the "about phone" properties !
Luckily, got it back within restoring the backup 🥵
Ah. I have the same problem with the latest.
 
The whole network frame is mess. Like I said.. also VPN stuff don't work properly(some apps "works" with data leaking, ergo not working - read useless).
As some of us we are on LOS 16.. No big bugs, except NFC battery eating.. workaround is disable it asap.
Anyway, its nice to see new LOS 17.1 on prehistoric phone.. I know its hard and I salute vlv for his work.
Hope someone will find the solution soon. There is LOS 18.1 out there but not for this phone. Maybe we will, some days, see that on this devices.
Just dreaming lol.
 

Ud4ba

Senior Member
Jul 17, 2019
57
19
Update is on currently is on testing with no news when will come out.
 

Top Liked Posts