Development [ROM] [11.0.0] [alioth/aliothin] ArrowOS 11.0 [OFFICIAL] [CLOSED]

Search This thread


Jan 25, 2021
Update 2022-02-26

ROM changelog:

Installation instruction:

Download: (Select version/build -> Arrow-11.0/Official)

- Recommend use with fw part MIUI V12.5.4.0 and newer (global/India/etc).

P.S. My personal Telegram support chat:
Dear Community/Dev.,

Could I know in this build (Gapps Build), which Gapps package (Niks, Bits, Flame, Mind) are being integrated?

Purpose: 1 of my app (SMS Organizer) keeps crashing except in this particular great rom & I wish to narrow down the cause of crash & version of GApps may be playing a role in it. Hence...

Also, if time allows,
Can anyone educate me about differences between multiple Gapps (Niks, Bits, Flame etc.) about how they defer & which are better comparatively.


Apr 19, 2016
Hi guys, I have a question. In some instructions on how to install arrow os on poco f3, I see that they use a command
fastboot --set-active=a

However, in the instruction in #2 , there is no command like that. Is this command not neccesary any more? Or does it depend on adb version or anything else?

Thanks for helping.


Senior Member
Jun 14, 2015
Anyone else experiencing this wakelock?

c440000.qcom,spmi:qcom,[email protected]:qcom,qpnp-smb5

Running latest 18 Juni build

Coming from

Thanks @palaych for this great ROM!
Months after and this wakelock still exist. It has a source in MIUI (mine and results I see in LOS and in Havoc ...
This is result of using Acc for adaptive charge.
Last edited:


Senior Member
Jun 14, 2015
I migrated to arrow11 from arrow12.1 . It is not possible to use 12.1 because it is not compatible with applications with old api used for android 10. What I can write about arrow11? I used LOS so far but I looked for rom which will let to use my F3 longer. The LOS 18.1 is possible to work and use 0.4% of battery during night hour. The arrow11 needs only 0.15% for the same. I was able to receive the same result in LOS after kernel change , but it was not easy to find correct kernel, because result was not repeatable. The kernel build-in arrow is very good optimised.
LOS has some very usefull options, but life without it in arrow is possible.
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 88


    is an AOSP/CAF based project started with the aim of keeping things simple, clean and neat.

    Telegram: Channel | Chat
    Code Review:
    PayPal: Donate to me

    Installation instructions: Click here

    Checkout more documentation at (maintainership/contributing): Check this out

    • Almost everything

    • You tell me
    Be sure to include a log : check how to

    Click here to Download
    Tip: Select OEM -> Device,choose Arrow version, choose build type: "GAPPS" or "VANILLA" to download.
    Read our blog article/post about:
    * GAPPS and VANILLA variants
    * Checking build integrity

    XDA:DevDB Information
    ArrowOS 11.0, ROM for POCO F3 / Redmi K40 / Mi 11x

    Source Code:
    Kernel Code:

    ROM OS Version: Android 11
    ROM Kernel: Linux 4.x
    ROM Firmware Required: MIUI R
    Based On: AOSP

    First installation (Clean flash):

    You need adb/fastboot tools.
    Download boot, vendor_boot and rom zip:

    Reboot in fastboot. Flash arrowos recovery (boot.img and vendor_boot.img):

    fastboot flash boot_ab boot_alioth.img fastboot flash vendor_boot_ab vendor_boot_alioth.img

    Reboot in ArrowOS Recovery:

    fastboot reboot recovery

    Make format data (Factory reset -> Format data).

    Flash ROM (Apply update -> Apply from ADB):

    adb sideload

    Follow what show on device, should be ... Step 1/2 -> 2/2, then flashing ended, can reboot device in system. (In cmdline: If the process succeeds the output will stop at 47% and report `adb: failed to read command: Success`. In some cases it will report `adb: failed to read command: No error` which is also fine!")

    If you want install separate gapps on vanilla buildtype, after flash ROM:

    Advanced -> Reboot to recovery

    Flash gapps (Apply update -> Apply from ADB):

    adb sideload


    Install Update (dirty flash):

    Go in Settings -> System -> Updater

    Downlad new build -> Install

    Device will automatically download, reboot into recovery and install a new build.


    Also you can use TWRP. Can find info in theme:


    My official telegram group: CLICK HERE
    Update 2021-09-11

    Device changelog:
    • - Remove qti telephony injection (Fix SIM-Switcher)
    • - sepolicy: Address denials
    • - rootdir: Disable sched_walt_rotate_big_tasks
    • - Build with Clang 13.0.1
    • - media: Sync configs with CAF
    • - audio: Sync configs with CAF
    • - proprietary-files: Restore all vibrator firmware
    • - proprietary-files: Unpin Display blobs
    • - Convert CarrierConfig overlays into RRO
    • - rro_overlays: {Wifi,Tethering}Overlay: Move to vendor
    • - Import full QTI Codec2 HAL and switch to Codec2 by default
    • - libinit: Switch to walleye oreo build fingerprint
    • - Misc fixes and upstream changes.

    Kernel changelog:
    • - Merge branch android-4.19-stable android kernel common
    • - Merge CAF tag "LA.UM.9.12.r1-12800.01-SMxx50.QSSI12.0"
    • - cpu-boost: Rework
    • - Misc fixes and upstream changes.

    ROM changelog:

    Installation instruction:


    - Don't use fw Global/India or China 12.5 Enhanced! (Use previous, example Global)

    P.S. My personal Telegram support chat:
    I've been using this ROM for a few weeks and it's great but I noticed a couple of things and have tried to fix them.

    The phone doesn't always go into full suspend mode because there's an misconfigured interrupt from the always on processor.
    This should fix it:

    The display doesn't go into low power mode when the always on display is enabled. There's also a clock with the wrong name in the device tree.
    Here's a quick fix for both those things:

    Attached is a zip containing a new boot.img and also a new dtbo.img, the dtbo isn't really necessary but I updated it to match the panel settings in the stock MIUI tree. In a dark room, the always on display might be quite bright but it's actually using less power than it used to.

    You can check the power usage with the display off by connecting adb over wifi and looking for lines like this in the kernel messages:

    <12>[ 309.495162] healthd: battery l=78 v=4129 t=31.5 h=2 st=3 c=40039 fc=4568000 cc=14 chg=

    It's the c= number that's important, this is the power consumption. With the display off it's about 17K, with the display in low power mode it's about 40K and without my fixes it was over 100K with AOD on.

    flash from fastboot (not recovery) with:

    fastboot flash boot boot.img
    fastboot flash dtbo dtbo.img

    This boot.img is patched with magisk, has root and should pass safetynet.

    You can also try the kernel out using:

    fastboot boot boot.img

    Unplug usb quickly after it says it's booting or it will just show a charging icon. This won't modify your system, just reboot to go back to the original kernel.

    All this should be quite stable but because the system wasn't previously going into suspend it might show up other bugs in some drivers. Use at your own risk!
    Update 2021-07-24
    Device changelog:
    • - parts: Add High Touch Polling Rate support
    • - Update blobs to V12.5.2.0.RKHMIXM
    • - Update config DisplayCutout to MIUI V12.5.2.0
    • - Update QDCM calibration configs to MIUI V12.5.2.0 and switch smart_MC1 by default mode
    • - Update WCNSS config to MIUI V12.5.2.0
    • - Remove SmartCharging
    • - Add missed audio props
    • - overlay: Return COLOR_MODE_SATURATED
    • - Remove unused jars and libs
    • - Kernel: Update display panel configuration to MIUI V12.5.2.0
    • - Kernel: fixes for freq table
    • - Misc fixes and upstream changes.

    ROM changelog:

    Installation instruction: