• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM] [11.0.0] ArrowOS POCO X3 [OFFICIAL][SURYA][UNIFIED]

Search This thread

zpower

Senior Member
Oct 21, 2007
252
68
Xiaomi Poco X3 NFC
Unlocking bootloader is the first step in flashing roms. Again, research and try to help yourself. I am not assuming anything except the fact that you did no effort to help yourself or do any sort of reading regarding this matter. The real bloat is asking before reading. We are all learning here but please make the effort.
I understand your point of view.
In last two weeks i reply the same thing over and over again to help other people and sometimes the answer its on the same page. No effort of the people.
Noting against nobody but there are no effort so i give up to help other.
People need to read Frist page at first then after ask just go back later posts at least 3 or 4 pages back, after that use search and then ask.
 
  • Like
Reactions: AEALO12

zpower

Senior Member
Oct 21, 2007
252
68
Xiaomi Poco X3 NFC
I was looking for the guide on unlocking "Mi Bootloaders". If you worked with Bootloaders, you know that it's not the same process for all vendors. Searched XDA but didn't get any good results for unknown reason. There are other guides on the internet but I prefer XDA guides. Lastly, try to understand what I actually asked for and try not to be rude about it.
Try here:
 
  • Love
Reactions: Ahmed

ruchimes

Senior Member
Jul 27, 2016
51
9
What is that about recoverys the op says about twrp and arrow recoverys.
I have Orangefox and installed all the pre oss builds. Do I have to change the recovery for latest oss ones?
 

SkaboXD

Senior Member
Jan 18, 2017
1,068
390
Ganja
Xiaomi Poco X3 NFC
What is that about recoverys the op says about twrp and arrow recoverys.
I have Orangefox and installed all the pre oss builds. Do I have to change the recovery for latest oss ones?
It will not harm anything, but it's preferable to change to TWRP or ArrowOS recovery by your choice as they are tested to work properly with ArrowOS. TWRP is my recommendation.
 

inunxelex

Senior Member
Mar 15, 2008
372
193
nfc only working when reading balance of nfc top up card, but can't update balance when refilling, Arrow-v11.0-surya-OFFICIAL-20210617-GAPPS
Screenshot_20210620-021731.png
 

Top Liked Posts

  • 1
    Hello, after downloading the OTA update and rebooting into twrp. It asks for password.. but I haven't set any password in twrp. What are we supposed to enter there ?
    That's what worked for me, cancel and disable forced encyprion again if you previously done that and the phone will boot.
    1
    When I tried to shutdown or reboot the phone after a day long use, the device freeze and I need to hold power button until it restarts. Is there a way to fix this behavior? Currently on latest GAPPS build, TWRP, and 12.5.1 FW. Also no root.
    I had the same problem on Crdroid and here on Arrow this bug still exsist in my case too. but maybe soon will be some fix for that.
    1
    I'm trying to figure out whether I've a hardware issue, software issue, or a poltergeist! On occasion, the phone will start to behave as if I was switching screens and touching things on the screen. Ghost touches I suppose. Once, it managed to send 5 messesger messages to my local pizza place. Thank goodness they were just nonsense pictures. :-D

    I've dropped this phone a million times, but no cracks or damage.
    Well if you've dropped it a million times, the digitizer could have been damaged even though there is no visible damage. I suggest getting it looked at.
    1
    Well if you've dropped it a million times, the digitizer could have been damaged even though there is no visible damage. I suggest getting it looked at.
    I dropped mine ZERO times and it behaves the same. Only on low reception.
  • 5
    payment by NFC does not work. I'm on 08/29 build
    I got the same message today, even though I'm using 20210601 build.

    SafetyNet also started failing this morning.

    Edit: The fix is rather easy. Flash this Magisk module:


    You need the safetynet-fix-v1.2.0-MOD
    4
    Please don't address another ROM in this thread.

    This thread is for the Arrow OS ROM.

    Thank you.
    And we're talking how Arrow compares to other ROMs.

    Please mind your business.

    Thank you.
    4

    bagus101

    Hello.

    I have a similar problem that I reported yesterday on GitLab.

    https://gitlab.com/arrowos-support/issues/android/-/issues/241

    So can you comment on my GitLab post as well ?

    Maybe the developers will notice it sooner :)

    Thanks.
    3
    My list of modules is rather small:
    - ANX camera
    - Systemless hosts
    - Universal SafetyNet fix (linked above)

    I also use Magisk Hide and have hid Magisk. It's somewhere in the settings. The Magisk APK then gets a different name and different icon
    Alright, I think I got it working. I had Magisk Hide for Google apps and banking already activated. I hadn't hidden the manager yet though.

    Guide for anyone experiencing the same problem. What I did was:

    1. Make sure MagiskHide was active for everything Google and banking app
    2. Hide Magisk Manager App through the option (I renamed it to "Admin")
    3. Clear any storage of Google Pay, Google Play Store and Google Play Services through Settings > Apps & notifications
    4. Install SafetyNet-Fix-Mod.zip from storage in Magisk Manager
    5. Restart the device
    6. Open Play Store
    7. Open Google Pay and set up contactless payment

    Some of the steps might be redundant, but the old error doesn't show up and in theory it should work. Will have to see if actual payments work.

    Anyways, thanks for the guideline in the right direction, @Noter2017 !

    Edit: Payment works!
    3
    Just FYI, SafetyNet is ok again on latest (2021-09-08) build
  • 71
    logo.png

    ArrowOS

    ABOUT
    ArrowOS
    is an AOSP/CAF based project started with the aim of keeping things simple, clean and neat.

    Website: https://arrowos.net
    Telegram: Channel | TG Portal/Links
    Github: https://github.com/ArrowOS
    Code Review: review.arrowos.net
    E-mail: arrowos.contact
    PayPal: Donate to us
    Blog: blog.arrowos.net

    Checkout more documentation at (maintainership/contributing): Check this out

    WHAT WORKS?
    • Almost everything

    WHAT DOESN'T WORK?
    • You tell me
    Be sure to include a log : check how to

    DOWNLOADS
    POCO X3 (NFC) (surya/karna)

    Note: These are enforcing builds. Safety net checks pass out of the box! No need to flash magisk modules, which might in turn break the integrity!

    Builds have been unified now under surya codename for both NFC and non-NFC variants

    Tip: Select OEM -> Device,choose Arrow version, choose build type: "GAPPS" or "VANILLA" to download.

    Latest Instructions for OSS builds (w.e.f 10/05/2021)
    If migrating from pre OSS builds
    • Flash the latest available MIUI 11 firmware. (Flash global or any if you can't find your region)
    • Download and copy arrow build to a OTG prendrive or sd card.
    • Now flash Arrow Vanilla/Gapps build.
    • FORMAT DATA. (You'll loose all your data!)
    • Reboot.
    Fresh install coming from MIUI
    • Flash latest available MIUI 11 if you aren't on it already.
    • Install any suitable recovery (mentioned below).
    • Download and copy arrow build to a OTG prendrive or sd card.
    • Flash latest Arrow Vanilla/Gapps build.
    • FORMAT DATA. (You'll loose all your data!)
    • Reboot.
    TWRP Recovery by @brigudav :
    Note: This build of twrp will support decryption on ArrowOS OSS builds.

    ArrowOS Recovery :
    Note: This is a very basic aosp recovery only intended for OTA installs. Do NOT expect other functionalities.​
    * Do not use with DFE or while unencrypted.​
    F.A.Q :

    1. My WiFi, bluetooth and network aren't working after updating to OSS build?
    A. This happens if you're still on the old Q firmware. Flash the latest available R firmware and then follow the above give steps to properly flash the rom.​

    2. Unable to update OTA's using TWRP?
    A. The current available recoveries are outdated and are no longer supported for OSS builds. To have a hassle free OTA experience use the above mentioned ArrowOS recovery.
    A. Two of the currently supported recoveries are mentioned above.​

    Read our blog article/post about:
    * GAPPS and VANILLA variants
    * Checking build integrity

    ROM Source: https://github.com/ArrowOS
    Kernel Source: https://github.com/ArrowOS-Devices/android_kernel_xiaomi_surya

    XDA:DevDB Information
    ArrowOS, ROM for the Xiaomi Poco X3 NFC

    Contributors
    ganesh varma, kubersharma, palaych
    Source Code: https://github.com/ArrowOS

    ROM OS Version: Android 11
    ROM Kernel: Linux 4.x
    ROM Firmware Required: Latest R firmware
    Based On: AOSP, CAF

    Version Information
    Status:
    Stable
    Stable Release Date: 2020-11-19

    Created 2020-11-19
    Last Updated 2021-05-18
    14
    So i haven't been around here for a while, after looking at the recent posts many seem to be confused, blaming and do not understand on migrating to OSS builds. In the final MIUI vendor builds the OTA functionality was blocked in order to prevent users from directly updating to OSS builds as it will be needing a MIUI 11 firmware followed by a clean flash. The same has been notified in our device changelogs. Every step and preventive measures have been taken, there's only much i can do from my side in clearing things up. We have this forum and community in place to help each other out, so lets not be pointing fingers here!

    Here again i would like to make it clear with a simple guide on how to migrate onto OSS build!

    Note: This update will require a CLEAN FLASH (format data), so please backup everything beforehand.
    • Flash the latest available MIUI 11 firmware. (Region doesn't matter!!)
    • Now flash Arrow Vanilla/Gapps build.
    • FORMAT DATA. (You'll loose all your data!)
    • Reboot.
    Beware that the current available recoveries haven't been updated yet to support decryption for OSS builds at this point.
    13
    Here are the instructions on how you should flash the new OSS Vendor ROM since most people here are confused:

    - Flash latest TWRP by brigudav
    - Flash Android 11 12.0.7 MIUI firmware
    - Reboot recovery
    - Format Data
    - Reboot recovery
    - Flash ArrowOS

    OPTIONAL:
    - Flash Magisk
    - Flash Gapps (If you're on Vanilla build & If you want custom gapps)

    - Reboot system

    Download link:
    - Firmware: https://xiaomifirmwareupdater.com/firmware/surya/stable/V12.0.7.0.RJGEUXM/
    - TWRP: You can find it on 4pda but you need an account. I'm not allowed to share it, so you have to get it yourself.

    This firmware is for NFC model as I'm not sure where is A11 firmware for non-NFC model. It can possibly work for non-NFC model, feel free to try.
    10
    Mission Impossible in all custom ROMs !

    1. Safetynet check the bootloader status and will automatically fail if magisk is not installed (Magisk Hide ON must be applied for this) !

    2. Furthermore, now you have to install the safetynet-fix module to make your banking apps working !

    3. Finally, you must hide Magisk Manager.apk with a random name too (Magisk Settings)
    To everyone, please STOP this misconception about having the need to flash magisk in order to pass safety net. Do read the OP I've clearly mentioned there's no need of a magisk or modules for safety net. Device is certified and passes safety net out of the box without need of any modifications.

    By improper usage of magisk and mods you're further complicating and breaking things when they're completely unnecessary which end up causing unrelated issues which you end up calling them rom source bugs ¯\(◉‿◉)/¯

    P.S : I'm not against magisk, but when you do prefer using modifications do ask yourself on your needs and if you're able to rectify the issues it might generate. Isolate yourself from magisk or any form of modifications to recheck and confirm the issue before making a bug report.
    8
    Even dev says in dec the 3rd changelog that notification led was implemented, it still doesn't work for me :(
    I'm aware of the notification led issue, its interlinked to an sepolicy denial from vendor which is quite tricky to address it while we're using the prebuilt/stock vendor. For now you can assume it as a trade off for enforcing builds. I'm working on a fix, once we start a full transition towards an OSS vendor these issues will be more convenient to be addressed.