• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][11.0.0_r39] POSP DumAloo (v4.1.2+18) - begonia [OFFICIAL]

Search This thread

Majaque

Member
Aug 24, 2013
28
43
Got some issues with proper sound playback - if I get voice notification (or make a screenshot) while listening music on headphones, music starts playing again on internal speaker.
I'm on build 4.2.0+17 Crispy
 

Top Liked Posts

  • There are no posts matching your filters.
  • 7
    main.png


    C++:
    #include <std_disclaimer.h>
    /*
    * Your warranty is (not?) void.
    *
    * I am not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at me for messing up your device, I will laugh at you.
    */

    Now that I'm done saving my butt, let's proceed :D

    about.png


    Potato Open Sauce Project is a butter smooth Android aftermarket firmware.
    We handpicked the best features around and are adding our own sauce to it.
    Get ready to taste the unique features it brings with itself.
    We aim to deliver an experience with original ideas and features along with the useful things
    the community is accustomed to.

    Team Potato
    @Agent_fabulous
    @ZerNico
    @raj_jdja
    @ShreyanshLodha
    @ATechnoHazard
    @HrX

    Design:
    @McAwesomePL
    Valvze
    Joshua Baldassarre

    Got an issue or suggestion? Reach us at
    Telegram
    : https://telegram.me/SaucyPotatoesOfficial
    Twitter: https://twitter.com/PotatoAndroid

    features.png


    - Custom RGB/HSL/HSV accent picker for dark/light themes
    - Custom volume panels
    - Three mode Notch Handler (Notch-City)
    - Icon shapes and icon pack support
    - Lockscreen media art and media art blur level
    - Permission hub
    - Signature spoofing
    - QS panel tweaks
    - Various custom QS tiles
    - Custom clocks
    - Brightness slider tweaks
    - Doubletap/longpress power to toggle Flashlight
    - Double tap to sleep on lockscreen
    - Per app network isolation option
    - Google feed integration in launcher
    - Other miscellaneous tweaks

    sources.png


    POSP: PotatoProject
    POSP Device Sources: PotatoDevices
    POSP Code Review: Gerrit Code Review
    Begonia common kernel: AgentFabulous/begonia

    install.png



    Clean Install
    - Backup all your data (Important)
    - Wipe /system, /data and cache.
    - Flash the ROM + NikGApps (Download link below)
    - Reboot

    Updates
    - Flash ROM
    - Reboot!

    download.png


    ROM Download: GitHub Releases
    NikGApps: NikGApps

    Credits
    - Google for AOSP
    - Team Potato
    - LineageOS
    - ArrowOS
    - OmniROM
    - AOSiP
    - And everyone else who helped out!
    3
    A step by step tutorial on how to flash and what to flash. And is it CFW/VNDK30/nonCFW, TWRP unified etc.
    I am sure this would be greatly appreciated not only by newbies.
    Well, here goes nothing, gonna make it as general as I can so it can be applied to other roms as well.
    Also extra stuff like passing safetynet and other things.
    TLDR it's non-cfw & get unified 3.5

    UP TO DATE POSP RELEASES FROM HERE BTW, the sourceforge link is outdated​

    $Blue - specifics for POSP 11
    #Green - comments
    Red - warnings

    and with that out of the way...


    ________________________________________________________________________________________________________________________

    SHAI'S MEDIOCRE ROM HOW TO: FOR DUMMIES

    FROM DUMMIES

    FOR DUMMIES



    ________________________________________________________________________________________________________________________


    Python:
    import disclaimer
    
      """
    This how-to is presented to you from my own experiences, AS IS.
    By using it, you agree not to hold me responsible for any bricked devices,
    melted icecream or lost cat pics. Don't blame me if you forgot to back up some things before proceeding.
    Check that all your data has been backed up before proceeding with this and then check again, can never be too safe.
    If I missed something or you'd like to add your own experiences to this so it's all in 1 place let me know.
    """


    ________________________________________________________________________________________________________________________

    [1. PREREQUISITES]​

    0*. UNBRICK GUIDE:
    # the mega-thread preloader is redundant since this became a thing imo

    1. TWRP:
    - ANDROID 9: TWRP 3.3

    - ANDROID 10: # no problems encountered with any of them for me, go crazy

    - ANDROID 11: # trying to install an A11 rom from twrp 3.3 RESULTED IN A BRICK
    # following ones confirmed to be working | | 3.4 may work on noncfw, if anyone tested it out lmk
    CFW: https://sourceforge.net/projects/begonia-oss/files/CFW-TWRP/ #3.4 tested -> working
    NONCFW: 3.5 unified or forks of it [BlackCatTWRP , unofficialTWRP tested] worked for me,

    # MAKE SURE NOT TO MIX UP CFW & NONCFW RECOVERIES
    # CAUSES-> unable to boot in recovery, bootloop[from OTA update while first effect ] ! ! and in few cases BRICKS
    2. CFW:
    # check megathread for dowloads and the tags on the rom that you're installing to know what to get... except this # guide wouldn't be a thing if those were accurate.... sigh..

    3. Your ROM... duh

    Now that that's over time to get on with the main course



    ________________________________________________________________________________________________________________________


    [2. INSTALLATION]​


    $ assuming you're coming from miui android 10, should work with other AOSP roms.
    $ If you're on android 9 for some reason it'd be ideal to update beforehand, you've been warned

    1. TWRP INSTALLATION: #included in my mediocre rom scripts
    - install ADB & fastboot tools
    - enter fastboot mode $use what I mentioned in the NONCFW A11 section
    -
    after connecting phone to your PC, type in cmd " fastboot flash recovery <recov_name>.img
    - type fastboot reboot recovery

    2. ROM INSTALLATION:
    - on recovery -> WIPE: FORMAT DATA && ADVANCED WIPE [dalvik, system, cache, data] #somewhat overkill
    - on pc cmd -> adb push <drag n drop rom file> / #or /sdcard if you want | | repeat for w/e you add
    - on recovery -> INSTALL:
    $ sourceforge version VDNK30 / github ones / OTAs noncfw
    $ don't touch the sourceforge one since you'll have to move to the others either way

    - # install cfw beforehand if needed by your rom select and flash ROM along with anything else you need like gapps/magisk
    - reboot & proffit


    ________________________________________________________________________________________________________________________

    [3. MAGISK AND SAFETYNET PASSING]​


    1. INSTALLATION: rename LATEST MAGISK APK to .zip and flash it, or use your recovery's built in if it's up to date... that's it

    2. PASSING SAFETYNET: - I use magiskhide on google play store & services
    - flash from magisk kdrag0n's universal safetynet fix
    - if on android 10: I use magiskhide props config to change fingerprint to begonia
    $ only univ safetynet fix needed for me to pass, if you're having problems try this?

    ________________________________________________________________________________________________________________________

    [4. TROUBLESHOOTING]​

    1. Trying to recover from brick: Mediatek device shows up broken in device manager

    -> REDO STEPS 2-4 ON THE UNBRICK TOOL​


    2. Recovery crashes after a few seconds in it

    ->YOU FLASHED NONCFW RECOVERY ON CFW BUILD, INSTALL PROPER​


    3. Device shows up with wrong/halfed memory capacity

    ->FORMAT DATA FROM RECOVERY #obviously erases all data


    More to be added when people have troubles.



    ________________________________________________________________________________________________________________________

    [X. MILASCENIOUS]​


    # Things that don't really belong anywhere but yeah
    -> POSP 11's lawnchair rewrite is still in alpha, I don't really recommend using it for the time being since a lot of features are still missing, get the one from the play store til it gets some polish. Most notably categories & hide app missing
    -> On android 10 you can get ANXCamera for all the camera sensors + 64MP camera, haven't looked into a11's
    -> For really big mistakes: this is how you remove magisk modules from recovery
    -> Extra used things: STOCK ROM [MIUI 12 a10] for those that bricked their phone | blackcat recovery working on posp 11 & that 1 batch recovery script
    -> I really wish they're gonna add back the POSP swag (icon on top left statusbar w posp logo)
    -> Mug cakes are really great, you should make 1 sometime
    3
    I've bought the device a week ago. The first thing I did is unlock the bootloader. 1 week today. So I started to look into installing a custom ROM. I must say that this device (or Mediatek) is quite tricky. I had to go through a lot of threads to figure the safe thing to do.

    So, here it goes, to whom it might concern, this is what I've done to install this ROM from MIUI 11.0.5 (Android 9), from scratch:
    (I made a .txt for myself before doing it, and it's mostly the instructions from Agent_fabulous' Megathread. With some modifications to work easily with this ROM, with what I've uncovered and the modified filenames).

    POSP ROM INSTALLATION from scratch process for noobs like me

    Migrate to CFW - Place all files to "work_folder" (adb)
    - Download preloader_begonia.bin and lk.img from Megathread attachments
    - Execute:
    fastboot flash preloader preloader_begonia.bin fastboot flash lk lk.img fastboot flash lk2 lk.img
    - Flash non-CFW recovery. Execute:
    fastboot flash recovery twrp-nonCFW-3.3.1-0-begonia_UNOFFICIAL_3012.img fastboot reboot
    - Boot using power and volume up.
    - Boot into recovery
    - Wipe system, cache, dalvik
    - Flash CFW, then flash CFW compatible ROM
    adb push *.zip /sdcard and flash them
    - Format data (not wipe, select "Format Data")
    - Reboot to bootloader
    - Flash CFW recovery
    fastboot flash recovery twrp-CFW-3.3.1-0-begonia_UNOFFICIAL_0506.img
    - Reboot! You're now on CFW!
    fastboot reboot

    cd filepath adb devices adb reboot bootloader fastboot devices fastboot flash recovery twrp.img adb push *.zip /sdcard

    And I'll attach all the files I've used. Drivers and all. Name is pretty self-explanatory if you've read the megathread. In the "work_folder" zip there are all files needed to do it all (including latest posp, twrp, cfw...).
    2
    Just fixed the SafetyNet by using Pixel 4 XL (A10) FP and also used Pixel 4XL in forcing BASIC key attestation.

    The root variant of Youtube Vanced is not working. It says the app needs google play services in order for the app to run. I switched to the nonroot variant instead.

    There's an issue in the auto brightness feature also just like the other A11 roms... Either it will only change to 0% or 50% brightness.

    Also, tigr's camera is working in this rom and haven't experience any issues yet. I flashed wyroczen's buffer fix in magisk before installing the camera.

    This rom looks great and thank you devs for making such awesome rom for us to use and enjoy! ;)






    YOUTUBE vanced root variant 15.33.34 is the only version to work perfectly
    2
    YOUTUBE vanced root variant 15.33.34 is the only version to work perfectly
    Thanks! Guess I'll try going back to root variant and test install the version.

    How You fix the Safety Net issue.
    Can you elaborate in simple....
    Thanks in advance.
    Assuming you're device is rooted with Magisk 😄
    1. Install Termux or any alternatives
    2. Go to Magisk and install the MagiskHide Props Config (it's available in the online lists on modules) and reboot.
    3. Go to Termux and type and enter su. Grant the app for superuser access.
    4. Enter props then wait for the module to load.
    5. Once loaded, enter 1 (Edit Device Fingerprint) then f (Pick a certified fingerprint) then look for Google then look for Pixel 4XL then choose the Android 10 version (Try using the A11. I just used the A10 because it was the original fingerprint of the ROM - coral 😅) once successfully changed, reboot.
    6. Go again to Termux and open props. Enter 2 (Force BASIC Key Attestation) then choose Pick from device list and just like choosing the fingerprint - look and choose for Google and choose Pixel 4XL. Choose yes then reboot.
    7. Go to Magisk and enable MagiskHide in settings. Go to SuperUser section then go to MagiskHide. Look for Google Play Services and just check the checkbox.
    8. Check SafetyNet and let me know if it worked.

    Plus, You cannot play games like Call of Duty, Pubg Mobile, and these games on this version of Rom Cause There is problem of "Performance is impacted. To disable check bootloader" as appears in a sticky notification due to this Games keep stopped again and again after some time while playing game.
    Please Consider...Fix

    Meanwhile Rom is quite Awesome. ⚡
    I can play Heroes Evolved smoothly with 55-58fps 😅 I disabled the message just long press the notification and turn off the notification. Just turn off the developer messages. I don't know if this will fix the issue you're having but it worked for me.

    I don't know if this glitch causes by the app or the OS. I tried opening Just Dance Now and it automatically goes in landscape mode even if the app display is portrait. Hence the app will not open and just displays black screen. After troubleshooting, I figured out that the auto landscape is caused by my display size (small), I tried going back to the default size and voila, the app is now loading and functioning. Can someone try other portrait games/apps in small display size?