[ROM][11.0][4.9][AOSP][SUZU] Explosive Lobster

DominikGX

New member
Jan 14, 2021
4
1
3
justfun666: The trick is to flash Stock rom and (without booting into stock), do the steps in the installation guide

Nonetheless: I am also using F5121, and have some wifi bugs. I will create logs
 
  • Like
Reactions: danidarklord

DominikGX

New member
Jan 14, 2021
4
1
3
My bug is WPA3 related. It works when using WPA2. Can this be fixed somehow?

01-17 22:25:44.535 1085 2937 D SupplicantStaIfaceHal: connectToNetwork "WLAN Router"SAE
01-17 22:25:44.536 1085 2937 D SupplicantStaIfaceHal: Network is already saved, will not trigger remove and add operation.
01-17 22:25:44.537 5437 5437 I wpa_supplicant: wlan0: Trying to associate with SSID 'WLAN Router'
01-17 22:25:44.538 5437 5437 W wpa_supplicant: wlan0: WPA: Failed to select authenticated key management type
01-17 22:25:44.538 5437 5437 W wpa_supplicant: wlan0: WPA: Failed to set WPA key management and encryption suites
 

justfun666

Member
Jan 17, 2021
7
0
11
justfun666: The trick is to flash Stock rom and (without booting into stock), do the steps in the installation guide

Nonetheless: I am also using F5121, and have some wifi bugs. I will create logs
Thx for the info mate, WiFi works now.
I thought that Stock Rom wasnt needed for this one lol.
 

justfun666

Member
Jan 17, 2021
7
0
11
Front camera doesnt work in other applications, for example Snapchat, only works in preinstalled camera application from this ROM.

Also quality of taken pictures is a lot worse then they should be.

Edit: Suddenly, front camera started working in other apps lol
 
Last edited:

tamisoft

Member
Jan 27, 2010
11
1
23
Also quality of taken pictures is a lot worse then they should be.
Yeah, I have that as well.

edit1. I have built the virgin sony aosp android 10, QQ3A.2008.05.001 vendor image, 4.9.213 kernel, and it does the same with the camera. It has an effect, that EV compensation 0 and under works, but not +1 +2. At least this didn't have glitching green lines in the video recording in the cold :) But image is pretty dark

edit2. Well this is very unfortunate seems like this device suffers from the usual Sony problem. When the bootloader is unlocked it wipes out the DRM keys from the TA? partition, and that disables many fcuntionality on the camera. eg. low light images, greenish tint etc. Let me know if there is a similar hack to fool the system like there is for the Z2. I think this should be highlighted on every custom rom what's not working section.
 
Last edited:

justfun666

Member
Jan 17, 2021
7
0
11
edit2. Well this is very unfortunate seems like this device suffers from the usual Sony problem. When the bootloader is unlocked it wipes out the DRM keys from the TA? partition, and that disables many fcuntionality on the camera. eg. low light images, greenish tint etc. Let me know if there is a similar hack to fool the system like there is for the Z2. I think this should be highlighted on every custom rom what's not working section.
Hopefully there is some kind of DRM-Fix possible?
 

GOrMHATRe

Senior Member
May 10, 2017
71
2
18
Front camera doesnt work in other applications, for example Snapchat, only works in preinstalled camera application from this ROM.

Also quality of taken pictures is a lot worse then they should be.

Edit: Suddenly, front camera started working in other apps lol
Did you perform any steps to resolve that front cam problem cause I have the same problem.
 

mase76

Senior Member
Aug 26, 2011
333
54
58
I mean, how did you get it to boot correctly? I still get a "There's an internal error wirh your device". This is a known issue, but there are no builds with a fix available. It seems. that nobody else has this issue.